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1. Home

Welcome to the LightBurn documentation!

Use the search bar at the top of the page or click the closest match below to find information on the tool or topic you'd like to learn about.

You can make LightBurn feature requests on our suggestion site.

Get Started

If you're new to LightBurn or laser cutting in
general, we'll walk you through installing
LightBurn, setting up your laser, and
creating your first project.

License & FAQs

Information about LightBurn's pricing and
licensing model.

Tools and Features

Information about using each of LightBurn's
tools and features.

How-To Guides

Follow these step-by-step guides to learn
how to do new things in LightBurn.

Troubleshooting

If you're running into problems, you may
find a solution here.

Collections

Take a look at our collections based around
common use cases for LightBurn.

If you need to read our documentation in a different language, you can use Google Translate to translate this website into your preferred
language.

For your convenience, we have shortcuts to Google translate for Spanish (Español), German (Deutsch), Italian (Italiano), Chinese (漢語), and
French (Français).

For more help using LightBurn, please visit our forum to talk with LightBurn staff and users, or email support.

_index
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2. Safety

 WARNING

LASERS USE INTENSE BEAMS OF LIGHT, INCLUDING LIGHT THAT MAY NOT BE VISIBLE.

IMPROPER USE OF LIGHTBURN SOFTWARE WITH ANY DEVICE MAY BE DANGEROUS AND COULD RESULT IN PERSONAL INJURY, DEATH, OR
PROPERTY DAMAGE. ALWAYS FOLLOW THE DEVICE MANUFACTURER'S INSTRUCTIONS AND GUIDELINES.

ALWAYS WEAR PROPER EYE PROTECTION WHEN USING YOUR LASER.

 WARNING

DO NOT LEAVE A LASER UNATTENDED WHILE IN OPERATION.

For more help using LightBurn, please visit our forum to talk with LightBurn staff and users, or email support.

safety

2. Safety
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3. License & FAQs

3.1 How the License Works

A LightBurn license is a digital key used to unlock the software for permanent use.

Every new license comes with a year of free updates from the date you first activate it. After a year, you'll still be able to use any version of
LightBurn released before your license expired, but you'll need to renew your software update period in order to continue receiving updates
for another year. If you renew before your key expires, you'll receive an additional two months on your one-year renewal. 

The type of license you need depends on the controller used by your laser. LightBurn supports three device types: GCode, DSP, and Galvo. 

LightBurn Core supports GCode-based devices.

LightBurn Pro supports both DSP and Galvo devices, in addition to GCode-based devices. 

If you're not sure what type of license you need, see Identify Your Laser.

If you started with a license that supports one type of device, and now need to use LightBurn with a different type, you can add support for
the new device type to your existing key. Please note that adding support for additional devices does not renew your key.

A LightBurn license automatically comes with 3 seats, meaning you can activate it on three computers at one time. You can use our License
Portal to view and remove activations on your key, freeing up activations in use on old or inoperable computers so you can activate on new
ones. 

If you already have a key, you can purchase additional seats here. If you would like to purchase a new key with more seats than the default of
3, or are interested in a Floating license setup, see our Educational and Volume Licensing page.

If you sell your laser and wish to sell your license along with it, that is permitted. Please note that it is not permitted to sell part of your license
to someone else.

Have questions? Read our FAQ or contact us at support@lightburnsoftware.com

3.2 Additional License Information

License Management
Guide

System Locked and
Floating Licenses

License Management
Reference

3.3 Frequently Asked Questions

No. You pay once, and the software will work forever as long as you have your license key. 

After a year, you'll need to renew your software update period in order to continue receiving updates.

The type of license you need depends on the controller used by your laser. LightBurn supports three device types: GCode, DSP, and Galvo. 

LightBurn Core supports GCode-based devices.

LightBurn Pro supports both DSP and Galvo devices, in addition to GCode-based devices. 

If you're not sure what type of license you need, see Identify Your Laser.

• 

• 

Is a LightBurn license a subscription?

Which version do I need?

• 

• 

3. License & FAQs
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Yes, the same key can be used to activate LightBurn on Windows, macOS, or Linux. 

A LightBurn License automatically comes with 3 seats, meaning you can activate LightBurn on 3 computers at one time. You can use our License
Portal to manage your activations. 

If you'd like to activate LightBurn on more than 3 computers, you can purchase additional seats for your license here. The cost of each additional
seats depends on your license type.

If you would like to purchase a new key with more seats than the default of 3, or are interested in a Floating license setup, see our Educational
and Volume Licensing page.

No, but your license's update period has an expiration date — a year from when you first activated it. When the update period ends, the key is
still valid, but you won't be able to use any version of LightBurn released after the end of the update period. Any version released before the key
expired will continue to work. 

To download and revert to a version of LightBurn compatible with your key, visit Releases. 

If your key's update period has expired, a renewal will add a year of updates, starting from the date you purchase the renewal.

If you renew before your update period expires, the renewal period will be extended starting from the date your key was set to expire. You'll also
receive an additional two months on your one-year renewal.

The price to renew your license's update period and receive another year of software updates is $30.

Starting in 2025, the price to renew your license's update period will depend on when you purchased your key, and how long since you last
renewed. A renewal is:

$50, if you're buying updates again after having lapsed (with a big exception for existing customers, see below)

$45, if you've been paying for software updates for at least a year, including the year that came with a new license purchase

$40, if you've been paying for software updates continuously for 2+ years

If your license key dates from 2024 or earlier, we will always allow you to buy another year of updates at the lowest offered price, even if you
lapse. 

Renew your license here.

No. The price of a renewal is the same regardless of the number of seats on your license.

Yes. You can upgrade your license here.

Can I use the same license key on any operating system?

How many computers can I use it on?

Does the license expire?

My license expired, how do I revert to a compatible version of LightBurn?

How do renewals work?

How much is it to renew?

• 

• 

• 

Do renewals cost more if I have more than 3 seats on my license?

Can I add support for a new type of laser to my existing key?

3.3 Frequently Asked Questions
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No. A license upgrade adds supported device types to your key, but doesn't take any away. 

No. Adding support for a different device type does not renew your key, or affect your key's update period in any way.

Yes. If you are already have a LightBurn license, but would like to try it with a device type your key does not currently support, go to Help ➝ 
License Management and click Deactivate License, then Extend Trial.

Our systems are fully automated, and all upgrades are processed promptly. However, LightBurn will need to contact our licensing server to
register any upgrade, and it can take up to 24 hours for LightBurn to sync with the server. You can force LightBurn to check back in by
deactivating and then reactivating your key in the License Management window. 

If you've already activated your license, but aren't sure if it supports your type of laser, go to Help ➝ License Management to see a list of device
types supported by your license. 

If you're unsure whether your laser is one of the types listed, see Identify Your Laser.

If you're unable to connect to your laser even though it is supported by your license, see Troubleshooting: Connection Problems. 

Yes. You are free to transfer your key to another user, or sell it along with your laser. The recipient will need to contact us with the key in order for
us to transfer it to their email address, granting them access to our License Portal. 

Please note that selling or sharing individual seats on your license key is not permitted. Keys must be transferred in their entirety, including all
seats. 

For more help using LightBurn, please visit our forum to talk with LightBurn staff and users, or email support.

FAQ license

Will I lose support for other devices when upgrading?

Does adding support for a different device type renew my key?

I already have a LightBurn license. Can I try a different version before upgrading?

How do I know when my upgrade has been applied?

How do I know if my license supports my laser?

Can I transfer my key to another user?

3.3 Frequently Asked Questions
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4. Get Started

4.1 Getting Started

If you're new to LightBurn, the information here will help you learn to use LightBurn and your laser.

Identify Your Laser

Install LightBurn

Add a Laser

First Project

Next Steps

Next: Identify Your Laser 

For more help using LightBurn, please visit our forum to talk with LightBurn staff and users, or email support.

get-started

• 

• 

• 

• 

• 

4. Get Started
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4.2 Identify Your Laser

You'll need to know what type of laser you're using in order to know which LightBurn license you need. Your laser type also affects what your
laser is capable of, what the LightBurn UI looks like, and how you interact with your laser.

To get started with LightBurn, you'll need to know two things about your laser:

What controller does your laser use?

What motion system does your laser use?

4.2.1 Controllers and Firmware

The controller — and the firmware it runs — determines whether
or not a machine is compatible with LightBurn, and what type of
license you need. 

A controller is essentially a computer within your laser, and the
firmware it runs determines the type of instructions it can
translate into signals it delivers to the motion system. 

LightBurn needs to know what type of firmware your laser's
controller is running to know what "language" to speak to the
machine. In most cases, LightBurn can automatically identify the
firmware if you set up your machine using Find My Laser, but
you'll need to be able to identify the controller yourself in order
to complete a manual setup.

LightBurn is currently compatible with three main categories of
controllers: GCode, DSP, and Galvo.

To connect to a GCode-based laser, you'll need a LightBurn
Core license.

To connect to a DSP or Galvo laser, you'll need a LightBurn Pro
license. LightBurn Pro licenses also support GCode-based lasers.

Below is a brief description of each type, as well as a list of
common controllers/firmware used by each. If you're not sure
what controller or firmware your laser uses, consult your
machine's manufacturer, or contact us at 
support@lightburnsoftware.com.

GCODE

Most entry-level diode lasers use GCode-based controllers.

Supported controllers/firmware: GRBL, Smoothieware, Marlin,
FluidNC, grblHAL, xTool

DSP

DSP controllers are common in more industrial-grade machines.
If your machine is a CO2 laser in a metal case and has an LCD
display, it is most likely a DSP model.

Supported controllers: Ruida, Trocen, TopWisdom

GALVO

Galvo lasers use a fixed scanning head mounted to an arm, and
project the beam from above. If your laser uses EZCAD2 or
SeaCAD as its default software, it is this type of laser. 

Supported controllers: EZCAD2, EZCAD2 Lite, BSL

4.2.2 Motion System

The motion system consists of the mechanical components that
direct the beam from the laser source to the material. These
include parts such as motors, mirrors, lenses, axes. 

The choice of motion system determines which LightBurn tools
are available for your machine, as well as the maximum job size,
and the speed of the laser.

Many tools in LightBurn are only available for machines with a
particular type of motion system.

There are two common forms of motion systems: 

Gantry motion systems have frames, wheels, and motors
that move a laser head around a work area. Some Gantry
lasers use a system of mirrors to reflect a beam from its
source, while others hold the laser source and move it around
directly. Gantry systems are relatively slow due to the mass of
the components moving around, but can have very large
working areas. 

Galvo motion systems use tiny moving mirrors to bounce the
beam to different locations on a large lense, which focuses the
beam and points it back down at the work. Because the
mirrors are so lightweight, they can bounce the light around at
very high speeds, but Galvos are limited by the size of the
lense to relatively small jobs. 

All Gantry lasers supported by LightBurn have GCode-based or
DSP controllers.

Almost all Galvo lasers supported by LightBurn use EZCAD2 or
BSL controllers and require a LightBurn Pro license. However,
there are a limited number of GCode-based Galvo lasers that are
compatible with LightBurn Core, and require special setup —
consult your laser's manufacturer for more information.

4.2.3 Additional Information

Knowing your laser's controller/firmware and motion system is
enough to get you started, but there's a lot more to know about
laser cutting and engraving. For additional information on the
ins-and-outs of different types of lasers and accessories, see 
Laser Types.

• 

• 

• 

• 

Note

• 

• 

Note
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 Previous: Getting Started

Next: Install LightBurn 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

get-started hardware laser-general

4.2.3 Additional Information
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4.3 Install LightBurn

4.3 Install LightBurn
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4.3.1 Computer Requirements

Current versions of LightBurn run on the following operating
systems:

64-bit Windows 7.0 or later

macOS 10.13 or later

64-bit Ubuntu Linux 20.04 or later

LightBurn does not require a powerful computer for most work,
although more memory is helpful for designs with a lot of
images. As with most things, a faster computer will make it
easier to work with large images or complex graphics.

Previous versions of LightBurn going back to version 0.6 are
archived on our website.

macOS users running versions older than 10.13 should
download LightBurn 1.6.03, which supports macOS 10.11 or
newer.

Users limited to 32-bit versions of Windows should download 
LightBurn 1.5.06, which is the final 32-bit release of LightBurn.

Ubuntu 18.04 users unable to upgrade to a more recent
operating system should download LightBurn 1.2.01, which is
the last release compatible with Ubuntu 18.04.

LightBurn 1.7 will be the final LightBurn version available for
both Linux and macOS versions prior to 11. 

4.3.2 Download LightBurn

To ensure you get the most recent version of LightBurn,
download LightBurn directly from the Download / Trial page at 
lightburnsoftware.com. On this page, you'll find links to
download the current version of LightBurn, as well as links to
previous versions of the software and public beta versions. 

When you've completed the download, you should see the file in
your "Downloads" folder or a manually selected folder.

4.3.3 Installation Directions.

Choose your operating system below for additional installation
help.

Windows Installation

Installation works the same way as most Windows software.
Start the installer by double-clicking the file you downloaded
from the LightBurn website. Windows may ask if you trust us
first.

Click Next, then click Install to begin the installation process.
When it completes, you'll see the following screen with options
for installing drivers, viewing the change log, and launching
LightBurn.

If you have never installed LightBurn on this computer before,
you might need to install drivers. This is not necessary when
updating an existing installation.

The FTDI driver is mostly used by DSP controllers, like Ruida and
TopWisdom.

The EZCAD2 driver is used by supported Galvo devices using
EZCAD2 boards. Read more on our Galvo Installation page.

Start LightBurn however you usually do to begin using the
software.

• 

• 

• 

Support for older operating systems

• 

• 

• 

• 

Windows Installation

Installing Drivers

• 

• 

4.3.1 Computer Requirements
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macOS Installation

To install LightBurn on an ARM-based Mac (using an M1 chip
or later), you must have Rosetta installed.

In most cases, Rosetta is automatically installed on ARM-
based Macs, and manual installation is unnecessary. If
Rosetta is not installed, you'll be prompted to install it when
you attempt to open LightBurn. 

Installation works the same way as most macOS software. After
downloading the DMG file, open the file and drag LightBurn into
your Applications folder.

Versions before 1.2 were not notarized to be recognized by
your computer as coming from a trusted developer. If you
installed an older version, you'll need to follow the steps
below the first time you run LightBurn:

Open a Finder window.

Browse to the Applications folder.

Right-click or two-finger tap the LightBurn icon.

Choose Open from the menu.

When macOS asks if it should open the program, say yes to
add an exception allowing your computer to run LightBurn
normally. Once this is done, you will not need to repeat the
process unless you reinstall LightBurn.

Video walkthrough

macOS Installation

Installing on M1 or newer Macs

Notarization bypass for LightBurn 1.1 and earlier

1. 

2. 

3. 

4. 

5. 

4.3.3 Installation Directions.
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Linux Installation

ADDITIONAL COMPATIBILITY INFORMATION

LightBurn is tested on Ubuntu Linux, and current releases are
officially supported on Ubuntu 20.04 and 22.04.

Ubuntu 18.04 users unable to upgrade to a more recent version
should download LightBurn 1.2.01, the last release compatible
with their operating system.

Ubuntu 20.04 users can use any of the installation methods
described below.

Ubuntu 22.04 users will need to use the AppImage to run
LightBurn.

USING APPIMAGE

LightBurn is now available as an AppImage for easier setup
and increased compatibility. To use the LightBurn
AppImage:

Download the AppImage file.

Add the user to the dialout and tty groups.

Make sure libfuse is installed.

Make the file executable.

Double-click the AppImage file to run it.

Add User to Dialout and TTY

In the command below, $USER  doesn't need to be
replaced with your username. It's a standard system
variable, and if entered exactly as shown below will
automatically refer to the logged-in user's username.

Open a terminal and run the following command. When
complete, be sure to log out and log back in to refresh
permissions:

Install libfuse

Ubuntu 22.04 does not have the FUSE library, which
prevents AppImage from working as expected. To install the
library, use the following command in the terminal:

Graphical method to make the AppImage file executable:

Right-click on the .appimage  file.

Select Properties.

Go to the Permissions Tab.

Check the Allow executing file as program box.

Command line method:

Replace <AppImage File>  with the actual .appimage  file and run
the following:

AppImage Troubleshooting

Make sure you've logged out and back in after adding the
current user to the dialout and tty groups.

If you're having trouble with the AppImage, you may find
this guide from itsfoss.com useful: itsfoss.com/cant-run-
appimage-ubuntu/.

Our support team is also available to help. When reaching
out to support, please include in your message that you're
using AppImage on Linux, and which Linux version you're
using. 

Ubuntu Linux Installation

• 

• 

• 

AppImage

1. 

2. 

3. 

4. 

5. 

Info

sudo adduser $USER dialout && sudo adduser $USER tty

sudo apt install libfuse2

1. 

2. 

3. 

4. 

chmod u+x <AppImage File>

• 

• 

• 

4.3.3 Installation Directions.

- 24/400 - ©️ LightBurn Software, LLC

https://github.com/LightBurnSoftware/deployment/releases/tag/1.2.01
https://itsfoss.com/cant-run-appimage-ubuntu/
https://itsfoss.com/cant-run-appimage-ubuntu/
mailto:support@lightburnsoftware.com


USING .RUN  OR .7Z  INSTALLER

In step 1 below, $USER  doesn't need to be replaced with
your username. It's a standard system variable, and if
entered exactly as shown below will automatically refer
to the logged-in user's username.

Open a terminal and run the following command:

sudo adduser $USER dialout && sudo adduser $USER tty

IMPORTANT! Log out and log back in (this refreshes the
permissions we just added).

Download the Linux 64-bit version, either the .run  file or the
.7z  file and follow the appropriate steps below.

.run  installer

Open your terminal and cd  to the directory you
downloaded the file to.

Run bash ./LightBurn-Linux64-v*.run

It will now automatically install and create a program listing
in your desktop environment.

.7z  installer

Extract the folder wherever you want LightBurn to exist.

Right click AppRun  → Properties → Permissions → "Allow
executing file as program"

Double-click AppRun  inside your LightBurn folder.

 Previous: Identify Your Laser

Next: Add a Laser 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

get-started help-and-software-questions

Traditional Installation

Info

1. 

2. 

3. 

4. 

1. 

2. 

3. 

1. 

2. 

3. 

4.3.3 Installation Directions.
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4.4 Find My Laser

Always consult the documentation that came with your laser, or the manufacturer's online resources, before beginning the device setup process.
Some manufacturers provide settings bundles, importable device profiles, or special setup instructions that are necessary to fully utilize their
machines with LightBurn.

Quickly add a new laser to your list of devices with the Find My Laser wizard.

If you don't have a laser yet, go to Create Manually to be able to create a dummy laser as a placeholder until you get a laser.

4.4.1 Automatically Add a Laser to LightBurn

Make sure that your laser is powered on and connected by USB
cable to a computer running LightBurn. Wait for the laser to
complete any power-on moves, like homing, before continuing.

Click on the Devices button in the Laser Window, found in the
lower right-hand corner of the program window by default, to open
the Devices window.

Click the Find My Laser button to launch the Device Discovery
Wizard.

Click the Next button to begin scanning for connected devices.

A new window will open showing the progress of scanning for USB-
connected devices.

The Device Discover Wizard will display a list of recognized devices.
Select your laser from the list and click Add Device.

Some laser models will appear on the list twice, with two
connection types, Packet/USB or Serial/USB. Serial/USB is the
recommended option, while Packet/USB is an alternative option
that does not work on all systems, but can sometimes improve file
transfer problems. 

Consult Manufacturer Instructions

Info

1. 

2. 

3. 

4. 

5. 

6. 

Ruida: Packet vs. Serial

4.4 Find My Laser
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If your laser wasn't found automatically, see Troubleshooting. 

If you don't have a laser available to connect, you'll need to 
manually create a device profile.

Manually Create Profile 

Some lasers require additional information in order to complete
the setup process. Continue below.

4.4.2 Additional Hardware-Specific Instructions

GCode Devices

Set the machine origin. Nearly all GCode systems use the Front
Left corner as the origin, regardless of where they home to. If
you select the incorrect origin, your output will be flipped or
mirrored — you can correct the origin later in Device Settings.

Enable Auto "home" your laser on startup if your machine has
homing or limit switches, to automatically send your laser a
homing command each time the device has been connected. 

If your laser does not have homing switches, leave Auto-
home off.

If you see Error: 9 in the Console Window later, it means
you've enabled this feature but your machine is not
equipped or configured for homing. You can disable Auto-
Home later in Device Settings.

Select Next to continue.

Click OK in the Devices window to exit and save the new device
profile.

Some GCode controllers used on X-Carve or Shapeoko
devices may need specific configuration settings. If your
device is not listed, click Other, and refer to manufacturer
documentation for machine-specific parameters.

Next: Connecting to the Laser 

Warning

Note

GCode Devices

1. 

2. 

Warning

3. 

4. 

Note for X-Carve and Shapeoko Users

4.4.2 Additional Hardware-Specific Instructions
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DSP Devices

Set the machine origin. For DSP lasers, the machine's origin is
the same as the location it homes to when it first starts up. If
unsure, select the Rear Right corner, as most DSP controllers
follow this convention. If you select the incorrect origin, your
output will be flipped or mirrored — you can correct the origin
later in Device Settings.

Select Next to continue.

Click OK in the Devices window to exit and save the new device
profile.

Next: Connecting to the Laser 

Galvo Devices

When adding a Galvo device, LightBurn will ask you to import
the machine-specific configuration file from your EZCAD2 setup
or installation drive. Navigate to the location it's saved and select
the file to import crucial device settings. See Add a Galvo Laser
for more information, including what to do if the configuration
file is not available.

Next: Add a Galvo Laser 

4.4.3 Troubleshooting

If LightBurn can't find your laser, it could be for a number of
reasons:

Missing drivers: Install your laser-specific drivers and
software. Even if you don't plan to use their software, many
device manufacturers include the necessary drivers that are
not included with LightBurn.

Ruida controllers use an FTDI driver available as part of the
LightBurn installation process. Re-install LightBurn and select
the box for the FTDI driver at the end of the process to install
the driver — no LightBurn settings will be lost in the re-
installation process.

Galvo devices require a LightBurn-specific driver. Re-install
LightBurn and select the box for the EZCAD2 driver at the end
of the process to install the driver — no LightBurn settings will
be lost in the re-installation process. See Galvo Driver
Installation for more information.

Most diode lasers require the CH340 driver, available here.

See Troubleshooting: Drivers for more information.

Can't connect: Only one application can talk to your laser at a
time. If you run other software, like RDWorks, Easel, Carbide
Create, AutoLaser, or LaserCAD, make sure that software is not
running when running LightBurn.

Networked device: Network-connected lasers cannot be
automatically connected. Follow the steps in Create Manually
to set up your device.

Marlin controller: Marlin controllers have a variety of baud
rates and configuration options. They take significantly longer
to reset than most other controllers, making them
incompatible with Find My Laser. Follow the steps in Create
Manually to set up your device.

 Previous: Install LightBurn Didn't work?

Next: Connect to the Laser 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

add-device beginner connection create-device devices

hardware homing name new-device-wizard origin

settings work-area work-size

DSP Devices

1. 

2. 

3. 

Galvo Devices

Video: Galvo Setup Guide

• 

• 

• 

• 

• 

• 

• 

• 

4.4.3 Troubleshooting
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4.5 Create Manually

Always consult the documentation that came with your laser, or the manufacturer's online resources, before beginning the device setup process.
Some manufacturers provide settings bundles, importable device profiles, or special setup instructions that are necessary to fully utilize their
machines with LightBurn.

If you need to add a laser that isn't connected to your computer or is connected over a network, you can create a device profile manually.

If you don't have a laser, use the No Machine device type to create a placeholder device of any size you want.

4.5.1 First Steps

Start by clicking the Devices button in the Laser window to open
the Devices window.

Click the Create Manually button in the Devices window to open
the New Device Wizard.

4.5.2 New Device Wizard

Device Type

On the first page of the New Device Wizard, you'll see a list of
controllers and types of firmware supported by your version of
LightBurn.

If you don't have a device to connect yet, choose the No
Machine type to move ahead with using the software.

The Custom GCode device type allows you to create custom
templates for generating GCode. This won't be necessary for
most users, but if you have a custom machine or purchased a
machine from a vendor using non-standard GCode, go to 
Custom GCode to learn more.

All other options refer to specific controllers or types of
firmware. If you are unsure what type of controller or firmware
your laser is using, consult your laser's manufacturer.

After choosing the correct device type for your laser, click Next. 

Consult Manufacturer Instructions

What if I don't have a laser yet?

LightBurn Without a Laser

• 

• 

• 

4.5 Create Manually
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Connection Type

The next step is choosing how you connect to your laser. The
choices you see will depend on the type of connection methods
supported by your controller and LightBurn. 

Ethernet/UDP or Ethernet/TCP is used for both wired and
wireless network connections. 

See Connecting via Ethernet to Ruida Controllers or GRBL
Network Connection for more information.

Serial/USB is the most common connection type, used for
direct USB connections. 

Packet/USB is an alternative option for Ruida controllers only,
which uses a built-in driver, similar to RDWorks. This option
can be inconsistent on some systems, and is best not to use
unless you're having issues with a Serial/USB connection.

LightBurn Bridge is used to connect to a LightBurn Bridge.
This option is available for Ruida controllers only, and if this is
your first time setting up a Bridge, it's best to use the Bridge
Discovery Wizard instead of Create Manually.

After selecting your connection method, click Next.

ETHERNET AND LIGHTBURN BRIDGE — SET IP ADDRESS

If you selected Ethernet/UDP, Ethernet/TCP, or LightBurn
Bridge as your connection type, you'll need to enter the device's
IP address on your local network.

After setting the IP address, click Next.

Name and Work Area Size

You can give your laser a custom name, which is often useful if
you have more than one, or just leave it as is.

You must set the size of the work area for your laser so that
LightBurn can customize the Workspace to match the laser's
working dimensions. If you don't know the exact size, you can
change this later in the Device Settings window.

After naming and entering your machine's dimensions, click 
Next.

Laser Origin And Homing

The Origin setting is your laser's 0,0 point — where the X & Y
Axis both meet and begin. If you get this wrong, you can change
it later in the Device Settings window.

With a few exceptions, the Origin for GCode lasers is almost
always the bottom left. 

If you have a DSP laser, set the Origin to the location the laser
homes to when it first powers o. 

If you are unsure about your laser's Origin point, consult your
laser's manufacturer. 

• 

• 

• 

• 

• 

• 

• 

• 

4.5.2 New Device Wizard
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The Origin also controls the orientation of output to your laser
— if it's wrong, output to your laser may be mirrored or upside
down.

If you have a GCode based system, you'll see the option to send
the homing command each time LightBurn first connects to your
laser. You can change this setting later in the Device Settings
Window.

If your laser does not have homing switches, leave this off.

After setting the Origin, click Next.

Review Settings

The final page will show you a summary of your choices. You can
click Back to return to a previous step and fix anything if
necessary, or click Finish to create the new device entry.

4.5.3 Confirming Device Creation

Click OK to save and confirm the creation of the new device.
You'll return to the Devices window once you've exited the New
Device Wizard. 

If you click Cancel or click the window close button, all the
changes you have made in the Devices window will be discarded
— including creating the new device.

 Previous: Add a Laser

Next: Connect to the Laser 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

Ethernet LightBurn-Bridge add-device beginner

connection create-device devices hardware homing

ip-address name new-device-wizard origin settings

work-area work-size

• 

Warning

4.5.3 Confirming Device Creation
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4.6 Connecting to the Laser

Once a laser has been added to LightBurn, it should appear in the list of devices to the right of the Devices button in the Laser Window. If
you only have a single laser, it will be automatically chosen for you.

If you have more than one laser set up, you might need to select the one to connect to by clicking here:

Depending on the type of controller you have, you might have to manually choose the port that the laser is connected to, by clicking where
you see Choose in the Laser Window:

As long as your laser is connected to the same communication port, LightBurn will reconnect when you re-start. If you reboot your computer,
or plug the controller into a different USB port, you might need to re-select it.

If you see the (Choose) as shown above, you need to select the port. If no ports are listed in the drop-down, it means that no devices were
found, which could mean that it is not plugged in correctly, isn't powered, or you're missing a driver.

If your laser disconnects for some reason, or enters an alarm state and needs to be reset, you can quickly re-connect by right-clicking the 
Devices button in the Laser Window.

4.6.1 Troubleshooting

If you're having trouble connecting to your laser, see Connection
Troubleshooting for help. Linux users should also visit Linux
Troubleshooting

 Previous: Add a Laser

Next: First Project 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

connection get-started

4.6 Connecting to the Laser
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4.7 Add a Galvo Laser

Always consult the documentation that came with your laser, or the manufacturer's online resources, before beginning the device setup process.
Some manufacturers provide settings bundles, importable device profiles, or special setup instructions that are necessary to fully utilize their
machines with LightBurn.

When adding a Galvo device, LightBurn will ask you to import the machine-specific configuration file from your EZCAD2 or SEACAD
installation drive or an existing installation. If you don't have this file, you can also use manual entry to configure your laser with settings
provided by the manufacturer.

It's a good idea to set up a new device profile for each lens you have, because changing lenses will affect many parameters. You can
duplicate a device after setting it up by right-clicking on it in the Devices window and choosing Duplicate. This is the easiest way to add a
new profile while keeping the settings, so you only have to update parameters that change with the lens.

See Changing a Galvo Laser Lens for more information.

4.7.1 Import Settings

Follow the directions in Find My Laser to begin the process of
adding your Galvo laser. Your laser should be detected as 
JCZFiber (for EZCAD2 devices) or BSLFiber (for SeaCAD devices).
Select the appropriate device and connection type – USB is
currently the only supported type for Galvo devices – and
continue with the process. 

The New Device Wizard will ask you to import a configuration
file. The name and expected location will vary depending on the
type of Galvo laser you've selected: 

For JCZFiber devices based on EZCAD2, the file is typically 
markcfg7 .

For BSLFiber devices based on SeaCAD, the file is typically 
BslCAD.cfg  or LmcPar.cfg .

See the window in LightBurn for additional details on where to
look for the file.

Importing an EZCAD config file

Consult Manufacturer Instructions

• 

• 

4.7 Add a Galvo Laser
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Importing a SeaCAD config file

Select your configuration file – typically found on the USB drive
you received from the manufacturer – and click Next. LightBurn
will show you a preview of the settings to be imported.

If you don't have a configuration file, click Next without selecting
a file and you'll be able to enter settings manually. If your laser's
manufacturer didn't provide the necessary settings, please
contact them for assistance.

If your markcfg7 file includes information about Lens Correction,
LightBurn will attempt to automatically import this for you. If
your configuration file doesn't include this info, you'll need to
manually enter it in Device Settings after finishing the New
Device Wizard.

After entering the size of the work area and setting the name of
the laser, you're ready to connect to your laser.

 Previous: Add a Laser

Next: Next: Connect to the Laser 

4.7.2 Manual Add a Galvo

If your laser did not come with the settings on a USB drive or if
you don't have the USB drive available, you may need to contact
the manufacturer for settings. Galvo settings can't be found
through trial and error, due to the complexity and variety of
machine configuration. Settings that work on one laser may
destroy another.

If your settings were provided on a card, in an email, or in any
other way that doesn't work with the automatic importer, click 
Next when asked to import the EZCAD config to skip this step,
and enter your settings manually after adding the laser.

Go to Edit → Device Settings to open the Device Settings
window. From here, you can manually enter the settings
provided by the manufacturer in the Galvo and Basic Settings tab
and the Ports and Laser Settings tab.

Info

4.7.2 Manual Add a Galvo
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The Galvo and Basic Settings tab

The Ports and Laser Settings tab

Please note that when entering these settings manually, the 
Additional Settings tab needs to be updated with the correct
information for the simulation in Preview to function correctly. 

 Previous: Add a Laser

Next: Next: Connect to the Laser 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

LightBurn-Pro add-device configuration connection

devices galvo hardware import

4.7.2 Manual Add a Galvo
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4.8 First LightBurn Project

One of the best ways to learn to use Lightburn is to use it. We recommend following along with our laser-engraved QR Code WiFi coaster to
start exploring LightBurn. By the end, you'll be familiar with LightBurn's user interface and general workflow, and you'll have a coaster your
friends and family can scan to log into your WiFi network without needing to type anything in.

The video above shows the same project in an older version of LightBurn. The overall process is the same, but some tools will look a little
different, and the QR Code tool is replaced by the Bar Code tool.

Before you begin, familiarize yourself with your laser and how to operate it safely according to manufacturer instructions. Never run your
laser unsupervised.

4.8.1 What You'll Need

LightBurn installed on your computer.

A laser added to LightBurn.

Suitable material for the coaster. Our video uses laser-safe
plywood, but you can use any laser-safe material you have on
hand if you don't have that available.

Your WiFi information to enter into the QR Code.

4.8.2 LightBurn User Interface

Once LightBurn is installed and activated, you'll see LightBurn's 
Main Window. You can click on the image below to find out more
about any of the highlighted portions of the screen. 

Before you begin, we recommend that you make sure Beginner
Mode is active. If it is, you'll see (Beginner Mode) in the title bar
of the LightBurn window. You can turn on Beginner Mode by
going to Edit → Settings and turning on the setting for Beginner
Mode.

Your LightBurn window may not match the screenshot exactly.
LightBurn's user interface changes depending on what type of
laser is selected and whether Beginner Mode is active.

4.8.3 Designing Your Coaster

Moving Around the Workspace

As you're working on this project, you'll probably want to Zoom
In occasionally to take a closer look at your design. Scroll up and
down with the scroll wheel on a mouse – or use the equivalent
gesture on a trackpad – to zoom in and out. 

When you're zoomed in, you might not be able to see the entire
workspace on your screen. You can Pan by holding down the
scroll wheel or the Space  bar while moving the mouse.

You can always use Zoom to Page with the shortcut Ctrl /
Cmd + 0  to reset the zoom level to show the entire 

Workspace.

The Zooming and Panning page describes those tools in more
detail.

Create Text

You're going to start by creating text to engrave onto your
coaster. 

Click on the Text tool  in the Tools Toolbar.

Click in the Workspace to place a cursor and type something out.
Our demo coaster will say "WiFi", since that's what the QR Code will
be for.

• 

• 

• 

• 

Info

⌃

⌘

1. 

2. 

4.8 First LightBurn Project

- 36/400 - ©️ LightBurn Software, LLC

../../img/Icon-CreateEditText.png
../../img/Icon-CreateEditText.png


Find the Text Options Toolbar near the top of the screen above the
Workspace. When you have text selected, this toolbar becomes
active, and provides several options for modifying the selected text.
For this project, try the following steps:

Select a font you like from the Font dropdown. LightBurn can use
any font installed on your computer.

Adjust the size with the Height box.

When you're done typing, return to the Select tool by pressing 

Esc  or clicking the cursor icon  in the Tools Toolbar. You
can come back and edit the text later by double-clicking it with the
Select tool active.

Create a QR Code

LightBurn has a built-in Bar Code tool, which can generate QR
Codes as well as a variety of other scannable codes. You'll use
this to generate a QR Code that automatically logs someone into
your WiFi network.

Go to Tools → Create Bar Code to open the Bar Code tool. You'll see
the cursor change to a QR Code. Click and drag in the Workspace to
set the initial size of your QR Code and start creating it. Put it
somewhere near where you want it — you'll improve the placement
in the next step.

Make sure the Bar Code Type is set to QR Code and click on the 
WIFI Tab. 

Enter your WiFi login info into the window – be very careful with
your spelling and capitalization – and click OK to create the QR
Code. 

Adjust the size with the Width and Height boxes in the Numeric
Edits Toolbar. Make sure the lock icon is closed so the code's aspect
ratio is maintained as you make adjustments, and it doesn't get
distorted. Enter a size into either Width or Height — somewhere
between 40 and 60 mm is generally a good size.

3. 

• 

• 
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Aligning and Grouping

Now that you have text and a QR Code, you'll want them to line
up nicely. This is a great opportunity to try out the Align and 
Group tools.

New LightBurn installations start in Beginner Mode, which
simplifies the user interface by hiding less-used options.
Beginner Mode combines all of LightBurn's alignment tools into
the Align Tools Helper.

If you aren't in Beginner Mode, go to Arrange → Align → Align
V-Center for this step, or enable Beginner Mode in your 
Settings.

Make sure you have the Selection tool active by clicking on the 

 icon or pressing Esc .

Select the QR Code by clicking on it. Drag to place it where you
want it relative to the text. You can quickly spot selected objects by
looking for the animated "marching ants" pattern on the outline of
the shape.

With the QR Code still selected, hold down the Shift  key and
click on the text to select that as well.

Go to Arrange → Alignment Tools to open the Align Tools Helper,
which will preview different alignment options as you hover over

them. Use the bottom Align Centers button  to vertically
center both shapes.

With both objects still selected, press Ctrl / Cmd + G  to 
Group them. This way both shapes will move together without
having to remember to select them both. To move them
individually, you'll need to Ungroup them by selecting them and
pressing Ctrl / Cmd + U .

Layer Modes

Now we'll preview your design and edit your cut settings. We'll be
introducing the Preview function and the Cuts / Layers Window.

LightBurn offers Wireframe and Filled options for the View
Style. After setting Layer 0 to Fill, if you don't see the shape filled
in, you can use Alt  / Option + W  to toggle between
Wireframe and Filled view styles. Read more at View Style Types.

Open the Preview window with Alt / Option + P . This window
shows your design as it will be sent to the laser, and can even
simulate the engraving to estimate time and visualize what the
laser will be doing. Try pressing play to see how it works.

By default, your design will be on Layer 00 and set to Line Mode,
which means the laser will trace the outside of the shapes rather
than filling them in. Click on the dropdown under Modes and select
Fill. Next to Speed and Max Power, set appropriate speed and
power settings for the material you're using. Check your laser's
user guide for recommended settings.

Turn off the Air toggle to disable air assist for this layer. It's helpful
for cutting, but less useful for engraving.

No Alignment Tools Option?

1. 
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Preview the design again, and you should see the design filled in
instead of outlined.

Create a Decorative Border

With the QR Code and text ready to engrave, we'll move onto a
different style of engraving.

When you set Layer 00 to Fill, the preview shows that the laser
will move back and forth over the area to engrave, very much like
printing on paper. A raster engraving like this is the most
common way to engrave, but you can also engrave (or score) in 
Line Mode by using a lower power and higher speed than you
would use to cut through the material. This tends to be faster
and produce cleaner results on thin lines than a raster engraving.
It's particularly effective with single line fonts.

DRAW AND POSITION THE CIRCLE

Select the Ellipse tool  from the Tools Toolbar.

Click near the top left of your QR Code and text to start drawing the
circle. Drag toward the bottom right, holding down the Shift

key as you go to keep the width and height the same, and then
release to draw the circle. Don't worry too much about the exact
size and position yet.

Press Esc  to exit the Ellipse tool. This should leave the circle you
just drew selected. Hold down the Shift  key and click to select
the Grouped text and QR Code as well.

Center the circle around the rest of your design by going back to 
Arrange → Alignment Tools and choosing Align Center.

If you need to adjust the size of the circle, use the Width and 
Height boxes in the Numeric Edits Toolbar to adjust. You may need
to repeat Step 4 after doing this.

LAYERS AND CUT SETTINGS

When entering Speed values recommended by your laser's
manufacturer or other LightBurn users, make sure to use the 
same units of distance and time as those from the recommendation,
or to convert the values to your preferred units.

A given number of millimeters per second is much faster than
that same number in millimeters per minute. Mixing up units
can lead to reduction in power output due to unexpectedly high
speeds, or excessive power output — and even fire — due to
unexpectedly slow speeds. 

Change your displayed units in the Units and Grids tab of the 
Settings window. LightBurn automatically converts any existing
values when you switch between units.

Right now, your circle is on the same layer as the QR Code and
text. This means it'll be filled in like them as well. We'll need to
move it to a different layer and give it its own cut settings.

A filled shape inside of another filled shape will act as a cutout,
similar to a donut hole. We'll fix this in a moment. 

Make sure the circle – but nothing else – is selected.

At the bottom of the main window, look for the Color Palette. Select
a layer other than Layer 00 or the Tool Layers, T1 and T2.

In the Cuts / Layers Window, adjust the Speed and Max Power
settings to a higher speed and lower power than your
manufacturer recommends for cutting through the material you're
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⇧
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Always pay attention to units of distance and time
when entering Speed settings
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using. This will let you engrave (or score) a line without cutting
through.

Preview your design. Your QR Code and text should still be filled in,
but the circle should be just a line that the laser travels along.

Creating the Cut Line

The last piece of the design is the circle to cut out. You could do
the same thing we did for the previous step – draw a circle and
center it with the Alignment tools – but this is a wonderful
opportunity to get familiar with the Offset Shapes tool.

Make sure the circle is selected.

Go to Tools → Offset Shapes or press Alt / Option + O  to
open the Offset window.

Make sure the Direction is set to Outward and Optimize /
Simplify results is enabled. Adjust the Distance so that it looks
good to you – LightBurn will give you a live preview as you adjust it.
Somewhere around 6 mm or ¼" should work well, but this is your
coaster and it's up to you. Press OK to create the new circle.

As you did before with the first circle, move this circle to a different
layer and adjust the cut settings. See your laser's user guide for
recommended speed and power settings to cut through the
material you're working with.

4.8.4 Previewing Your Design

It can be tempting to start a design without previewing it,
especially when you're in a rush, but it's one of the best ways to
catch errors before you start burning your material.

Now that your design is complete, preview it one more time.
Remember that you can open the Preview window with Alt /

Option + P . Press play to preview what your laser will do. You
can use the slider at the bottom to speed up or slow down the
simulation.

In the simulation, you should see the following happen in order:

Raster engraving to fill in the text and QR Code.

Vector engraving the decorative border — the laser should follow
the outline of the circle.

Vector cutting the outer circle.

It's generally best to do engravings before cutting out your
design. If you followed along with the steps above, your layers
should already be in the right order. If they aren't, you can drag
them around in the Cuts / Layers Window to change the order –
by default, LightBurn will run each layer in order from top to
bottom.

If you make changes, preview them again before moving on to
cutting your design.

4.8.5 Engraving and Cutting Your Design

Now that you've created and previewed your design, it's time to
load material into your laser and begin cutting.

Since you'll be cutting through the material, make sure that
whatever is underneath your material is either scrap that you
don't mind burning into or won't be damaged by lasering. This
might be a thin sheet of aluminum, a honeycomb bed, or a piece
of scrap wood.

Focusing the Laser

Lasers need to be focused correctly to achieve good results. 

Place the material in the laser and move the head over the
material. LightBurn has jog controls in the Move Window to make
this easier.

Focus the laser according to your laser's user guide:

Diode lasers have a focusing spacer to set the distance between
the laser and the material.

CO2 lasers may require manual focusing with a focusing spacer or
may support auto-focus with the Focus Z button.
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Start From

LightBurn has three different Start From modes: Current
Position, User Origin, and Absolute Coordinates. For this
project, you'll be using Current Position.

To learn more about the different Start From modes in LightBurn,
check out the video below or go to Start From and Job Origin.

Set Start From to Current Position using the dropdown in the 
Laser Window.

Set the Job Origin in the Laser Window to the center of the
artwork.

With these two settings, your engraving will be centered
wherever the laser is positioned when you start the job.

Framing

Framing allows you to more accurately see where the design will
be engraved. Using either of the two Frame buttons commands
the laser head to travel around the outside of your design to
indicate where it will be engraved. The Frame button with a
rectangle will show the bounding box of the artwork, while the
other Frame button will travel in an irregular "rubber band"
border around the shape, following more closely around complex
shapes.

If your laser has a red dot pointer, it makes framing easier to see.
Otherwise, your laser will travel around with the laser turned off.
LightBurn does offer the ability to run diode lasers at a very low
power for the purpose of framing. To do this:

Go to Edit → Device Settings to open the Device Settings window.

In the Basic Settings tab, toggle on the Enable laser fire button
and Laser on when framing settings. Click OK to apply.

The Move Window should now have a Fire button and a box to
enter a power level. In our example we used 0.25% power. Keep
this value very low to avoid burning the material.

The Fire button will toggle the laser on and off. Now you can use
the Frame command with the laser visible.

Adjust the position of the material and/or the laser head until
you're happy with the layout of the design.

The Fire button should only be used for diode lasers, which
generally don't have a red dot pointer for Framing.

Always wear proper eye protection when Firing your laser.
Consult your laser's manufacturer for information on the proper
eye protection required for your laser.

This should never be used for a CO2 laser, which has an invisble
beam that could blind you or start a fire.

4.8.6 Running the Job

Press the Start button in the Laser Window to tell your laser to
begin running your project. 

If all goes well, you'll have a new coaster in a few minutes. 

Go and make more stuff!

If the result isn't what you were expecting, revisit previous steps
to make sure you followed them all, visit our Troubleshooting
section, join our forum to look for advice, or email us at 
support@lightburnsoftware.com.
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 Previous: Connect to the Laser

Next: Next Steps 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

get-started project
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4.9 Next Steps

If you've been following along, you've installed LightBurn, added a laser, and created your first project. At this point, you know enough to
explore LightBurn on your own, but we have some additional resources to help you continue getting familiar with LightBurn.

Collections

Collections of pages to
help you find the right
tools for your unique
goals.

LightBurn's YouTube
Channel

Our YouTube channel has
a variety of videos to help
you get familiar with what
LightBurn can do and how
to make it happen.

LightBurn Forum

Talk with other users and
LightBurn staff, see and
share finished projects,
and ask questions on our
forum.

 Previous: First LightBurn Project

For more help using LightBurn, please visit our forum to talk with LightBurn staff and users, or email support.

get-started

4.9 Next Steps
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5. Tools & Features

5.1 Tools and Features

Our reference pages are here to help you use all of LightBurn's tools and features.

If you know what tool you're looking for, you can search for it or use the navigation list on the left side of the page. If you know what you
want to do but not what tool you need, try looking through the collections below.

5.1.1 Essential Functions

File
Management

Selection Zoom
and Pan

Undo and
Redo

Clipboard Transform
Controls

Grouping Preview

5.1.2 Layout and Design

Creation Tools

Draw
Lines

Create
Primary
Shapes

Create
and Edit
Text

Variable
Text

Create
Bar
Code

Shape
Properties

Measure Art
Library

Editing

Numeric
Edits
Toolbar

Edit
Nodes

Scissor/
Trim
Tool

Convert
to Path

Auto-
join
Selected
Shapes

Close
Path

Break
Apart

Optimized
Selected
Shapes

Warp
and
Deform

Modifying and Combining

Mirror Offset
Shapes

Boolean
and Weld
Operations

Cut
Shapes

Grid
Array

Circular
Array

Copy
Along
Path

Apply
Path
to
Text

Radius/
Fillet
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Make
Same
Width/
Height

Resize
Slots

Arrangement

Align Distribute Docking

Move
Selected
Objects

Nest
Selected

Image Tools

Adjust
Image

Masking Convert
to
Bitmap

Save
Processed
Bitmap

Trace
Image

Image
Options

5.1.3 Laser Control

Cut Settings

Cuts/
Layers
Window

Cut
Settings
Editor

Line

Fill Offset
Fill

Image

Tabs Kerf
Offset

Perforation
Mode

Lead
In/Out

Galvo
Timing

Dot Width
Adjustment

Output and Positioning

Laser
Window

Coordinates,
Origin, and
Start From

Move/
Jog

Framing Optimization
Settings

Cut
Selected/
Use
Selection
Origin

Position
Laser

Set Start
Point

Quality Optimization

Material
Test

Focus
Test

Interval
Test

Material
Library
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Modes and Advanced Control

Print
and
Cut

Rotary
Mode

Repeat
Marking

Feeder
Setup

Center
Finder

Cylinder
Correction

Taper
Warp

Galvo
Lens
Calibration

Machine Management

Machine
Settings

Console
Window

File
List
Window

5.1.4 Camera

Camera
Selection
Helper

Camera
Installation
and Focusing

Camera
Window

Camera
Calibration

Camera
Alignment

Save
Background
Capture

Head
Mounted
Camera

Camera
Troubleshooting

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

_index

5.1.4 Camera
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5.2 User Interface

5.2.1 Main Window

Below is the default layout of the full LightBurn window, for a
GCode-based device. This layout will be slightly different
depending on the type of laser you're working with.

For information on rearranging the layout, see Customizing the
LightBurn Window.

For a full list of available windows and toolbars, see Window
Menu.

Click any UI element in the image below to go directly to the
relevant page for that element, or scroll down for a list of
elements.

A: Workspace / Edit Window

B: Menus

C: Main Toolbar

D: Arrange Toolbar

E: Numeric Edits Toolbar

F: Text Options Toolbar

G: Modes Toolbar

H: Docking Toolbar

I: Tools Toolbar

J: Modifiers Toolbar

K: Cuts / Layers Window

L: Move Window

M: Console Window

N: Laser Window

O: Material Library Window

P: Color Palette

Q: Transform Control Toggles

R: Status Bar

Workspace / Edit Window

The area where you create, adjust, modify, and arrange artwork
in LightBurn.

See Workspace for more information.

Menus

Contains all of LightBurn's top-level menus. Individual menus
contain a wide range of tools and features. 

See Menu Toolbar for a full list of top-level menus.

Main Toolbar

Contains functions for opening or importing files, saving, using
the clipboard (copy and paste), moving or zooming the view.

See Main Toolbar for more information.

Arrange Toolbar

Contains tools for positioning objects, both on an individual
basis, and in relation to each other. 

See Arrange Toolbar for more information.

Numeric Edits Toolbar

Contains options for adjusting the size, position, and orientation
of shapes or groups of shapes in your project.

See Numeric Edits Toolbar for more information.

Text Options Toolbar

Contains options for adjusting attributes of Text Objects,
including, Font, size (Height), spacing (HSpace and VSpace), and
more.

See Create and Edit Text — Text Options Toolbar for more
information.

5.2 User Interface
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Modes Toolbar

Contains buttons to open dialog windows or wizards for
advanced lasering processes. 

See Modes Toolbar for more information.

Docking Toolbar

Contains tools to move selected objects left, right, up, or down,
until they meet the edge of the Workspace or another object.

See Docking for more information.

Tools Toolbar

Contains tools for selecting objects in your Workspace, or
creating Primary Shapes, text, lines, and more.

See Tools Toolbar for a full list of tools.

Modifiers Toolbar

Contains tools for combining, altering, and producing arrayed
duplicates of graphics.

See Modifiers Toolbar for a full list of tools.

Cuts / Layers Window

Shows the layers currently assigned to graphics in your design,
and lets you alter common Cut Settings, or double-click to access
additional settings.

See Cuts / Layers Window for more information.

Move Window

Provides buttons to jog and position your laser, along with
additional options for users with GCode-based lasers.

See Move Window for more information.

Console Window

Available for GCode-based lasers only.

Displays messages from your laser's controller and commands
sent to it by LightBurn. You can also input direct commands to
your laser through this window. 

See Console Window for more information.

Laser Window

The hub for setting up and selecting a laser, Framing and Starting
jobs, determining job positioning, and more.

See Laser Window for more information.

Material Library

Provides a place to store, organize, and apply preset Cut Settings
for different operations and materials.

See Material Library for more infomration.

Color Palette

Contains the colors/layers that you can assign to individual
graphics in LightBurn. Use these colors/layers to assign different
kinds of operations and settings to the shapes in your design.

See Color Palette for more information.

Transform Control Toggles

Switches that enable and disable specific types of editing across
an entire project, in order to prevent accidental edits, such as
inadvertently scaling a design that contains strict sizing, or
moving tightly nested parts.

See Transform Control Toggles for more information.

Status Bar

Provides contextual information related to the active tool or
process being performed.

See Status Bar for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI default-layout first-steps main-window

windows-and-toolbars

Note

5.2.1 Main Window
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5.2.2 Arrange Menu

The Arrange Menu contains tools for positioning objects, both
on an individual basis, and in relation to each other. It also
contains tools for moving the physical laser in relation to objects
within your project. 

Click any option in the image below to go directly to the relevant
page for that tool, or scroll down for a list of options and
descriptions.

Group

Ctrl  / Cmd  + G

Combines multiple objects into a single entity, allowing you to
move, resize, and manipulate them as though they were one
object. 

See Grouping for more information.

Ungroup

Ctrl  / Cmd  + U

Splits Groups back into the individual objects that make them up.

See Grouping for more information.

AUTO-GROUP

Groups objects that fall within the boundaries of a closed shape
together with the outermost shape.

See Auto-Group for more information.

Flip Horizontal / Vertical

Flip Horizontal — Mirrors objects along the X Axis.

Shift  + Ctrl  / Cmd  + H

Flip Vertical — Mirrors objects along the Y Axis. 

Shift  + Ctrl  / Cmd  + V

See Mirror Tools for more information.

Mirror Across Line

Shift  + Ctrl  / Cmd  + M

Flips objects along a selected line. 

See Mirror Tools — Mirror Across Line for more information.

Rotate 90° Clockwise / Counter-Clockwise

Rotate 90° Clockwise — Rotates the object to the right by 90°.

.

Rotate 90° Counter-Clockwise — Rotates the object to the
left (anti-clockwise) by 90°. 

,

See Transform Controls — Rotate for more information.

Two-Point Rotate / Scale

Ctrl  / Cmd  + 2

Rotates and resizes objects around custom pivot points in your 
Workspace. 

See Two-Point Rotate / Scale for more information. 

Align

Repositions objects according to their edges or centers. 

See Align for more information. 

Distribute

Evenly spaces objects either vertically or horizontally, spaced
from their centers or edges.

See Distribute for more information. 

⌃ ⌘

⌃ ⌘

• 

⇧ ⌃ ⌘

• 

⇧ ⌃ ⌘

⇧ ⌃ ⌘

• 

• 
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DISTRIBUTE → MOVE TOGETHER

Arranges objects so that their edges abut along horizontal or
vertical planes.

See Distribute — Move Together for more information. 

Nest Selected

Arranges objects to minimize material waste using an online
service.

See Nest Selected for more information. 

Dock

Moves selected objects left, right, up, or down, until they meet
the edge of the Workspace or another object.

See Docking for more information. 

Move Selected Objects

Moves objects to a corner, midpoint, or center of your 
Workspace. If you have a Gantry style laser, it can also move
selected objects to the last reported position of your laser head.

See Move Selected Objects for more information. 

Move Laser to Selection

Moves your laser in its physical work area to a location that
corresponds to a position on your current selection in your
LightBurn Workspace.

See Move Laser to Selection for more information. 

MOVE LASER TO SELECTION → JOG LASER

Moves the laser by the amount specified in the Move Window, in
a chosen direction.

See Move Window — Jogging for more information. 

Grid Array

Creates copies of an object (or objects) in regularly spaced rows
and columns, and includes options to adjust spacing, mirror the
shapes, randomize orientation, and more.

See Grid Array for more information. 

Circular Array

Arranges multiple copies of an object — or multiple objects — in
a radial pattern around either a point in space, or a central
object.

See Circular Array for more information.

Copy Along Path

Creates duplicates of an object that follow the contour of a path. 

See Copy Along Path for more information.

Create Rubber-Band Outline from Selection

Makes a new shape outlining the graphics in your current
selection. The new shape is defined as the shortest possible path
that can contain all graphics in your selection, as if a rubber band
were stretched around them.

See Create Rubber-Band Outline for more information. 

Break Apart

Alt  / Option  + B

Separates paths into their constituent lines and curves.

See Break Apart for more information. 

Push in Draw Order

Changes the order of objects in the draw order, which affects the
visual appearance of graphics in your Workspace, when using a 
Wireframe View Style.

See Push in Draw Order for more information.

Lock Selected Shapes / Unlock Selected Shapes

Lock Selected Shapes prevents editing of selected objects. 

Unlock allows them to be edited once again.

See Lock Shapes for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI arrangement layout-and-design
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5.2.3 Arrange Toolbars

The Arrange Toolbars each contain a selection of tools found in
the Arrange menu, that are broadly used for positioning objects.

The toolbars come in a long version, for high-resolution screens,
and a shorter one, with sub-menus to fit on smaller screens. 

Accessing the Arrange Toolbars

The Arrange Toolbar is located near the center of the top
toolbar in LightBurn by default, to the right of the Main Toolbar.

If you have closed the Arrange Toolbar, go to Window → Arrange
to re-enable it. 

To restore it and all other toolbars and windows to their default
positions, go to Window → Reset to Default Layout.

To enable the Arrange (long) Toolbar, go to Window → Arrange
(long).

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Arrange Toolbar Options

Click any button in the images below to jump to information on
that tool, or scroll down for a list of options and descriptions.

GROUP AND UNGROUP 

Combines multiple objects into a single entity, allowing you to
move, resize, and manipulate them as though they were one
object.

See Grouping for more information.

FLIP OR MIRROR 

Flips objects across their vertical or horizontal centers, or a
custom-selected line.

See Mirror Tools for more information.

ALIGN 

Repositions multiple objects in relation to the last object
selected, according to their edges or centers. 

See Align for more information. 

MAKE SAME WIDTH OR HEIGHT 

Resizes the selected object to match the width or height of the
last object selected.

See Make Same Width or Height for more information.

DISTRIBUTE 

Evenly spaces objects either vertically or horizontally, spaced
from their centers or edges.

See Distribute for more information. 

MOVE SELECTED OBJECTS 

Moves objects to a corner, midpoint, or center of your 
Workspace. If you have a Gantry style laser, it can also move
selected objects to the last reported position of your laser head.

See Move Selected Objects for more information. 

MOVE SELECTED OBJECTS / MOVE LASER TO SELECTION DROPDOWN 

This button opens a dropdown menu containing all the Move
Selected Objects and Move Laser to Selection options.

Tip
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For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI arrangement layout-and-design
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5.2.4 Color Palette

In LightBurn, different colors indicate different layers. These
colors don't represent the final product's colors but instead
differentiate each operation needed to complete the job. 

Use the Color Palette to assign colors/layers to graphics in your 
Workspace. A common convention is to use bright red for cuts
and black for engravings, but how you use the colors/layers is up
to you.

After assigning colors to your graphics, you can adjust their layer
settings in two places:

Cuts / Layers Window — where you can re-order layers and
change critical settings. 

Cuts Settings Editor — which contains the full suite of settings
available for adjustment.

Accessing the Color Palette

The Color Palette is located along the bottom of the Main
Window by default, though a common alternative is docking it
along the left side of the Workspace.

The colors currently used in your design will also appear as
entries in the Cuts / Layers Window, where you can choose the
operations that each color represents.

If you have closed the Color Palette, go to Window → Color
Palette to re-enable it.

To restore it and all other toolbars and windows to their default
positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Change the Color for New Objects

With nothing selected
in your Workspace, click
a color entry.
Subsequent new
shapes will be created
in that color, and
assigned to the
corresponding layer in
the Cuts / Layers
Window.

Change the Color of Existing Objects

With the objects already
selected, click a color

entry to switch them to that color, and assign them to the
corresponding layer in the Cuts / Layers Window. 

Tool Layers

There are two colors/layers at the end of the palette labeled T1
and T2. These refer to Tool layers — special layers that have no
cut parameters and will never be output to the laser. 

Use Tool layers to create non-output shapes in your designs. For
example you can use them to:

Describe the boundary of your material

Create guidelines for aligning shapes

Apply a Path to Text without the path being output

Apply a Mask to an Image

Importing Graphics from Other Software

When importing graphics, LightBurn will attempt to match the
colors used in that file to the default LightBurn Color Palette.
Use exact matches for the colors used by LightBurn to ensure
layers are assigned properly. 

DOWNLOADABLE COLOR PALETTES

We have color palettes available for Inkscape, CorelDRAW,
Affinity Designer, and Adobe Illustrator. The .ase  file provided for
Adobe and Affinity products can be imported into many other
programs as well.

Download .gpl for Inkscape/GIMP

Download .xml for Corel Products

Download .ase for Adobe and Affinity

Please see your preferred program's documentation for
directions on installing color palettes.

RGB AND HEX CODES FOR THE LIGHTBURN COLOR PALETTE

The table below contains RGB and hex values for each of
LightBurn's layer colors. You can use it to assign the right color
for any software that doesn't support the above files. 

• 

• 

Tip

• 

• 

• 

• 

Layer RGB Values Hex Values

00 rgb( 0, 0, 0) #000000

01 rgb( 0, 0, 255) #0000FF

02 rgb( 255, 0, 0) #FF0000

03 rgb( 0, 224, 0) #00E000

04 rgb( 208, 208, 0) #D0D000

05 rgb( 255, 128, 0) #FF8000

06 rgb( 0, 224, 224) #00E0E0

07 rgb( 255, 0, 255) #FF00FF

08 #B4B4B4
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Related Topics

Cuts Settings Editor

Cuts / Layers Window

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI

rgb( 180, 180,
180)

09 rgb( 0, 0, 160) #0000A0

10 rgb( 160, 0, 0) #A00000

11 rgb( 0, 160, 0) #00A000

12 rgb( 160, 160, 0) #A0A000

13 rgb( 192, 128, 0) #C08000

14 rgb( 0, 160, 255) #00A0FF

15 rgb( 160, 0, 160) #A000A0

16 rgb( 128, 128,
128)

#808080

17 rgb( 125, 135,
185)

#7D87B9

18 rgb( 187, 119,
132)

#BB7784

19 rgb( 74, 111,
227)

#4A6FE3

20 rgb( 211, 63,
106)

#D33F6A

21 rgb( 140, 215,
140)

#8CD78C

22 rgb( 240, 185,
141)

#F0B98D

23 rgb( 246, 196,
225)

#F6C4E1

24 rgb( 250, 158,
212)

#FA9ED4

25 rgb( 80, 10, 120) #500A78

26 rgb( 180, 90, 0) #B45A00

27 rgb( 0, 71, 84) #004754

28 rgb( 134, 250,
136)

#86FA88

29 rgb( 255, 219,
102)

#FFDB66

T1 rgb(243, 105,
38)

#F36926

T2 rgb(12,150, 217) #0C96D9

• 

• 
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5.2.5 Edit Menu

The Edit Menu contains tools for selecting and manipulating
objects, in addition to program, device, and machine settings.

Click any option in the image below to go directly to the relevant
page for that tool, or scroll down for a list of options and
descriptions.

On macOS, Settings are accessible in the LightBurn menu,
labeled as Preferences, or by pressing Cmd  + ,

Undo

Ctrl / Cmd + Z

Reverses previous actions taken, starting with the most recent
action taken, and proceeding to previous actions with successive
Undos. 

See Undo/Redo for more information.

Redo

Ctrl / Cmd + Shift + Z

Restores actions previously reversed using Undo, starting with
the most recent action Undone, and proceeding to previous
reversed actions with successive Redos. 

See Undo/Redo for more information.

Note for macOS users

⌘

⌃ ⌘

⌃ ⌘ ⇧

5.2.5 Edit Menu

- 55/400 - ©️ LightBurn Software, LLC

../../../img/Ref-EditMenu-macOSPreferencesInMenu.png
../../../img/Ref-EditMenu-macOSPreferencesInMenu.png


Select All

Ctrl / Cmd + A

Selects all objects in your Workspace.

See Selection Tools for more information.

Invert Selection

Ctrl / Cmd + Shift + I

Deselects all objects that are currently selected and selects all
objects that are not currently selected.

See Selection Tools for more information.

Cut

Ctrl / Cmd + X

Deletes selected objects while copying them to clipboard at the
same time. 

See Clipboard Tools for more information.

Copy

Ctrl / Cmd + C

Saves a copy of selected objects to your computer's clipboard
(temporary storage location).

See Clipboard Tools for more information.

Duplicate

Ctrl / Cmd + D

Create duplicates of selected objects directly on top of the
existing objects.

See Clipboard Tools for more information.

Paste

Ctrl / Cmd + V

Inserts objects that are copied to your clipboard (temporary
storage location) into your. Pasted objects are centered at the
location of the cursor at the time of pasting. 

See Clipboard Tools for more information.

Paste in Place

Inserts objects copied to your clipboard (temporary storage
location) into your Workspace, and positions them according to
their location in the project they were copied from. 

See Clipboard Tools for more information.

Delete

Del

Deletes selected objects, removing the from your Workspace.

See Clipboard Tools for more information.

Convert to Path

Ctrl / Cmd + Shift + C

Converts squares, ellipses, polygons, text, or QR codes created
using LightBurn's Creation Tools into editable paths made up of
lines, curves, and nodes.

See Convert to Path for more information.

Convert to Bitmap

Ctrl / Cmd + Shift + C

Converts selected vector graphics into a bitmap image.

See Convert to Bitmap for more information.

Close Path

Connects a shape with one start and one end node by creating a
new line between them. The existing start and end nodes must
be within .5 mm of one another.

See Close Path for more information.

Close Selected Paths With Tolerance

Opens a dialog window to close selected paths with one start and
one end node within a specified distance apart from one another,
and to move their ends together or join them with lines.

See Close Selected Paths with Tolerance for more information.

Auto-Join Selected Shapes

Alt / Option + J

Joins many disconnected line segments together at once, if the
segments' end points are almost touching (within .05 mm of one
another).

See Auto-Join Selected Shapes for more information.

Optimize Selected Shapes

Alt / Option + Shift + O

Smooths selected shapes or fits them to arcs or lines. The dialog
box allows you to set your tolerance for how much deviation
from the original shape is acceptable. 

See Optimize Selected Shapes for more information.

⌃ ⌘

⌃ ⌘ ⇧

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌦

⌃ ⌘ ⇧

⌃ ⌘ ⇧

⎇ ⌥

⎇ ⌥ ⇧
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Delete Duplicates

Alt / Option + D

Deletes duplicated objects (objects with identical shapes, sizes,
and positions) in your Workspace.

See Delete Duplicates for more information.

Select Open Shapes

Selects all shapes in the Workspace that are open, meaning they
are not paths that form a closed, continuous loop but, instead,
have start and end points that are different from one another.

See Selection Tools for more information.

Select Open Shapes Set to Fill

Selects all shapes assigned to a layer set to Fill or Offset Fill mode
that are open, meaning they are not closed, continuous loops
but, instead, have start and end points that are different from
one another.

See Selection Tools for more information.

Select All Shapes in Current Layer

Selects all shapes in the active layer in the Cuts / Layers window.

See Selection Tools for more information.

Select Contained Shapes

Selects all shapes contained by the currently selected shape. The
currently selected shape remains in the resulting selection.

See Selection Tools for more information.

Select Shapes Smaller Than Selected

Selects all shapes that are smaller than the currently selected
shape. Currently selected shape remains in the resulting
selection. 

See Selection Tools for more information.

Image Options

Provides a set of tools for updating and changing imported
images.

See Image Options for more information.

REFRESH IMAGE

Reloads the selected image file. Useful if an imported image file
has been updated.

REPLACE IMAGE

Replaces the selected image with a different image file.

REPLACE IMAGE TO FIT

Replaces the selected image with a different image file, adjusting
the size of the new image to fit in the same space as the original
image.

Settings

View and edit general, device-independent LightBurn settings.

On macOS, Settings are accessible in the LightBurn menu,
labeled as Preferences, or by pressing Cmd  + ,

See Settings/Preferences for more information.

Device Settings

View and edit device-specific settings for the currently active
device. The contents of this window vary depending on the
device in use.

See Device Settings for more information.

Machine Settings

View and edit device parameters for lasers with supported
controllers.

See MachineSettings for more information.

Get Controller Info

Reads firmware version and usage statistics from supported
laser controllers and displays the information.

See Get Controller Info for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

⎇ ⌥

Note for macOS users

⌘
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5.2.6 File Menu

The File Menu contains tools for creating, opening, and saving
projects; importing designs and images; and changing, saving, 
exporting, or importing your LightBurn preferences.

Click any option in the image below to go directly to the relevant
page for that tool, or scroll down for a list of options and
descriptions.

New

Ctrl  / Cmd + N

Clears your current LightBurn project and starts a new, blank
project.

See File Management — New for more information.

New Window

Opens a separate instance of LightBurn in a new window,
allowing you to edit multiple projects at once, or edit one file
while cutting a different one.

See New Window for more information.

LightBurn will automatically save the current preferences and
settings of the most recently closed window — overriding any
changes made in other windows.

See Multiple Independent LightBurn Instances for more
information on running two completely independent LightBurn
instances.

Recent Projects

View a running list of up to 24 projects recently opened in
LightBurn.

See File Management — Recent Projects for more information.

Open

Ctrl  / Cmd + O

Opens LightBurn project files saved in .lbrn or .lbrn2 format.

Click on the dropdown in your system's file browser to show all
supported file types, including supported image and vector file
types.

Selecting a supported image or vector file instead of a project
file will create a new LightBurn project, replacing the currently
loaded project. Use Import to bring artwork files or designs into
an existing project.

See File Management — Open for more information.

Import

Ctrl  / Cmd + I

Adds additional artwork, designs, and objects stored in a range
of file formats to an existing, open project.

See File Management — Import for more information.

Show Notes

Ctrl  / Cmd  + Alt / Option + N

⌃ ⌘

Note

⌃ ⌘

Warning

⌃ ⌘

File Type Files

LightBurn
Project Files

.lbrn2, .lbrn

MillMage
Project Files

.mage

Image Files .bmp, .jpg, .pg, .gif, .tif, .tiff, .tga, .webp

Vector Files .ai, .pdf, .dxf, .nc, .hpgl, .svg

Additional Files .gc, .gcode, .plt, .rd, .sc, .scpro2,

⌃ ⌘ ⎇ ⌥

5.2.6 File Menu

- 59/400 - ©️ LightBurn Software, LLC



Store and view project-specific notes and comments.

See Show Notes for more information.

Save

Ctrl + S

Saves the current project for later editing and production. Saving
a file saves it under the current file name. Saving a file without an
existing name will open a Save Project window.

See File Management — Save for more information.

Save As

Ctrl  / Cmd + Shift + S

Saves the current project under a different file name.

See File Management — Save As for more information.

Save Machine Files

Alt / Option + Shift + L

This option will change depending on the type of laser you're
using — it may say Save GCode (for GRBL, Smoothieware, or
Marlin controllers), Save RD File (Ruida), Save OUT File
(TopWisdom), or Save UD5 File (Trocen).

All options save your current project as a machine-ready file, in
the appropriate format for your type of laser. You can transfer
this file to your machine to run it without ever having to directly
connect using LightBurn.

See Laser Window — Save Machine Files for more information.

Export

Alt / Option + X

Exports currently selected graphics in .ai , .svg , or .dxf  format.
If there is nothing in your current selection, the entire contents
of your current project will be Exported.

See File Management — Export for more information.

Preferences

See Preferences Submenu for more information.

IMPORT PREFS

Import previously copied or exported .lbprefs  LightBurn
preference files.

A new project is required to import .lbprefs  LightBurn
preference files.

EXPORT PREFS

Export the current LightBurn preferences.

OPEN PREFS FOLDER

Opens the folder on your computer containing the LightBurn
preferences files, created automatically at program close or
when settings are changed. Only the latest 50 preference backup
files are preserved.

Windows LightBurn Preferences Folder

%localappdata%/LightBurn C:\Users\username\AppData\Local\LightBurn

LOAD PREFS BACKUP

Import a built-in LightBurn preferences back up file.

Windows LightBurn Preferences Backup Folder

%localappdata%/LightBurn/backup C:
\Users\username\AppData\Local\LightBurn/backup

EDIT HOTKEYS

Create and change the keyboard shortcuts of many LightBurn
functions and commands in the Hotkey Editor.

See Hotkey Editor for more information.

Bundles

Bundles simplify the process of migrating LightBurn by bundling
everything that needs to be moved into a single .lbzip  file.

Bundles can include:

LightBurn Settings

Custom Hotkeys

Image Presets

Devices

Material Libraries

Art Libraries

See the User Bundles for more information.

IMPORT BUNDLES

Load previously exported Bundles into the current instance of
LightBurn. Any component contained within the bundle that your
computer detects is already present will be grayed out and
unavailable on import. Devices can be imported even if already
present, and will create a new copy of the device. Bundles can
also be imported by dragging the .lbzip  file into LightBurn.

EXPORT BUNDLE

Create a Bundle of LightBurn settings, laser devices, Material and
Art libraries, and more.

Print (black only)

Ctrl  / Cmd + P

Output a black and white document to a printer or built-in "Print
to PDF" tool. This document is saved exclusively in black and
white.

⌃

⌃ ⌘ ⇧

⎇ ⌥ ⇧

⎇ ⌥

Note

• 

• 

• 

• 

• 

• 

⌃ ⌘
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See Print for more information.

Print (keep colors)

Ctrl  / Cmd + Shift + P

Output a document to a printer or built-in "Print to PDF" tool.
This document is saved with the assigned colors in the current 
Color Palette.

See Print for more information.

Saved Processed Bitmap

Exports a copy of an adjusted bitmap.

See Save Processed Bitmap for more information.

Save Background Capture

Saves a bitmap image of a Workspace Overlay produced by a
camera affixed over your laser's work area.

See Save Background Capture for more information.

Exit

Ctrl  / Cmd + Q

Completely close and exit LightBurn. You will be prompted to
save the current project if there are any unsaved changes,
discard any changes and close without saving them, or cancel
the process of closing LightBurn.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI file-management file-menu migration

settings-and-preferences user-bundles

⌃ ⌘ ⇧

⌃ ⌘
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5.2.7 Help Menu

The Help Menu contains links to documentation and
instructional videos; information on your LightBurn license and
version; and tools for troubleshooting software issues. 

Click any option in the image below to jump to more information,
or scroll down for a list of options and descriptions.

About LightBurn

Opens the Help and Notes window, where additional
information on keyboard shortcuts, a few general LightBurn tips,
and important program build/version data is listed.

See Help and Notes for more information.

LightBurn Support Forum

Get help with LightBurn from the developers, support staff, and
other users. Join the community to share projects, discuss
hardware and software settings, and learn how to get the most
out of LightBurn.

Access the LightBurn forum at: Forum.LightBurnSoftware.com.

Quick Help and Notes

F1

Opens the Help and Notes window, directly to the Hotkeys tab,
which features a small partial list of mouse gestures, keyboard
shortcuts, and other hotkey tips.

See Help and Notes for more information.

Online Documentation

Find guides and detailed information on getting the most out of
LightBurn. If you're reading this, you're already here!

PDF Documentation Link

View the current printable PDF of the LightBurn documentation.

This menu entry will always point to the latest copy of the
LightBurn documentation PDF.

Online Video Tutorials

Access a curated list of tutorial videos from a library of over a
hundred helpful guides at LightBurnSoftware.com.

View the full library of LightBurn tutorial videos on YouTube.

CorelDRAW Macro Setup Help

Simplify and speed up the process of sending work out of
CorelDRAW to LightBurn on Windows-based computers.

See CorelDRAW Macro Setup for more information.

Generate Support Data

Generates encoded data that helps the LightBurn support team
answer your questions.

See Generate Support Data for more information.

Camera Selection Help

Opens a window to help select an appropriate camera for your
laser based on machine size and mounting height.

See Camera Selection Help for more information.

Check for Updates

Checks whether there is a more recent version of LightBurn
available than the version currently running, and whether it was
released within your license's valid update period.

See Check for Updates for more information.

License Management

Opens the License Page, where you can activate or deactive your
license, and see the number of days remaining in your license's
update period.

See License Management for more information.

Enable Debug Log

Begins recording a log saved to the My Documents folder on
Windows or Documents on macOS, to aide in troubleshooting
and bug fixing when communicating with LightBurn support.

See Enable Debug Log for more information.
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Debug Drawing

Activates the internal tool that shows the bounds of shapes
being drawn in the Workspace, to aid LightBurn developers in
troubleshooting and debugging.

See Debug Drawing for more information.

Convert to Cut (Debug)

Activates the internal tool that converts selected shapes into the
cuts that would be sent to a laser, and makes a new shape from
the result.

Do not use this tool unless directed to do so by a LightBurn
developer or support agent.

See Convert to Cut for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

CorelDRAW UI build-date convert-to-cut debug

documentation forum help help-and-notes

help-menu hotkeys keyboard-shortcuts

license-management support support-data version

video-tutorials

Warning
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5.2.8 Language Menu

Change the LightBurn program interface language by selecting
between 25 supported translations. The currently selected
language is indicated by a dot next to the language in the list.
English (United States) is enabled by default.

See Create and Edit Text — Text Settings for information on
additional text settings. The Right-To-Left setting will
automatically be enabled when the current program language is
set to Arabic or Hebrew.

The Right-To-Left text setting will automatically be enabled in
your Settings when the current program language is set to
Arabic or Hebrew.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

RTL UI languages localization preferences

right-to-left-text settings
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5.2.9 Laser Tools Menu

The Laser Tools menu contains tools, tests, and step-by-step
wizards for performing advanced lasering operations, dialing in
settings to optimize product quality, and setting up accessory
hardware. 

You'll see different menu options depending on the type of laser
you have selected. 

Click any option in the images below to go directly to the relevant
page for that tool, or scroll down for a list of options and
descriptions.

The Laser Tools Menu for Gantry style lasers (GCode and DSP)

The Laser Tools Menu for Galvo style lasers

Print and Cut

Aligns your current LightBurn project to target locations in a
previously output design. Using Print and Cut requires a properly
homed Gantry style laser with an accurate motion system. 

See Print and Cut for more information.

Calibrate Camera Lens

Corrects for camera lens distortion when producing a camera
overlay for the LightBurn Workspace.

See Camera Lens Calibration for more information.

Calibrate Camera Alignment

Aligns a pre-processed camera capture to the LightBurn 
Workspace and laser coordinate system by engraving and
tagging target markers. 

See Calibrate Camera Alignment for more information.

Rotary Setup

Ctrl / Cmd + Shift + R

Rotaries are used to turn cylindrical objects so that their surfaces
can be marked by a laser. In order to use your laser with a rotary,
you must first establish several important parameters in the 
Rotary Setup window that control the rotary's motion and adjust
the output sent to your laser.

For more information on using a rotary with your type of laser,
see:

Rotary Mode (DSP)

Rotary Mode (GCode)

Rotary Mode (Galvo)

Feeder Setup

Opens the Auto-feed settings dialog to set up auto-feeder
controls for lasers with Ruida or Trocen controllers and auto-feed
devices. 

See Feeder Setup for more information.

Cylinder Correction Setup

Warps the output of your design to correct for the expansion that
happens when you mark on a cylindrical object, like a cup or
tumbler, allowing you to mark cylindrical objects with a Galvo
style laser, without using a rotary.

See Cylinder Correction for more information.

Repeat Marking

Enables the use of a Rotating or Linear axis table with Galvo
lasers, to move parts past a laser while running repetitions of
identical jobs.

See Repeat Marking for more information

Focus Test

Use the Focus Test setup dialog to set parameters and generate
a test pattern to identify optimal focal height. Requires a
machine with a mechanized, controllable Z Axis. 

⌃ ⌘ ⇧

• 

• 

• 
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See Focus Test for more information.

Interval Test

Generates a test pattern to identify the optimal Line Interval for
engraving at a given combination of Speed and Power.

See Interval Test for more information.

Material Test

Generates a test grid of varying combinations of two selected
variables. Testable variables are device-dependent, and include 
Speed, Power, Interval, Passes, Frequency, and Q-Pulse.

See Material Test for more information.

Center Finder

Finds the center of a circular object in the laser's physical work
area, by aligning the laser to three points on the object. Can also
be used with any object whose shape can be described with a
circle diameter.

See Center Finder for more information.

Taper Warp

Adjusts a design to compensate for the difference in diameter
between the top and bottom of a cylindrical object, when
engraving using Rotary Mode or Cylinder Correction.

See Taper Warp for more information.

Calibrate Galvo Lens

Marks a test pattern that is then measured and input into
LightBurn, to compensate for distortion effects from a new or
uncalibrated Galvo lens. 

See Calibrate Galvo Lens for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI advanced-control camera camera-alignment

camera-calibration center-finder cylinder-correction

feeder feeder-setup focus-test interval-test

laser-control modes optimization print-and-cut

quality repeat-marking rotary rotary-setup

taper-warp
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5.2.10 Main Toolbar

The Main Toolbar contains tools for creating, opening, and
saving projects; copying, pasting, and deleting graphics;
accessing your LightBurn preferences and Device Settings; and
more.

Accessing the Main Toolbar

The Main Toolbar is located on the left side of the top toolbar in
LightBurn by default, to the left of the Arrange Toolbar.

If you have closed the Main Toolbar, go to Window → Main to re-
enable it. 

To restore it and all other toolbars and windows to their default
positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Main Toolbar Options

Click any option in the image below to go directly to the relevant
page for that tool, or scroll down for a list of options and
descriptions.

FILE MANAGEMENT

See File Management for more information on New, Open, Save,
and Import.

New 

Ctrl / Cmd + N

Creates a new file. A new, unnamed project will replace any
existing projects loaded in the LightBurn workspace.

Open 

Ctrl / Cmd + O

Opens a file. The dialog box filters for .lbrn  and .lbrn2
LightBurn files by default. Click on the dropdown to show all
supported file types, including supported image and vector file
types.

Selecting a supported image or vector file instead of a project
file will create a new LightBurn project, replacing the currently
loaded project. Use Import to bring artwork files or designs into
an existing project.

Save 

Ctrl / Cmd + S

Saves your current project in .lbrn  or .lbrn2  format.

Import 

Ctrl / Cmd + I

Loads graphics from a variety of file formats into LightBurn. 

UNDO AND REDO 

Reverse or reapply past actions and design changes in LightBurn.

See Undo/Redo for more information.

CLIPBOARD TOOLS

See Clipboard Tools for more information on Copy, Cut, Paste,
and Delete.

Copy 

Ctrl / Cmd + C

Saves a copy of selected objects to your clipboard.

Cut 

Ctrl / Cmd + X

Deletes selected objects in your Workspace while saving a copy
of them to your clipboard at the same time. 

Paste 

Ctrl / Cmd + V

Inserts objects copied to your clipboard into your Workspace.
Pasted objects are centered at the location of your cursor at the
time of pasting. 

Delete 

Del

Deletes selected objects. 

Tip

⌃ ⌘

⌃ ⌘

Warning

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌦
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PAN / DRAG VIEW 

Click to drag the Workspace around. Mouse users can click the
mouse wheel or third button and drag.

See Panning for more information.

ZOOM TOOLS

See Zoom for more information on Zoom to Page, Zoom In, 
Zoom Out, and Zoom to Frame Selection.

Zoom to Page 

Adjusts the view in your Workspace to center and show the grid
as large as possible.

Zoom In and Zoom Out 

Adjusts the view in your Workspace in to get a closer view, or out
to see more at once.

Zoom to Frame Selection 

Zooms in or out to show all selected objects as large as possible,
centered within your view. If no objects are selected, it will
instead zoom to show all objects in the Workspace.

UPDATE THE BACKGROUND FROM THE CAMERA 

Captures a new image to use as an Overlay for your Workspace.
This button is only selectable when a camera is in use.

See Camera Control Window for more information.

PREVIEW 

Opens the Preview window, which displays the simulated
movements and lasering operations for the project in your 
Workspace.

See Preview for more information.

SETTINGS 

Opens the Settings window, which contains global user
preferences for LightBurn — these settings apply regardless of
what lasers you have set up, and which one you currently have 
selected.

See Settings/Preferences for more information.

DEVICE SETTINGS 

Opens the Device Settings window, which contains device-
specific settings for your laser. The settings available change
based on the device selected.

See Device Settings for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI clipboard device-settings essential-functions

file-management pan preview settings

settings-and-preferences zoom
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5.2.11 Menu Toolbar

The Menu Bar contains all of LightBurn's top-level menus. 

Click any menu in the image below to go directly to the relevant
page for that menu, or scroll down for a list of menus and
descriptions.

On macOS, the menus will be shown at the top of the screen,
rather than as part of the LightBurn window.

File

Contains options for saving, opening, importing, and exporting
files, as well as accessing and exporting your LightBurn settings.

See File Menu for a full list of options in the File Menu.

Edit

Contains tools for selecting and manipulating objects, in addition
to program, device, and machine settings.

See Edit Menu for a full list of options in the Edit Menu.

Arrange

Contains tools for positioning objects, both on an individual
basis, and in relation to each other. It also contains tools for
moving the physical laser in relation to objects within your
project.

See Arrange Menu for a full list of options in the Arrange Menu.

Laser Tools

Contains tools, tests, and step-by-step wizards for performing
advanced lasering operations, dialing in settings to optimize
product quality, and setting up accessory hardware. 

See Laser Tools Menu for a full list of options in the Laser Tools
Menu.

Window

Use the Window Menu to control and customize your Workspace
view, enable and disable Windows and Toolbars, or reset
LightBurn's layout to its original state. 

See Window Menu for a full list of options in the Laser Tools
Menu.

Language

Use Language Menu to switch the LightBurn interface into 1 of
24 different languages.

See Language Menu for a full list of languages.

Help

Contains links to LightBurn resources, access to the License
Management window, and a handful of diagnostic tools.

See Help Menu for a full list of options in the Help Menu.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI arrangement batch-production beginner-mode

customization editing fixing-designs image

image-editing image-raster-bitmap image-tools

laser-control layout-and-design material-utilization

modifying-and-combining nesting node-editing

object-manipulation object-repair optimization

output-and-positioning path path-editing path-tools

testing-tools troubleshooting vector vector-editing

vector-path-curve-lines vector-tools workflow

workflow-optimization

Note
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5.2.12 Modes Toolbar

The Modes Toolbar contains buttons to open dialog windows or
wizards for advanced lasering processes. 

The Modes Toolbar appears differently depending on the type of
laser you have selected. 

For Gantry style lasers, you'll see buttons for Rotary Mode and 
Print and Cut.

For Galvo style lasers, you'll see buttons for Rotary Mode and 
Cylinder Correction.

Accessing the Modes Toolbar

The Modes Toolbar is located near the top right of the top
toolbar in LightBurn by default, between the Text Options
Toolbar and the Docking Toolbar.

If you have closed the Modes Toolbar, go to Window → Modes to
re-enable it.

To restore it and all other toolbars and windows to their default
positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Modes Toolbar Options

Click any button in the images below to jump to information on
that option, or scroll down for a list of options and descriptions.

The Modes Toolbar for Gantry style lasers (GCode and DSP)

The Modes Toolbar for Galvo style lasers

ROTARY MODE 

Rotaries are used to turn cylindrical objects so that their surfaces
can be marked by a laser. In order to use your laser with a rotary,
you must first establish several important parameters in the 
Rotary Setup window that control the rotary's motion and adjust
the output sent to your laser.

For more information on using a rotary with your type of laser,
see:

Rotary Mode (DSP)

Rotary Mode (GCode)

Rotary Mode (Galvo)

PRINT AND CUT 

Print and Cut aligns a current project to existing Target
Positions — also called registration marks — in a previously
output design.

Print and Cut works by measuring the difference in location,
orientation, and scale between two Target Positions in your
laser's physical work area and the positions of two
corresponding graphics in your LightBurn Workspace.

See Print and Cut for more information.

This option is available for Gantry style lasers only.

CYLINDER CORRECTION 

Cylinder Correction (called ProjectMark in EZCAD) warps the
output of your design to correct for the expansion that happens
when you mark on a cylindrical object, like a cup or tumbler,
without using a rotary.

See Cylinder Correction for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI advanced-control cylinder-correction galvo gantry

laser-control modes print print-and-cut rotary

rotary-mode
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• 
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5.2.13 Modifiers Toolbar

The Modifiers Toolbar contains tools for combining, altering,
and producing arrayed duplicates of graphics.

Accessing the Modifiers Toolbar

By default, the Modifiers Toolbar is located in the bottom half of
the left-side toolbar in the main LightBurn window.

If you have closed the Modifiers Toolbar, go to Window → 
Modifiers to re-enable it. 

To restore it and all other toolbars and windows to their default
positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Modifiers Toolbar Options

Click any button in the image below to jump to information on
that tool, or scroll down for a list of options and descriptions.

The Modifiers Toolbar is normally vertical, but can also be
removed from the left-side toolbar and oriented horizontally, as
presented below. See Customizing the LightBurn Window for
more information.

OFFSET SHAPES 

Alt / Option + O

Creates a new shape by outlining the shapes in your selection at
a distance you specify, either inward, outward, or in both
directions at once.

See Offset Shapes for more information.

BOOLEAN TOOLS 

Modify two overlapping shapes (or two Groups of shapes) to
create new shapes. 

Boolean Union merges two shapes.

Boolean Subtract removes one shape from another.

Boolean Intersection leaves only the area covered by both
shapes.

Weld can merge more than two shapes at once.

See Boolean Tools for more information.

GRID ARRAY 

Creates copies of an object (or objects) in regularly spaced rows
and columns, and includes options to adjust spacing, mirror the
shapes, randomize orientation, and more.

See Grid Array for more information. 

CIRCULAR ARRAY 

Creates copies of an object (or objects) in a regularly spaced
circular (radial) pattern, with options to adjust spacing, rotate
copies, and more.

See Circular Array for more information.

SET START POINT 

Allows you to specify where on a shape your laser will begin
cutting, and in which direction it will cut. 

See Set Start Point for more information.

RADIUS 

Fillets (rounds over) sharp corners, takes a round bite out of a
corner (using a negative radius value), or turns a radius back into
a sharp corner (removes a radius).

See Radius/Fillet for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

Tip

Note

⎇ ⌥
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• 

• 
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5.2.14 Status Bar

The Status Bar provides contextual information related to the
active tool or process being performed. Check the Status Bar for
related information, instructions on the next steps, or options
available.

Locating the Status Bar

The Status Bar is located in the bottom left-hand portion of the
LightBurn window directly to the right of the Transform Control
Toggles, and shows the precise location of the mouse cursor/
pointer; the dimensions and status of items selected; the 
Notification Area where important tool, program, and laser
messages are displayed; and the special Modes indicator.

Cursor Coordinates

View the live and precise X and Y Axis coordinates of the mouse
cursor within and around the LightBurn Workspace on the left
side of the Status Bar. The displayed coordinates will stop
updating when the mouse cursor leaves the area around the
Workspace — for example when choosing tools, working within 
windows and toolbars, or interacting with menus.

Tool Status

The Tool Status section to the right of Cursor Coordinates
displays information on the currently selected object(s) or tool.

EXAMPLE TOOL STATUSES

Selection Tool

Message: Min (34.5x, 43.5y) to Max (67.5x, 70.5y) 2 objects

Meaning: The rectangular selection bounding box has the
corner closest to the origin at (34.5, 43.5) and the corner the
farthest away from the origin at (67.5, 70.5), with two objects
included and selected.

Draw Lines Tool

Message: x: 258.00, y: 66.00 (dx: 239.00, dy: 32.00, len: 241.13)

Meaning: Current cursor coordinates (difference in travel from
the start of the line in the X and Y Axis, length of line)

The Cursor Coordinates are always displayed to the left of Tool
Status, and are displayed twice with this tool.

Note
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Notification Area

The Notification Area on to the right-hand side of the Status
Bar displays tool-specific messages, in addition to important
information from the program. The exact message that's
displayed will change depending on the tool you're currently
using, or the last action you took. 

CONNECTION STATUS

If you've set up and selected a DSP or Galvo device profile, the
connection status of your device will be shown in the 
Notification Area.

DSP

If you've selected a DSP profile, and your laser is not connected,
you'll see a No device found message. 

If it is found and connected, you'll see a message identifying the
laser's controller, and indicating that the device has been found.

Galvo

If you've selected a Galvo profile, and your laser is not connected,
you'll see a Waiting for connection... message.

If the connection is established, you'll see message identifying
the laser's controller, and indicating that it is connected.

If you are unable to connect to your laser, see Troubleshooting:
Connection Problems.

Modes Indicator

The last section of the Status Bar displays the name of any active
special Modes, including Rotary Mode, Print and Cut, and 
Cylinder Correction.

Related Topics

Workspace / Edit Window

Transform Control Toggles

Color Palette

Rotary Mode

Print and Cut

Cylinder Correction

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI messages notifications selection-status status
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5.2.15 Tools Menu

The Tools Menu contains an array of options for selecting,
creating, editing, and modifying graphics.

Click any option in the image below to go directly to the relevant
page for that tool, or scroll down for a list of options and
descriptions.

Select

Esc

The primary means of selecting and deselecting objects.

See Selection Tools for more information

Draw Lines

Ctrl / Cmd + L

Allows you to create custom shapes by placing points, with lines
or curves between them.

See Draw Lines for more information. 

Rectangle

Ctrl / Cmd + R

Creates rectangles or squares. 

See Rectangles, Ellipses, and Polygons for more information.

Ellipse

Ctrl / Cmd + E

Creates ovals or circles. 

See Rectangles, Ellipses, and Polygons for more information.

Polygon

Creates regular polygons — hexagons by default — with an
adjustable number of sides. 

See Rectangles, Ellipses, and Polygons for more information.

Edit Nodes

Ctrl / Cmd + `

Allows you to edit vector graphics by adding, deleting, or moving
their points, or altering the shape of the lines/curves between. 

See Edit Nodes for more information. 

Trim Shapes

Ctrl / Cmd + K

Cuts lines back to the next point at which they intersect with
another line.

See Trim Shapes for more information.

Add Tabs

Ctrl / Cmd + Tab

Specifies small sections of cuts that the laser is commanded to
skip, used to prevent objects that you are cutting from
immediately falling out of the base material.

See Add Tabs for more information. 

Edit Text

Ctrl / Cmd + T

Activates the Create / Edit Text tool, allowing you to add, edit,
and format text. 

See Create and Edit Text for more information. 

⎋

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘ ⇥

⌃ ⌘
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Position Laser

Ctrl / Cmd + L

Commands your laser to jog to a location in its physical work
area, by clicking in your LightBurn Workspace.

See Position Laser for more information.

Measure

Ctrl / Cmd + M

Allows you to hover over any shape in your Workspace and
display an array of useful information about it, including
perimeter and overall dimensions.

See Measure for more information.

Create Bar Code

Generates a Bar Code or QR Code which stores data that's visible
when the Code is scanned. 

See Bar Code for more information.

Offset Shapes

Alt / Option + O

Creates a new shape by outlining the shapes in your selection at
a distance you specify, either inward, outward, or in both
directions at once.

See Offset for more information.

Weld Shapes

Ctrl / Cmd + W

Combines two or more overlapping vector graphics into a single
a shape. 

See Boolean Tools for more information.

Boolean Union

Alt / Option + +

Combines two overlapping vector graphics into a single shape.

See Boolean Tools for more information.

Boolean Subract

Alt / Option + -

Removes one vector graphic from a second graphic where they
overlap, creating a new shape from the area that remains of the
second.

See Boolean Tools for more information.

Boolean Intersection

Alt / Option + *

Creates a new shape from the area where two vector graphics
overlap.

See Boolean Tools for more information.

Boolean Assistant

Ctrl / Cmd + B

Opens a dialog window that shows a preview of what each of the
Boolean operations will do to your selected shapes and gives you
the option to click OK to confirm the change, or Cancel to
discard it.

See Boolean Tools for more information.

Cut Shapes

Alt / Option + Shift + C

Cuts vector shapes — dividing them into new shapes — using a 
Closed Shape as the cutting tool.

See Cut Shapes for more information.

Adjust Image

Alt / Option + I

Opens a window where you can alter image properties such as
Contrast, Brightness, and Gamma while also changing Layer
Settings.

See Adjust Image for more information.

Trace Image

Alt / Option + T

Outlines the content of a bitmap image, turning the outlines into
vector graphics.

See Trace Image for more information.

Apply Path to Text

Attaches text to a vector object, reshaping it to follow the
contour of the chosen path.

See Apply Path to Text for more information.

Apply Mask to Image

Cuts a bitmap image using a closed vector graphic, leaving only
the area of the image that is contained within the vector.

See Apply Mask to Image for more information. 

⌃ ⌘

⌃ ⌘

⎇ ⌥
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⎇ ⌥

⎇ ⌥

⎇ ⌥

⌃ ⌘
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Resize Slots in Selection

Adjusts the dimensions of slots or tabs in selected objects, based
on user specifications.

See Resize Slots for more information.

Warp Selection (4 Points)

Allows you to modify text, shapes, or images by dragging 4
handles — one on each corner of your selection.

See Warp/Deform Selection for more information.

Deform Selection (16 Points)

Allows you to modify text, shapes, or images by dragging 16
handles spread out in a 4 x 4 grid across your selection.

See Warp/Deform Selection for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI arrangement batch-production creation-tools

customization editing fixing-designs layout-and-design

material-utilization modifying-and-combining node-editing

object-manipulation object-repair path path-editing

path-tools troubleshooting vector vector-editing

vector-path-curve-lines vector-tools workflow
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5.2.16 Tools Toolbar

The Tools toolbar contains tools for selecting, creating, and
editing objects.

Accessing the Tools Toolbar

By default, the Tools Toolbar is the upper toolbar on the left-
hand side of the screen.

If you have closed the Tools Toolbar, select Window → Tools to re-
enable it. 

To restore it and all other toolbars and windows to their default
positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Tools Toolbar Options

Click any button in the image below to jump to information on
that tool, or scroll down for a list of options and descriptions.

The Tools Toolbar is normally vertical, but can also be removed
from the left-side toolbar and oriented horizontally, as presented
above. See Customizing the LightBurn Window for more
information.

SELECT 

Esc

Objects in LightBurn must be selected before they can be
modified. With the Select tool active, you can click on objects to
select them, or click, hold, and drag to select objects contained or
crossed by a selection box.

See Selection for more information.

DRAW LINES 

Ctrl / Cmd + L

Creates vector paths out of straight and curved lines. With the
tool active, click to place points.

See Draw Lines for more information.

CREATE RECTANGLE 

Ctrl / Cmd + R

With Create Rectangle active, click and drag to create a
rectangle.

See Primary Shapes for more information. 

CREATE ELLIPSE 

Ctrl / Cmd + E

With Create Ellipse active, click and drag to create an ellipse.

See Primary Shapes for more information. 

CREATE REGULAR POLYGON 

With Create Regular Polygon active, click and drag to create a
polygon. Change the number of sides in the Shape Properties
window.

See Primary Shapes for more information. 

EDIT NODES 

Ctrl / Cmd + `

Use the Edit Nodes tool to edit the nodes, or points, that make
up vector paths. This only works on Ungrouped vector paths.

See Edit Nodes for more information.

TRIM SHAPES 

Ctrl / Cmd + K

Use the Trim Shapes tool to remove sections of vector graphics
that lie between intersections.

See Trim Shapes for more information.

ADD TABS 

Ctrl / Cmd + Tab

Use Add Tabs to add tabs – small sections of material
deliberately left uncut – to your project. Tabs prevent cut objects
from immediately falling out of the base material.

Tip

Tip

⎋

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘ ⇥
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See Add Tabs for more information.

CREATE / EDIT TEXT 

Ctrl / Cmd + T

Use Create / Edit Text to create or change Text Objects in your
design. 

See Create and Edit Text for more information. 

POSITION LASER 

Alt / Option + L

With Position Laser active, click the Workspace to move the laser
to the corresponding location in its physical work area. Make
sure nothing is in the path of your laser before using this tool.

See Position Laser for more information.

MEASURE 

Alt / Option + M

With the Measure tool active, hover over an object to see
measurements and node information, or click and drag to
measure the distance between any two points.

See Measure for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI creation-tools cut-lines draw-lines edit-nodes

editing ellipse layout-and-design measure move-laser

nodes polygon position-laser rectangle select tabs

text tools trim-shapes

⌃ ⌘

⎇ ⌥

⎇ ⌥
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5.2.17 Window Menu

Use the Window Menu to control and customize your Workspace
view, enable and disable windows and toolbars, or reset
LightBurn's layout to its original state. 

Any window or toolbar that is currently enabled will have a check
mark next to it. Click unchecked windows or toolbars to enable
them, and click again to disable them. 

For more information on enabling, disabling, and customizing
the position of windows and toolbars, see Customizing the
LightBurn Window.

Click any option in the image below to go directly to the relevant
page for that tool or window, or scroll down for a list of options,
toolbars, windows, and descriptions.

Reset to Default Layout

Restores the layout of the full LightBurn window to the same
format when first installed.

See Reset to Default Layout for more information.

5.2.17 Window Menu
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Preview

Alt / Option + P

Displays a simulation of movements and lasering operations
before a project is sent to the machine.

See Preview for more information.

Zoom

The Zoom options allow you to increase or decrease the visual
size of your design on your screen, without changing the actual
dimensions in the final output to the laser.

See Zoom and Pan for more information.

View Style

Changing the View Style alters the appearance of vector
graphics in your Workspace, which can be useful for spotting
potential design issues and visualizing the final output from a
project.

See View Style for more information.

Toggle Side Panels

F12

Toggle off to automatically disable all currently-enabled windows.
Toggle back on to re-enable the same set of windows.

See Customizing the LightBurn Window for more information. 

Windows and Toolbars

ART LIBRARY

Stores artwork, to enable quick access when designing.

See Art Library for more information.

ARRANGE AND ARRANGE (LONG)

Provide tools for positioning graphics, relative to other graphics
or positions in your Workspace.

See Arrange Menu for more information.

MODIFIERS

Contains tools for adjusting, combining, and arraying graphics.

See Modifiers Toolbar for more information.

CAMERA CONTROL

Provides options for capturing, adjusting, and displaying an
overlay image of your laser's work area in the LightBurn 
Workspace.

See Camera Control Window for more information. 

CONSOLE

Displays messages from your laser's controller and commands
sent to it by LightBurn. You can also input direct commands to
your laser through this window.

The Console window functions are only available when LightBurn
is directly connected to a GCode-based laser.

See Console Window for more information.

CUTS / LAYERS

Shows the list of layers and operations in your design. Select an
entry on this list to edit select settings for that layer directly in
the Cuts / Layers Window, or double-click to open the Cut
Settings Editor, where additional options are presented.

See Cuts / Layers Window for more information.

COLOR PALETTE

Contains colors representing twenty-nine different layers, and
two tool layers, which you can select and assign to objects in
your Workspace.

See Color Palette for more information. 

DOCKING

Provides tools to move selected objects left, right, up, or down,
until they meet the edge of the Workspace, or another object.

See Docking for more information.

FILE LIST

Lists the jobs and estimated run times of files physically hosted
on DSP controllers.

See File List Window for more information. 

LASER

Serves as the hub for setting up and selecting a laser, framing
and starting jobs, determining job positioning, and more.

See Laser Window for more information.

MATERIAL LIBRARY

Stores preset cut settings for different operations and materials,
so you can quickly reapply them later.

See Material Library for more information.

MAIN

Contains tools for saving and opening files, importing artwork, 
copying and pasting graphics, adjusting view, and more. 

See Main Toolbar for more information.

MODES

Contains buttons to open dialog windows or wizards for
advanced lasering processes.

See Modes Toolbar for more information.

MOVE

Provides tools to jog your laser, set a custom User Origin, or view,
save, and recall machine coordinates.

⎇ ⌥
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See Move Window for more information.

NUMERIC EDITS

Contains fields to adjust the scale, position, and rotation of
selected objects.

See Numeric Edits Toolbar for more information. 

SHAPE PROPERTIES

Displays editable properties of selected objects. Properties vary
based on the type of object currently selected.

See Shape Properties Window for more information.

TEXT OPTIONS

Presents options to adjust attributes of text objects, including, 
font, size (height), spacing (HSpace and VSpace), and more.

See Create and Edit Text — Text Options Toolbar for more
information.

TOOLS

Contains tools for creating and editing graphics.

See Tools Toolbar for more information.

VARIABLE TEXT

Provides options for controlling and incrementing Variable Text
output. Variable Text allows you to use special codes in text
entries that will be substituted for something else when a project
is sent to your laser.

See Variable Text for more information. 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI default-layout frame menus open-closed-windows

preview reset-layout restore-windows view-style

window-menu wireframe zoom
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5.2.18 Workspace / Edit Window

The Workspace, or Edit Window, is the area where you create, 
adjust, modify, and arrange artwork in LightBurn. 

LightBurn sets the size of the border and grid within the
Workspace to the machine-specific laser cutting and marking
area. Machines equipped with a camera can capture the
machine's working area and update the Workspace background
image.

The objects arranged and displayed within the Workspace will be
processed based on user-configured operations that are
established for each artwork element using the Color Palette, 
Cuts / Layers Window, and Cut Settings Editor. 

Customizing the Workspace Appearance

CHANGING THE SIZE OF THE WORKSPACE

Change the size of the Workspace in the Device Settings window by

clicking on the  icon in the Main Toolbar or going to 
Edit → Device Settings → Basic Settings → Working Size. Adjust
the Working Size Width and Height entries to match the
manufacturer-provided values.

ENABLING DARK BACKGROUND

Switch from the default light background to a dark background in the 

LightBurn Settings window by clicking on the  icon in the Main
Toolbar or by going to Edit → Settings → Display → Display / Graphics
→ Use Dark Background.

Background Examples

Default Light Color Background
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Dark Color Background
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CUSTOMIZING THE WORKSPACE BACKGROUND

Machines equipped with a camera can capture an image of the
work area and display that behind the Workspace grid to aid in
artwork positioning.

Alternatively, the material being cut or marked can be drawn
within the Workspace as a Tool layer with the available LightBurn
design Creation tools for similar element alignment and laser
framing operations.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI background-image camera edit-window first-steps

grid workspace

LightBurn Camera Setup
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5.3 Essential Functions

5.3.1 File Management

Use the file management tools to start New projects, Save
projects you're working on, Open previously saved projects, and 
Import or Export artwork in alternative file formats. 

Most file management options are available in the Main Toolbar,
with a few additional options available in the File Menu.

New 

Ctrl / Cmd + N

Clears your current LightBurn project and starts a new, blank
project. 

Opening a new project does not change any Settings, window
customizations, and special modes active from the last opened
project.

If you have an existing project open with unsaved changes,
LightBurn will ask you if you'd like to Save before starting the
new project, click No to discard the changes, or Cancel to abort
the process. 

Open 

Ctrl / Cmd + O

Opens a .lbrn  or .lbrn2  project file previously stored on your
computer.

If you have an existing project open with unsaved changes,
LightBurn will ask you if you'd like to Save before Opening the
project, click No to discard the changes, or Cancel to abort the
process. 

If you have multiple device profiles, and the device you were
using when you Saved the file is not currently selected, LightBurn
will ask if you'd like to automatically switch to that device profile.

Click Yes to switch or No to open the file with your current
device.

Click on the dropdown in your system's file browser to show all
supported file types, including supported image and vector file
types.

Selecting a supported image or vector file instead of a project
file will create a new LightBurn project, replacing the currently
loaded project. Use Import to bring artwork files or designs into
an existing project.

RECENT PROJECTS

Hover over Recent Projects in the File Menu to open a submenu
containing a list of projects you've recently worked on and 
Saved. 

Click any file in the list to Open it. 

⌃ ⌘

⌃ ⌘

Warning
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Save 

Ctrl / Cmd + S

The Save and Save As commands offer the option of saving as
.lbrn2  (default) or .lbrn  (LightBurn Legacy Project). 

Unless you need to maintain compatibility with extremely old
versions of LightBurn or need an easily human-readable file, we
recommend leaving the file type set to .lbrn2 .

Saves your current project in .lbrn  or .lbrn2  format.

If you haven't Saved it previously, a dialog window will open
where you can name it and choose the location to Save it.

If you have already Saved a copy, the existing copy will be
immediately overwritten with any new changes you've made. 

Save As 

Ctrl / Cmd + Shift + S

Rather than immediately overwriting your existing file, Save As
opens a dialog window where you can save a renamed copy to a
new file, leaving the current file unchanged.

Save Machine File

This option will change depending on the type of laser you're
using — it may say Save GCode (for GRBL, Smoothieware, or
Marlin controllers), Save RD File (Ruida), Save OUT File
(TopWisdom), or Save UD5 File (Trocen).

All options save your current project as a machine-ready file, in
the appropriate format for your type of laser. You can transfer

this file to your machine to run it without ever having to directly
connect using LightBurn.

See Laser Window — Save Machine Files for more information.

Import 

Ctrl / Cmd + I

Loads graphics from a variety of file formats into LightBurn. Click
on the dropdown in your system's file browser to filter for
supported image and vector file types. 

LightBurn can Import the following formats:

Vector / mixed formats:

.ai  - Adobe Illustrator

.svg  - Scalable Vector Graphics

.dxf  - AutoCAD Drawing Exchange Format

.pdf  - Adobe Portable Document Format

.plt  / .hpgl - Plotter / Hewlett-Packard Graphics Language

Image formats:

.png  - Portable Network Graphics

.jpg  / .jpeg  - Joint Photographic Experts Group format

.bmp  - Windows Bitmap

.gif  - Graphics Interchange Format

.tif  / .tiff  - Tagged Image File Format

It is also possible to Import .lbrn  or .lbrn2  files — however,
Importing these types of files does not load the cut settings or
any other project-specific information saved to the file. Only the
graphics will be loaded.

In order to load graphics along with all other settings, you must
use Open instead.

LightBurn will warn you if you attempt to Import a .lbrn  or
.lbrn2  file.

Click Open to load the graphics and all other settings, Import to
load only the graphics, or Cancel to abort the process. 

Export 

Alt / Option + X

⌃ ⌘

.lbrn and .lbrn2

• 

• 

⌃ ⌘ ⇧

⌃ ⌘

• 

• 

• 

• 

• 

Quick Tip: Drag and drop directly into LightBurn

• 

• 

• 

• 

• 

Importing .lbrn  or .lbrn2  files

⎇ ⌥
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Exports currently selected graphics in .ai , .svg , or .dxf  format.
If there is nothing in your current selection, the entire contents
of your current project will be Exported. 

Exporting in one of these formats does not save cut settings or
any other project-related settings. 

Related Topics

Clipboard Tools

Undo/Redo

File Menu

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

beginner essential-functions export import

machine-file recent-projects save• 

• 

• 
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5.3.2 Selection Tools

In order to modify graphics, you must first select them. The 
Select tool is the primary means of selecting objects, but
LightBurn also includes several additional options for making
selections based on their type, size, layer, and more. 

Making Selections

The Select tool is active by default. To reactivate it after using a
different tool, click the cursor icon in the Tools Toolbar, or press
the Esc  key. 

CLICK SELECTION

With the Select tool enabled, click any object in your Workspace
to select it. 

To increase or decrease the distance your cursor must be from
an object in order to select it when you click, adjust Click-
Selection Tolerance in your Settings/Preferences.

BOX SELECTION

Select several shapes at once using one of two box selection
options.

Enclosing Selection

With the Select tool enabled, click, hold, and drag to the right to
create a red Enclosing Selection box. Release to select all objects
that are fully contained within the box. 

Crossing Selection

Click, hold, and drag to the left to create a green Crossing
Selection box. Release to select all objects that are fully contained
or crossed by the lines of the box. 

SELECTION MODIFIERS

To supplement both click and box selection, LightBurn supports
the following modifier keys. 

While clicking or box-dragging:

Hold Shift  to add a new object or objects to your current
selection.

Hold Ctrl  / Cmd  to toggle the selection status of an
object or objects, deselecting selected objects, or selecting
unselected objects.

Hold both Ctrl  / Cmd  and Shift  to remove an object
or obects from your current selection.

Additional keyboard shortcuts:

Press the Esc  key, or click in any open area in your 
Workspace to remove all objects from your selection.

Press Tab  to cycle your selection sequentially through
objects or Grouped objects in your Workspace. Sequence is
determined by the order in which the objects were created. 

Press both Tab  and Shift  to cycle your selection
sequentially through objects or Grouped objects in your
Workspace, in reverse order.

Selection Indicators

Selected objects are drawn with an animated dash pattern
instead of solid lines. If you select Grouped objects, you'll see a
dot-dot-dash pattern instead. 

⎋

Tip

• ⇧

• ⌃ ⌘

• ⌃ ⌘ ⇧

• ⎋

• ⇥

• ⇥ ⇧
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Ungrouped Objects Selected

Grouped Objects Selected

Several options for modifying or manipulating objects are
available once they are selected:

The Transform Control handles for Sizing, Moving, Skewing, or 
Rotating the selection appear.

The size and position of your selection is shown in the Numeric
Edits Toolbar.

Other controls are enabled depending on the type of object
you've selected:

If you select a Text Object, the Text Options Toolbar becomes
active.

If you select a shape made by the Rectangle, Ellipse, or
Polygon tools, shape-specific adjustment options are
presented in the Shape Properties Window.

If you select an Image, image adjustment options are
presented in the Shape Properties Window.

Additional Selection Tools

Several other selection options are available in the Edit Menu.

SELECT ALL

Ctrl  / Cmd  + A

Selects all graphics in your project.

INVERT SELECTION

Ctrl  / Cmd  + Shift  + I

Deselects all objects that are currently selected and selects all
objects that are not currently selected.

SELECT OPEN SHAPES

Selects all shapes in your project that are open, meaning they are
not paths that form a closed, continuous loop. See Open vs. Closed
Shapes for more information on open shapes.

SELECT OPEN SHAPES SET TO FILL

Selects all shapes in your project that are open, and assigned to a
layer set to Fill or Offset Fill Mode. LightBurn is unable to fill open
shapes — this tool is a useful option for identifying them.

• 

• 

• 

• 

• 

• 

⌃ ⌘

⌃ ⌘ ⇧
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SELECT ALL SHAPES IN CURRENT LAYER

Selects all shapes assigned to the active layer in the Cuts / Layers
Window. 

You can perform the same action by holding Shift  while
clicking on a layer in the Cuts / Layers Window.

SELECT CONTAINED SHAPES

Selects all shapes contained by the currently selected shape. To
use this tool, the selected shape must be closed — a path that
forms a continuous loop. The containing object remains in the
resulting selection.

SELECT SHAPES SMALLER THAN SELECTED

Selects all shapes that are smaller than the currently selected
object. The currently selected object remains in the resulting
selection.

Troubleshooting

Grouped objects are treated as single objects when using click
or box selection, and any selection modifiers. All objects in a
Group must be entirely contained by an Enclosing Selection
in order to be selected, and if any object in a Group is crossed
by a Crossing Selection, the entire group will be selected. 

There are a handful of exceptions to the behavior of Grouped
objects with the additional selection tools:

Select contained shapes does not select any contained
shapes that are Grouped. 

When using Select shapes smaller than selected, any
Grouped objects that are smaller than the selected shape will
be selected, and automatically removed from their Group. The
objects they were Grouped with will not be selected.

When using Select open shapes or Select open shapes set to
Fill, any Grouped objects that are open will be selected, and
automatically removed from their Group. The objects they
were Grouped with will not be selected.

If you find that you're getting odd flashing instead of the 
expected pattern when selecting objects, the most likely
problem is overlapping geometry. This is often the result of
importing the same file twice, or other design software
exporting paths improperly.

To solve this problem, try deleting duplicate shapes using Edit
→ Delete Duplicates ( Alt  + D ).

For more manual control, you can also try 
Ungrouping( Ctrl / Cmd + U ) and deleting individual
shapes.

Related Topics

Group/Ungroup

Workspace

Zoom

View Style

Open vs. Closed Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

essential-functions first-steps object-manipulation

open-vs-closed-shapes selection
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5.3.3 Zooming and Panning

Use the Zooming and Panning functions to adjust the visible
area in your Workspace while designing and making edits.

Zooming In can make fine details easier to work on, and 
Zooming Out can provide a better view of an overall
composition. 

Panning allows you to move the area your screen is focused
over, sliding the field of view between locations in your
Workspace.

Zooming

ZOOM IN AND OUT

The most common method to quickly navigate a design is by
zooming with the scroll wheel on a mouse, followed by two-
finger dragging if you're using a trackpad. By default, rolling it
backwards will Zoom Out, and rolling it forward will Zoom In,
toward whatever your cursor is pointing. 

These directions can be swapped by going to File → Settings
(LightBurn → Preferences on Mac) and toggling on Invert
mouse wheel zoom direction.

However, there are many ways to Zoom In and Out: 

There are several Windows and Toolbars in LightBurn that accept
user input — when a window is clicked on, it is in focus and
accepting input.

If a window other than the Edit Window is in focus, click
anywhere in the Workspace to bring it into focus.

ZOOM TO PAGE

To Zoom your field of view to show the entire Workspace, go to 
Window → Zoom to Page, press Ctrl  / Cmd + 0 , or click

the Zoom to Page button  in the Main Toolbar.

FRAME SELECTION

To Zoom your field of view to frame your current selection, go to 
Window → Frame Selection, press Ctrl  / Cmd + Shift

+ A , or click the Frame Selection button  in the 
Main Toolbar.

Panning

Panning slides your field of view around the Workspace. There
are a few options for enabling Panning mode:

Method Zoom In Zoom Out

Roll the scroll
wheel on a
mouse

Forward Backward

Slide two fingers
on most
touchpads

Backward Forward

Window Menu Zoom In Zoom Out

Keyboard
shortcuts (Edit
Window in
focus)

+ -

Keyboard
shortcuts (Edit
Window not in
focus)

Ctrl  / Cmd

+ +

Ctrl  / Cmd

+ -

Main Toolbar

⌃ ⌘ ⌃ ⌘

What does it mean for a window to be in focus?

⌃ ⌘

⌃ ⌘ ⇧
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Click the Pan / Drag View icon  in the Main Toolbar.

Press and hold the middle mouse button and move your
mouse.

Hold down Space  on your keyboard. 

When you've enabled Panning mode using any of the above

methods, you'll see the mouse cursor change to a hand ,
and then you can click and drag the view with the left mouse
button.

To exit Panning mode, press the Esc  key, or enable any other
tool. 

Related Topics

Selection

Main Toolbar

Window Menu

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

essential-functions invert-zoom pan preferences

settings view workspace zoom
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5.3.4 Undo/Redo

Reverses or reapplies changes.

Quick Reference: Undo/Redo

5.3.4 Undo/Redo
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Location

Main Toolbar

Edit → Undo/Redo

Keyboard Shortcuts

Undo

Windows: Ctrl + Z

Mac: Cmd + Z

Redo

Windows: Ctrl + Shift + Z

Mac: Cmd + Shift + Z

Undo and Redo reverse or reapply changes you've made to your
project, allowing you to backtrack if you've made edits you
regret, or restore the edits you reversed, if that regret was only
temporary.

Undo and Redo in LightBurn are unlimited — the list of actions
that can be reversed and reapplied is only reset when closing out
of the program or opening a new project.

Using Undo and Redo

Undo reverses previous actions taken, starting with the most
recent action, and proceeding to previous actions with successive
Undos.

To Undo, press Ctrl / Cmd + Z , click the Undo icon in the 
Main Toolbar, or go to the Edit Menu and select Undo.

Redo restores actions previously reversed using Undo, starting
with the most recent action Undone, and proceeding to previous
reversed actions with successive Redos. 

To Redo, press Ctrl / Cmd + Shift + Z , click the Redo
icon in the Main Toolbar, or go to the Edit Menu and select Redo.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

editing essential-functions optimize workflow

⌃

⌘

⌃ ⇧

⌘ ⇧

⌃ ⌘

⌃ ⌘ ⇧

5.3.4 Undo/Redo

- 95/400 - ©️ LightBurn Software, LLC

https://forum.lightburnsoftware.com/
mailto:support@lightburnsoftware.com


5.3.5 Clipboard Tools

The clipboard commands are tools for copying, inserting,
removing, or duplicating objects in your Workspace, and
transferring graphics into and out of LightBurn.

The clipboard commands are accessible in the Edit Menu, Main
Toolbar, by hotkey, or by right-clicking in your Workspace to open
a context menu. 

Your computer's clipboard is a temporary storage location used
to save items that you copy, so you can paste them to another
location shortly after. 

COPY 

Ctrl / Cmd + C

Saves a copy of selected objects to your clipboard.

CUT 

Ctrl / Cmd + X

Deletes selected objects in your Workspace while saving a copy
of them to your clipboard at the same time. 

DUPLICATE

Ctrl / Cmd + D

Creates copies of selected objects, directly on top of the existing
objects.

PASTE 

Ctrl / Cmd + V

Inserts objects copied to your clipboard into your Workspace.
Pasted objects are centered at the location of your cursor at the
time of pasting. 

You can copy text, vector graphics, and images from other
design software, and paste them directly into your LightBurn
Workspace.

PASTE IN PLACE

Alt / Option + V

Inserts objects copied to your clipboard into your Workspace and
positions them according to their location in the project they
were copied from.

DELETE 

Del

Deletes selected objects. 

Troubleshooting

By default, LightBurn uses your system's clipboard. If you're
experiencing slow performance when using the clipboard
commands, disable Use System Clipboard in the Settings/
Preferences window.

With this setting disabled, you'll no longer be able to copy and
paste from other programs into LightBurn, or between
LightBurn windows.

Related Topics

Selection Tools

Undo/Redo

Zoom

Edit Menu

Main Toolbar

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

beginner clipboard essential-functions

Info

⌃ ⌘

⌃ ⌘

⌃ ⌘

⌃ ⌘

Drag and drop directly into LightBurn

⎇ ⌥

⌦
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5.3.6 Transform Controls

The Transform Controls are tools for directly editing selections
in your Workspace by clicking and dragging control handles that
alter their position, dimensions, orientation, or shape. 

Control Handles

Control handles appear on and around the selection area of any
object or objects you select.

Imagine the selection area as the smallest possible rectangle
that can contain every object in your selection. The edges and
center of a selection are the same as the edges and center of
that imaginary rectangle.

Move

The Move handle is a square located in the center of your
selection area. When you hover over the Move handle, the four-
arrow icon will appear. 

Click, hold, and drag the Move handle to move the selection
around your Workspace. 

Release to place the selection in its new position. 

Press Esc  before releasing to deselect and return the
selection its original position after releasing. 

To precisely adjust a selection's position, use the Numeric Edits
Toolbar.

MOVING FROM SNAPPING POINTS

Hover over a line, corner, intersection, midpoint, or other node
on any shape in your selection, then click, hold, and drag to move
all objects in the selection from that point, and snap it to another
point on another shape in your Workspace.

See Snapping for more information. 

MODIFIER KEYS

Hold Shift  while dragging to lock a selection's movement
to a 90° or 45° angle from its current position.

Hold Alt / Option  to show temporary Alignment Guides
for selection snapping. 

Hold Ctrl / Cmd  to disable snapping while moving
selections. 

MOVE INCREMENT HOTKEYS

You can also use your keyboard's arrow keys to move objects in
your Workspace by set increments. 

These hotkeys only work when you have objects selected and the
Edit Window (Workspace) — the area where you create and edit
graphics — is in focus.

There are several windows in LightBurn that accept user input —
when a window is clicked on, it is in focus, and accepting input.

If a window other than the Edit Window is in focus, click
anywhere in the Workspace to bring it into focus.

The Left , Right , Up , and Down  arrow keys nudge
your selection by 5 mm, by default.

Hold Ctrl  while pressing an arrow key to nudge your
selection 1 mm, by default.

Hold Shift  while pressing an arrow key to nudge your
selection 20 mm, by default.

You can adjust the nudge distance of each arrow key and
modifier in the Units and Grids tab of the Settings window,
under Shape Move Increments.

• 

• 

• ⎋

Tip

• ⇧

• ⎇ ⌥

• ⌃ ⌘

What does it mean for a window to be in focus?

• ← → ↑ ↓

• ⌃

• ⇧
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Size

The Size handles are squares located around the perimeters of
your selection area — at each corner, and the midpoints of each
side. When you hover over a Size handle, the two-arrow icon will
appear.

Use the corner handles to rescale both dimensions of your
selection while maintaining its aspect ratio.

Use the midpoint handles to rescale a single dimension at
once. 

When dragging any of the Size handles, the behavior is
asymmetric — the other side of the object acts like an anchor
and stays in place.

Click, hold, and drag a Size handle to rescale your selection.
Drag outward to make it larger, or inward to make it smaller.

Release to set the selection to its new scale. 

Press Esc  before releasing to deselect and return the
selection its original scale after releasing. 

MODIFIER KEYS

Hold Shift  while dragging from a corner handle to rescale
both dimensions at once, while not maintaining the original
aspect ratio. Left-right movement will adjust the width, while
up-down movement will adjust the height.

Hold Ctrl  while dragging from any Size handle to rescale
the selection symmetrically from its center, rather than from
the chosen handle. 

To precisely adjust a selection's dimensions, use the Numeric
Edits Toolbar.

Rotate

There are four Rotate handles — they're the curved two-arrow
icons, one on each corner of your selection. When you hover over
a Rotate handle, your cursor will change to the curved two-arrow
icon as well.

Click, hold, and drag a Rotate handle clockwise or
counterclockwise to turn the selection around its center point.

Release to leave the selection in its new orientation. 

Press Esc  before releasing to deselect and return the
selection its original orientation after releasing. 

As you Rotate your selection, the Status Bar will actively show the
change in degree of rotation.

MODIFIER KEYS

Hold Shift  while dragging to lock rotation to 15°
increments.

Hold Ctrl / Cmd  to lock to 5° increments.

ROTATE HOTKEYS

These hotkeys only work when you have objects selected and the
Edit Window/Workspace — the area where you create and edit
graphics — is in focus.

There are several windows in LightBurn that accept user input —
when a window is clicked on, it is in focus, and accepting input.

If a window other than the Edit Window is in focus, click
anywhere in the Workspace to bring it into focus.

• 

• 

• 

• 

• 

• ⎋

• ⇧

• ⌃

Tip

• 

• 

• ⎋

Use Two-Point Rotate / Scale to turn your selection from
a custom pivot point instead of a Rotate handle.

• ⇧

• ⌃ ⌘

What does it mean for a window to be in focus?

Action Windows macOS

Rotate 90°
clockwise

. .

Rotate 90°
counterclockwise

, ,

Rotate 45°
clockwise

Shift + . Shift + .⇧ ⇧

5.3.6 Transform Controls

- 98/400 - ©️ LightBurn Software, LLC



ROTATE IN THE ARRANGE MENU

You can also select Rotate 90° Clockwise or Rotate 90°
Counter-Clockwise from the Arrange Menu.

ROTATE IN THE NUMERIC EDITS TOOLBAR

Enter an angle of rotation in the Rotate field of the Numeric
Edits Toolbar to Rotate objects at any angle. This field accepts
negative values. 

Shear

The two Shear handles are small squares located just above or
below and just to the left or right of a corner of your selection. 

The handle above or below skews your selection vertically,
while the handle to the left or right skews it horizontally.

Click, hold, and drag a Shear handle to skew the selection. 

Release to apply the new skew to the selection. 

Press Esc  before releasing to deselect and return the
selection to its original skew.

Use Warp/Deform Selection to skew selections in any direction.

Transform Control Toggles

Use the Transform Control Toggles in the bottom left of the
LightBurn window to enable and disable specific types of editing
across an entire project, and prevent accidental edits, such as
inadvertently scaling a design that contains strict sizing, or moving
tightly nested parts. 

This feature is disabled when using Beginner Mode. 

The Transform Control Toggles are all enabled by default. Each
toggle enables or disables a different type of editing:

Move: shifting, repositioning, relocating, dragging, or
rearranging objects.

Size: scaling, resizing, enlarging, or shrinking objects.

Rotate: spinning, turning, tilting, or adjusting the angle of
objects.

Shear: skewing or slanting objects.

When a toggle is enabled, the corresponding Transform Controls
appear around selected objects. As toggles are disabled the
controls disappear, restricting that type of editing. 

Use Lock Shapes to lock editing of individual objects in a design. 

Action Windows macOS

Rotate 45°
counterlockwise

Shift + , Shift + ,

Rotate 15°
clockwise

Ctrl + . Cmd + .

Rotate 15°
counterclockwise

Ctrl + , Cmd + ,

Rotate 5°
clockwise

Ctrl

+ Shift + .

n/a

Rotate 5°
counterclockwise

Ctrl

+ Shift + ,

n/a

⇧ ⇧

⌃ ⌘

⌃ ⌘

⌃

⇧

⌃

⇧
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Related Topics

Lock Shapes

Selection Tools

Snapping

Select

Numeric Edits Toolbar

Warp/Deform Selection

Status Bar

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

control disable-move disable-rotate disable-shear

disable-size essential-functions handles move rotate

shear size snap transform
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5.3.7 Grouping and Ungrouping

Group combines collections of objects into single units, which can be split using Ungroup.

Quick Reference: Grouping/Ungrouping

5.3.7 Grouping and Ungrouping
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Location

Arrange Toolbar

Arrange → Group/Ungroup

Right-click → Group/Ungroup

Keyboard Shortcuts

Grouping

Windows: Ctrl + G

Mac: Cmd + G

Ungrouping

Windows: Ctrl + U

Mac: Cmd + U

The Group tool combines collections of objects into single units,
and the Ungroup tool splits Groups back into the individual
objects that make them up. 

Normally, all objects are independent of one another, and can be
manipulated individually. But it's sometimes helpful to treat a
collection of things as a single unit, to make sure they keep their
relative position and size when you're moving them around.

LightBurn also provides options in Optimization Settings to tell
your laser to engrave Grouped objects together or to cut and
engrave multi-layer Groups in order, completing each layer in
each Group before moving on to the next one.

Both Group and Ungroup are available in the Arrange Menu, 
Arrange Toolbar, and by hotkey. 

Grouping and Ungrouping

GROUP 

Ctrl / Cmd  + G

Group selected objects to treat them as a single unit when they
are:

Selected

Moved

Resized

Used with the Boolean tools

You can create Groups out of any objects, including objects
assigned to different layers, and multiple types of objects such as
lines, shapes, text, and images. You can even combine objects
that have already been Grouped into other Groups. 

UNGROUP 

Ctrl / Cmd  + U

Ungroup selected (previously Grouped) objects to treat them as
discrete, independently adjustable units again.

If you have a Group made up of other Groups, you'll need to
Ungroup multiple times to separate all objects into individual
units again. 

SELECTION APPEARANCE OF GROUPED OBJECTS

You can tell whether an object is Grouped based on its
appearance when you select it. 

Ungrouped objects are drawn with an animated dash pattern
instead of solid lines, while Grouped objects are drawn with a
dot-dot-dash pattern. 

⌃

⌘

⌃

⌘

⌃ ⌘

• 

• 

• 

• 

⌃ ⌘
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Ungrouped Objects Selected

Grouped Objects Selected

Auto-Grouping

Auto-Group identifies shapes that are fully contained within
another shape and Groups them together with the outer shape.

In the animation above, the objects shown in red are unaffected
by Auto-Group, either because they're not fully contained within
the rectangle or because they are already Grouped. The green
objects are automatically Grouped with the rectangle.

To use Auto-Group:

Select the shapes you want to use Auto-Group on.

Make sure the shapes are not Grouped using Arrange → Ungroup
or Ctrl + U .

Use Arrange → Auto-Group to automatically group all fully
contained shapes inside the outermost shape.

Troubleshooting

Imported shapes are Grouped by default. Disable Group
imported shapes in your Settings to turn off automatic
Grouping upon importation. 

The following tools cannot be used with Grouped objects:

Edit Nodes

Trim Shapes

Resize Slots

Convert to Path

1. 

2. 
⌃

3. 

Note

• 

• 
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Auto-Join Selected Shapes

Close Path

Close Selected Paths with Tolerance

Break Apart

Optimize Selected Shapes

Select contained shapes

Grouped objects are treated as single units when working with
the Boolean tools. If any object in a Group is an open shape,
the entire Group cannot be used with the Boolean tools. 

Using Select open shapes, Select open shapes set to Fill, and 
Select shapes smaller than selected will select applicable
Grouped shapes, and remove them from their Group.

Auto-Group only works on shapes that are fully contained
within the outer shape. If any portion of a shape extends
outside the outer shape, it will be left out of the Group.

Auto-Group only works on Ungrouped shapes. Use Ungroup to
remove shapes from an existing Group.

Related Topics

Fill Groups Together

Order by Group

Selection Tools

Numeric Edits Toolbar

Align

Docking

Grid Array

Boolean Tools

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement essential-functions layout-and-design

object-manipulation workflow
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5.3.8 Preview

The Preview window shows what LightBurn will send to the laser, with black lines representing cuts and red lines travel.

Location

Main Toolbar

Window → Preview

Keyboard Shortcuts

Windows: Alt + P

Mac: Option + P

The Preview window simulates movements and lasering
operations before sending a project to the machine. Use it to:

See the order in which cuts will be completed

Check that your laser will do what you expect

Estimate how long a job will take based on the information in
the Additional Settings tab of Device Settings

Recover interrupted jobs using Start Here

Using the Preview Window

The Preview window is an accurate representation of what
LightBurn will send to the laser. Black lines represent cut moves,
while red lines are travel moves between cuts. 

It's a good practice to check the Preview window before starting
any job, to make sure the simulated output matches your
expectations, or to identify any problems before it's too late.

To open the Preview window, go to Window → Preview, or click

the Preview icon  in the Main Toolbar, or press Alt /
Option + P .

TIME SLIDER

The Time Slider allows you to slide quickly through the project
and see the cut order.

Quick Reference: Preview

⎇

⌥

• 

• 

• 

• 

⎇

⌥
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JOB TIME STATISTICS

Below the Time Slider are statistics about the job and the
estimated run time. The Additional Settings tab in Device
Settings can help you get more accurate time estimates – see
the video above for help.

Cut distance shows the distance the laser will travel while on,
and the estimated time it will take the laser to complete those
movements in parentheses.

Rapid moves shows the distance the laser will travel while off,
between cutting and engraving, and the estimated time it will
take the laser to complete those movements in parentheses.

Total estimated time shows the combined time it will take the
laser to complete all Cut and Rapid moves.

PREVIEW SETTINGS

The settings here only affect the Preview window – they don't
change anything about LightBurn's output to the laser.

START HERE

Use the Start Here button to recover interrupted jobs by starting
the laser at a precise time partway through the operation. Move
the Time Slider to the point at which you want to start, then click 
Start Here.

SAVE IMAGE

Saves the current Preview as an image file.

PLAY

Animates the simulation to show the job from start to finish at
the speed set in Playback Speed.

Troubleshooting

If the time estimates are inaccurate, update the Simulation
Settings in Device Settings — Additional Settings.

If the output of the laser doesn't match the Preview, see 
Troubleshooting: Job Quality.

Related Topics

Print and Cut

Device Settings — Additional Settings

Cut Settings

Optimization Settings

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

essential-functions

• 

• 

• 

Setting Description

Playback Speed Sets the speed of playback with
the Play button – ranges from ⅕
of actual speed to 5 times the
actual speed.

Show Traversal
Moves

If enabled, shows travel moves in
red. If disabled, travel moves are
hidden.

Shade According
to Power

If enabled, uses grayscale shading
to indicate higher and lower
power cut moves. This only works
with the Grayscale Image Mode or
Power Scaling.

Invert If enabled, sets cut moves to
white on a black background.
Useful when engraving on dark
surfaces that engrave lighter, such
as slate.
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• 

• 

• 

• 

• 
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5.3.9 New Window Quick Reference: New Window

5.3.9 New Window
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Work on more than one project at a time. 

Location

File → New Window

New Window opens a separate instance of LightBurn in a new
window, allowing you to edit multiple projects at once, or edit
one file while cutting a different one.

Working With Multiple Windows

Go to File → New Window to open a separate instance of
LightBurn in a new window. 

All open windows share the same settings and preferences. The last
window closed after changing LightBurn settings will save those
changes to the preferences file and will overwrite any changes
made previously in other open instances.

Windows users can also double-click the LightBurn application or
shortcut to open a new instance. 

Note

5.3.9 New Window
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Related Topics

For an alternate method that creates fully independent
instances of LightBurn, refer to the Running Multiple
Independent Instances of LightBurn guide.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

batch-production editing essential-functions

optimization workflow workflow-optimization

• 
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5.3.10 View Style

Switch between wireframe and filled display rendering.

Quick Reference: View Style

5.3.10 View Style
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Location

Window → Toggle Wireframe / Filled

Keyboard Shortcuts

Option  / Alt + W

Changing the View Style alters the appearance of vector
graphics in your Workspace, which can be useful for spotting
potential design issues and visualizing the final output from a
project. 

These options only change the rendering of the objects in your
Workspace and do not affect the final work produced by the
laser. 

View Style Types

Filled: shapes that are assigned to layers set to Fill Mode will
appear as solid shapes, blocking out shapes behind them on
other layers. This is handy for getting a better understanding
of the overall design, but may hide duplicate or unwanted
shapes on different layers. Filled View Styles may also be
trickier to edit, as some objects are hidden behind others and
not easily selected. Render times may be longer on older or
less-powerful computers. 

Wireframe: all vectors in the design appear as outlines
(strokes). This style renders quickly and makes issues in a
design more obvious, but does not provide a visual indication

of which graphics are assigned to layers set to Fill Mode. Use 
Preview to see a rendering of your finished result instead. 

EDGE RENDERING QUALITY

Smooth: High detail, slower rendering. 

Course: Lower detail, faster rendering. 

Changing View Style

Select your desired View Style from the Window Menu.

Toggle between Wireframe and Filled mode at any time by
pressing Option  / Alt + W .

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

edge edge-rendering fill-mode filled preview

rendering rendering-quality vector view wireframe

⌥ ⎇
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5.3.11 Show Notes

Show Notes allows you to add, edit, and view notes for a project.
This is often useful for files that will be shared with others, or to
store related information for working with a project in the future.
Go to File → Show Notes or press Ctrl + Alt + N .

Edit the Notes by typing into the text box and clicking OK to save.
Press Cancel to discard any changes and close the window.

Enable the Show on File Open toggle to show the notes
automatically when the file is opened in LightBurn.

Related Topics

Job Checklist

File Management

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

editing optimization organization workflow

⌃ ⎇
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5.3.12 Print

Use File → Print (Black Only) or File → Print (Keep Colors) to
print the current contents of the work area using your
computer's print dialog. Most computers have built-in PDF
creation tools, allowing you to export a PDF using these tools as
well.

Be aware that the page size is controlled by the print dialog, not
by LightBurn. If your work area is larger than the paper selected
for printing, your design will be scaled to fit on the paper.

Windows 10 print dialog showing options including sending to a
printer and Print to PDF

Troubleshooting

If your design is printing too small, check the paper size you're
printing on. 

Beyond that, printing problems are likely to be related to your
computer and/or printer, rather than LightBurn. Please see the
relevant customer service resources for more help.

Related Topics

Save Processed Bitmap

Export

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

export file-management print

Page Size Warning

• 

• 
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Places nodes with straight lines or curves between them. 

Location

Tools Toolbar

Tools → Draw Lines

Keyboard Shortcuts

Windows: Ctrl + L

Mac: Cmd + L

Keyboard Modifiers

Press S  to toggle between placing corner and smooth
nodes.

Draw Lines is the fundamental tool for creating vector paths out of
straight lines and curves. Use it to create designs from scratch,
modify existing graphics, or to manually trace outlines around
images (see Trace Image for automatic tracing).

It's often helpful to refine designs with the Edit Nodes tool
after roughing them out with the Draw Lines tool.

Draw Lines allows you to place nodes (points in space, sometimes
called anchor points) that are linked by straight lines or curves
(Béziers). Curved lines are described by the length and direction of 
handles (tangents) that appear at one or both of the nodes at
either end of a curve. 

USING THE DRAW LINES TOOL

Activate the Draw Lines tool by clicking the pencil icon in the 
Tools Toolbar or pressing Ctrl / Cmd + L .

Once the tool is active, the cursor will change to indicate when
you are placing corner or smooth nodes.

Lines 

Placing corner nodes and creating lines is the default behavior of
the Draw Lines tool. 

Click anywhere in the Workspace to place a node at the start of a
new line, then move your cursor and click again in a different
location to place another node with a line in between. 

Draw Lines will continue adding nodes with line segments
between them as you click, until you either click back at the
starting point to close a shape, right-click your mouse to stop, or
press the Esc  key.

Quick Reference: Draw Lines

⌃

⌘

Tip

⌃ ⌘

⎋
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Curves 

There are two options for placing smooth nodes and creating
curves:

Auto-Smoothed Mode: press S  to toggle between creating
corner and smooth nodes (the cursor will change to indicate
which mode you're in). After toggling, click to place a smooth
node. The next line you create after placing a smooth node will
be curved, and its direction and intensity will be determined by
the placement of the next node.

Controlled Mode: click, hold, and drag while placing a node to
create a smooth node with control handles — move your
cursor while holding the click to control the direction and
intensity of the curve handle. Release to place the handle, then
click to place a node.

Constrain Placement Angle

Hold Shift  while moving your cursor to constrain node and
handle placement to a horizontal, vertical, or 45 degree angle
from the last node placed.

Continue an Existing Drawing

Click on the start or end point of an open path to continue an
existing drawing — new lines started from these points are
automatically connected to the pre-existing path.

If you create a line or curve that connects the start or end points
of two existing open shapes, LightBurn will Auto-Join them, and
the new, combined path will be indicated by the animated dash 
selection pattern.

Hold Ctrl / Cmd  while placing nodes to disable the Auto-Join
behavior.

Snapping

In either placement mode, you can add nodes by Snapping to
points on existing geometry: lines, corners, midpoints of lines,
intersections of lines, and other nodes. 

Your cursor will change to indicate the type of Snapping point
you're hovering over, and when you move your cursor close
enough to a valid point, it will Snap into position — click to place
a node perfectly aligned to that point.

• 

• 

⇧

⌃ ⌘
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Hold Option / Alt  while moving your cursor to Snap to points
from farther away.

Measuring

To measure while drawing a line, check the Status Bar. 

It shows: 

dx: the placement of the cursor along the X (horizontal) axis

dy: the placement of the cursor along the Y (vertical) axis

len: the length of the line segment that is currently being
placed

The angle between successive line segments as you create
them

HOW TO PRACTICE

RELATED TOPICS

Edit Nodes

Snapping

Selection

Images vs. Vectors

Open vs. Closed Shapes

Trace Image

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

creation-tools customization draw-lines

layout-and-design node-editing path path-creation

path-editing path-tools vector vector-creation

vector-editing vector-path-curve-lines vector-tools

⌥ ⎇
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Primary Shapes: Rectangles, Ellipses, and Polygons

This page covers the creation and editing of various Primary
Shapes, including: 

Rectangles and squares

Ellipses (ovals) and circles

Polygons with any numbers of sides, such as triangles,
pentagons, hexagons, octagons, etc.

The products of these tools are often used to create the
foundation of a design, either on their own, or combined with
other objects to build up complexity. 

These shapes are a special kind of vector object called Built-in
Shapes that retain editable properties such as number of Sides
for Polygons, or Corner Radius for Rectangles. 

SHAPE CREATION

Click one of the Primary Shape tools in the Tools Toolbar, Tools
Menu, or use the following keyboard shortcuts: 

Rectangle/Square: Ctrl  / Cmd + R

Ellipse/Circle: Ctrl  / Cmd + E

Polygon has no keyboard shortcut — select it from the toolbar.

Click, hold, and drag in your Workspace to create the selected
Primary Shape.

By default, the shape will begin at the first point you click, and
extend from that point in both directions as you drag.

Holding Ctrl  / Cmd  will instead draw the shape from the
center outward, which can be useful when aligning shapes to
other parts of a design. 

Holding Shift  while dragging will make the shape into its 
regular form — the Rectangle tool will make a square, the
Ellipse a circle, and the Polygon tool will make an equal-sided
polygon. 

Hold both keys at once to combine their effects. 

EDITING PRIMARY SHAPES

It's possible to adjust various aspects of an existing Primary
Shape in the Shape Properties Window, or by using special 
control handles on the shape in your Workspace. The aspects vary
between shape types but include dimensions, Corner Radius,
and number of Sides. 

Dimensions

You can change Width and Height in the Shape Properties
Window and the Numeric Edits Toolbar.

Corner Radius — Rectangle Only

Corner Radius rounds out the corners by a given amount, which
remains consistent even if the dimensions of the rectangle are
later changed. 

With a Rectangle selected, hold Ctrl  / Cmd , and a blue 
control handle will appear. Drag the blue handle away from the
corner to increase the radius of all four corners, and drag back
toward the corner to decrease it. Dragging vertically creates a
reversed radius, with a bite taken out of the corner.

You can also edit Corner Radius numerically in the Shape
Properties Window. 

Sides — Polygon Only

Adjust the number of Sides of a Polygon in the Shape Properties
Window to form different shapes — 3 will create a triangle, 6 will
create a hexagon, 8 will create an octagon, and so on. 

It's also possible to change the number of sides by holding 
Ctrl  / Cmd  and dragging the purple control handle that

appears near the polygon. 

• 

• 

• 

• ⌃ ⌘

• ⌃ ⌘

• 

• 

• ⌃ ⌘

• ⇧

• 

⌃ ⌘

⌃ ⌘
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Node-Editing a Primary Shape

Primary Shapes must be Converted to Paths to make editing
their nodes possible. This process permanently removes the
ability to edit a shape's dimensions, Corner Radius, or number
of Sides in the Shape Properties Window.

RELATED TOPICS

Create and Edit Text

Draw Lines

Shape Properties

Convert to Path

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

circle dimensions ellipse node-editing primary-shapes

radius rectangle shapes sides square

Create and Edit Text

Create, edit, and apply effects to text. 

Location

Tools Toolbar

Tools → Edit Text

Keyboard Shortcuts

Windows: Ctrl + T

Mac: Cmd + T

• 

• 

• 

• 

Quick Reference: Text

⌃

⌘
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Use the Create Text Tool to add text to your projects. Text created using the Create Text Tool is a special
type of built-in shape called a Text Object. 

There are several special settings you can apply to Text Objects through the Text Options Toolbar, Shape
Properties Window, or by directly editing them in your Workspace.

Use these settings to adjust font and size, change spacing, bend or curve your text, create Variable Text,
and more.

CREATING TEXT

To add a Text Object to your project, click the Create Text icon in
the left sidebar, go to Tools → Edit Text, or press Ctrl / Cmd

+ T .

Click anywhere in your Workspace and type in the text you'd like
to add.

Press Enter  while typing your text to jump to a new line and
continue typing. 

Press Esc  to finish creating the Text Object. 

By default, the location you click will be the center of the Text
Object you create, but you can adjust alignment in the Text
Options Toolbar.

EDITING TEXT

To edit a Text Object after creating it, enable the Create Text
Tool and click on it again, or double-click it without the Create
Text Tool enabled.

Right-click any Text Object and select Edit Text Shape to open a
dialog window where you can directly edit and adjust the text's
attributes.

Enable Selection double-click shows Text Edit dialog in the 
Settings window to open the Edit Text Shape window by double-
clicking instead.

BENDING TEXT

In addition to the Transform Control Handles used to Move, 
Resize, Rotate, and Shear objects, Text Objects have a special
handle for Bending. 

Select any Text Object to show a blue dot over the the text, then
hover your cursor over the dot until you see the Bend cursor 

.

Click, hold, and drag the cursor up or down to curve the text
around an imaginary circle.

Double-click the dot to clear the curve and restore the text.

Enable or disable the Distort toggle in the Text Options Toolbar
to choose whether to distort the text as part of the curve, or
leave the individual characters unchanged.

⌃ ⌘

⏎

⎋

Note

Using the Edit Text Shape window
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.

TEXT OPTIONS TOOLBAR

The Text Options Toolbar is where you adjust attributes of Text
Objects, including, Font, size (Height), spacing (HSpace and 
VSpace), and more.

Accessing the Text Options Toolbar

The Text Options Toolbar is located in the top toolbar in
LightBurn by default, to the right of the Numeric Edits Toolbar.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Options

Use the Font dropdown menu to select a a font. See below for
more information on fonts.

Height sets the overall height of text. Height varies based on
your selected font, and is not exact — it is generally the height
of a capital letter X in the font, but every font has an internal
size that is scaled by this Height, and the dimensions aren't
required to be accurate.

HSpace adjusts the horizontal spacing between individual
characters, as a percentage of the font size. Positive numbers
space the characters out more, and negative numbers move
them closer together.

VSpace adjusts the vertical line spacing as a percentage of the
font height. Positive numbers increase the distance between
lines, and negative numbers reduce it.

In the case of text, horizontal always refers to the direction of
the text as it is read, regardless of whether the Text Object is
rotated. Vertical refers to the opposite direction, regardless of
rotation. 

HSpace always controls distance between individual
characters,and VSpace always controls distance between
lines. 

Align X determines the horizontal anchor position of the text
— Left, Right, or Middle.

Align Y determines the vertical anchor position of the text — 
Bottom, Top, or Middle. Top aligns text to the top of capital
letters, and Middle aligns to roughly the middle of the capital
letters. This is most useful when using Apply Path to Text.

Enabling Bold displays the font in bold typeface, if available for
the selected font.

Enabling Italic displays the font in italics, if available.

Enabling Upper Case forces all characters to be upper case.

Welded enables automatic welding of characters. When
characters touch or overlap, as is common with script fonts,
enabling this option will automatically weld the overlaps
together. Characters will also weld together if HSpace is
reduced to a point where they overlap.

To curve text around more complex paths, use Apply
Path to Text.

Tip

• 

• 

• 

• 

Note

Adjusting HSpace and VSpace

• 

• 

Using Align X and Align Y

• 

• 

• 

• 
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Distort controls whether individual characters in a Text Object
will be warped when Bending them.

Enabling Right-to-Left forces Right-to-Left text rendering. This
option will not appear unless it's enabled in your Settings.
Right-to-Left will automatically be enabled if your current input
language is Right-to-Left.

The Text Mode dropdown menu and Offset field are used
when working with Variable Text. For information on these
options, see Variable Text.

Leave this value set to Normal if you are not using Variable
Text

FONTS

The list of fonts in LightBurn is taken from your computer
system. If you want to use a new font in LightBurn, install it on
your computer, then re-start LightBurn.

On Windows, after you have downloaded a font, right-click it and
choose Install. On Mac, double-click the font and click Install in
the font preview window that opens.

Favoriting and Filtering Fonts

Your most recently used fonts will always appear near the top of
the font list in the Recent section.

After selecting a font, you can right-click it in the dropdown
menu for additional options.

Select Add to Favorites to add the font to the your Favorite list.
Favorites will appear at the top of the font list. To remove it from
the list, right-click again and select Remove from Favorites.

Select Hide this font to remove the font from your list.

Click to enable or disable Show System Fonts, Show SHX Fonts,
or Show Hidden Fonts — a checkmark will appear next to each
option when it's enabled. SHX and System fonts are always
displayed by default, while Hidden fonts are not. When displayed,
Hidden fonts are shown in red. 

See below for more information on SHX Fonts.

Text Settings

There are several global font settings in the Editor Settings tab
of the Settings window.

Default Font changes the automatically selected font for new
projects.

Default Height changes the automatically applied font Height
for new projects.

Enable Right-to-Left text support allows you to turn on
Right-to-Left font rendering for any text. This setting is
automatically enabled on first run if a Right-to-Left language is
the current system input language, but it can be forced on
here later if necessary.

SHX Fonts

Set SHX Font Path sets the directory containing SHX font files —
clicking this button will open up your system's file explorer
window, where you can navigate to the location of the SHX font
folder on your computer. Click the button next to Set SHX Font
Path to clear the path. 

Once LightBurn knows where to load the SHX fonts from, they
will automatically appear in the Font dropdown menu in the Text
Options Toolbar. 

SHX Fonts are differentiated from normal fonts by the icon next
to each entry:

 denotes an SHX font.

 denotes a standard operating system font.

SHX fonts lack many of limitations of standard system fonts and
have the ability to define single line fonts, such as this:

MOVING LIGHTBURN FILES WITH FONTS

If you want to move designs containing text between computers
and continue to edit the Text Objects, be sure to install all
necessary fonts on all computers you're using.

When you save a copy of a file that contains text, LightBurn
automatically includes a copy of the text as a path and embeds it
into the file. If you open the file on another computer that has
the same font, you will be able to edit the Text Objects as usual. 

Welded vs. Unwelded comparison

• 

• 

• 

Installing fonts

• 

• 

• 

• 

• 
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However, if you open the design on a computer without the font,
LightBurn will warn you about the missing font(s) and load the
path embedded in the file. This prevents the file from breaking
when you move to another computer, but you won't be able to
edit the text without the correct font. 

If the font is installed at a later time, LightBurn will recognize it
and the text will become fully editable again. 

Right-click the imported text and select Convert to Text to
change the font of the text, and regain the ability to fully edit it.

Right-click the imported text and select Convert to Path to
change the text into a standard vector graphic that can be edited
using the Edit Nodes tool. Note that this change is permanent,
and you'll be unable to edit any of its text properties later. 

IMPORTING OTHER FILES WITH TEXT

If you open files not made in LightBurn that contain text, make
sure that any fonts used in the file are installed on your
computer, or that the text has been converted to paths using
whatever tools are available in the other program. 

Different programs use different terms for this process, but
terms such as welding, convert to outline, and convert to path are
common.

CONVERTING TEXT TO PATHS IN LIGHTBURN

In order to directly edit the lines and nodes of text in LightBurn, 
select all Text Objects you wish to convert, then go to Edit → 
Convert to Path, press Ctrl / Cmd  + Shift  + C , or
right-click in your Workspace and select Convert to Path from the
menu.

Read more about Convert to Path here.

RELATED TOPICS

Variable Text

Apply Path to Text

Convert to Path

Rectangles, Ellipses, and Polygons

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

creation-tools customization editing layout-and-design

text

Variable Text

VARIABLE TEXT

Use Variable Text to have LightBurn automatically substitute
specially formatted expressions with alternate data when you
output a project to your laser. 

In addition to outputting alternate text when you Start or Send a
project to your laser, the expressions will be replaced when you 
Preview, save a project in machine-specific format, or Export
graphics in SVG, DXF, or AI format.

You can use Variable Text to replace special expressions with:

Date or time stamps

Entries in a CSV file

Serial numbers

Cut Settings

See Variable Text Formatting for full details on supported
formatting expressions.

Selecting a Variable Text Mode

To create Variable Text, first use the Create Text tool to enter the
appropriate expressions for the type data you'd like to output,
then select the matching Text Mode from the dropdown menu in
the Text Options Toolbar.

Select Date/Time (for date and time stamps), Merge/CSV (for
entries in a CSV file), Serial Number, or Cut Setting.

If you select Merge/CSV or Serial Number formatting, you'll have
additional controls available in the Variable Text Window.

Accessing the Variable Text Window

The Variable Text Window is not enabled by default. To enable
it, go to Window → Variable Text.

The Variable Text Window will appear docked behind the Cuts /
Layers Window on the upper right side of your screen. Click the
Variable Text tab to bring the Variable Text Window to the front. 

⌃ ⌘ ⇧
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• 
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The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Variable Text Window Options

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Current

Determines the serial number or row from a CSV file that will be
substituted in place of the formatted expressions the next time
the project is output. 

The Current value advances between the Start and End values.
In other words, the sequence returns to the Start value when
increasing beyond End, or to the End value when decreasing
beyond Start.

Start

Determines the first serial number or row from a CSV file to be
output. 

For values other than 0, on the first run of a project you must 
Reset the Current value to the Start value, or the values will not
match. The Current and Start values are only matched
automatically when advancing forward from the End value,
returning to the beginning of the sequence.

End

The last serial number or row from a CSV file to output, before
advancing back to the Start value. 

Advance By

Tells LightBurn how many entries to advance (or reverse) the 
Current value each time you click Next or Previous.

Auto-Advance

When enabled, tells LightBurn to advance the Current value by
the amount entered in the Advance by field each time you Start, 
Send, or save a project in machine-specific format.

Previous

Decreases the Current value by the amount set in the Advance
by field. 

Next

Decreases the Current value by the amount set in the Advance
by field.

Reset

Resets the Current value to the Start value.

Test

Displays the text that will be output in place of the formatted
expressions, for as long as the button is held. 

Bake

Converts the formatted expressions to whatever data would be
output based on the Current value in the Variable Text Window,
in your Workspace.

The Baked text will no longer increment as a Variable Text Object
— the displayed text is exactly what will be output to your laser. 

Browse

Opens your systems's file browser, where you can navigate to
and load a CSV file saved to your computer. The name of the CSV
file will display in the Variable Text Window after it has been
loaded. 

Clear

Unloads a previously loaded CSV file.

Variable Text Offsets

Text Objects in LightBurn have an adjustable property called 
Offset, available in the Text Options Toolbar. Using Offsets allows
you to use the same formatting expression to output different
data.

Tip

Note

Warning
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The Offset value is added to the Current value in the Variable
Text Window when LightBurn evaluates the Text Object to
determine the data to output in its place.

For example, if you applied an Offset of 2 to a Text Object
formatted to output a serial number, with a Current value of
1000, the output serial number will be 1002.

Use the Offset value in conjunction with the Advance by value to
increment batches of the same design using Variable Text. For
instance, if you created a design with 4 name tag labels on the
page, you would set the Offset value for the four labels to 0, 1, 2,
and 3, and set the Current value to Advance by 4 with each run. 

Automatic Offsets

Some LightBurn tools can apply automatically advancing Offset
values to duplicated objects. 

Use Grid Array, Circular Array, or Copy Along Path to lay out
copies of designs while increasing the Offset of each copy by a
specified amount. 

Tip
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Shape Properties and Variable Text

There are three settings in the Shape Properties Window that are
useful when working with Variable Text.

Max Width sets the maximum possible width of selected Text
Objects — use this field to prevent Variable Text outputs from
exceeding a specified width after they're converted from
formatted expressions.

The Squeeze toggle determines whether Text Objects will be
rescaled in both directions in order to fit within the Max Width
value. 

When enabled, text will be shrunk horizontally, if necessary to
stay within the Max Width, but maintain the same height. 

When disabled, text will be shrunk proprotionally, both
horizontally and vertically.

Ignore Empty Vars instructs LightBurn to remove newlines
preceding empty Variable Text fields when aligning text.

Related Topics

Variable Text Formatting

Create and Edit Text

Repeat Marking

Grid Array

Circular Array

Copy Along Path

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

batch-production creation-tools customization editing

layout-and-design text workflow-optimization
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VARIABLE TEXT FORMATTING

Use the following formatting expressions with the appropriate 
Variable Text mode to have LightBurn replace the expressions
with alternate data when you output a project to your laser.

In order for each type of formatting expression to be replaced
with alternate data, you must also select the corresponding
mode from the dropdown menu in the Text Options Toolbar.

Use the Test button to verify that you have entered the
formatting expressions correctly, before sending a project to
your laser.

Date/Time

When using Date/Time formatting, LightBurn will automatically
substitute special combinations of characters with values for the
current local date and time, as determined by your system's
clock.

Use the following expressions for dates:

Use the following expressions for time:

Additional Notes

Any sequence of characters enclosed in single quotes will be
included verbatim in the output string (stripped of the quotes),
even if it contains formatting characters. 

Two consecutive single quotes ('') are replaced by a single
quote in the output. 

Tip

Output Expression

The day as number without a
leading zero (1 to 31)

d

The day as number with a leading
zero (01 to 31)

dd

The abbreviated localized day name
(e.g. "Mon" to "Sun"). Uses the
system locale to localize the name.

ddd

The long localized day name (e.g.
"Monday" to "Sunday"). Uses the
system locale to localize the name.

dddd

The month as number without a
leading zero (1-12)

M

The month as number with a
leading zero (01-12)

MM

MMM

Output Expression

the abbreviated localized month
name (e.g. "Jan" to "Dec"). Uses the
system locale to localize the name.

the long localized month name (e.g.
"January" to "December"). Uses the
system locale to localize the name.

MMMM

the year as two digit number
(00-99)

yy

the year as four digit number yyyy

Expression Output

h The hour without a leading zero (0
to 23 or 1 to 12 if AM/PM display)

hh The hour with a leading zero (00 to
23 or 01 to 12 if AM/PM display)

H The hour without a leading zero (0
to 23, even with AM/PM display)

HH The hour with a leading zero (00 to
23, even with AM/PM display)

m The minute without a leading zero
(0 to 59)

mm The minute with a leading zero (00
to 59)

s The whole second without a
leading zero (0 to 59)

ss The whole second with a leading
zero where applicable (00 to 59)

z The fractional part of the second, to
go after a decimal point, without
trailing zeroes (0 to 999). Thus
" s.z " reports the seconds to full
available (millisecond) precision
without trailing zeroes.

zzz The fractional part of the second, to
millisecond precision, including
trailing zeroes where applicable
(000 to 999).

AP or A Use AM/PM display. A/AP will be
replaced by either "AM" or "PM".

ap or a Use am/pm display. a/ap will be
replaced by either "am" or "pm".

t The time zone (e.g. "CEST")

• 

• 
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All other non-formatting characters in the input string are
included verbatim in the output.

Formats without separators (e.g. "ddMM") are supported but
must be used with care, as the resulting strings aren't always
reliably readable (e.g. if "dM" produces "212" it could mean
either the 2nd of December or the 21st of February).

Serial Number

When using Serial Number formatting, LightBurn will
automatically substitute special combinations of characters with
the Current serial number value.

Use the following expressions for serial numbers:

The number of characters controls how many digits will output. If
the Current serial number is larger than the number of digits
allowed, as many digits as will fit from the end of the number will
be displayed. For example, if your Current serial number is 1234,
the table below shows how that number would be formatted for
each of the displayed formatting inputs:

Additional Notes

Any sequence of characters enclosed in single quotes will be
included verbatim in the output string (stripped of the quotes),
even if it contains formatting characters. 

All other non-formatting characters in the input string are
included verbatim in the output.

Use the Offset field in the Text Options Toolbar to enter
multiple indentical formatting strings that output a different
serial number.

You cannot mix decimal and hexadecimal formatting in the
same text entry.

You cannot split a serial number with other characters. For
example, because of the hyphen between the two groups of
format characters, this string is not valid: ddd-ddd. 

Invalid strings will output as "bad serial format".

Merge/CSV

When using Merge/CSV formatting, LightBurn will automatically
substitute special combinations of characters with an entry from
a CSV file.

A CSV file is a Comma Separated Values file — a very simple text
format that uses a line in a file as the row, and commas to

• 

Tip

Output Expression

The serial number as a decimal
value

d

The serial number as a
hexadecimal value, lower case

h

The serial number as a
hexadecimal value, upper case

H

Tells LightBurn to pad the number
with leading zeros

0

Input Output Input Output

d 4 0d 4

dd 34 0dd 34

ddd 234 0ddd 234

dddd 1234 0dddd 1234

ddddd 1234 0ddddd 01234

dddddd 1234 0dddddd 001234

• 

• 

• 

• 

• 

• 
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separate columns. You can create a CSV file using a plain text
editor, or by exporting from most common spreadsheet software.

In a Merge/CSV entry in LightBurn, the text you enter uses the
percent sign followed by a number to look up a column in the
current row of the CSV file. 

Columns and rows are numbered starting from 0. 

Refer to the first column in a CSV using the formatting "%0",
the second using "%1", the third using "%2", and so on. 

A Current value of 0 refers to the first row, 1 to the second, 2
to the third, and so on.

For example, using a CSV file with the following content:

And entering this formatting:

"I'm thinking of buying %0, it costs $%1."

Would output:

"I'm thinking of buying LightBurn, it costs $80."

Additional Notes

Use the Offset field in the Text Options Toolbar to enter
multiple indentical formatting strings that output a different
row from a CSV.

Cut Setting

When using Cut Setting formatting, LightBurn will automatically
substitute certain characters with values from the Cut Settings
applied to the text, or another specified layer.

Use the following expressions for Cut Settings:

Additional Notes

Any sequence of characters enclosed in single quotes will be
included verbatim in the output string (stripped of the quotes),
even if it contains formatting characters. 

All other non-formatting characters in the input string are
included verbatim in the output.

Related Topics

Variable Text

Create Text

Repeat Marking

Grid Array

Circular Array

Copy Along Path

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

• 

• 

• 

LightBurn,80,10
Corel,300,20

• 

Expression Output

C Followed by a number, pulls
settings from the numbered cut
layer (e.g. C03) for the remainder of
this string

s Speed, as a number in the current
speed units

S Speed, including the current units
(like mm/sec)

p Max Power, as a percentage

Expression Output

P Max Power, including the percent
sign

m Min Power, as a percentage

M Min Power , including the percent
sign

d / D DPI, as a number, always dots per
inch

i Interval, in the current distance
units

I Interval, including the current
distance units (like mm)

L Displays the name of the laser. Can
optionally be followed by a
character index to start displaying
from, and optionally, a comma and
a 2nd number for the number of
characters to display. For example,
if L displayed "Ruida 6442G", L6
would display "6442G", and L6,4
would display "6442" (without the
quotes)

z Z Offset for the current layer, in the
current distance units

Z Z Offset for the current layer
including the units (eg, mm)

q Q-Pulse width

Q Q-Pulse width, followed by "ns" to
indicate the units

k Frequency in kHz

K Frequency in kHz, followed by "kHz"
to indicate the units

• 

• 

• 

• 

• 

• 
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batch-production creation-tools customization

layout-and-design object-modification text variable-text

workflow-optimization

Create Bar Code

Generates a Bar Code which stores data that's visible when the code is scanned later.

Location

Tools → Create Bar Code

Create Bar Code generates a Bar Code which stores data that's
visible when the Code is scanned. This tool offers a wide range of
common Bar Code formats, including QR Codes. 

CREATING BAR CODES

To activate Create Bar Code, go to Tools → Create Bar Code. 

Quick Reference: Create Bar Code
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Click, hold, and drag in your Workspace to define the size of the
Bar Code, then release to create it. You can resize the Bar Code
later. 

The Bar Code Properties window will automatically open, where
you can select a Bar Code format, enter data, and adjust
additional options. 

The appearance of the Bar Code will live-update in your
Workspace as you make changes. 

Click OK to finish creating the Bar Code, or Cancel to delete it.

EDITING BAR CODES

There are two ways to re-open the Bar Code Properties window
after making a Bar Code:

Double-click the Bar Code.

First select it, then right-click in your Workspace, and select Edit
Bar Code from the context menu.

Edit Bar Code will only appear in the context menu if you have
exactly one Bar Code — and nothing else — in your selection.

• 

• 

Note
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BAR CODE PROPERTIES

Bar Code Type

Select a Bar Code Type from the dropdown menu at the top of the 
Bar Code Properties window.

The default Bar Code Type for all newly created Bar Codes is QR
Code, or the last format you selected.

2 of 5

2 of 5 IATA

2 of 5 Industrial

Aztec

Chinese Sensible

CodaBar

Code 128

Code 93

Data Matrix

EAN

Grid Matrix

ISBN

PDF417 

PDF417 Compact

PDF417 Micro

Plessey

QR Code

QR Micro

QR Micro Rectangular

UPC A

UPC E

VIN

Data Entry Field

Enter data to store in the Bar Code in the Raw Content field. 

For QR Codes, you can choose to enter data as Raw Content, WIFI
credentials, or Contact information.

Any data entered in the WIFI or Contact tab will automatically
populate the Raw Content tab. 

The last tab you enter data into overwrites data previously entered
into another tab.

Full list of supported Bar Code Types

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 
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The WIFI and Contact tabs for QR Codes
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Character Limit

The character limit beneath the Raw Content field displays the
amount of remaining characters supported by the Bar Code
Type you have selected.

Text Evaluation

See Variable Text and Variable Text Formatting for full details on
working with Variable Text in LightBurn.

The Text Evaluation dropdown menu allows you to select a 
Variable Text format that will substitute different output in place
of specially formatted codes. 

Normal is selected by default — the data stored in your Bar Code
will match the Raw Content exactly, if you leave Normal
selected.

You'll see the output that will result from your formatted codes in
the Evaluated Text field.

Variable Offset

Variable Offset adds to the Current value in the Variable Text
Window by the entered amount, allowing you to have multiple
Bar Codes in your Workspace using the same Variable Text
formatting, but displaying different Serial Numbers, or referring
to different rows of a CSV. 

Process Control Characters

Enable this switch to convert specially formatted characters ( <RS> , <ACK> , etc.)
into non-printable characters used by GS1 compliant systems.

Control characters should be enclosed in <> brackets like this:

[)><RS>06<GS>17V8X691<GS>1P02551706-01<GS>S062<RS><EOT>

When Process Control Characters is enabled and valid characters are
entered, you'll see converted characters in red in the Evaluated Text field.

Error Correction Level

Error Correction helps to keep Bar Code data readable even if
the Bar Code is partially damaged or obscured — use the Error
Correction slider to adjust the amount of Error Correction in a
Bar Code.

Different Bar Code Types provide different ranges of possible
Error Correction — the highest Error Corrections produce Bar
Codes that are more resilient to damage, but are visually denser
and more complex.

Not all Bar Code Types support Error Correction.

Aztec

Chinese Sensible

Grid Matrix

PDF417 

PDF417 Compact

PDF417 Micro

QR Code

QR Micro

QR Micro Rectangular

Info

Bar Code Types supporting Error Correction

• 

• 

• 
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Show Bar Code Text

For supported Bar Code Types, tells LightBurn to output the text
from the Raw Content field along with the Bar Code. This switch
is enabled by default.

2 of 5

2 of 5 IATA

2 of 5 Industrial

CodaBar

Code 128

Code 93

EAN

ISBN

Plessey

UPC A

VIN

Extra Data Spacing

Some Bar Code Types support adding a secondary Bar Code
based on extra data input after a "+" symbol. The Extra Data
Spacing slider controls the distance between the primary and
secondary Bar Codes.

EAN

ISBN

UPC A

UPC E

Force Square

When Data Matrix is the selected format, some data inputs can
result in a rectangular Bar Code. Enable Force Square to have
the Data Matrix always remain square. This switch is enabled by
default. 

Error Messages

If the data you've entered is invalid for the type of Bar Code
you've selected, you'll see an X in the Workspace and an error
message in the Bar Code Properties window.

The error message will indicate which characters are invalid. 

RELATED TOPICS

Variable Text

Repeat Marking

Create and Edit Text

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

Bar Code Types supporting Barcode Text
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Bar Code Types supporting Extra Spacing
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QR-code bar-code batch-production creation-tools

layout-and-design object-customization variable-text

Shape Properties Window

The Shape Properties Window displays editable properties of 
selected objects. 

ACCESSING THE SHAPE PROPERTIES WINDOW

The Shape Properties Window is not enabled by default. Select 
Window → Shape Properties to enable the window.

The Shape Properties Window will appear docked behind the 
Cuts / Layers Window on the upper right side of your screen.
Click the Shape Properties tab to bring the Shape Properties
Window to the front. 

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

SHAPE PROPERTIES OPTIONS

The options available in the Shape Properties Window depend
on the type of object you have selected.

Three options are available for all types of objects, or when you
have multiple types of objects selected at once. 

Cut Order Priority: sets the order this shape is cut by the
laser. Lower values are cut first, starting with 0 as the highest
priority. You must also select Order by Priority in the 
Optimization Settings for this setting to take effect.

Power Scale: rescales the power used to cut this shape by this
percentage, between Min Power and Max Power. For devices
that do not support the Min Power setting, power is scaled as
a percentage between 0 and Max Power. 

Locked: prevents any edits to the selected shape(s). See Lock
Shapes for more information. 

When multiple shapes are selected, changing these values acts
on all selected shapes at once.

See below for additional properties that are presented only when
you've selected specific types of objects. 

Tip

• 

• 

• 
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IMAGE

These settings are presented for image graphics.

Gamma: adjusts
mid-tones shades
— Lower values
lighten the mid-
tones, and higher
values darken
them. 1.0 is normal.

Contrast: increases
or decreases image
contrast — higher
values make light
tones lighter and
dark tones darker. 

Brightness:
increases or decreases image brightness, making both light
tones and dark tones lighter or darker.

Enhance: increases the contrast of edges within the image - also
known as Unsharp Masking and High-Pass Sharpening.

Enhance Radius: controls the spread of edge contrast — a larger
radius spreads the Enhance effect further from the edges within
an image. 

Enhance Amount: controls the intensity of the edge contrast. 

Enhance Denoise: reduces noise in smooth areas. 

ELLIPSES

These settings are presented for shapes made using the Create
Ellipse tool.

Width: the length
of the ellipse in the
horizontal (X Axis)
dimension.

Height: the length
of the ellipse in the
vertical (Y Axis)
dimension.

POLYGONS

These settings are presented for shapes made using the Create
Polygon tool.

Width: the length of
the polygon in the
horizontal (X Axis)
dimension.

Height: the length
of the polygon in the
vertical (Y Axis)
dimension.

Sides: sets the number of sides of the shape — 3 = triangle, 6 =
hexagon, 8 = octagon, etc. 

RECTANGLES

These settings are presented for shapes made using the Create
Rectangle tool.

Width: the length of
the rectangle in the
horizontal (X Axis)
dimension.

Height: the length of
the rectangle in the
vertical (Y Axis)
dimension.

Corner Radius:
applies a radius to corners. Positive values create curved corners,
negative values takes a bite out of the corner. 

TEXT

These settings are presented for text made using the Create Text
tool.

Max
Width:
text
begins
scaling if
the length
in the
horizontal
(X Axis)
dimension
exceeds
this — use
0 for no limit.

Squeeze: when enabled, as the text exceeds the Max Width, the
horizontal axis is scaled, but the vertical height remains the
same, resulting in a squished appearance. When disabled, text
will shrink proportionally, both horizontally and vertically.

Ignore Empty Vars: instructs LightBurn to remove newlines
preceding empty Variable Text fields when aligning text.

RELATED TOPICS

Adjust Image

Primary Shapes

Create and Edit Text

• 

• 

• 
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For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

QR-code built-in-shapes circle ellipse image path

polygon rectangle square text vector

Add Tabs

Tells your laser to skip small sections of cuts, to prevent cut objects from immediately
falling from the base material.

Location

Tools Toolbar

Tools → Add Tabs

Keyboard Shortcuts

Windows: Ctrl + Tab  Mac: Cmd + Tab

Tabs are small sections of cuts that the laser is commanded to skip, used to prevent objects that you are cutting from immediately falling out of the base material. When sized
appropriately, the tabs can be broken with minimal force and the objects removed from the material after the job is finished cutting.

You can create tabs manually using the Add Tabs tool, or LightBurn can generate them automatically. Options controlling the size of Manual tabs, and spacing, number, and
positioning of Automatic tabs, are available in the Cut Settings Editor.

In the example below, the left square has no tabs applied, while the right has a single 1 mm wide tab on each side.

Quick Reference: Add Tabs

⌃ ⇥ ⌘ ⇥
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ADDING TABS MANUALLY

To manually add tabs, select Add Tabs from the Tools Toolbar (or
press Ctrl  / Cmd + Tab ), then hover over a shape in your 
Workspace that's assigned to a layer set to Line Mode. 

If you are hovering over a valid shape, you'll see the Insert Tab

cursor ( ). Click to insert a tab at that location. A red dot will
appear on the shape, indicating that the tab has been placed. 

Click and drag the red dot to move its location on the shape, or
even to another valid shape in your Workspace.

The default width of manually-placed tabs is .5 mm. Tabs cannot
be placed closer together than is allowed by their width. See the
next section for information on adjusting tab width. 

To remove an existing tab, double-click the red dot, or hold the 
Shift  key while clicking it. 

AUTOMATIC TAB GENERATION AND TAB SETTINGS

To adjust the settings for Manual tabs, or enable and adjust
settings for Automatic tabs, double-click a layer set to Line
Mode in the Cuts / Layers Window, to open the Cut Settings
Editor. 

Tab settings are available in the lower half of the Cut Settings
Editor.

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Global Enable / Disable

The switch next to Tabs / Bridges controls whether tabs are
enabled for the layer. If you have manually added tabs to a
shape, this will automatically be switched on for the layer the
shape is assigned to. 

Switch Tabs / Bridges off to disable tabs. Tab settings and
placement are not lost when this switch is turned off, and are
restored exactly as they were if it is switched on again.

Tab Generation

Manual: all tabs must be manually placed using the methods
described above.

Automatic: tabs will be placed on shapes assigned to the
layer, based on the values of Even Spacing, Tabs Per Shape,
and Skip Inner Shapes.

Tab Size

This setting affects both Manual and Automatic tabs.

Tab Size defines the total length of all tabs, in the currently
configured system unit type (mm or inch). The laser will skip
cutting for this distance, if possible.

Even Spacing

With Even Spacing selected, each contiguous path section will
have at least one tab applied at the very start of the path and
then again at the distance interval set in the Spacing field.

Spacing is set in the currently configured system unit type (mm
or inch).

⌃ ⌘ ⇥

⇧

• 

• 
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Limit Max Tabs

Enable Limit Max Tabs to set an upper bound on how many tabs
can be automatically generated for each path, when using Even
Spacing.

Tabs Per Shape

Select the Tabs Per Shape option to specify the number of tabs
to create on each path assigned to the layer. Tabs will be
automatically spaced evenly along the path.

Tab Cut Power

This setting affects both Manual and Automatic tabs.

If Tab Cut Power is set to any value other than 0%, the laser will
make pulsed cuts across the width of the tabs instead of skipping
them completely.

Increasing the percentage increases the amount the laser pulses
on during tabs, resulting in tabs that are more weakly connected
to the base material.

In the example below, the top tab is set to 25%, while the bottom
tab is set to 75%. The black lines represent areas along the path
where the laser is on, and the red lines represent areas where
the laser is off. 

Skip Inner Shapes

When enabled, any shapes that are completely contained by
another shape in the same cut layer will not have Automatic
tabs applied. This does not affect Manual tab placement.

Containing shapes must be closed, continuous loops in order for
LightBurn to identify shapes within them. See Open vs. Closed
Shapes for more information. 

Clear Tabs

Deletes all tabs (Manual or Automatic) from every shape on this
cut layer.

TROUBLESHOOTING

Tabs functions are not available if you are using Beginner
Mode. You can disable Beginner Mode in Settings/Preferences.

RELATED TOPICS

Cut Settings Editor

Perforation Mode

Kerf Offset

Ramp Length

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

creation-tools cut-settings laser-control

layout-and-design line

Warning

• 

• 

• 

• 
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Measure

Displays an array of useful information about objects.

Location

Tools Toolbar

Tools → Measure

Keyboard Shortcuts

Windows: Alt + M

Mac: Option + M

Keyboard Modifiers

Hold Shift  while dragging a temporary line to lock it to
horizontal, vertical, or a 45 degree angle.

Use the Measure tool to hover over any shape in your 
Workspace and display an array of useful information about it,
including perimeter, overall dimensions, whether it is Open or
Closed, and the lengths of individual line or curve segements

within it. You can also click and drag to create and measure a
temporary line between two points.

To enable the Measure tool, click on the ruler icon in the Tools Toolbar, or press Alt / Option + M . 

USING THE MEASURE TOOL

Hover your cursor over any shape in your Workspace to see
information on a given shape. Move your cursor over any
individual line or curve segment in a shape to see information on
that specific segment.

As you hover the cursor over shapes, individual shapes are
highlighted in green, and the segment the cursor is currently
hovering over is highlighted in purple, as shown below:

Drag Measure

Click, hold, and drag between any two points in your Workspace
to display information on a temporary line created between
those points. You can snap to a shape or node on a shape, or
click anywhere in your Workspace, even if no shape is present. 

Hold Shift  while dragging to lock the temporary line to
horizontal, vertical, and 45 degree angles.

Quick Reference: Measure

⎇

⌥

⇧

⎇ ⌥

⇧

5.4.1 Creation Tools

- 142/400 - ©️ LightBurn Software, LLC

../../img/Ref-Measure-InToolbar.png
../../img/Ref-Measure-InToolbar.png


When using any of LightBurn's shape creation tools, you can also
view the measurements of the shape you're creating in the 
Status Bar. 

MEASUREMENT WINDOW

The Measurement dialog window describes the highlighted
shape and individual segment. The dialog displays the following
values:

RELATED TOPICS

Selection Tools

Numeric Edits Toolbar

Shape Properties

Alignment

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement editing layout-and-design testing-tools

troubleshooting workflow

View shape dimensions as you create them

Value Explanation

Nodes Number of nodes (points at starts
and ends line segments and
curves)

Lines Number of straight lines

Curves Number of arcs or Bézier curves

Perimeter
Length

Total length of all line/curve
segments

Closed/Open Whether or not the shape is closed

Area The total area of the shape. Empty
for open shapes

Segment Length Length of the highlighted line/
curve segment

Start Point X, Y coordinate of the start node of
the highlighted segment

End Point X, Y coordinate of the end node of
the highlighted segment

Difference Difference in X and Y between the
start and end nodes

Angle Angle of the line between the start
and end points

Arc Radius Radius of the arc, if the curve is a
true circular arc. Empty otherwise

Value Explanation

Arc Center Center point of the arc, if the curve
is a true circular arc. Empty
otherwise

• 

• 

• 

• 
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Art Library

An Art Library provides a way to store artwork so you can
quickly access and reuse it in future projects. 

You can load multiple Art Libraries at the same time, and
separate Libraries are a great way to split artwork up by theme
(holidays, birthdays, animals), or purpose (tests, tools, templates,
boxes). 

An entry in an Art Library can contain any combination of objects
that would normally make up a project, including text, Primary
Shapes, paths, and images. 

The Library only stores artwork, much like the contents of AI,
SVG, DXF, or image files — it doesn't store any Cut Settings
applied to the artwork. If you wish to store cut settings with your
design, you must Save your work instead.

ACCESSING THE ART LIBRARY WINDOW

The Art Library Window is not enabled by default. To open it, go
to Window → Art Library. 

By default, the Art Library will appear docked on the left side of
your Workspace.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

USING THE ART LIBRARY

You'll see a list of Art Libraries on the left, and thumbnails of the
artwork within the currently selected Library on the right. 

If there are no Libraries listed, a New Library must be created, or
an existing one Loaded, in order to access artwork. 

Creating a Library

To create an empty Library, click the New button, then choose a
location and name for the .lbart  file — this is where added
artwork will later be stored, in compact form.

Loading and Unloading Libraries

To add a previously saved Library, click the Load button in the
bottom of the Art Library Window. Saving, transferring, and
Loading Libraries makes it possible to share artwork between
computers and users. 

To remove a Library from the list, click Unload. Unloading a
Library removes it from view, but does not delete the file or its
contents from the hard drive where it is saved. 

Storing Art in a Library

Use the Import button to add artwork from saved files to your
Library. You can import multiple files at once using this method,
and each will become an individual entry in the current Library. 

To add selected objects from your current project, click Import
Graphic from Project, or right-click in the Art Library Window
and choose Add Selection to Library.

Editing Art and Libraries

Right-clicking artwork in an Art Library brings up the options to 
Delete or Rename it.

To change the name of a Library, change the .lbart  file name in
your file browser, and then Unload and Reload the Library in
LightBurn.

Adding Art to a Project

Dragging a thumbnail from the Art Library into a project adds it
to the project wherever the mouse is released. 

Clicking the Add Graphic to Project button adds the selected
artwork into the center of the current field-of-view in the 
Workspace. 

RELATED TOPICS

Import

Save

Material Library

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

Note

Tip

Note

• 

• 

• 
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5.4.2 Editing

Edit Nodes

Edit vector paths by moving, changing, or deleting nodes, lines, and curves. 

Location

Tools Toolbar

Tools → Edit Nodes

Keyboard Shortcuts

Windows: Ctrl + `

Mac: Cmd + `

Edit Nodes allows you to make precise, granular edits to vector paths, by controlling the placement and behavior of nodes (points in space, sometimes called anchor points) which are linked by straight lines or curves. The curved lines are described by the length and direction of handles (tangents) which appear on one or both nodes at
either end of a curve. 

Quick Reference: Edit Nodes

⌃

⌘
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USING EDIT NODES

To enable Edit Nodes, click on the Edit Nodes icon in the Tools
Toolbar or press Ctrl / Cmd  + `  on your keyboard. 

If you already have an object (or objects) in your selection, its
nodes will appear. If you do not have anything currently selected,
click an object to view and edit its nodes.

Mouse Actions

Click and and drag on nodes, handles, or curves to move
them.

Click any node or handle to select it, and then use the
keyboard arrow keys and modifier keys to move it by the
increments set in the Shape Move Increments fields in the 
Settings window.

With a node or handle already selected, hold Shift  while
clicking on another node or handle to add it your selection,
then drag or use the arrow keys to move each selected node
or handle in unison.

Click any straight line and drag to automatically turn it into a
curve. 

Drag disconnected nodes on top of one another to
automatically join them, turning the lines on either side into a
single shared path.

Keyboard Actions

There are several additional keyboard commands, listed below,
that you can use to edit and manipulate lines, curves, and nodes. 

You can quickly reference the keyboard commands for each of
these at any time by hovering over the Edit Nodes tool in the
toolbar. 

⌃ ⌘

• 

• 

• ⇧

• 

• 

Action Key Description Method

Delete node D Delete nodes
and combine
adjacent lines

Hover over a
node (or select
multiple nodes)
and press key

Insert I Insert node
anywhere on
path

Hover over
curve or line
and press key

Insert node at
midpoint

M Insert node at
the halfway
point between
two nodes

Hover over
curve or line
and press key
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Trim and Extend Demo

Snap to Existing Geometry

Snapping allows you to align your nodes or handles to specific
points on existing objects.

Constrain Movement

Hold Shift  while moving a node or handle to constrain
movement to a 90° or 45° angle from its starting position,
indicated by temporary guidelines in your Workspace.

If you select multiple nodes or handles at once, only the
movement of the last-selected node or handle will be
constrained, and the other nodes or handles will move along
with it.

REQUIREMENTS

You can only use Edit Nodes with paths. You can create paths
with the Draw Lines tool or Import vector objects into
LightBurn from another source.

To use Edit Nodes with other, built-in vector objects, you must
first use Convert to Path to turn them into standard paths. This
requirement applies to:

Text Objects

Primary Shapes: Rectangles, Ellipses, and Polygons

Barcodes

You cannot use Edit Nodes with Grouped objects. Ungroup
them first.

HOW TO PRACTICE

RELATED TOPICS

Draw Lines

Trim Shapes

Snapping

Selection

Images vs. Vectors

Open vs. Closed Shapes

Action Key Description Method

Convert smooth
node to corner

C Convert node to
corner (curve
handles will
have
independent
angles)

Hover over
smooth node
and press key

Smooth corner
node

S Convert node to
smooth (curve
handles will
have same
angle)

Hover over
corner node and
press key

Break shape at
point

B Open path at
node

Hover over a
node and press
key (move one
of the nodes to
reveal the gap)

Delete line D Delete line or
curve (open or
split path)

Hover over a
line or curve
and press key

Convert curve to
line

L Convert to line
(straighten a
curve and
remove
handles)

Hover over a
curve and press
key

Convert line to
smooth curve

S Convert to curve
(add handles
either side of
line)

Hover over line
and press key

Align to angle A Rotate selection
by aligning
segment to
nearest
horizontal,
vertical, or 45°
angle — all
selected objects
will rotate along
with the
segment

Hover over line
and press key

Trim line T Cut line under
mouse back to
the next place it
intersects with
another line

Hover over
curve or line
and press key

Extend line E Extend line to
nearest
intersecting
path

Hover over an
open end point
and press key

⇧

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 
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Auto-Join Selected Shapes

Break Apart

Trace Image

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.
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node-editing object-manipulation path path-editing

path-tools vector vector-editing vector-path-curve-lines

vector-tools

Trim Shapes• 

• 

• 
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Cuts lines back to the next place they intersect with another line.

Location

Tools Toolbar

Tools → Trim Shapes

Keyboard Shortcuts

Windows: Ctrl + K

Mac: Cmd + K

Keyboard Modifiers

Hold Ctrl  / Cmd  to disable Auto-joining.

Use the Trim Shapes tool to cut line segments back to the next
intersection with another line.

If a shape does not intersect with any other lines, Trim Shapes
deletes the entire shape.

USING TRIM SHAPES

To enable Trim Shapes, click the scissor icon in the Tools Toolbar or press Ctrl / Cmd + K .

After activating the Trim Shapes tool, hover over any vector object in your Workspace to see a preview of
the effect Trim Shapes will have on that object.

When you hover over a valid line segment, the cursor will change to the scissor icon, and the segment to be
deleted will turn red. 

Click to delete the segment.

This feature works with Primary Shapes, but will remove the
ability to edit their special Shape Properties, as they are 
Converted to Paths in the process.

If you hover over a shape that does not intersect with any other
lines, the entire shape will be highlighted in red, and deleted
when you click.

Auto-Joining With Trim Shapes

When possible, Trim Shapes joins the new vector objects at the
points where they used to intersect, combining them into a
single path. 

Quick Reference: Trim Shapes

⌃

⌘

⌃ ⌘

⌃ ⌘

• 

• 

Primary Shapes
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When a shape has been joined with another, it will automatically
be selected, and you'll see the animated dash pattern that
indicates selected objects.

Hold Ctrl  / Cmd  while clicking to disable automatic joining
when using Trim Shapes.

TROUBLESHOOTING

Trim Shapes does not work on Grouped objects — you'll need
to Ungroup them first. 

RELATED TOPICS

Edit Nodes

Boolean Tools

Cut Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

creation-tools layout-and-design

Numeric Edits Toolbar

Use the Numeric Edits Toolbar to adjust the size, position, and 
orientation of shapes in your selection using precise numeric
values. 

When adjusting objects through the Numeric Edits Toolbar, all
objects in your current selection are treated as a single unit,
maintaining their relative positions and scale as you make
changes. 

ACCESSING THE NUMERIC EDITS TOOLBAR

The Numeric Edits Toolbar is located in the top toolbar in
LightBurn by default, to the left of the Text Options Toolbar.

If you have closed the Numeric Edits Toolbar, go to Window → 
Numeric Edits to re-enable it. To restore it and all other windows
to their default positions, go to Window → Reset to Default
Layout

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

NUMERIC EDITS TOOLBAR OPTIONS

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

9-Dot Control

When working with any of the Numeric Edits options, imagine
the selection area as the smallest possible rectangle that can
contain every object in your selection. Each position in the 9-Dot
Control is a point around the perimeter of that rectangle, or in its
center.

The 9-Dot Control determines the location on the current
selection that is referenced when displaying and adjusting
selection coordinates; the anchor point which objects are 
rescaled in toward or away from; and which point to use as the
center of rotation when rotating the selection.

Note

⌃ ⌘

• 

• 

• 

• Tip

Note
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XPos and YPos

XPos and YPos display the current X (horizontal) and Y (vertical)
positions of your selection, relative to the point in your selection
indicated by the 9-Dot Control, and your laser's Origin. 

The laser's Origin is indicated by a small red square in a corner of
the Workspace. Positive XPos and YPos values are always within
the Workspace, and negative values outside of it.

Adjusting either field will move the indicated position on the
current selection to the new location you enter, and all objects in
the selection will move in unison. 

You can adjust position by imprecise values directly in your 
Workspace using the Move handle on your selection.

Width and Height

Width and Height display and determine the length of your 
selection in the X (Width) and Y(Height) dimensions. You can
enter exact values in the field directly to the right of Width and
Height, or change the size of either dimension by percentage in
the fields to the right of those. 

The chosen location in the 9-Dot Control determines an anchor
point that objects will be rescaled in toward or away from. 

You can adjust Width and Height by imprecise values directly in
your Workspace using the Size handles on your selection.

Lock

The Lock icon to the left of Width and Height determines
whether the aspect ratio of the selection is maintained as objects
are resized. 

In locked mode — indicated by a highlighted, closed lock icon
— the proportions of your selection remain consistent as
they're resized. 

As an example, a rectangle that is currently 50 mm wide and
25 mm tall is twice as wide as it is tall, for a 2:1 aspect ratio. If
the aspect ratio is locked, changing the width to 80 mm will
automatically change the height to 40 mm. 

In unlocked mode — indicated by an unhighlighted, open lock
icon — the proportions of your selection will not remain
consistent as they're resized, and will instead change
independently. 

Click the icon to change modes.

Rotate

Use the Rotate field to turn the current selection by a precise
number of degrees. Positive values rotate the selection
clockwise, while negative values rotate it counterclockwise.

The chosen location in the 9-Dot Control determines the center
of rotation.

You can rotate your selection by imprecise values directly in your
Workspace using the Rotate handles, or by precise values using
hotkeys.

Tip

Tip

• 

• 

• 

Tip
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Units Toggle

Click the Units Toggle to switch your current unit of
measurement between imperial and metric. You can also adjust
units in the Settings window.

The current unit of measurement is displayed as mm for
millimeters or in for inches.

EQUATION SUPPORT

The XPos, YPos, Width, Height, and Rotate fields all accept
equations.

Examples of valid equations are: 

58 + 37

89 - 13

10.25 / 2

(10+2) * 4 + 1

Press enter to process the equation and adjust the value. 

You can also use the constants e and pi, and functions like sin,
cos, tan, sqrt, abs, atan, log, pow, and more.

AUTOMATIC UNIT CONVERSION

The XPos, YPos, Width, and Height fields accept units of
measurement as well. 

If you are working in millimeters, but you want to create a shape
that is 5 inches wide, you can enter 5in or 5" into the width field
and LightBurn will convert it to millimeters for you.

RELATED TOPICS

Transform Controls

Text Options Toolbar

Shape Properties

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.
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vector vector-editing vector-path-curve-lines

vector-tools

Convert to Path

Turns built-in shapes (text, polygons, etc.) into editable paths.

Location

Edit → Convert to Path

Right-click → Convert to Path

Keyboard Shortcuts

Windows: Ctrl + Shift + C

Mac: Cmd + Shift + C

Convert to Path transforms built-in shapes created in LightBurn
into paths made up of lines, curves, and nodes, that can be
edited using the Edit Nodes tool. 

The following built-in shapes must be converted to paths in order
to edit their lines, curves, and nodes:

Rectangles, Ellipses, and Polygons

Text Objects

Bar Codes

USING CONVERT TO PATH

Select all shapes you wish to convert, then go to Edit → Convert
to Path, press Ctrl / Cmd  + Shift  + C , or right-click in
your Workspace and select Convert to Path from the context
menu.

The objects become normal paths, and their lines, curves, and
nodes can be adjusted using the Edit Nodes tool. The letters of 
Text Objects are separated into discrete shapes that can be
moved and manipulated individually. 

• 

• 

• 

• 

• 

• 

• 

Quick Reference: Convert to Path

⌃ ⇧

⌘ ⇧

• 

• 

• 

⌃ ⌘ ⇧
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TROUBLESHOOTING

Grouped objects cannot be converted to paths, and the option
will be grayed out or unavailable if you have Grouped objects
selected. Ungroup any object you'd like to convert. 

After converting an object to a path, you will lose the ability to
adjust attributes associated with the type of shape it was
converted from. 

The following attributes can no longer be edited in the Shape
Properties Window:

The Width and Height of Rectangles, Ellipses, and Polygons.

The Corner Radius of Rectangles.

The number of Sides of Polygons.

The Max Width of Text.

Text properties are no longer adjustable in the Text Options
Toolbar.

Variable Text input will no longer be substituted for different
output. 

The content of a Bar Code can no longer be edited. 

RELATED TOPICS

Edit Nodes

Create Rectangle

Create Ellipse

Create Polygon

Create and Edit Text

Create Bar Code

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.
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vector-editing vector-path-curve-lines vector-tools

Auto-join Selected Shapes

Auto-join selected shapes connects ends of lines or curves that are near one another or touching, but not technically connected.

Location

Edit → Auto-join selected shapes

Keyboard Shortcuts

Windows: Alt + J

Mac: Option + J

Auto-join selected shapes connects line or curve segments
whose start and end nodes are directly on top of (or very near to)
one another, but not technically connected. When the segments

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

Quick Reference: Auto-join Selected Shapes

⎇

⌥
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are connected, they are combined into a single path (a sequence
of lines, curves, and nodes). 

Auto-Join is most often helpful in cases where you've Imported
graphics containing open shapes that you would like to use with
a function that requires closed shapes.

To connect start and end nodes using Auto-Join, the nodes must
be within .05 mm of one another. 

To use Auto-Join, select all segments you want to join, then go to 
Edit → Auto-join selected shapes, or press Alt / Option

+ J .

TROUBLESHOOTING

In some cases where Auto-Join fails to join segments with start
and end points within the necessary .05 mm tolerance, it can
help to first go to the Arrange Menu and select Break Apart
( Alt / Option + B ), before again trying Auto-Join. 

RELATED TOPICS

Edit Nodes

Close Path

Close Selected Paths With Tolerance

Break Apart

Open vs. Closed Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

auto-join break-apart closed-shapes curve-segments

design editing import-graphics layout line-segments

nodes path

Close Path

Joins the start and end of a path.

Location

Edit → Close Path

Close Path connects individual shapes with one start and one
end point by creating a new line between the points.

Several functions in LightBurn, including Fill Mode, require
shapes that are closed loops, with start and end points that are
the same. If the start and end points of a shape are very close,
but not quite connected, use Close Path to connect them.

USING CLOSE PATH

Select all shapes you wish to close, then go to Edit → Close Path.

You can select and close multiple paths at once, but, in order for
a path to be connected by Close Path, it must already be
completely connected except for its start and end nodes. 

⎇ ⌥

⎇ ⌥

• 

• 

• 

• 

• 

Quick Reference: Close Path
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Close Path cannot connect fully separate paths, each with their
own start and end nodes.

The start and end nodes of selected paths must be within .5 mm
of one another in order for Close Path to connect them.

For gaps larger than .5 mm, use Close Selected Paths with
Tolerance instead.

RELATED TOPICS

Edit Nodes

Open vs. Closed Shapes

Close Selected Paths with Tolerance

Auto-Join Selected Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.
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vector-path-curve-lines vector-tools

Close Selected Paths With Tolerance

Connects the start and end of a path, within a specified distance. 

Location

Edit → Close selected paths with tolerance

Close selected paths with tolerance connects individual shapes
with one start and one end point by creating a new line between
the points, or moving the two points together. By specifying a
tolerance, you can determine how near to one another the start
and end points must be in order to be closed. 

Several functions in LightBurn, including Fill Mode, require
shapes that are closed loops, with start and end points that are

• 

• 

• 

• 

Quick Reference: Close Selected Paths With Tolerance
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the same. This option works similarly to Close Path to close
shapes with start and end points that are not the same, while
providing greater control over how far apart they must be in
order to connect them, and how they will be connected.

USING CLOSE SELECTED PATHS WITH TOLERANCE

Select all paths you wish to close and go to Edit → Close selected
paths with tolerance to open a dialog window. 

Use the slider to set the Distance Threshold, or tolerance,
which determines the maximum distance between start and
end points to be connected. Start and end points that are
farther apart than this threshold will be ignored. 

Select Move Ends Together to connect the start and end
points by bringing existing lines together. 

Select Join with Line to create a new line segment between
start and end points.

The readout at the bottom of the window shows how many
open shapes were found, how many shapes have been closed,
and how many open shapes remain in your selection.

Click OK to confirm the changes and close the selected shapes,
or Cancel to discard them and leave the shapes open.

Close selectected paths with tolerance can close muliple paths
at once, but they must already be completely connected except
for their start and end nodes. This tool cannot connect fully
separate paths, each with their own start and end nodes.

RELATED TOPICS

Close Path

Auto-Join Selected Shapes

Edit Nodes

Open vs. Closed Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.
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Delete Duplicates

Eliminates identical, overlapping objects.

Location

Edit → Delete Duplicates

Keyboard Shortcuts

Windows: Alt + D

Mac: Option + D

Quick Reference: Delete Duplicates

⎇

⌥
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Delete Duplicates finds and removes duplicated objects in your
project. Objects don't need to be selected in order to be
identified and deleted, but must be Ungrouped and identical in
size, shape, and position.

To use Delete Duplicates, go to Edit → Delete Duplicates or
press Alt / Option + D .

Delete Duplicates in use. The circle furthest to the right is duplicated.

Duplicated objects can cause filled objects to appear as outlines
in the Workspace, even with View Style set to Filled. Those objects
may also disappear in the Preview window. Duplicated objects
can cause extra passes in Line Mode and failures to engrave in 
Fill Mode.

TROUBLESHOOTING

Make sure objects are Ungrouped in order to be detected by 
Delete Duplicates.

RELATED TOPICS

Preview

Additional Selection Tools

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement editing fixing-designs layout-and-design
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Break Apart

Seperates paths into pieces.

Location

Arrange → Break Apart

Keyboard Shortcuts

Windows: Alt  + B

Mac: Option  + B

Break Apart separates the paths of selected vector graphics into
the individual curves and lines that make them up. The individual
segments become disconnected, allowing them to be selected
and manipulated independently. 

To use Break Apart, select all objects you wish to break, then go
to Arrange → Break Apart, or press Alt  / Option  + B .

For example, a rectangular vector graphic is a path made of four
straight lines connected by four nodes, with one node that is

⎇ ⌥

• 

• 

• 

Quick Reference: Break Apart

⎇

⌥

⎇ ⌥
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both the start and end of the path. Breaking Apart a rectangle
results in four disconnected lines, each with their own start and
end node. 

Left: an unbroken rectangle with one start and end node in green Right:
four separate lines with eight start and end nodes 

RELATED TOPICS

Edit Nodes

Auto-Join Selected Shapes

Open vs. Closed Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.
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Optimize Selected Shapes

Simplifies and smooths objects.

Location

Edit → Optimize selected shapes

Keyboard Shortcuts

Windows: Alt + Shift + O

Mac: Option + Shift + O

The Optimize Shapes tool simplifies and smooths selected
shapes by reducing the node-count or by fitting them to arcs or

• 

• 

• 

Quick Reference: Optimize Selected Shapes

⎇ ⇧

⌥ ⇧
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lines. This is often useful when importing art created in other
software, or cleaning up traced artwork.

USING OPTIMIZE SHAPES

To use Optimize Shapes, select the shapes you want to
Optimize, and make sure they're Ungrouped. Go to Edit → 
Optimize selected shapes or use the shortcut Alt / Option

+ Shift + O  to open the Optimize Shapes window.

Text objects or Primary Shapes must be Converted to Paths in
order to Optimize them.

OPTIMIZE SHAPES WINDOW

The Optimize Shapes tool adjusts selected shapes within a
specified error tolerance, which defines the maximum amount the
new optimized shapes can deviate from the original source
shapes. 

Error tolerance is controlled by the sliders beneath each
optimization option. Switches next to each option control
whether they are enabled or disabled.

Optimizations are visible in your Workspace as you make
changes — adjust the tolerance sliders or enable and disable
options to see the result of different combinations of tolerances
and optimizations.

Press OK to confirm changes and Optimize the source shapes, or
Cancel to discard the changes and leave the shapes as they are.

Smooth source shapes

Smooth source shapes smooths out wavy or jagged lines. This is
often useful for cleaning up vectors from Image Tracing. Increase

the value to strengthen the smoothing effect, at the expense of
potentially losing small details or rounding off sharp corners.

Fit shapes to lines

Fit shapes to lines simplifies shapes by turning sections that are
close to being a line into lines. This can reduce node count or
help clean up graphics with many small or overlapping lines.

Fit shapes to arcs

Fit shapes to arcs simplifies shapes by converting lines into arcs.
This can reduce node count or recreate true arcs from software
that exports them as many small line segments.

Points, Lines, and Curves

At the bottom of the window, LightBurn displays the number of 
Points (nodes), Lines, and Curves (arcs) in the original shapes
and in the optimized versions of the shapes. 

TROUBLESHOOTING

If the Optimize selected shapes menu option is grayed out,
or the shortcut key doesn't open the Optimize Shapes
window, make sure you have at least one object selected.

If the Optimize Shapes window shows 0 points, 0 lines, and 0
curves, make sure your shapes are Ungrouped and that any 
Primary Shapes and Text have been Converted to Paths.

RELATED TOPICS

Trace Image

Edit Nodes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

editing fixing-designs layout-and-design node-editing

object-manipulation object-repair optimization path

path-editing path-tools troubleshooting vector

vector-editing vector-path-curve-lines vector-tools
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Warp and Deform
Quick Reference: Warp and Deform
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Location

Tools → Warp Selection

Tools → Deform Selection

Use Warp Selection and Deform Selection to stretch and shape
objects in a non-linear fashion by dragging handles positioned
around the perimeter of the selection or in a grid overlaid on the
selection.

USING WARP OR DEFORM

Select all objects you wish to edit, and choose either Warp
Selection or Deform Selection from the Tools Menu. 

Then click and drag the handles that appear on the object to
make your changes. 

You can modify the edit behavior in the following ways:

Double-click on a handle to reset it.

Hold Shift  while dragging a handle to maintain horizontal
symmetry.

Hold Alt / Option  while dragging a handle to maintain
vertical symmetry.

WARP SELECTION

Stretch and compress your selection according to its rectangular
perimeter by dragging the handles at each of the four corners. 

Use Warp to: 

Adjust the percieved perspective of an object (apply a
perspective warp) 

Stretch or compress the corners of objects

Create dramatic text effects

DEFORM SELECTION

Distort your selection in an organic manner by moving the 16
handles at the intersections of the overlaid grid. 

• 

• ⇧

• ⎇ ⌥

• 

• 

• 
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Use Deform to:

Fit text into the shape of another object

Make an object fit the countours of another

Create interesting organic shapes

RELATED TOPICS

Transform Controls

Shear

Bend Text

Apply Path to Text

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

customization deform editing layout-and-design

object-manipulation tools-menu warp

Two-Point Rotate / Scale

Rotates and resizes objects around custom pivot points.

Location

Arrange → Two Point Rotate / Scale

Keyboard Shortcuts

Windows: Ctrl + 2

Mac: Cmd + 2

Two-Point Rotate / Scale allows you to turn and resize objects
around custom pivot points in your Workspace.

• 

• 

• 

• 

• 

• 

• 

Quick Reference: Two Point Rotate / Scale

⌃

⌘
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USING TWO-POINT ROTATE/SCALE

Select the objects you wish to edit and go to Arrange → Two-
Point Rotate / Scale, or press Ctrl / Cmd + 2 . 

The Status Bar will prompt you to Select the first point - the
center of rotation. Any object can be Rotated and Scaled using
this tool, including images, Text Objects, Primary Shapes, and
custom paths. 

Click anywhere in the Workspace to choose this point — you can
choose a point on any object in your project (such as nodes,
midpoints, intersections, corners), or even a point in empty
space.

The Status Bar will then prompt you to Click and drag the 2nd

point, where you will rotate from. As you click and drag, the
object Rotates. 

Hold Shift  while dragging to also Scale the shape while
rotating it.

As you drag, your cursor will Snap to existing objects in your
Workspace, including lines, corner points, or other nodes. 

Release the mouse to apply the previewed edits, or press Esc  to
discard the edits and return the object to its original position. 

MATCHING THE SIDES OF TWO OBJECTS

To align the sides of two objects and make their sides an equal
length, start by aligning a node from each side of each object using
the Select tool and Snapping. As the cursor hovers over a node, it
will change to a crosshair, to assist in precise placement. 

Next, select the object you wish to edit, open the Two-Point Rotate
/ Scale tool, and select the aligned node as the center of rotation. 

Click and drag the node at the other end of the side on the edited
shape to the point on the other end of the side on the stationary
shape while holding Shift . 

Release your mouse once it has snapped into place, to finalize the
rotation.

CALIBRATING AN IMAGE TO KNOWN DIMENSIONS

You can use Two-Point Rotate / Scale to straighten and calibrate
an image to its real-life dimensions. This is especially useful when
designing to fit existing, tangible items. 

Take a photo or scan of your object with a ruler (or other object
of known-size) next to it, and import that image into LightBurn. 

Create a line the length of your ruler. 

Align one end of the line to one end of the ruler. 

Run the Two-Point Rotate / Scale tool on the image, with the first
point being the aligned end, and the second being clicked from
the other end of the ruler in the image, and dragged to the other
end of the line. 

After that, you can use the calibrated image in your project — for
example, by Tracing it — and your project will be made to the
correct, real-life scale. 

RELATED TOPICS

Align Tools

Docking

Snapping

Transform Controls — Rotate

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement customization editing layout-and-design

object-manipulation rotate
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Create Rubber-Band Outline

Outlines a selection of objects with a new path. 

Quick Reference: Create Rubber Band Outline
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Location

Arrange → Create Rubber Band Outline

Create rubber-band outline automatically makes a new shape
outlining the graphics in your current selection. The new shape is
defined as the shortest possible path that can contain all
graphics in your selection, as if a rubber band were stretched
around them. 

Use this tool to quickly create cut lines around images or
complex graphics, or to negate Filled areas in vector engravings. 

After making a selection, go to Arrange → Create rubber-band
outline from selection. 

The outline that's created will automatically be set to the last
layer you selected from the Color Palette. 

RELATED TOPICS

Offset

Selection Tools

Draw Lines

Edit Nodes

Trace Image

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement editing layout-and-design node-editing

object-manipulation path path-editing path-tools

vector vector-editing vector-path-curve-lines

vector-tools
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Reverse/invert objects along various axes. 

Location

Arrange Toolbar

Arrange Menu

Keyboard Shortcuts

Various

Flip Vertical and Flip Horizontal mirror selected objects across
their vertical or horizontal centers.

Mirror Across Line creates a mirrored duplicate of selected
objects across a custom-selected line, at any angle. 

Use these tools to correct orientation of graphics, or to speed up
the design process when making symmetrical projects.

FLIP VERTICAL AND HORIZONTAL

Flip Vertical and Horizontal are both available in the Arrange
Menu, Arrange Toolbar, and by hotkey (see below).

Flip Vertical mirrors all selected objects across the vertical
center of the selection area. The vertical center is an imaginary
line across the halfway point of a selection's full height.

Flip Horizontal mirrors all selected objects across the horizontal
center of the selection area. The horizontal center is an
imaginary line across the halfway point of a selection's full width.

Imagine the selection area as the smallest possible rectangle
that can contain every object in your selection. The vertical and
horizontal centers of a selection are the same as the vertical and
horizontal centers of that imaginary rectangle.

MIRROR ACROSS LINE

Mirror Across Line is available in the Arrange Menu, Arrange
Toolbar, and by hotkey (see below).

Mirror Across Line creates a mirrored duplicate of your selection
across a custom-selected line. 

Quick Reference: Flip and Mirror
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The line must be the last object added to your selection — in
other words, you must first select the objects you'd like to
Mirror, then select the line you'd like to Mirror them across.

The line must be a straight line with only two points.

Draw half the original shape, then mirror it to create the other
half, like this: 

HOTKEYS

The keyboard shortcuts listed under Edit Window in Focus will
only work when the Workspace — the area where you create and
edit graphics — is in active focus. 

There are several Windows and Toolbars in LightBurn that accept
user input — when a window is clicked on, it is in focus and
accepting input.

If a window other than the Edit Window is in focus, click
anywhere in the Workspace to bring it into focus.

RELATED TOPICS

Transform Controls

Align

Distribute

Grid Array

Circular Array

Copy Along Path

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement customization editing layout-and-design

object-manipulation
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Use Mirror Across Line to create a symmetrical shape

What does it mean for a window to be in focus?

Action Icon Hotkey Edit Window in
Focus

Flip Vertical Ctrl / Cmd

+ V

V

Flip Horizontal Ctrl / Cmd

+ H

H

Mirror Across
Line

Ctrl / Cmd

+ Shift + M

n/a

⌃ ⌘

⌃ ⌘

⌃ ⌘

⇧
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Offset Shapes

Creates an outline around selected shapes, at a specified distance away or within.

Quick Reference: Offset Shapes
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Location

Modifiers Toolbar

Tools → Offset Shapes

Keyboard Shortcuts

Windows: Alt + O

Mac: Option + O

Keyboard Modifiers

Hold Ctrl / Cmd  and click to apply the last-used Offset
parameters.

The Offset Shapes tool creates a new shape by outlining the shapes in your selection at a distance you specify,
either inward, outward, or in both directions at once.

It's great for making borders around text, cut lines around engravings, and a variety of patterns. 

Offset Shapes works with any vector graphic, including paths, Primary Shapes, and Text Objects. You can offset
multiple shapes, as well as Grouped shapes, all at the same time.

USING THE OFFSET SHAPES TOOL

To open the Offset Shapes tool, first select all shapes you'd like
to offset, then go to Tools → Offset Shapes, click the Offset
button in the Tools Toolbar, or press Alt / Option + O  to
open the Offset dialog window, where you establish the settings
that will determine the size, shape, and direction of your offset. 

Offset Distance controls the amount the new shape will be
offset away from the original. Adjust the distance by typing a
value into the adjacent field, clicking the arrow buttons,
hovering over it and scrolling with your mouse wheel, or
dragging with two fingers, if you're using a trackpad. 

Direction determines on which side of the original shapes the
new offset shape will be created. 

Outward (left) offsets away from the original shapes.

Inward (right) offsets in toward the center of the original
shapes.

Both creates two new offset shapes, one Outward and one
Inward from the originals. 

You can only create Inward offsets for shapes that are closed,
meaning they are complete, continuous loops whose start
and end nodes are the same.

Corner Style controls the style of the corners in the offset
shapes. You can choose Round, Bevel, or Corner.

Corner Style affects outward- and inward-pointing corners
differently — offset corners are only beveled or rounded when
they're created in the direction a corner points. In the
opposite direction, offset corners are always corners as well.

Notice the difference in the inward and outward offsets for
the letter T below. The corners of the outer offset are beveled
and rounded where the corners of the T point out, while the
corners of the inner offset are beveled and rounded where
the T's corners point in.

Each switch beneath Options can be enabled or disabled.
When enabled:

Outer shapes only: will ignore any shapes contained within
others when creating the offset, leaving just the outermost
border.

Select resulting objects: will select the new path you created
upon completion of the offset. 

Delete original objects: will delete the objects that you had
selected before opening this dialog, replacing them with the
new offset.

Optimize / Simplify results: will reduce the number of nodes
in the result, great for reducing file size of complex objects
such as image traces. 

Click OK to create the offset, or Cancel to discard the settings
and exit the window. 

⎇

⌥

⌃ ⌘

⎇ ⌥
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• 
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• 

Note

• 

Corner Style and Inward/Outward Corners

• 

• 

Use Offset Shapes to create a cut around a complex
engraving

• 

• 

• 
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To repeat an offset with the last settings you used, select the
shapes you wish to offset, then hold Ctrl / Cmd  while
clicking the Offset button. It will perform the offset operation
using the previous settings, without bringing up the dialog.

When you open the Offset dialog window, the offset that will be
created as the result of your settings will appear in your 
Workspace, and will live-adjust to reflect settings changes you
make.

TIPS

If you need to offset every vector in your design to
compensate for the thickness of your laser beam (for example
in the case of fitted parts) check out Kerf Offset in the Cut
Settings Editor instead.

Offset Shapes can sometimes fix odd or broken vectors by
running the offset with a Distance of 0.

RELATED TOPICS

Create Rubber-Band Outline

Draw Lines

Edit Nodes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

customization layout-and-design

modifying-and-combining object-manipulation vector

vector-editing vector-tools

Boolean Tools
Tip

⌃ ⌘
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Quick Reference: Boolean Tools
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Location

Modifiers Toolbar

Tools Menu

Keyboard Shortcuts

Various

Use the Boolean tools to combine existing shapes (or Grouped
shapes) into new or more complex shapes. There are three Boolean
options, along with one very similar option, Weld. 

USING THE BOOLEAN TOOLS

All of the Boolean tools and Weld are available in the Modifiers
Toolbar, Tools Menu, or by keyboard shortcut.

There are a few important things to keep in mind when using the
Boolean tools and Weld:

All selected shapes must be closed shapes, meaning they are
complete, continuous loops whose start and end points are
the same. If there are open shapes in your selection, the tools
will be grayed out and unavailable. 

The Boolean tools work with vector objects only. If there are
any images in your selection, the tools will be grayed out and
unavailable. 

To use any of the Boolean tools, you must have exactly two
shapes, two Groups of shapes, or one shape and one Group
selected. If you have more than two shapes or Groups
selected, the Boolean tools will be grayed out and unavailable. 

You can use Weld to combine more than two shapes at once. 

Grouping multiple shapes together tells LightBurn to treat
them as a single shape. For example, Group an outer circle
with an inner circle to treat it as a donut shape rather than two
separate circles. Grouping shapes in this way can sometimes 
yield different results than you'll see with the same objects
when they're not Grouped.

Boolean Union 

Alt / Option + +

Boolean Union merges two shapes into one.

Boolean Subtract 

Alt / Option + -

Boolean Subtract removes one shape from another.

The second shape you add to your selection is subtracted from
the first, and deleted. 

If you select the shapes in the incorrect order, and subtract the
wrong shape from the other, Undo the action, then use Boolean
Subtract again — the alternate shape will be removed instead.

Boolean Intersection 

Alt / Option + *

Boolean Intersection creates a new shape out of the
overlapping area of two shapes.

Weld 

Ctrl / Cmd + W

• 

• 

• 

• 

• 

⎇ ⌥

⎇ ⌥

⎇ ⌥
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Weld works similarly to Boolean Union, but instead of being
limited to combining only two shapes or two Groups of shapes,
you can use Weld with any number of objects.

BOOLEAN ASSISTANT

Ctrl / Cmd + B

If you have Beginner Mode enabled, all three Boolean tools will
be replaced in the Modifiers Toolbar with a single icon that
opens the Boolean Assistant.

The Boolean Assistant is a dialog window that shows a preview
of what each of the Boolean operations will do to your selected
shapes, and gives you the option to click OK to confirm the
change, or Cancel to discard it and close the Boolean Assistant. 

To open the Boolean Assistant, go to Tools → Boolean Assistant.

Click an operation to see a preview of the result in your 
Workspace. If the shapes are not too complex, hovering over an
operation without clicking will also show what the result will be. 

Click or hover over Reset to return the shapes to their original
appearance, while keeping the Boolean Assistant open.

WELD VS. BOOLEAN UNION

In cases where some shapes are fully contained within other
outer shapes, using Weld won’t yield the result you’re looking for,
but Grouping related shapes together and using Boolean Union
will.

If you Weld something and some or all of the middle content
disappears — for example if you are trying to Weld text inside a
ring, and the text disappears — use Boolean Union after making

two Groups: one of the border pieces, and one of the middle
content. 

HOTKEYS

RELATED TOPICS

Cut Shapes

Trim Shapes

Grouping

Masking

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

layout-and-design modifying-and-combining

⌃ ⌘

Note

Action Icon Hotkey

Boolean Union Alt / Option

+ +

Boolean
Subtract

Alt / Option

+ -

Boolean
Intersection

Alt / Option

+ *

Weld Ctrl / Cmd

+ W
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Cut Shapes

Divides selected objects along the perimeter of another shape. 

Location

Tools → Cut Shapes

Keyboard Shortcuts

Windows: Alt Shift  + C

Mac: Option Shift  + C

The Cut Shapes tool divides selected vector objects into separate
shapes, using a closed shape as the cutting tool. The last shape you
add to your selection is used as the cutting tool, and all other
selected shapes are cut at the locations they intersect with the
cutting tool.

USING CUT SHAPES

To use Cut Shapes, first select the shapes you wish to cut, then
add the cutting tool shape to your selection.

Go to Tools → Cut Shapes or press Alt / Option + Shift

+ C  to activate the tool.

A few things to always keep in mind when selecting and using a
cutting shape:

The last shape you add to your selection is used as the cutting
tool. 

The cutting tool must always be a closed shape, meaning it is a
complete, continuous loop whose start and end points are the
same.

The cutting shape must not be Grouped with any other
shapes. Ungroup any shape you'd like to use as a cutting
shape.

The cutting tool is deleted in the process — if you'd like the
shape you're using as a cutting tool to remain in your design
after using it with Cut Shapes, first Duplicate it, and then select
just one copy to use with Cut Shapes.

And note the following about the resulting shapes:

The resulting shapes are automatically sorted into two Groups
— one Group for shapes that were inside the cutting tool, and
another for shapes that were outside it. You'll need to 
Ungroup the shapes to manipulate them individually. 

The resulting shapes are automatically closed if they were set
to a Fill or Offset Fill layer, or left open if they were set to a Line
or Tool layer.

In other words, for shapes set to a Fill or Offset Fill layer,
LightBurn will automatically add a new line on all new shapes,
connecting the gap where the cutting shape severed the
originals. If they are set to a Line or Tool layer, the gap will
remain. 

Quick Reference: Cut Shapes

⎇ ⇧

⌥ ⇧

⎇ ⌥ ⇧

Use Cut Shapes to cut a project into smaller sections
that can be run separately, allowing you to create
projects that are larger than your laser's work.
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Cut Shapes and Images

If you use Cut Shapes with an image, LightBurn will
automatically create two masked copies of the images — one
copy will be masked to show the part of the image that was
inside the cutting shape, and the other copy will be masked to
show the part that was outside. The cutting shape will also be
duplicated, and each copy will be reassigned to a Tool layer. 

TROUBLESHOOTING

If Cut Shapes is grayed out in the Tools Menu, it means the
object you selected last is not a valid shape to use as a cutting
tool.

The cutting tool must be a closed shape, meaning it is a
complete, continuous loop whose start and end points are the
same.

The cutting tool must not be Grouped with any other objects.

RELATED TOPICS

Trim Shapes

Boolean Tools

Apply Mask to Image

Print and Cut — Cutting a Project Larger Than Your Laser's
Workspace

Open vs. Closed Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

boolean customization editing layout-and-design

modifying-and-combining node-editing

object-manipulation path path-editing path-tools

vector vector-editing vector-path-curve-lines

vector-tools
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Grid Array

Copies objects into rows and columns.

Location

Modifiers Toolbar

Arrange → Grid / Array

The Grid Array tool creates copies of an object (or objects) in
regularly spaced rows and columns, and includes options to
adjust spacing, mirror the shapes, randomize orientation, and
more.

Use the Grid Array tool to:

Duplicate designs for batch production

Maximize material utilization

Create designs that require precise spacing

Make interesting patterns

GRID ARRAY SETTINGS

To open the Create Grid Array window, select all objects you'd
like to array, then go to Arrange → Grid / Array, or click the Grid
Array button in the Modifiers Toolbar. 

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

X Columns and Y Rows

Specify the number of copies to make in the horizontal (X) and
vertical (Y) dimensions.

Total Width and Total Height

Alternative options for specifying the number of copies to make
in each dimension. Set the values in these fields to match the size
you'd like the grid to occupy, and LightBurn will set X Columns
and Y Rows to whatever is necessary to fill the specified size
without going over, taking into account the other settings below. 

If you do not adjust these fields directly, they will automatically
change to reflect the width and height of your grid, as
determined by your other settings.

X Spacing and Y Spacing

Determine the distance between each copy, in the horizontal and
vertical dimensions. For each dimension, you can select to space
based on Distance from center to center of objects or Padding
between edges of objects (see below).

Distance From Center to Center

When selected, X and Y Spacing will set the distance between
the centers of each copy in the grid.

Padding Between Edges

When selected, X and Y Spacing will set the distance between
sides of each copy in the grid.

X Column Shift and Y Row Shift

Offset every other column or row by the specified amount,
shifting alternate columns or rows left, right, up, or down. 

Quick Reference: Grid Array

• 

• 
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Reverse Direction

Changes the direction in which copies are produced. Can be
enabled individually for each dimension.

Shift by half

Offsets alternate columns or rows by half the total width or
height of the original object.

Mirror Alternate Columns in X or Y and Mirror Alternate Rows in X or Y

Flip copies of the original object(s) in the selected dimension, for
alternate columns or rows.

Use the X/Y Spacing, X/Y Shift, and Mirror options individually or
in combination with one another to efficiently lay out objects for
maximum material utilization. 

Random Orientation

Randomly rotates each copy of the original object(s). Use the
field next to the Random orientation switch to enter a seed
number that is used as the starting point of the randomly
generated orientation. Re-using the same seed number will
duplicate the same randomly generated orientation later on. 

Auto-Increment Variable Text

Applies an Offset to text in each copy created in the array,
automatically advancing output if you are using Merge/CSV or 
Serial Number formatting. The field next to the switch
determines the amount by which each duplicates' Offset will
advance.

See our documentation on using Variable Text for more
information.

Create Virtual Array

Makes an array of synced clones of the original object(s), instead
of independent copies. See below for more information.

Total Size and Count

Display the resulting array's size in and X and Y, and total number
of copies, including the original.

Group Results

When enabled, automatically Groups all objects in the array after
it's created.

Select Results

When enabled, all objects in the array are automatically added to
your selection when it's created.

OK and Cancel

Press OK to confirm your settings and create the array, or Cancel
to discard settings and not create the array. 

VIRTUAL ARRAYS

Enabling the Create Virtual Array option in the Create Grid
Array window generates an array of synced clones, instead of
making copies of the original objects.

The clones render with dashed outlines and muted fill colors, to
indicate that they are virtual copies. 

Any changes made to the original copy in the array will be
applied to the clones, but the clones themselves are not
selectable or adjustable. 

Modifying Virtual Arrays

Select and right-click any original object that is part of a Virtual
Array to open a context menu where you'll see several additional
actions you can perform after creating the array. 

You do not have to select all original objects used in the array.

Edit Array displays the Create Grid Array dialog again, allowing
you to modify any of the parameters, and even convert the array
into a normal array by unchecking Create Virtual Array.

Duplicate Array duplicates the entire Virtual Array and all of the
objects in it. 

Flatten Array converts the Virtual Array into a standard array
where all objects are separate copies and no longer synced to the
original objects.

Remove from Array remove the currently selected object(s) from
the virtual array.

Add to Array adds any currently selected object not in the virtual
array to the array. Note: to see this option, you must select at least
one object that is currently in a virtual array and one object that is
not.

Exit Array removes the Virtual Array, without deleting the original
copies.

Maximize material utilization with Grid Array

Use Grid Array to automatically increment Variable Text

• 

• 

• 

• 

• 

• 
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RELATED TOPICS

Variable Text

Circular Array

Copy Along Path

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement batch-production editing

layout-and-design material-utilization

modifying-and-combining nesting object-manipulation

optimization workflow workflow-optimization

Circular Array

Creates copies of objects in a circular pattern.

Location

Modifiers Toolbar

Arrange → Circular Array

Circular Array arranges multiple copies of an object — or
multiple objects — in a radial pattern around either a point in
space, or a central object. 

Use the Circular Array Tool to:

• 

• 

• 

Quick Reference: Circular Array
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Create organic radial patterns such as mandalas and flowers
by duplicating simple shapes

Create even spacing around a circle, such as numerals and
markings on a clock face

Make geometric radiating designs such as starburts or cogs

Create decorative round frames or borders

Distribute mounting holes in a circular formation

CIRCULAR ARRAY SETTINGS

To open the Circular Array window, select all objects you'd like to
duplicate, then go to Arrange → Circular Array, or click the
Circular Array button in the Modifiers Toolbar. 

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Copies

Enter the number of items you wish to appear in the final array
into the Copies field. 

Center of Rotation

There are two ways to set the center of rotation for your array:

Enter the x and y coordinates of a spot in your Workspace into
the Center fields. 

Turn on Use last selected object position as center to array
the copies around the center of the last object you added to
your selection. 

Start and End

An array doesn't have to span the whole 360-degree rotation,
you can limit the duplications to only part of the circle using the 
Start and End fields.

Step

You can specify the angle between the copies in the Step field.
This value is mathematically tied to the End and Copies fields. 

Rotate Object Copies

Enable Rotate object copies to turn copies so that the same part
of each duplicate faces the center, like the tickmarks on a
stopwatch. Disable it to keep the copies in their original rotation,
like the numerals of a clock that remain upright for readability. 

Auto-Increment Variable Text

Auto-Increment variable text works in conjunction with 
Variable Text, increasing the Offset value in the Text Options
Toolbar value by the specified amount for each copy. Using
Offsets allows you to use the same formatting expression to
output different data. 

Group Results

Enable Group Results to have the output automatically Grouped
upon completion of the array. 

Select Results

Enable Select Results to have output automatically selected
upon completion of the array. 

OK and Cancel

Press OK to confirm your settings and create the array, or Cancel
to discard settings and not create the array.

RELATED TOPICS

Grid Array

Variable Text

Copy Along Path

• 

• 

• 

• 

• 

• 

• 

• 
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For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrays batch-production layout-and-design

modifying-and-combining

Copy Along Path

Duplicates an object along a line, curve, or other shape. 

Location

Arrange → Copy Along Path

Quick Reference: Copy Along Path
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Use Copy Along Path to create repeated designs that follow a
line, curve, or perimeter of a shape, for example: 

Decorative borders along, inside, or outside edges of a shape.

Repetitive designs that flow along a line such as ropes, vines,
and chains.

Precisely-spaced patterns that follow a vector path, for
example measurements on a curved ruler.

USING COPY ALONG PATH

Copy Along Path works by duplicating copies of one object along the path of another.

Select the object to be copied first. Add the path to the selection (hold Shift  while clicking the path), and go to Arrange → Copy Along Path to open the tool. 

Adjust the options according to your needs — you'll see a preview of the result in the Workspace as you make changes. 

Click OK to confirm the copies, or Cancel to discard them. 

REQUIREMENTS

The object to be copied must be: 

A vector object — not an image

A single object or a single Group of objects

Selected first

The path must be:

A vector — not an image

A single, individual object — not a Group

Selected second

• 

• 

• 

⇧

• 

• 

• 

• 

• 

• 
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Placement

The placement of the original object to be copied relative to the
start of the path determines the position of the copies. 

Place the center of the object to be copied on the start of the
path to superimpose each copy over the path.

Offset the object to be copied from the start of the path to
maintain that distance from the path with each copy.

Open vs. Closed

When using a closed path, the copied objects will start at
whatever part of the path is closest, and then wrap around the
circuit of the path to meet back up at the same point. 

When using an open path, it's best to center the object to be
copied over an end point of the path. This will create even
spacing along the entire path. 

OPTIONS

Spacing

The spacing of copied objects is measured from the centers of
each copied object. There are two ways of spacing the copies
objects along the path: 

Number of Copies spreads a certain quantity of them along
the path, with even spacing between.

Space Between Copies fills the path with as many copies as it
can fit, given the spacing you provide. This usually leaves some
excess line at the end of the path. 

Rotate Copies

Enable Rotate Copies to create duplicates that are oriented
acording to the changes in direction of the path. Disable this
option to create objects that remain in the same orientation as
the originally-copied object.

• 

• 
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Scale Copies

Enable Scale Copies and enter a value in the adjacent field to
incrementally change the size of each copy, with the final one
reaching a size equal to this percentage of the original's size. A
number larger than 100 will increase the sizes of the copies, a
number lower than 100 will decrease them, and setting it to 100
(or disabling the switch) will keep the copies the same size as the
original. 

Auto-Increment Variable Text

Use Auto-Increment variable text in conjunction with Variable
Text to add text-based codes that are substituted for other data
when you send a project to your laser. Enabling Auto-Increment
variable text will apply an Offset to each copied Text Object, so
different data will output in the place of the same formatting
expressions.

TROUBLESHOOTING

Copy Along Path is not to be confused with Apply Path to
Text, which attaches a single Text Object to a vector object,
reshaping it to follow the contour of the chosen path.

If your copies aren't appearing where you expected, check that
their starting placement is set appropriately for your goals. 

If Copy Along Path is grayed out in the menu, it's likely that
your objects are not suitable or they haven't been selected in
the correct order.

RELATED TOPICS

Apply Path to Text

Circular Array

Grid Array

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement editing layout-and-design node-editing

object-manipulation path path-editing path-tools

vector vector-editing vector-path-curve-lines

vector-tools

Apply Path to Text

• 

• 

• 

• 

• 
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Quick Reference: Apply Path to Text
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Location

Tools → Apply Path to Text

Right-click → Apply Path to Text

Apply Path to Text attaches text to a vector object, reshaping it
to follow the contour of the chosen path. This tool makes it
possible to use existing or custom-created paths to apply more
complex curves to text than can be achieved using the text Bend
tool.

Using Apply Path to Text

Select a single block of text and single shape at the same time, then
go to Tools → Apply Path to Text, or right-click and select Apply
Path to Text from the context menu.

The text is automatically moved to the location of the shape, and
adjusted to follow its contour. 

The text can no longer be independently moved after it is attached
to the path, but all text attributes in the Text Options Toolbar can
still be modified. 

MAKING ADJUSTMENTS IN THE TEXT OPTIONS TOOLBAR

In the case of text, horizontal always refers to the direction of the
text as it is read, regardless of whether the Text Object is rotated.
Vertical refers to the opposite direction, regardless of rotation. 

The horizontal position of the text is oriented relative to the start
and end points of the path using the Align X options. Middle
aligns the text between the start and end points, Left aligns it so
that the start of the text is next to the start point of the path, and
Right aligns it so that the end of the text is next to the end of the
path.

The vertical position of the text is positioned using the Align Y
options. Middle places the text's vertical center on the path, 
Bottom places the bottom of the text directly on top of the path,
and Top places the top of the text directly under the path. 

Manipulating and Deleting Paths

The position and shape of the path remain manipulable, and the
text will automatically adjust to follow any changes made to the
contour of the path.

Use the Edit Nodes tool to manipulate nodes on a path that has
already been applied to text, and adjust its appearance
according to your visual preference.

To remove the text from the path, the path must be deleted.
Deleting the path returns the text to its original orientation, but
does not affect any settings in the Text Edit toolbar. 

If you have applied text to a path that you do not want cut or
engraved by your laser, but do not wish to delete either, assign
the path to a Tool layer, as shown in the demonstrations above.
Tool layers are special layers that are never sent to your laser. 

TROUBLESHOOTING

If text applied to a path is upside down or mirrored, you may
need to Flip the text before applying the path to it, or Rotate or
re-construct the path to correct the orientation. 

When manually creating a path with the Draw Lines tool, the
first point you click is always the start point, and the last is
always the end point. 

To use Apply Path to Text, you must have exactly one Text
Object and one vector object selected. If the option is grayed
out and unavailable, make sure the vector object you have
selected is a single, connected path, and not multiple adjacent
but disconnected paths. Use Edit Nodes or Auto-Join Selected
Shapes to join disconnected paths.

Note

Using Edit Nodes to manipulate paths

Tip

• 

• 
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Grouped objects do not work with Apply Path to Text. 
Ungroup all text or vector objects you wish to use with this
tool. 

RELATED TOPICS

Create and Edit Text

Text Options Toolbar

Copy Along Path

Draw Lines

Edit Nodes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

layout-and-design modifying-and-combining

object-modification text vector vector-graphics

Radius/Fillet

Rounds over sharp corners, takes a round bite out of a corner, or removes an existing radius.

Location

Modifiers Toolbar

Use the Radius Tool to fillet (round over) sharp corners, take a
round bite out of a corner (using a negative radius value), or turn
a radius back into a sharp corner (remove a radius).

You can use Radiuses to: 

Round out corners for a softer appearance

Create smooth transitions between sharp lines

• 

• 

• 

• 

• 

• 

Quick Reference: Radius/Fillet

• 

• 
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Form more complex shapes (varying sizes and types)

Add rounded details to projects

Round out corners of tabs, to enable easy assembly 

USING THE RADIUS TOOL

You can apply a radius to any corner node of any Ungrouped
path or Primary Shape, provided that the lines on either side of
the node can accomodate the size of the radius. Radiuses can be
applied to text if you first convert it to paths. 

Add a Radius to a Path

To add a radius, first click the Radius Tool icon in the Modifiers
Toolbar.

Set the radius value to the size of the radius you wish to create —
there must be enough room between the corner and nearby
points to accomodate this value. 

If you change the radius to a negative number it takes a fancy
little bite out of the corner. 

Select the object you want to modify, and click on a corner to
apply the radius.

To exit the Radius Tool, press Esc  on your keyboard.

When the Radius Tool is active, the icon changes as you hover
over a corner to indicate whether the Radius Tool can be used. If
it can't be used, the cursor will change to indicate that there is
not enough space. 

Remove or Change a Radius

You can also use the Radius Tool to remove rounded corners
(returning them to a sharp one) by clicking on them. This even
works on imported designs that were made in different software,
as long as the software exported actual arcs.

After removing a radius, you can then apply a differently-sized
one to the corner, as normal. 

Adding a Radius to a Rectangle

You can apply radiuses to Rectangles in the Shape Properties
Window. This method has the advantage that resizing the
rectangle won't change the size of the radius, allowing you to
maintain consistency in a design. 

Rectangles also have a handle that acts as a shortcut for the
Radius value. With a Rectangle selected, hold Ctrl  / Cmd ,
and a blue corner radius control will appear. Drag the blue handle
away from the corner to increase the radius of all four corners,
and drag back toward the corner to decrease it. Dragging
vertically creates a reversed radius, with a bite taken out of the
corner.

TROUBLESHOOTING

The Radius Tool cannot be used with Grouped shapes. 
Ungroup any shapes you'd like to apply a radius to.

If the cursor isn't appearing as you hover over a corner, make
sure you've selected the Radius Tool in the Modifiers Toolbar.
The Radius icon should be highlighted. Also check that you
have selected the object you wish to edit by clicking on it.

• 

• 

• 

⎋

Icon Meaning

Click to fillet corner

Click to remove fillet

Can't fillet — not enough space

⌃ ⌘

• 

• 
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Radiuses can only be applied where there is room for the
radius to be applied. If you see the following icon, it means
there is not enough room: 

If a radius still can't be applied, it might be because the two
lines that make up the corner aren't actually joined at that
point. To check, move the corner using the Edit Nodes tool. If it
splits off into two lines, bring the one you moved back toward
the other so that they snap together and join, and then try the
radius again. 

If you are having trouble converting a rounded corner back
into a sharp one, it could be because there is not a true arc at
the corner. This is most common with imported shapes,
because some programs export arcs as a series of tiny lines.
You can try recovering the arcs with Optimize Selected Shapes.

RELATED TOPICS

Edit Nodes

Primary Shapes: Rectangles, Ellipses, and Polygons

Shape Properties

Offset Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

customization editing layout-and-design node-editing

object-manipulation path path-editing path-tools

vector vector-editing vector-path-curve-lines

vector-tools

Make Same Width or Height

Resizes objects to the same X or Y dimensions. 

Location

Arrange Toolbar

Keyboard Modifiers

Hold Shift  to lock aspect ratio.

The Make Same Width and Make Same Height buttons resize
all objects in your selection to the width or height of a single
object in the selection. 

By default, all selected objects will be resized to the width or
height of the last object you added to the selection. For
exceptions to that rule, see below.

USING THE MAKE SAME WIDTH AND HEIGHT TOOLS

Both buttons are available in the Arrange Toolbar and Arrange
(long) Toolbar.

• 

• 

• 

• 

• 

• 

• 

Quick Reference: Make Same Width or Height

⇧
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Select all objects you wish to resize, followed by the object whose
width and/or height you wish to match, then click either Make
Same Width or Make Same Height.

Grouped objects are treated as single objects when using the Make
Same tools — the overall width or height of an object or entire
Group will change to match the width or height of the last-selected
object or other Group.

Hold Shift  while clicking to lock the aspect ratio of the objects
you're resizing, adjusting both dimensions at once. 

Holding Shift does not change both dimensions of objects in
your selection to match those of the last-selected object — it
only matches the selected dimension to that of the last-selected
object, and adjusts the alternate dimension to maintain the
same proportional length to the changed dimension.

For example, for a 40 mm (wide) x 20 mm (high) square, if you
held Shift  while clicking Make Same Width to match it to a 10
mm wide object, it would become a 10 mm x 5 mm square. 

RESIZING PRIORITY

When using either of the Make Same options, all selected
objects are matched to the width or height of a single object or 
Group in your selection.

The object that is matched to is determined according to the
following priorities:

Selection order: by default, all objects are resized to match the
last object you added to your selection.

Draw order: if you have nothing selected, then select multiple
objects at once, they are matched to the first object in your
selection's draw order. Use Push to front to move an object to
the first position in the draw order.

Combined order: if you add multiple objects at once to an
existing selection, all selected objects are matched to the first
object in the draw order of the objects you added to your
selection last.

If a single object in your selection is Locked, all objects are
matched to the Locked object.

If multiple objects in your selection are Locked, the Locked
objects are not matched, and the rest of the objects are
matched according to selection order or draw order.

RELATED TOPICS

Numeric Edits Toolbar

Align Tools

Push in Draw Order

Distribute

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

customization editing layout-and-design

object-manipulation optimization transform workflow

workflow-optimization

Option Icon

Make Same Width

Make Same Height

⇧

Note

⇧

⇧

• 

• 

• 
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Resize Slots

Adjusts the dimensions of slots, fingers, or tabs.

Location

Tools → Resize Slots in Selection

Use Resize Slots to adjust the dimensions of slots or tabs in 
selected objects.

You can use Resize Slots to adjust a jointed design that was
intended for a material of a different thickness, or to adjust slots

or tabs back to their original size after you rescaled an entire
design.

This tool works on two main forms of geometry:

Slots, like those found in 3D puzzles or partitions in trays,
somewhat similar to a traditional halved joint or dado. 

Tabs, like a tenon or the fingers in a box joint, usually found in
boxes and drawers.

This is a separate tool from Add Tabs, which creates small
sections of cuts that the laser is commanded to skip, to prevent
objects that you are cutting from immediately falling out of the
base material.

USING RESIZE SLOTS

Before opening the Resize Slots tool, you'll need to know the
existing length of the lines you want to adjust. Use the Measure
tool to read the length of an individual slot or tab.

Select all objects with slots or tabs you'd like to resize, then go to 
Tools → Resize Slots in Selection to open the Resize Slots dialog
window.

Settings

Old Material Thickness defines the current length of the slots
or tabs you want to identify and adjust. 

New Material Thickness defines the length you want to
adjust the slots or tabs to.

Tolerance specifies an added amount of padding to Old
Material Thickness — slots or tabs that are within the range of

Quick Reference: Resize Slots
• 

• 

Note

• 

• 

• 
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Old Material Thickness plus or minus Tolerance will be
identified by the resizer. 

This helps if the slots or tabs vary slightly in length, or if there
are kerf offsets built into the original design.

Select Adjust Slot Depth to adjust the bottom/innermost line
of slots. This allows you to keep the outer size of the
assembled piece the same.

Select Adjust Slot Width to adjust the sides of slots. Typically
used when the slots are meant to intersect on the interior of a
laser cut piece instead of on the corners, like boxes.py's tray
insert.

Select Adjust Tab Height to adjust the top/outermost line of
tabs. This allows you to keep the interior size of the assembled
piece the same, while making it bigger or smaller on the
outside.

Click Apply to implement a given set of adjustments and
continue working in the Resize Slots dialog window.

Click OK to implement of a set of changes and immediately
exit.

Click Cancel to immediately exit and discard changes, if you
have not already pressed Apply to implement them. To revert
changes you already implemented with Apply, exit the Resize
Slots dialog window, then press Ctrl / Cmd + Z  to Undo
them.

TROUBLESHOOTING

The tool doesn't work on internal slots/cutouts/mortises, as it's
tricky for the computer to determine which direction they
should grow or shrink.

The tool searches Ungrouped objects. Exit the Resize Slots
dialog and Ungroup your objects if you see a warning
message indicating that there are Grouped objects in your

selection. 

The tool only works on sharp (not filleted/rounded) corners.
Some tools (like boxes.py) default to adding small loops on
internal corners and small fillets/rounded corners on external
ones. Remove the external fillets using the Radius tool and the
internal loops using the Offset tool, set to 0. 

The tool requires well-formed shapes as an input. If the shape
has extra nodes, or if any of the lines are technically curves
(even if they're straight), it will interfere with slot/tab detection.
The highlighted sections in the image below show examples of
problematic shapes. Use Optimize Selected Shapes to try to
repair these shapes.

RELATED TOPICS

Kerf Offset

Measure

Grouping

Optimize Selected Shapes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

customization editing fixing-designs

modifying-and-combining object-manipulation

object-repair troubleshooting
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⌃ ⌘
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5.4.4 Arrangement

Align Tools

Arrange selected objects along edges or center points.

Location

Arrange Toolbar

Arrange → Align

Keyboard Shortcuts

Various

The Align tools reposition selected objects to align them along
their:

Top, bottom, left, or right edges

Vertical or horizontal centers

Center points

By default, the Align tools move objects in your selection to align
them to an edge or center of the last object you added to your
selection. For exceptions to that rule, see below.

ALIGN OPTIONS

The Align tools are available in the Arrange Menu and Arrange
Toolbar.

In the standard Arrange Toolbar, they are presented in dropdown
menus for the vertical and horizontal options:

In the Arrange (long) Toolbar, the Align tools are each
presented individually:

Hotkeys

All seven Align options and their actions are listed in the table
below. 

The hotkeys listed under Windows and macOS will work at any
time that you have objects selected. 

The hotkeys listed under Edit Window in Focus will only work
when the Workspace — the area where you create and edit
graphics — is in active focus. 

There are several Windows and Toolbars in LightBurn that accept
user input — when a window is clicked on, it is in focus and
accepting input.

If a window other than the Edit Window is in focus, click
anywhere in the Workspace to bring it into focus.

Quick Reference: Align

• 

• 

• 

What does it mean for a window to be in focus?

Align Option Icon Action Windows macOS Edit Window in
Focus (All
Systems)

Align Centers Aligns the
center points of
selected objects.

n/a Option  + Fn

+ Left

n/a

Align Vertical
Centers

Aligns selected
objects along
their vertical
centers.

Alt  + Pg Up Option  + Fn

+ Up

C

Align Horizontal
Centers

Aligns selected
objects along
their horizontal
centers.

Alt  + Pg Dwn Option  + Fn

+ Down

E

Align Left Aligns selected
objects along
their left edges.

Alt  + 
Left

Option  + 
Left

L

Align Right Aligns selected
objects along
their right
edges.

Alt  + 
Right

Option  + 
Right

R

⌥

←

⎇ ⌥

↑

⎇ ⌥

↓

⎇

←

⌥

←

⎇

→

⌥

→
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USING THE ALIGN TOOLS

Click a given Align icon or use its hotkey to align selected objects to
the last object you added to your selection (exceptions below). 

Edges of individual objects are defined according to their farthest
points in each direction. For example, the top edge of a triangle is a
horizontal line extending from its top point, its left edge is a vertical
line extending from its bottom left corner, and so on.

An object's vertical center is defined as a vertical line dividing it
halfway along its total width, and its horizontal center is a
horizontal line halfway along its total height. Its center point is the
location where those lines intersect. 

Grouped objects are treated as single objects when using the Align
tools — they will always maintain their relative position to one
another, and their edges and centers are defined according to the
dimensions of the entire Group. 

ALIGN TOOLS HELPER

If you're using Beginner Mode, clicking the Align Left icon 
in the Arrange Toolbar will open the Align Tools Helper.

Click or hover over any button in the Helper to see a preview of
how alignment will change. 

Click OK to confirm the changes, or Cancel to discard them.

Align Option Icon Action Windows macOS Edit Window in
Focus (All
Systems)

Align Bottom Aligns selected
objects along
their bottom
edges.

Alt  + 
Down

Option  + 
Down

B

Align Top Aligns selected
objects along
their top edges.

Alt  + Up Option  + 
Up

T

⎇

↓

⌥

↓

⎇ ↑ ⌥

↑
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ALIGNMENT PRIORITY

When using any of the Align options, all selected objects move to
align to an edge or center of a single object or Group in your
selection. 

The object that is aligned to is determined according to the
following priorities:

Selection order: by default, all objects are aligned to the last
object you added to your selection.

Draw order: if you have nothing selected, then select multiple
objects at once, they are aligned to the first object in your
selection's draw order. Use Push to front to move an object to
the first position in the draw order.

Combined order: if you add multiple objects at once to an
existing selection, all selected objects are aligned to the first
object in the draw order of the objects you added to your
selection last. 

If a single object in your selection is Locked, all objects are
aligned to the Locked object.

If multiple objects in your selection are Locked, the Locked
objects are not moved, and the rest of the objects are aligned
according to selection order or draw order. 

RELATED TOPICS

Automatic Guidelines

Selection Tools

Push in Draw Order

Docking

Distribute

Move Together

Move Selected Objects

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement beginner-mode customization editing

layout-and-design material-utilization object-manipulation

Distribute and Move Together

Seperates objects evenly or abuts them together. 

Location

Arrange Toolbar

Arrange → Distribute

The Distribute tools move selected objects to evenly space them
either vertically or horizontally, with options to set the same
distance between the centers, or edges of each object.

The Move Together tools move selected objects so that they are
evenly distributed, and their edges are abutting along horizontal
or vertical planes.

DISTRIBUTE

The Distribute tools are available in the Arrange Menu and 
Arrange Toolbar.

In the standard Arrange Toolbar, they are presented in dropdown
menus for the vertical and horizontal options:

In the Arrange (long) Toolbar, the Distribute tools are each
presented individually:

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

Quick Reference: Distribute and Move Together
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Distribute Vertically

Distribute V-Spaced  creates even spacing between the 
edges of all selected objects in the vertical dimension. 

Distribute V-Centered  creates even spacing between the 
centers of all selected objects in the vertical dimension. 

Distribute Horizontally

Distribute H-Spaced  creates even spacing between the 
edges of all selected objects in the horizontal dimension. 

Distribute H-Centered  creates even spacing between the 
centers of all selected objects in the horizontal dimension. 

Notes on Spacing

The Distribute tools take an average of the current spacing
between the edges or centers of your selected objects and move
them to equalize that distance. 

It is not always the case that the resulting average distributes
objects such that there is positive spacing between all edges of all
objects — only that the distance is even. If the amount of existing
negative spacing (overlap) between objects in your selection
exceeds positive spacing, the resulting distribution will also have
overlap.

If large and small objects are distributed together with even
spacing between their centers, they may overlap afterward, even
if they were not overlapping to begin with.

MOVE TOGETHER

Both Move Together options are available in the Distribute
submenu of the Arrange Menu, and by hotkey.

Move H Together

Alt / Option + Shift + H

Moves all selected objects so that they are evenly distributed,
and their horizontal edges are abutting along vertical planes.

The last objected added to your selection is anchored in place,
and all other objects will be moved relative to its location.

Move V Together

Alt / Option + Shift + V

Moves all selected objects so that they are evenly distributed,
and their vertical edges are abutting along horizontal planes.

⎇ ⌥ ⇧

⎇ ⌥ ⇧
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The last objected added to your selection is anchored in place,
and all other objects will be moved relative to its location.

RELATED TOPICS

Align Tools

Docking

Move Selected Objects

Grid Array

Selection Tools

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement editing layout-and-design

material-utilization nesting object-manipulation

optimization workflow workflow-optimization

Docking

Shifts objects together, removing blank space. 

Location

Docking Toolbar

Arrange → Dock

The Docking tool moves selected objects left, right, up, or down,
until they meet the edge of the Workspace or another object.
Docking can bring objects together or move them in unison,
making sure they maintain their relative position to one another. 

Docking is helpful for laying out graphics to efficiently utilize
space and material. 

ACCESSING THE DOCKING TOOLS

The Docking options are available in the Dock submenu of the 
Arrange Menu, or in the Docking Toolbar. 

• 

• 

• 

• 

• 

Quick Reference: Dock
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If you do not see the Docking Toolbar, go to Window → Docking
to enable it. By default, it will appear on the far right of the top
toolbar when enabled.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Docking Options

Each of the Docking buttons moves selected objects in a
specified direction, until they hit something — either the outer
edge of another object, or an inner edge of your Workspace. 

Objects contained within another object will not Dock to the
inside edge of the object they are contained in, instead, they will
continue past the inner edge until they hit the outer edge of
another object, or an edge of your Workspace. 

You can Dock objects:

Left 

Right 

Up 

Down 

In the Docking Toolbar there are three additional options to
control Docking behavior.

Move as group tells LightBurn to treat all selected objects as a
single group when Docking them — that means they will all
stop when one object in the group hits the edge of another
object or the Workspace, and all selected objects will maintain
their relative position to one another when they're Docked.

Grouped objects will always move together when Docked,
regardless of whether Move as group is enabled.

Lock inner objects maintains the relative position of objects
contained within other objects, when both are Docked at the
same time.

Padding sets an amount of space to maintain between objects
or the edge of the Workspace when docking. 

The units used for Padding (in / mm) are the same as the units
you have selected in the Numeric Edits Toolbar or your 
Settings.

Padding is only applied in the direction the objects are
Docking, and if an object is already closer to another object or
the edge of the Workspace than the Padding distance is set
to, the object won't be moved. To apply consistent Padding in
both directions, Dock objects away, then back again.

RELATED TOPICS

Snapping

Distribute

Move Together

Move Selected Objects

Grid Array

Tip

• 

• 

• 

• 

• 

Note

• 

• 

Creating even Padding in both directions

• 

• 

• 

• 

• 
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For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement customization editing layout-and-design

material-utilization nesting object-manipulation

Move Selected Objects

Move objects to a corner, midpoint, or center of your Workspace.

Location

Arrange Toolbar

Arrange → Move Selected Objects

Keyboard Modifiers

Hold Ctrl / Cmd  to Move Laser to Selection instead.

The Move Selected Objects tools move objects to a corner,
midpoint, or center of your Workspace. If you have a Gantry style

Quick Reference: Move Selected Objects

⌃ ⌘
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laser, it can also move objects to the last reported position of
your laser head. 

Use these tools to rearrange objects in your Workspace, or to
align graphics in LightBurn to the location of material placed in
your laser's bed, when using Absolute Coordinates positioning. 

UI LOCATIONS

All Move Selected Objects tools are available in the Arrange
Menu or as a drop down menu in the Arrange Toolbar. 

In the Arrange (long) Toolbar, the options to move to the center
of your Workspace, a corner of your Workspace, or the last
reported position of the laser head are available in the full
toolbar, while other options are available in a drop down menu.

OPTIONS AND ICONS

Holding the Ctrl  or Cmd  key while pressing one of these
buttons will move the laser to the indicated location on the
selection, in machine coordinates, instead of moving the
selected objects.

In order to use Move to Laser Position, LightBurn must be
connected to your laser, and it must be capable of reliably
homing and reporting its position accurately. If the position
reported by the laser is inaccurate, using this feature may cause
your laser to attempt to travel outside of its physical bounds. 

Move Selected Objects in the Arrange Menu

Move Selected Objects in the Arrange Toolbar

Move Selected Objects in the Arrange (long) Toolbar

Info

⌃ ⌘

Warning

Option Icon Action

Move to Laser
Position

Moves selected
objects in your 
Workspace to
the location that
corresponds to
last reported
position of the
laser in machine
coordinates.
This option is
not available for
Galvo lasers.

Move to Page
Center

Moves selected
objects to the
center of your
Workspace.

Move to Upper
Left

Moves selected
objects to the
top left corner
of your
Workspace.

Move to Upper
Right

Moves selected
objects to the
top right corner
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Move to Page Center Hotkey

Press P  to move selected objects to the center of your
Workspace.

This hotkey only works if the Workspace / Edit Window — the
area where you create and edit graphics — is in active focus.

There are several windows in LightBurn that accept user input —
when a window is clicked on, it is in focus, and accepting input.

If a window other than the Edit Window is in focus, click
anywhere in the Workspace to bring it into focus.

MOVEMENT OF SELECTIONS

When using the Move Selected Objects tools, all objects in your 
selection move as a single unit, maintaining their relative position
to one another. 

Edges of selections are defined according to the farthest points of
any object in the selection area, in each direction — imagine the
selection area as the smallest possible rectangle that can contain
every object in your selection. The edges of a selection are the
same as the edges of that imaginary rectangle. 

Selections are moved so that their edges abut the location you
move them to — for example, the left edge of a selection will move
to touch the left side of your Workspace when you use Move to
Left, and the top and right edges of a selection will touch the top
and right sides of your Workspace when you use Move to Upper
Right.

When using Move to Page Center, the center point of the entire
selection is moved to the center of your Workspace. 

RELATED TOPICS

Move Laser to Selection

Align Tools

Distribute

Move Together

Selection Tools

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

Option Icon Action

of your
Workspace.

Move to Lower
Left

Moves selected
objects to the
bottom left
corner of your
Workspace.

Move to Lower
Right

Moves selected
objects to the
bottom right
corner of your
Workspace.

Move to Left Moves selected
objects to the
far left of your
Workspace,
centered
between the top
and bottom.

Move to Right Moves selected
objects to the
far right of your
Workspace,
centered
between the top
and bottom.

Move to Top Moves selected
objects to the
top of your
Workspace,
centered
between the left
and right.

Move to Bottom Moves selected
objects to the
bottom of your
Workspace,
centered
between the left
and right.

What does it mean for a window to be in focus?

• 

• 

• 

• 

• 
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arrangement editing laser-control layout-and-design

material-utilization nesting object-manipulation

optimization positioning workflow

workflow-optimization

Nest Selected
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Quick Reference: Nest Selected
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Location

Arrange → Nest Selected

Nesting is method of arranging objects to maximize material
usage. LightBurn does not have its own nesting feature, but you
can use Nest Selected to automatically create and export an SVG
of selected graphics, upload it to SVGnest.com, and re-import it
after it nests the graphics contained in the file.

USING NEST SELECTED

Select any graphics you'd like to nest along with a container graphic
— usually a shape that has the same dimensions as the material
you are going to cut the nested graphics out of — then go to the 
Arrange Menu and click Nest Selected.

LightBurn will not export graphics that are contained inside
another graphic, because interior shapes will not maintain their
relative position to outer shapes during the nesting process. 

This means all of the graphics you'd like to nest must be outside the
container graphic you choose. 

Your default web browser will automatically open to SVGnest.com,
and a dialog window will open in LightBurn, informing you that an
SVG has been created and its file name (LightBurnNest.svg, along
with a file path), has been copied to your clipboard.

On SVGnest.com, click Upload SVG. Paste the automatically copied
name into the file browser, or navigate to the location the SVG
saved to and select it. 

Select the container shape, then click Start Nest.

When you are satisfied with the resulting nest, or the process is
complete, click Stop Nest, then Download SVG. Save the nested
SVG.

Back in LightBurn, click OK in the dialog box. Your file browser will
open — navigate to the location of the SVG you downloaded from
SVGnest, and import it into LightBurn. 

LightBurn will automatically delete the LightBurnNest.svg file it
created and exported after you import the new file from SVGnest.

RELATED TOPICS

Docking

Grid Array

Align

Distribute

Move Together

Move Selected Objects

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement batch-production editing fixing-designs

layout-and-design material-utilization nesting

object-manipulation optimization troubleshooting

workflow workflow-optimization

1. 

Important Note

1. 

2. 

3. 

4. 

5. 

Note

• 

• 

• 

• 

• 

• 
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Push in Draw Order

Visually re-order the stack of objects. 

Location

Arrange Menu

Keyboard Shortcuts

Various

The draw order is an internal list of objects in your Workspace. By
default, all objects are ordered according to when they were
created or added to your project — the last object added to your

project is the first in the draw order, the second to last added is
the second in the draw order, and so on.

The Push options change the order of objects in the draw order.
This is primarily useful when working with images and vector
graphics. Vector graphics may end up hidden behind Images,
making them difficult to manipulate — Push them forward to get
them back in view.

Changing the draw order only affects the display order when in 
Wireframe rendering mode, and not Filled. In Filled rendering
mode, the display order will always match the layer order.

PUSH TOOLS AND HOTKEYS

All Push options are available in the Arrange Menu or by hotkey.

Quick Reference: Push in Draw Order

Note

Push Option Action Hotkey

Push forward in
draw order

Moves selected
objects up one
position in the
draw order

PgDwn

Push backward
in draw order

Moves selected
objects up one
position in the
draw order

PgUp

Push to front Moves selected
objects to the
first position in
the draw order

Ctrl / Cmd

+ PgUp

Push to back Moves selected
objects to the
last position in
the draw order

Ctrl / Cmd

+ PgDwn

⌃ ⌘

⌃ ⌘
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USING THE PUSH TOOLS

Select an object and one of the Push options to move the
selected object in the draw order. 

If you have more than one object selected, they'll each move in
the draw order, but maintain their position in the order relative to
one another — in other words, if you Push the third and fourth
objects in your draw order to the front, they'll become the first
and second objects.

RELATED TOPICS

View Style

Cuts / Layers Window

Align Tools Priority

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement editing fixing-designs image-editing

layout-and-design object-manipulation reference

troubleshooting vector-editing workflow

• 

• 

• 
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Lock Shapes
Quick Reference: Lock Shapes

5.4.4 Arrangement

- 209/400 - ©️ LightBurn Software, LLC



Location

Shape Properties Window

Arrange → Lock/Unlock Selected Shapes

Right-click → Lock/Unlock Selected Shapes

The Lock Shapes tool locks selected objects in your design,
preventing any form of editing (including moving, resizing,
deleting, changing text, and more). Use Lock Shapes to prevent
unintentional design edits, secure graphics used for alignment,
preserve templates, and restrict editing in collaborative projects.

Locking and Unlocking Objects

Lock selected objects by toggling the Locked state on in the 
Shape Properties Window, by going to Arrange → Lock Shapes,
or by right-clicking the objects and choosing Lock Selected
Shapes.

To Unlock and enable editing of a Locked object, toggle the
Locked state off in the Shape Properties Window, go to Arrange
→ Unlock Shapes, or right-click the objects and choose Unlock
Selected Shapes.

Use the Transform Control Toggles to restrict specific types of
editing for the whole project.

RELATED TOPICS

Transform Controls

Transform Control Toggles

Shape Properties

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

lock move rotate shear size transform

Tip

• 

• 

• 
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Snapping

LightBurn's automatic Snapping tools help align objects to other
shapes in your Workspace, or to the Workspace grid itself —
when you move objects close to a valid location, they will snap to
that point.

As you hover your cursor over an object, the icon will change to
indicate when it is over a node, line, midpoint, center, or
intersection. Use these Snapping points when selecting, moving,
or creating objects to ensure exact alignment.

OBJECT SNAPPING

Object Snapping Points

Moving to Snapping Points

When you move objects near enough to a Snapping point, they'll
automatically align to that point, and the cursor will change to
indicate the type of Snapping point they've aligned to.

You can adjust how close your cursor must be to a point before
Snapping behavior is activated in the Units and Grids tab of the 
Settings window. This value is set in pixels — when your cursor is
within that distance from a valid point, it will automatically snap
to it, and change appearance to indicate the type of point it is
over. 

Selecting from Snapping Points

You can select and move objects directly from Snapping points
by clicking and dragging from a location where the cursor has
changed to one of the Snapping icons. 

To move multiple objects at once from a Snapping point on
just one object, you'll need to select them all at once, or Group
them first.

To move objects from a center point when using a Wireframe
View Style, you'll need to select them before hovering your
cursor over the center of the selection. 

The center of objects that are already selected is indicated by

the four-arrow icon 

Snapping Point Icon Description

Node The cursor is
over any node

in a vector
graphic, or the

corner of an
image.

Midpoint The cursor is
over the exact
halfway point
between two

nodes.

Center The cursor is
over the center

point of an
object.

Intersection The cursor is
over the

intersection of
two lines.

Line The cursor is
over a line, but

not a node,
midpoint, or

intersection on
that line.

Note

• 

Snapping multiple objects at once

• 

• 
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Creating From Snapping Points

When creating new objects using the Draw Lines tool or any of
the Primary Shapes tools, your cursor will change to indicate
when it is over a Snapping point.

Click and drag from any of those points to start a new line or
shape at that point.

When you drag near a Snapping point, the cursor will
automatically align to the point, and change to indicate the
type of point it is aligned over.

If you're using the Draw Lines tool, click again to place a node
at that point.

If you're using a Primary Shape creation tool, release to finish
creating the shape. 

SNAP TO GRID

Grid Snapping automatically aligns your cursor to nearby grid
corners when you're dragging objects or creating new ones. 

Grid Snapping points are determined by the Grid Snap Distance
setting in the Settings window, and not the Visual Grid Spacing
distance. 

Grid Snap Distance determines the size of the grid squares
whose corners your cursor will snap to — for example, if your 
units are set to millimeters, and your Grid Snap Distance is set to
1, your cursor will snap to the corners of a grid of 1 mm x 1 mm
boxes.

Visual Grid Spacing determines the visual size of grid squares at
the standard zoom level. As you Zoom In, you'll see a secondary
10 x 10 grid of squares within each larger square. Each smaller
square is 1/10th the size of the Visual Grid Spacing value. 

KEYBOARD MODIFIERS

Hold Alt / Option  while dragging to make Object
Snapping "stickier", meaning objects will automatically align
to Snapping points from further away. 

If you're moving an object or creating a shape, this will also
enable Alignment Guides — temporary visual indicators that
show when an object's edge or center is aligned to an edge or
center of another object in your Workspace.

Hold Ctrl / Cmd  while dragging to toggle either type of
Snapping on or off for as long as the key is held down. 

By default, this disables both types of Snapping. However, if
you've disabled Snap to Objects or Snap to Grid in the 
Settings window, it will instead enable that type of Snapping
for as long as the key is held down.

RELATED TOPICS

Automatic Guidelines

Align Tools

Docking

Edit Nodes

Selecting from a center point

• 

• 

• 

• 

Note

• 

• 

• ⎇ ⌥

Tip

• ⌃ ⌘

Tip

• 

• 

• 

• 
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For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement customization editing essential-functions

first-steps layout-and-design material-utilization

nesting object-manipulation

Automatic Guidelines

LightBurn features two types of automatic guidelines to help you
align objects relative to one another, or along vertical or horizontal
planes. 

Alignment Guides are temporary visual guides that indicate when
an object's edge or center is aligned to an edge or center of
another object in your Workspace.

Draggable Guidelines are persistent lines set to the T1 Tool layer
— they are perfectly vertical or horizontal by default, and you can 
snap other objects to them.

ALIGNMENT GUIDES

To enable Alignment Guides, hold Alt / Option  while
dragging a selected object or objects in your Workspace. 

As you move the selection around, temporary visual guides will
appear, indicating when an edge or midpoint of your selection
has Snapped into alignment with an edge or midpoint of another
object. 

DRAGGABLE GUIDELINES

To create Draggable Guidelines, hover over the ruler to the top
or left of the Workspace until the cursor changes to the line icon 

, then click and drag. Release when you've placed the
Guideline where you want it — you'll also be able to adjust its
position later.

Dragging from the top creates a perfectly horizontal guideline,
and dragging from the left creates a perfectly vertical guideline. 

These guidelines are set to the T1 Tool layer, and are treated like
any other object in LightBurn. You can move them around, snap
other objects to them, or Lock them to prevent accidental
movement.

• 

• 

⎇ ⌥
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Since they're set to a Tool layer, Draggable Guidelines will never
be output to your laser, but if you're using Current Position or 
User Origin as your Start From mode, you'll need delete them
first, or toggle off the Frame option in the Cuts / Layers Window
to exclude them when calculating Origin. 

RELATED TOPICS

Snapping

Align Tools

Docking

Distribute and Move Together

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

alignment arrangement editing layout-and-design
Warning

• 

• 

• 

• 
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5.4.5 Image Tools
Adjust Image

5.4.5 Image Tools
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Tweak image settings like contrast, brightness, and gamma while also changing layer settings.

Location

Tools → Adjust Image

Right-click → Adjust Image

Keyboard Shortcuts

Windows: Alt + I

Mac: Option + I

The Adjust Image tool streamlines the process of tweaking 
Image Settings such as Contrast, Brightness, and Gamma while
also changing Layer Settings, allowing you to adjust all of these
properties from a single window, and see an instant preview of
resulting output. 

To open the Adjust Image tool, select any single image, right-click, and choose Adjust Image from the context menu, or press Alt / Option + I .

Quick Reference: Adjust Image

⎇

⌥

⎇ ⌥
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ADJUST IMAGE WINDOW

The original source image is displayed in the top left of the 
Adjust Image window. The result of your chosen settings is
displayed as a processed image in the top right. 

Making any adjustment allows you to see an immediate preview
of the processed output, side-by-side against the source image.

Click and drag to pan around the image, and use the mouse
scroll wheel (or two-finger dragging if you're using a trackpad) to 
Zoom In and Out. The source image and processed image are
kept in sync while zooming and moving around.

LAYER SETTINGS

The Layer Settings group on the left contains settings that
correspond to those found in the Cut Settings Editor, as
highlighted below:

For more information on these settings, see Cut Settings —
Image Mode.

After adjusting settings, click OK to confirm and automatically
apply changes to the Layer Settings for the image you are
adjusting, or Cancel to discard the changes and leave the
settings unchanged. 

These settings will affect any image on the same layer as the one
you have selected.

IMAGE SETTINGS

The Image Settings group on the right contains settings that
correspond to those found in the Shape Properties Window.
Adjust these settings by dragging the sliders or directly editing
the numeric value of each property.

For more information on these settings, see Shape Properties —
Image.

As with Layer Settings, click OK to confirm changes, or Cancel
to discard them. 

INVERT DISPLAY

Turn on the Invert Display option to show the processed image
with black for the background and white for lasered lines.

Note

5.4.5 Image Tools
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Inverting provides a preview of what the resulting output will
look like when engraved on slate, black painted tile, black
anodized aluminum, or any other material where the marked
area will be lighter than the surface of the unmarked material.

This option affects the preview image only — it has no effect on
actual output. 

PRESETS

You can select Presets from the dropdown above Image
Settings on the right side of the Adjust Image window. 

Selecting a Preset automatically applies all the settings saved to
it, overwriting your existing settings. 

LightBurn provides two Built-In Presets, as well as the option to
save your own frequently used image settings as User Presets.

Basic is a good starting point for your own engravings or for
creating User Presets. 

Black Paint on White is similar, but inverted for engraving
light marks onto dark surfaces.

Save Image Preset 

The first button next to the Presets' dropdown allows you to save
your current settings as an image Preset. 

Enter a name for your Preset in the Preset Name field near the top
right of the window.

You can choose which Layer and Image Settings are included in
the Preset by toggling the switches next to each option. 

Click All to include all settings, None to exclude all settings, or 
Invert to include settings that are currently excluded, and exclude
settings that are currently included. 

Excluded settings well be ignored when loading the Preset later.

Click Save to store the selected settings as a Preset, or Cancel to
exit without saving.

Delete Image Preset 

The second button allows you to Delete image Presets. Make
sure the Preset you want to delete is selected in the dropdown
first.

Import/Export Image Preset 

The third and fourth buttons allow you to Import and Export
image Presets, which is useful for backing up your Presets and
for moving them between computers. 

You can also include these Presets as part of a User Bundle.

RELATED TOPICS

Cut Settings — Image Mode

Shape Properties

Apply Mask to Image

Save Processed Bitmap

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

brightness bundles contrast delete-preset design

export gamma image-tools import invert layout

presets save-preset

Note

• 

• 

1. 

2. 

3. 

4. 

Tip

• 

• 

• 

• 
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Apply Mask to Image
Quick Reference: Apply Mask to Image
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Location

Tools → Apply Mask to Image

Right-click → Apply Mask to Image

Use Apply Mask to Image to hide portions of images that you
do not want to engrave, or to divide them into more complex
engraving patterns. 

By default, image masking doesn't delete the data of the
removed part of the image, it just hides it from view and doesn't
output those parts to the machine.

You can use masking to remove the background of an image, for
example to isolate a pet or person from an photograph — a
great way to get more clarity in an image that doesn't have a
well-contrasted background. 

MASKING AN IMAGE

In addition to an image, masking requires a vector object, in any
desired shape. The vector object must be:

Placed on either a Tool or Line layer

A closed shape, with a single, shared start and end point

You can use use rectangles to perform standard crops, but the
shape can be a more complex path as well, or even a Group of
vectors (including text) provided that the Group is all on the same
layer. When shapes are placed on a shared layer, Grouped, and
used for masking, the area between the shapes that would
normally be solidly engraved with Fill Mode will be "filled" with
the image instead.

To Mask an Image, select the image and vector, then go to Tools
→ Apply Mask to Image, or right-click the selection and choose
Apply Mask to Image from the context menu. 

Tip

• 

• 
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To immediately Flatten the mask in the process, you can select 
Crop Image from the same menus instead — if you choose to
Crop an image, you will be unable to remove or edit the mask. 

If the vector is hidden by the image, use Push to Front to move it
forward in the draw order if you're also using a Wireframe View
Style.

If you're using a Filled View Style, adjust the order of the layers in
the Cuts / Layers Window.

REMOVING A MASK (RESTORING AN IMAGE)

You can fully restore the original image in two ways: 

Select the vector object you used for the mask and press 
Backspace / delete  on your keyboard to delete it.

Select the image, right-click it, and choose Remove Mask
from Image. 

EDITING A MASK

To change which parts of the image are revealed and hidden, you
can edit the existing mask as you would any other vector object,
for example with the Select, Edit Nodes, and Boolean tools. 

Once you have the mask as you want it, it's a good idea to Group
the vector and image to avoid accidentally moving one without
the other. 

FLATTENING (BAKING-IN) A MASK

The downside of preserving the hidden parts of the image is that
it can make masked images harder to align to other objects, but
it is possible to permanently remove the hidden areas of a
masked image (also called "baking in" the mask). 

To do so, right-click the masked image and select Flatten Image
Mask. 

This also removes the masking shape, leaving you with a only an
image in the shape it had been masked.

RELATED TOPICS

Cut Settings — Image Mode

Adjust Image

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

customization editing image image-editing

image-raster-bitmap image-tools layout-and-design

object-manipulation

Hidden Vector

• 
⌫

• 

Grouping

• 

• 
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Convert to Bitmap
Quick Reference: Convert to Bitmap
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Location

Edit → Convert to Bitmap

Right-click → Convert to Bitmap

Keyboard Shortcuts

Windows: Ctrl  + Shift  + B

Mac: Cmd  + Shift  + B

Convert to Bitmap turns selected vector graphics into bitmap
images.

Vector graphics are made up of lines, curves, and nodes that
define the contours of shapes, while bitmap images are made of
a grid of shaded pixels.

See Images vs. Vectors for more information on the differences
between images and vector graphics.

Once a vector graphic has been converted to a bitmap image, it
is set to Image Mode and can be engraved using a dithered
pattern. 

USING CONVERT TO BITMAP

Select all vector graphics you wish to convert and go to Edit → 
Convert to Bitmap ( Ctrl / Cmd + Shift + B ), or right-
click and select Convert to Bitmap. 

At the top of the Convert to Bitmap window you'll see a
preview of the bitmap image that will be created. As you adjust
the options the preview will live-update.

The Render Type option determines whether the resulting
bitmap will show just the Outlines of the vector graphics, will 
Fill All areas between the outlines, or Use Cut Settings to
determine whether to render outlines or solid fills depending
on whether the graphics are assigned to a layer set to Line
Mode.

⌃ ⇧

⌘ ⇧

⌃ ⌘ ⇧

• 

• 
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In order to Render a vector graphic as a solid, filled bitmap it
must be a closed shape. See Open vs. Closed Shapes for more
information. 

Set the DPI for the resutling bitmap by manually entering a
value into the DPI field, or by adjusting the slider below it. DPI
controls the density of the pixels in the bitmap — higher pixel
densities lead to sharper images.

The brightness value of each pixel is automatically set to 50%
gray. After converting vector graphics to bitmap images, you
can adjust their brightness using the Adjust Image tool.

Press OK to create the bitmap image, or Cancel to discard the
changes and leave the vector graphics as they are.

Converting a vector graphic into a bitmap image deletes the
vector graphic. To preserve the original graphic while creating
a bitmap from it, Copy or Duplicate it, then convert the second
copy.

RELATED TOPICS

Image Mode

Adjust Image

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement customization editing fixing-designs

image image-editing image-raster-bitmap image-tools

layout-and-design node-editing object-manipulation

object-repair path path-editing path-tools

troubleshooting vector vector-editing

vector-path-curve-lines vector-tools

Save Processed Bitmap
Note

• 

• 

• 

Warning

• 

• 
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Quick Reference: Save Processed Bitmap
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Location

File → Save Processed Bitmap

Right-click → Save Processed Bitmap

Use Save Processed Bitmap to save an image you have edited in
LightBurn, including any changes made using Adjust Image, or
any dithering mode applied to the image. 

SAVING PROCESSED BITMAPS

To save a processed image, first select an image, then go to File → Save Processed Bitmap or right-click in your Workspace and select Save Processed Bitmap from the context menu.

5.4.5 Image Tools
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Your system's file management window will open, where you can
name and select a location to save the processed image. After,
you'll be able to open the processed image using any software
that can open images.

5.4.5 Image Tools
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RELATED TOPICS

Adjust Image

Image Mode

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

customization editing export image image-editing

image-raster-bitmap image-tools import-export

layout-and-design reference troubleshooting

• 

• 
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Trace Image

Converts images into vector graphics.

Location

Tools → Trace Image

Right-click → Trace Image

Keyboard Shortcuts

Alt / Option + T

Use the Trace Image tool to convert imported images into vector
graphics.

This is useful if you want to edit an image that has high contrast
or well-defined edges, including logos, silhouettes, cartoons,
sketches, and handwriting. You can trace photographs as well,
but results will vary based on the composition of the photograph.

TRACE IMAGE WINDOW

After selecting an image in your Workspace, select Tools → Trace
Image, right-click the image and select Trace Image from the
context menu, or press Alt / Option + T  to open the Trace
Image window.

Preview

In the image above, the purple lines are the vectors that
LightBurn has produced from the image being traced. As you
adjust settings in the Trace Image window, the purple lines will
change to reflect the new vectors that will result from the
updated settings.

Navigation

You can Zoom and Pan the preview using the same controls as in
the Workspace, and double-click the middle mouse button to
reset the view. 

Fade Image

Click Fade Image to dim the image, increasing the visibility of
the vectors (purple lines) in the preview. 

Boundary

Click and drag in the preview to specify a portion of the image to
trace. Click Clear Boundary to reset it. 

Show Points

Quick Reference: Trace Image

⎇ ⌥

⎇ ⌥
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Click Show Points to toggle visibility of the nodes in the preview
of the resulting vectors. 

Trace Options

Cutoff and Threshold

The Cutoff slider controls the lower end of the range of
brightness values that LightBurn will outline with vectors, and
the Threshold slider sets the upper end. The default is 0 to 128,
which traces around all values in the range of 0 to 128
brightness, excluding lighter values in the range of 129 to 255
brightness.

Increase Threshold to include lighter values.

Increase Cutoff to remove darker values. 

Ignore less than

Instructs LightBurn not to trace areas where the amount of pixels
in the valid brightness range is lower than this number. Increase
the number of pixels in the Ignore less than field to clean up
noisy images by removing small areas from the result. 

Optimize

Increase the value in the Optimize field to reduce the number of
nodes in the resulting vectors, similar to Optimize Selected
Shapes. 

A value of 0 leads to no optimization, while excessively high
values can reduce accuracy. The default of 0.2 usually provides a
good balance between accuracy of the result and node count.

Smoothness

Increase Smoothness to turn more line segments of the
resulting vector into curves. Set it to 0.0 to create only lines (left),
and 1.33 to create only curves (right). 

Trace Transparency

Turn on Trace Transparency if you wish to trace an image based
on its alpha layer. 

Sketch Trace

Turn on Sketch Trace for photographs of pages with uneven
lighting — for example handwriting, sketches, and documents.
LightBurn will look for edges in the image with this setting
enabled, based on local differences in contrast, rather than
relying on the brightness or darkness of the whole image.

Delete image after trace

Turn on Delete image after trace to automatically remove the
image from your project upon hitting OK. 

EDITING THE TRACE

After hitting OK, you will be presented with a Group containing
the resulting vectors. To edit the shapes individually, you must
first Ungroup them.

After they are Ungrouped, you can edit them as you would any
other shape.

If you can't see the vector, it may be hidden by the original
image, click and drag the image out of the way to reveal it, or 
Push the image to the back of the draw order. 

TROUBLESHOOTING

Tracing works by automatically creating an approximation of the
pixel-based image in vector format, and while LightBurn's trace
function is extremely robust, it remains limited by both the
computationally-difficult nature of this task, and the quality of
the image it is presented with. In some instances fine details —
for example sharp corners and small text — may not be
converted well during this process. If changing the Trace options
doesn't overcome this issue, exit the Trace Image window and
try using Threshold Image Mode to engrave the original image
instead of tracing it. 

RELATED TOPICS

Adjust Image

Apply Mask to Image

Convert to Bitmap

Edit Nodes

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

boundary cutoff fade-image ignore image

image-tools optimize sketch smoothness threshold

trace-image trace-options transparency vector

Hidden Vector

• 

• 

• 

• 
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Image Options

Refresh or replace images in your project.

Location

Edit → Image Options

The three commands under Edit → Image Options — Refresh
Image, Replace Image, and Replace Image to Fit — provide
ways to refresh or replace images in your project. This is most
often useful if you've edited the image in a different editing
software and want to reload or replace the image currently open
in LightBurn. 

REFRESH IMAGE

After importing an image into a LightBurn project, changes to
the original image file aren't automatically reflected in LightBurn.
Use Refresh Image to reload the image file in its most recent
version.

REPLACE IMAGE

Replace Image opens a dialog box to select a new image. The
new image replaces the originally selected image in the
LightBurn project.

REPLACE IMAGE TO FIT

Replace Image to Fit replaces the image as described above,
automatically scaling it to fit in the space taken up by the
originally selected image.

TROUBLESHOOTING

If these commands are unavailable, check the following:

Make sure you have a pixel-based image selected in LightBurn.

Make sure the image is not Grouped with other objects.

RELATED TOPICS

Trace Image

Adjust Image

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

edit image image-options refresh replace

replace-to-fit

Quick Reference: Image Options

• 

• 

• 

• 

5.4.5 Image Tools

- 231/400 - ©️ LightBurn Software, LLC

https://forum.lightburnsoftware.com/
mailto:support@lightburnsoftware.com


5.5 Laser Control

5.5.1 Cut Settings

Cuts / Layers Window

The Cuts / Layers Window shows the list of layers in your
project. From the Cuts / Layers Window, you can assign different
operations to specific layers, control the order the laser
processes the layers, adjust an abbreviated set of settings for
each layer, and more.

To adjust all layer settings, double-click any layer in the Cuts /
Layers Window to open the Cuts Settings Editor, which contains
all available settings.

Use the Color Palette to change which layer the selected objects
are assigned to. 

In LightBurn, different colors indicate each layer. These colors
don't represent the final product's colors but instead
differentiate each operation needed to complete the job. Each
layer defines a process and a collection of settings that is
assigned to objects within the project.

In other words, layers let you tell the machine what it needs to
do to produce the final work.

Generally each color refers to a different layer, with one
exception — if you add an image to a vector layer (or vice versa),
then the layers will split to show two entries in the Cuts / Layers
Window.

ACCESSING THE CUTS / LAYERS WINDOW

The Cuts / Layers Window is located in the upper right of
LightBurn by default. If you have closed the Cuts / Layers
Window, go to Window → Cuts / Layers to re-enable it. To
restore it and all other windows to their default positions, go to 
Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

CUTS / LAYERS WINDOW OPTIONS AND SETTINGS

Columns

# (Layer Name)

Shows the layer name. You can adjust a layer's name in the Cuts
Settings Editor.

Layer

Shows the color and title of the layer. Colors and titles have
matching entries in the Color Palette.

Mode

View and change the Layer Mode of layers in your project. 

You can adjust the mode of vector graphics between Line, Fill,
and Offset Fill.

Layers containing images are automatically set to Image and
cannot be adjusted. 

Layers with multiple Sub-Layers are set to Multi. Open the Cut
Settings Editor to adjust Sub-Layer modes and other settings.

Spd/Pwr

Shows Speed and Power settings.

You can adjust these settings in Speed and Power Max fields
beneath the list of layers, or by opening the Cut Settings Editor.

About Layers in LightBurn

Tip

• 

• 

• 
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Output

Toggle to enable or disable which layers are output when you 
Preview, Start, Send, or save a project in machine-specific format.

The color of layers not set to output will be faded in your 
Workspace.

Use Preview to verify that only intended layers are set to output.

Right-click Output in the top bar to open a context menu where
you can select to: 

Enable all cut layers

Disable all cut layers

Invert enabled cut layers, turning currently enabled layers 
off and currently disabled layers on

Sort Cuts Last, moving cut layers to the bottom of the list. See
below for more information.

Show

Toggle which layers are visible in your Workspace.

Right-click Show in the top bar to open a context menu where
you can select to: 

Show all cut layers

Hide all cut layers

Invert visible cut layers, showing currently hidden layers and 
hiding shown layers

Sort Cuts Last, moving cut layers to the bottom of the list. See
below for more information.

Air

Toggle to enable or disable Air Assist for individual layers in your
project.

Right-click Air in the top bar to open a context menu where you
can select to: 

Enable all air assist, turning on Air Assist for all layers.

Disable all air assist, turning off Air Assist for all layers

Invert all air assist, turning Air Assist off for layers it is
currently enabled for, and on for layers it is disabled for

Sort Cuts Last, moving cut layers to the bottom of the list. See
below for more information.

Settings

Pass Count

Sets how many times the laser will repeat the shapes on this
layer.

Speed

Adjust the Speed to run the laser at for this layer.

Power Max

Adjust the maximum power output level of the laser for this layer.

Power Min

Adjust the minimum power output level of the laser for this layer.

This setting is only shown when you're using a DSP laser or are
engraving an image using Grayscale Mode, with any type of
laser.

Interval

Adjust the space between each scan line in a Fill or Offset Fill
operation.

Frequency

Tip

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

Note
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Available Galvo lasers only. 

Adjust the Frequency setting for this layer.

Q-Pulse

Available MOPA and UV Galvo lasers only. 

Adjust the Q-Pulse Width setting for this layer.

REARRANGE LAYERS

By default, layer operations are performed by your laser in the
order from top to bottom in which they are listed in the Cuts /
Layers window.

See Optimization Settings for information on alternate options
for ordering operations. 

The order that layers are completed is often important, as pieces
shift after being cut out. It's therefore best to engrave images
and marking/scoring lines before any cuts through the material.

To change the order of the selected layer in the list you can click
and drag to change its position or select a layer and click the up
and down buttons in the window. 

Sort Cuts Last

You can also automatically sort all layers, based on how likely
they are to cut through the material — with the least likely being
performed first. 

To do so, right click any heading on the table (e.g. Mode) and
choose Sort Cuts Last. 

This process orders layers first by their strength — stronger layers
have higher Power, lower Speed, and more Passes. It then
pushes all Line Mode layers to the end, so all engraving
operations are performed before cutting operations.

COPY LAYER SETTINGS

To copy settings between layers, first select a layer in the list and
click the right-arrow Copy button to copy its settings. Next, select
the layer you want to copy to, and click the left-arrow Paste
button. 

DELETE LAYERS

Click the Delete button to delete a layer and all objects assigned
to it in your Workspace

IDENTIFY AND SELECT ALL OBJECTS ON A LAYER

Right-click any layer in the list to flash the objects assigned to
that layer in your Workspace.

Hold Shift  and click any layer in the list to select all objects on
that layer.

RELATED TOPICS

Cut Settings Editor

Color Palette

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

cut-settings laser-control

Note

Note

Note

⇧

• 

• 
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Cut Settings Editor

CUT SETTINGS EDITOR

The Cut Settings Editor is where you adjust all settings for the
layers in your project. 

The settings presented in the Cut Settings Editor vary depending
on the type of laser you're working with, and the Layer Mode the
selected layer is set to. 

In all variations of the Cut Settings Editor, the most essential
settings — including Speed, Power, and Mode — are displayed at
the top of the window. More specialized options follow below, split
into two tabs — Common and Advanced.

Access the Cut Settings Editor by double-clicking any entry in the 
Cuts / Layers Window or Material Library. 

The window will open to settings for the entry you double-
clicked — click any other layer in the column along the left side to
access the settings for that layer.

The Cut Settings Editor for a layer set to Line Mode, using a GCode-
based laser.

You can adjust a narrower set of critical settings directly in the 
Cuts / Layers Window, instead of opening the Cut Settings Editor.

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.

Select an option below to learn more about different groups of
settings. 

Main /
Share
Settings

Settings
shared
by
almost
all types
of lasers
and
Layer
Modes,
including
critical
settings
like 
Speed
and 
Power.

Line
Mode

Tells
your
laser to
trace a
path
along
the
outlines
of
geometry
in your
project.

Fill
Mode

Tells
your
laser to
etch or
engrave
parallel
lines
inside
the
bounds
of
closed
shapes
in your
project.

Offset
Fill
Mode

Tells your
laser to
fill closed
shapes
with lines
that
follow
the
contour
of the
outer
shape.

Image
Mode

Works
similarly
to Fill
Mode,
but
applies
additional
special
settings
to
adjust
output
based
on the
pixels in
your
image.

Galvo-
Specific
Settings

Special
settings
that are
available
for
users
with
Galvo
style
lasers
only.

Note
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Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers
in your
project.

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can
reset to
at any
time.

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control

ESSENTIAL / SHARED SETTINGS

Several settings in the Cut Settings Editor are shared among
nearly all laser types and Layer Modes.

See Additional Options for information on specialized settings
not covered on this page.

Essential Settings

The settings near the top of Cut Settings Editor are fundamental
to all laser operations. You can edit many of these settings
directly in the Cuts / Layers Window as well.

Click any option in the images below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Left: Essential settings for a GCode-based laser
Right: Essential settings for a DSP laser 

Name

You can rename layers to help keep track of their settings and
purpose in your project. 

Output Switch

Toggle the Output switch on or off to determine whether a given
layer is included in the output when you Preview, Start, Send, or 
save a project in machine-specific format.

The color of layers not set to output will be faded in your 
Workspace.

Speed

The maximum speed the laser will reach when cutting or
engraving your design. 

Higher speed values can decrease the amount of time your laser
spends completing a job, but also tend to produce lighter marks
or shallower engravings than slower speed values. Cutting
through many materials requires relatively slow speeds, though
the exact values vary significantly depending on your laser and
material.

Depending on your laser, its firmware settings, and the design
you tell it to cut or engrave, the laser may not actually reach the
speed you set. Consult your laser's manufacturer for guidance
on the maximum speed your laser is capable of.

Note

Note

Note
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When entering Speed values recommended by your laser's
manufacturer or other LightBurn users, make sure to use the 
same units of distance and time as those from the recommendation,
or to convert the values to your preferred units.

A given number of millimeters per second is much faster than
that same number in millimeters per minute. Mixing up units
can lead to reduction in power output due to unexpectedly high
speeds, or excessive power output — and even fire — due to
unexpectedly slow speeds. 

Change your displayed units in the Units and Grids tab of the 
Settings window. LightBurn automatically converts any existing
values when you switch between units.

Default Speed Switch (Ruida Only)

Enable this switch to use the default Speed setting from the
laser's controller. You can adjust this default through the
controller's display.

Max Power

Use the Material Test to find optimal settings for your laser,
material, and desired outcome.

The maximum power level the laser will reach when cutting or
engraving your design.

High power levels produce darker marks and deeper engravings,
and relatively high powers are required to completely cut
through many materials. 

GRBL-based lasers ramp up to the maximum power level as they
increase in speed, only reaching Max Power when they also
reach the Speed you've set. If you set a Speed higher than your
laser can actually reach, it will never reach Max Power either.

See Troubleshooting: Low or No Power Output for more
information.

Min Power

This setting is only shown when you're using a DSP laser or are
engraving an image using Grayscale Mode, with any type of
laser.

Min Power determines the power level the laser will use when it
travels at slow speeds, such as when it slows down to reach the
ends of lines, changes directions, or turns corners. 

Some DSP controllers refer to this as the Corner Power for this
reason.

The laser's controller will automatically ramp power between Min
and Max Power as it accelerates to the maximum Speed you've
set.

Reduce Min Power if your laser is scorching or charring your
material when it turns corners, or increase it if it's having trouble
cutting through material on corners.

See Troubleshooting: Corners Are Too Dark, Too Light, or Missing
for more information.

Default Power Switch (Ruida Only)

Enable this switch to use the default Max and Min Power
settings from the laser's controller. You can adjust these defaults
through the controller's display.

Constant Power Mode (GRBL Only)

By default, LightBurn uses Variable Power mode (M4), which
ramps the power level of the laser up and down with the speed,
producing a more consistent burn. 

However, if you ask the laser to move faster than it's able, it will
never reach the requested speed or the requested power level.
It's generally best to stick with the default of Variable Power
mode and adjust the speed to be within the range your machine
can achieve, but if you want the same behavior as LaserGRBL,
whch defaults to Constant Power (M3), you can enable this
option.

See Troubleshooting: Low or No Power Output for more
information.

Air Assist

Enable this switch to turn on Air Assist, if your laser supports it.
Air assist can help in cutting through material.

Users with GCode-based lasers can select whether their air assist
is activated by an M7 or M8 command in Device Settings.

This setting is available for DSP and GCode-based lasers only.

If your laser has no air assist, or it must be activated manually,
enabling and disabling this switch will have no effect.

Mode Dropdown Menu

Select Line, Fill, or Offset Fill from the dropdown menu to change
how the laser will cut or engrave graphics assigned to a given
layer.

Images are automatically set to Image Mode and this dropdown
menu is not available for layers they are assigned to. 

Always pay attention to units of distance and time
when entering Speed settings

Tip

GRBL Power Ramping

Note

Min Power Troubleshooting

Note
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Additional Options

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.
Select an option below to learn more about different groups of
settings. 

Main /
Share
Settings

Settings
shared
by
almost
all types
of lasers
and
Layer
Modes,
including
critical
settings
like 
Speed
and 
Power.

Line
Mode

Tells
your
laser to
trace a
path
along
the
outlines
of
geometry
in your
project.

Fill
Mode

Tells
your
laser to
etch or
engrave
parallel
lines
inside
the
bounds
of
closed
shapes
in your
project.

Offset
Fill
Mode

Tells your
laser to
fill closed
shapes
with lines
that
follow
the
contour
of the
outer
shape.

Image
Mode

Works
similarly
to Fill
Mode,
but
applies
additional
special
settings
to
adjust
output
based
on the
pixels in
your
image.

Galvo-
Specific
Settings

Special
settings
that are
available
for
users
with
Galvo
style
lasers
only.

Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers
in your
project.

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can
reset to
at any
time.

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control

Note
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LINE MODE

Line Mode tells your laser to trace a path around the contours of
vector graphics. 

If you command the laser to move quickly, or with low Power, it
will likely just etch the surface (sometimes called scoring). If you
move slowly and with high power, especially with a CO2 laser, the
laser will cut deeper, or even completely through the material.
The only difference between surface marking and cutting with
Line Mode is the Power and Speed you set.

Line Mode Settings

There are several specialized options available in the Cut Settings
Editor for layers set to Line Mode, split into two tabs, Common
and Advanced.

See Main / Shared Settings for information on applying essential
settings like Speed and Power.

See Additional Options for information on specialized settings
not covered on this page.

Click any option in the images below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Many of the settings presented in the images below are available
for users with DSP lasers only, but most are shared between all
types of lasers. 

Left: Common Line Mode settings tab
Right: Advanced Line Mode settings tab 

Common Settings

Number of Passes

How many times the laser will repeat the shapes on this layer.
Sometimes, when cutting thick material, trying to engrave very

deep, or using a lower power laser, more than one pass may be
necessary.

Z Offset

If you have Z movement enabled, and your controller supports it,
you can use the Z offset setting to move the laser head closer to
the material (inward) or farther away from it (outward). Positive
values move the Z Axis inward, and negative values move it
outward. 

Focusing deeper into the material can sometimes help to cut
thicker material, and lifting the laser away from the material can
produce a thicker line.

Z moves have the potential to physically damage your laser by
crashing the head into the material.

If your system uses auto-focus, you may not be able to push the
focus point lower, because most systems treat the auto-focus
height as the lowest possible height (Z limit) to avoid crashing
the laser head.

Z Step per Pass

When doing more than a single pass over a shape, the Z step per
pass setting allows you to tell LightBurn to raise or lower the
laser with each pass by the same amount. 

By allowing you to shift the focus point deeper with each pass,
this is often useful for cutting thick materials or achieving deep
engravings, 

Kerf Offset

Because LightBurn must determine the inside and outside of a
shape in order to apply a Kerf Offset, this setting will only work
with closed shapes.

Kerf refers to the thickness or width of a cut made by a cutting
tool. The kerf of a laser is much narrower than that of a saw
blade, but the extra material removed can interfere with close-
fitting parts such as tabbed boxes or inlays.

Kerf Offset compensates for the extra material removed by
offsetting the path of the laser to the outside of closed shapes
(for positive values) or the inside (for negative values). This
doesn't modify the underlying shape, so you can use your design
on lasers with different kerfs by adjusting the Kerf Offset value.

The image below shows how Kerf Offset (dashed lines) relates to
the original shape (solid lines).

Note

Warning for Z Moves

Closed Shapes Only
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Perforation Mode

Enable Perforation Mode to specify a distance to Cut, followed by
a distance to Skip. 

As the laser traces the contours of shapes assigned to this layer, it
will turn on over the specified Cut distance, and off over the
specified Skip distance.

Perforation mode is useful if you're trying to cut fold lines in card
stock, stitch holes in leather, or make dashed lines.

This can also help when using delicate materials with a powerful
laser. With very low cut and skip values, the beam is rapidly
switched on and off, reducing the effective power output. Try
starting with cut and skip values of 0.1 mm each, and adjust the
ratio between cut and skip to tune it further.

Tabs / Bridges

Tabs are small sections of cuts that the laser is commanded to
skip, used to prevent objects that you are cutting from
immediately falling out of the base material. When sized
appropriately, the tabs can be broken with minimal force and the
objects removed from the material after the job is finished
cutting.

See Add Tabs for information on creating and adjusting Tabs /
Bridges settings.

Advanced Settings

Under the Advanced tab you'll find several less frequently-used
options. Many of the options presented here are available only
for particular types of lasers.

The Advanced tab is not available if you're using a Galvo laser.
See Galvo-Specific Cut Settings for information on advanced
settings for Galvo lasers.

Start / End Pause Time

Use these options to add a delay, in milliseconds, at the
beginning of a cut, the end, or both. 

If you also enable the Cut Through option, the beam will be
turned on during this pause, which can be used to prime the cut
and help pierce through thick material. The Power % value sets
the power of the laser during this pause.

Without the Cut Through toggle enabled, it can add a delay to
let the gantry settle down after a rapid move, or allow time for an
air assist solenoid to engage.

This setting is not available for lasers with TopWisdom
controllers. Dwelling without Cut Through enabled is not
available for lasers with Trocen controllers.

Overcut

Enable Overcut to tell your laser to extend a cut by a specified
amount past the end of closed shapes, on the final Pass.

Override PWM Frequency

If you have an RF Excited tube, this setting allows you to control
the PWM frequency of the pulses sent to the laser, and can
change the edge finish on certain materials.

This setting is only available for lasers with Ruida controllers.

Enable PPI

The PPI setting (Pulses Per Inch) lets you tell the laser to send an
exact number of pulses per inch of travel, instead of varying the
beam power directly. This is useful for delicate materials like
paper, and is similar to using Perforation Mode, but is handled by
the hardware itself.

This setting is only available for lasers with Trocen controllers.

Lead In / Lead Out

Lead-In and Lead-Out are optional lines or curves added to the
start or end of a cut. You can toggle each on or off individually,
and specify their Length, Angle and Style.

When cutting thick material, particularly if using Cut Through
delays, or cutting metal, there is often a mark left at the start of

Use Perforation Mode to reduce effective power output

Note

Note

Note

Note
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the cut that is slightly thicker than the rest, and can leave an
indent on an otherwise smooth edge. With this setting, you can
add a small line to the start or end of a cut, so that mark happens
off the cut line itself. 

The Angle value controls the placement of the lead line — a
positive number tells LightBurn to put the lead line outside the
shape, and a negative number means to put it inside. You can
choose to make the lead a straight Line, or a short Arc.

The shape above on the left is using an Arc set to +45 degrees, so
it starts outside the shape. The one on the right is a Line set to
-20 degrees, so it appears inside the shape.

Dot Mode

When enabled, the laser will pause and pulse at regular intervals
along the path, instead of cutting continuously. The Time value
specifies the pause delay in milliseconds, and the spacing
parameter sets how far apart the pulses are. 

This can be an effective way to do stitching holes, or cut very thin
or delicate materials, but the constant pausing can shake the
machine - using Perforation Mode is often preferable for this
reason. 

This setting is only available for lasers with Ruida controllers.

U Offset

Enter a distance here to set a per-layer U Axis offset. To use this
setting, your laser must support U Axis control, and you must
enable the U Axis in Device Settings.

This setting is only available for lasers with Ruida controllers.

Additional Options

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.
Select an option below to learn more about different groups of
settings. 

Main /
Share
Settings

Settings
shared
by
almost
all types
of lasers
and
Layer
Modes,
including
critical
settings
like 
Speed
and 
Power.

Line
Mode

Tells
your
laser to
trace a
path
along
the
outlines
of
geometry
in your
project.

Fill
Mode

Tells
your
laser to
etch or
engrave
parallel
lines
inside
the
bounds
of
closed
shapes
in your
project.

Offset
Fill
Mode

Tells your
laser to
fill closed
shapes
with lines
that
follow
the
contour
of the
outer
shape.

Image
Mode

Works
similarly
to Fill
Mode,
but
applies
additional
special
settings
to
adjust
output
based
on the
pixels in
your
image.

Galvo-
Specific
Settings

Special
settings
that are
available
for
users
with
Galvo
style
lasers
only.

Note

Note
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Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers
in your
project.

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can
reset to
at any
time.

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control

FILL MODE

Fill Mode tells your laser to etch parallel lines within the
boundaries of vector graphics. 

The distance between each line is determined by the Line
Interval setting, and the Speed and Power settings control the
darkness or depth of the etch. Use low Intervals, low Speeds, and
high Powers for deep engravings or dark marks, or tell your laser
to move quickly at low Power to lightly etch or mark the surface. 

Fill Mode Settings

There are several specialized options available in the Cut Settings
Editor for layers set to Fill Mode, split into two tabs, Common
and Advanced.

See Main / Shared Settings for information on applying essential
settings like Speed and Power.

See Additional Options for information on specialized settings
not covered on this page.

Click any option in the images below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Many of the settings presented in the images below are available
for users with specific kinds of lasers, but most are shared
between all types of lasers. 

Note
If you have two shapes set to the same layer, and one is
inside of the other, the area between the two outlines
will be filled.

Note
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Left: Common Fill Mode settings tab
Right: Advanced Fill Mode settings tab 

Common Settings

Bi-directional Fill

When enabled, the laser will engrave in a side-to-side sweeping
motion with the laser on and engraving in both directions. 

When disabled, the laser will engrave while traveling in one
direction, then return to the start of the next line without
engraving the return pass. Depending on the type of laser,
enabling this can save significant time on long engraving jobs.

Bi-directional fill

Uni-directional fill

Cross-Hatch

When enabled, the laser will run a second engraving pass 90
degrees rotated from the first, to ensure a consistent and
thorough fill.

Overscanning

This switch is not available for DSP controllers or Galvo lasers.
DSP controllers handle Overscanning automatically, while Galvo
lasers compensate for extra burning at edges with Delay
settings.

When enabled, adds extra moves to the beginning and end of
each line to give the laser time to speed up before firing, and
slow down afterward. Overscanning distance is calculated as a
percentage of Speed.

When Overscanning is not used or not set correctly, engraved
jobs appear more burned at the edges and lighter in the middle,
due to the laser slowing down to change scanning direction,
while firing. 

LightBurn can compensate for this by running the laser head
outside the boundaries of the engraving, but with the laser off.
This maintains an even speed on the engraving itself to provide a
consistent engrave. You need a little more space on either side of
the engraving to accommodate this Overscanning. 

If Overscanning is enabled on a GCode laser and there isn't
enough room at the edge of the job to accommodate the extra
travel distance, you may see LightBurn's Cut May Be Out Of
Bounds error, or your laser's controller may return an ALARM:2
error.

To correct the error, reduce Speed or Overscanning distance, or
move your graphics in toward the center of your Workspace, if
you are using Absolute Coordinates positioning. If you are using 
Current Position or User Origin to set a custom Origin, set it
closer to the center of your laser's work area.

Bi-directional vs. Uni-directional Fill Comparison

Cross-Hatch Demonstration

Note

Excessive Overscanning: GCode
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DSP controllers handle Overscanning in hardware, but the Speed
value you enter affects the amount of distance required. If a job
on a DSP laser requires Overscanning and there isn't enough
room at the edge of the job to accommodate it, your DSP
controller may return the Not Enough Extend Space error.

To correct the error, reduce Speed or move your graphics in
toward the center of your Workspace, if you are using Absolute
Coordinates positioning. If you are using Current Position or 
User Origin to set a custom Origin, set it closer to the center of
your laser's work area.

The extra Overscanning movements are indicated in red. Toggle on 
Show traversal moves in the Preview window to see these

movements.

Line Interval

Controls the spacing between scanned lines, and indirectly
controls Lines per Inch. 

Lower Line Interval values lead to a greater density of lines. The
ideal Line Interval will produce lines that just touch, without
overlapping. 

Increasing Line Interval to the maximum amount that doesn't
leave gaps between lines will lead to reduced runtimes for your
projects, with no loss in quality, but you may also need to
increase Power to achieve dark engravings.

Use the Interval Test or Material Test to find the optimal Line
Interval for your laser and material.

Lines Per Inch

A different, often more intuitive way of controlling the Line
Interval, or spacing between rows.

Scan Angle

Scan Angle defaults to 0, meaning the laser will scan back and
forth horizontally across the image, progressing from the bottom
of the image to the top. If you set this to 180, the laser will scan

the image from top to bottom. Setting this to 90 will scan the
laser vertically over the image, progressing from left to right.

If you have a DSP controller, we advise only using scan angles
that are a multiple of 90 degrees. Horizontal and Vertical
scanning is supported natively by the hardware, and it will
automatically handle Overscanning beyond the sides of the
image to get the head to full speed before engraving starts.
Scanning at non-90 degree angles is "emulated" using normal
cutting moves. It works, but it's mostly useful as a style option,
and not recommended for general use.

Number of Passes

How many times the laser will repeat the shapes on this layer.
Sometimes, when cutting thick material, trying to engrave very
deep, or using a lower power laser, more than one pass may be
necessary.

Z Offset

If you have Z movement enabled, and your controller supports it,
you can use the Z offset setting to move the laser head closer to
the material (inward) or farther away from it (outward). Positive
values move the Z Axis inward, and negative values move it
outward. 

Focusing deeper into the material can sometimes help to cut
thicker material, and lifting the laser away from the material can
produce a thicker line.

Z moves have the potential to physically damage your laser by
crashing the head into the material.

If your system uses auto-focus, you may not be able to push the
focus point lower, because most systems treat the auto-focus
height as the lowest possible height (Z limit) to avoid crashing
the laser head.

Z step per Pass

When doing more than a single pass over a shape, the Z step per
pass setting allows you to tell LightBurn to raise or lower the
laser with each pass by the same amount. 

By allowing you to shift the focus point deeper with each pass,
this is often useful for cutting thick materials or achieving deep
engravings, 

Fill Grouping

These options control which shapes are engraved at the same
time by the laser. If you run your laser fast, or your laser
accelerates slowly, it is often most efficient to scan things all at
once, so the laser spends most of its time moving at the speed
you've chosen, and less time changing direction. If you are
engraving slowly, your laser accelerates fast, or the design
contains a lot of blank space, it can be more efficient to fill
clusters of close shapes, or to fill the shapes one by one. 

Excessive Overscanning: DSP

Overscanning Demonstration

Optimizing Line Interval

DSP Scan Angle Warning

Warning for Z Moves
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If you aren't sure, try different options and use Preview to
estimate the time.

Fill all shapes at once: the default, this setting means that
everything on this layer will be filled at the same time,
sweeping back and forth across the whole job. If you are
running the laser fast (300 mm/sec or more) this is usually the
most efficient option, with some exceptions.

Fill groups together: this setting will fill all shapes in a Group
at the same time.

Fill shapes individually: this setting fills all shapes one by
one.

Advanced settings

Under the Advanced tab you'll find several less frequently-used
options. Many of the options presented here are available only
for particular types of lasers.

The Advanced tab is not available if you're using a Galvo laser.
See Galvo-Specific Cut Settings for information on advanced
settings for Galvo lasers.

Ramp Length

Use this setting to slope the sides of an engraving by varying the
laser power. The ramp length controls how far from the design
the slope will extend.

This setting is useful if you create rubber stamps, particularly if
the designs have thin regions that need extra support. 

Enable Ramp Outer Edge to slope the outer sides of an
engraving, and not just the inner sides (it's usually best to leave
this setting disabled for stamp-making).

On a DSP controller, the Ramp varies the laser power from Min
Power to Max Power, so you must set these differently to get a
ramped side. Typically, you should set Min Power to be just
above the firing threshold of your laser.

Flood Fill

Flood Fill calculates an engraving path that attempts to reduce
or eliminate travel moves across blank space. It's useful for
engraving things like large, empty rectangles, where the blank
area in the middle would consume most of the time spent. 

For Galvo lasers, Flood Fill is presented in the Common settings
tab.

Flood Fill is very sensitive to machine tuning and backlash, and
can cause gaps in your engraving if the design is too complex
and/or your machine is not set up optimally. Use it sparingly, and
use Preview to see how the option will engrave your design, so
you aren't surprised by the path it takes.

Override PWM Frequency

If you have an RF Excited tube, this setting allows you to control
the PWM frequency of the pulses sent to the laser, and can
change the edge finish on certain materials.

This setting is only available for lasers with Ruida controllers.

Enable PPI

The PPI setting (Pulses Per Inch) lets you tell the laser to send an
exact number of pulses per inch of travel, instead of varying the
beam power directly. This is useful for delicate materials like
paper, and is similar to using Perforation Mode, but is handled by
the hardware itself.

This setting is only available for lasers with Trocen controllers.

U Offset

Enter a distance here to set a per-layer U Axis offset. To use this
setting, your laser must support U Axis control, and you must
enable the U Axis in Device Settings.

This setting is only available for lasers with Ruida controllers.

Additional Options

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.
Select an option below to learn more about different groups of
settings. 
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Main /
Share
Settings

Settings
shared
by
almost
all types
of lasers
and
Layer
Modes,
including
critical
settings
like 
Speed
and 
Power.

Line
Mode

Tells
your
laser to
trace a
path
along
the
outlines
of
geometry
in your
project.

Fill
Mode

Tells
your
laser to
etch or
engrave
parallel
lines
inside
the
bounds
of
closed
shapes
in your
project.

Offset
Fill
Mode

Tells your
laser to
fill closed
shapes
with lines
that
follow
the
contour
of the
outer
shape.

Image
Mode

Works
similarly
to Fill
Mode,
but
applies
additional
special
settings
to
adjust
output
based
on the
pixels in
your
image.

Galvo-
Specific
Settings

Special
settings
that are
available
for
users
with
Galvo
style
lasers
only.

Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers
in your
project.

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can
reset to
at any
time.

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control
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OFFSET FILL MODE

Offset Fill mode works similarly to Fill Mode, but instead of
telling your laser to scan parallel lines within the boundaries of a 
vector graphic, it tells your laser to etch lines that follow the
contour of the shape.

As with both Line and Fill Mode, Speed and Power control the
depth and darkness of the etch, and, as with Fill Mode, the Line
Interval setting controls the spacing of the lines. 

Offset Fill is intended for designs with a lot of space in between
graphics, to cut down on the amount of travel time necessary to
fill large, hollow shapes. If that description does not apply to
your graphics, it's best to use Fill instead of Offset Fill. 

Offset Fill is very computationally expensive, and the more
complex the design, or the smaller the Line Interval set, the
more potential there is for the computation to cause LightBurn
to hang. Sometimes graphics with stray nodes or unusual paths
can confuse the calculation interminably.

Offset Fill Mode Settings

There are several specialized options available in the Cut Settings
Editor for layers set to Offset Fill Mode, split into two tabs, 
Common and Advanced.

See Main / Shared Settings for information on applying essential
settings like Speed and Power.

See Additional Options for information on specialized settings
not covered on this page.

Click any option in the images below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Many of the settings presented in the images below are available
for users with specific kinds of lasers, but most are shared
between all types of lasers. 

Left: Common Offset Fill Mode settings tab
Right: Advanced Offset Fill Mode settings tab 

Common Settings

Bi-directional fill, Cross-Hatch, Overscanning, and Scan Angle are
presented in this tab, but are grayed out and unavailable for use
with layers set to Offset Fill Mode. To use these settings, set the
layer to Fill Mode.

Line Interval

Controls the spacing between lines, and indirectly controls Lines
per Inch. 

Lower Line Interval values lead to a greater density of lines. The
ideal Line Interval will produce lines that just touch, without
overlapping. 

Increasing Line Interval to the maximum amount that doesn't
leave gaps between lines will lead to reduced runtimes for your
projects, with no loss in quality, but you may also need to
increase Power to achieve dark engravings.

Use the Interval Test or Material Test to find the optimal Line
Interval for your laser and material.

Lines Per Inch

A different, often more intuitive way of controlling the Line
Interval, or spacing between rows.

Number of Passes

How many times the laser will repeat the shapes on this layer.
Sometimes, when cutting thick material, trying to engrave very
deep, or using a lower power laser, more than one pass may be
necessary.

Offset Fill Computation Time

If you have two shapes set to the same layer, and one is
inside of the other, the area between the two outlines
will be filled.

Note

Optimizing Line Interval
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Z Offset

If you have Z movement enabled, and your controller supports it,
you can use the Z offset setting to move the laser head closer to
the material (inward) or farther away from it (outward). Positive
values move the Z Axis inward, and negative values move it
outward. 

Focusing deeper into the material can sometimes help to cut
thicker material, and lifting the laser away from the material can
produce a thicker line.

Z moves have the potential to physically damage your laser by
crashing the head into the material.

If your system uses auto-focus, you may not be able to push the
focus point lower, because most systems treat the auto-focus
height as the lowest possible height (Z limit) to avoid crashing
the laser head.

Z step per Pass

When doing more than a single pass over a shape, the Z step per
pass setting allows you to tell LightBurn to raise or lower the
laser with each pass by the same amount. 

By allowing you to shift the focus point deeper with each pass,
this is often useful for cutting thick materials or achieving deep
engravings, 

Fill Grouping

These options control which shapes are engraved at the same
time by the laser. If you run your laser fast, or your laser
accelerates slowly, it is often most efficient to scan things all at
once, so the laser spends most of its time moving at the speed
you've chosen, and less time changing direction. If you are
engraving slowly, your laser accelerates fast, or the design
contains a lot of blank space, it can be more efficient to fill
clusters of close shapes, or to fill the shapes one by one. 

If you aren't sure, try different options and use Preview to
estimate the time.

Fill all shapes at once: the default, this setting means that
everything on this layer will be filled at the same time,
sweeping back and forth across the whole job. If you are
running the laser fast (300 mm/sec or more) this is usually the
most efficient option, with some exceptions.

Fill groups together: this setting will fill all shapes in a Group
at the same time.

Fill shapes individually: this setting fills all shapes one by
one.

Advanced Settings

Under the Advanced tab you'll find a few less frequently-used
options. The options presented here are available only for
particular types of lasers.

Ramp Length and Flood Fill are presented in this tab, but are
grayed out and unavailable for use with layers set to Offset Fill
Mode. To use these settings, set the layer to Fill Mode.

The Advanced tab is not available if you're using a Galvo laser.
See Galvo-Specific Cut Settings for information on advanced
settings for Galvo lasers.

Override PWM Frequency

If you have an RF Excited tube, this setting allows you to control
the PWM frequency of the pulses sent to the laser, and can
change the edge finish on certain materials.

This setting is only available for lasers with Ruida controllers.

Enable PPI

The PPI setting (Pulses Per Inch) lets you tell the laser to send an
exact number of pulses per inch of travel, instead of varying the
beam power directly. This is useful for delicate materials like
paper, and is similar to using Perforation Mode, but is handled by
the hardware itself.

This setting is only available for lasers with Trocen controllers.

U Offset

Enter a distance here to set a per-layer U Axis offset. To use this
setting, your laser must support U Axis control, and you must
enable the U Axis in Device Settings.

This setting is only available for lasers with Ruida controllers.

Additional Options

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.
Select an option below to learn more about different groups of
settings. 

Warning for Z Moves
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Main /
Share
Settings

Settings
shared
by
almost
all types
of lasers
and
Layer
Modes,
including
critical
settings
like 
Speed
and 
Power.

Line
Mode

Tells
your
laser to
trace a
path
along
the
outlines
of
geometry
in your
project.

Fill
Mode

Tells
your
laser to
etch or
engrave
parallel
lines
inside
the
bounds
of
closed
shapes
in your
project.

Offset
Fill
Mode

Tells your
laser to
fill closed
shapes
with lines
that
follow
the
contour
of the
outer
shape.

Image
Mode

Works
similarly
to Fill
Mode,
but
applies
additional
special
settings
to
adjust
output
based
on the
pixels in
your
image.

Galvo-
Specific
Settings

Special
settings
that are
available
for
users
with
Galvo
style
lasers
only.

Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers
in your
project.

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can
reset to
at any
time.

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.
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IMAGE MODE

Image Mode is a special engraving mode for images, which
works similarly to Fill Mode, but allows you to select an additional
image processing mode that affects the appearance of the
engraving.

Speed, Power, and Line Interval are all crucial settings for 
achieving great image engravings, but the appropriate settings
are heavily dependent on your laser and material.

Several additional settings that affect the quality of the engraving
are applied on a per-image basis, using the Adjust Image tool or 
Shape Properties Window.

Image Mode Settings

There are several specialized options available in the Cut Settings
Editor for layers set to Image Mode. All settings are located in a
single Image Settings tab.

See Main / Shared Settings for information on applying essential
settings like Speed and Power.

See Additional Options for information on specialized settings
not covered on this page.

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Some of the settings presented in the images below are available
for users with specific kinds of lasers, but most are shared
between all types of lasers. 

Image Mode settings for a GCode-based laser

Bi-directional Scanning

When enabled, the laser will engrave in a side-to-side sweeping
motion with the laser on and engraving in both directions. 

When disabled, the laser will engrave while traveling in one
direction, then return to the start of the next line without
engraving the return pass. Depending on the type of laser,
enabling this can save significant time on long engraving jobs.Note
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Bi-directional scanning

Uni-directional scanning

Negative Image

This will invert your image during engraving. Light becomes
dark, and dark becomes light. This is useful for engraving slate or
glass, where burned areas become lighter.

Use this in conjunction with the Invert switch in the Preview
window to see how your engraving will look on dark surfaces.

Overscanning

This switch is not available for DSP controllers or Galvo lasers.
DSP controllers handle Overscanning automatically, while Galvo
lasers compensate for extra burning at edges with Delay
settings.

When enabled, adds extra moves to the beginning and end of
each line to give the laser time to speed up before firing, and
slow down afterward. Overscanning distance is calculated as a
percentage of Speed.

When Overscanning is not used or not set correctly, engraved
jobs appear more burned at the edges and lighter in the middle,
due to the laser slowing down to change scanning direction,
while firing. 

LightBurn can compensate for this by running the laser head
outside the boundaries of the engraving, but with the laser off.
This maintains an even speed on the engraving itself to provide a
consistent engrave. You need a little more space on either side of
the engraving to accommodate this Overscanning. 

If Overscanning is enabled on a GCode laser and there isn't
enough room at the edge of the job to accommodate the extra
travel distance, you may see LightBurn's Cut May Be Out Of
Bounds error, or your laser's controller may return an ALARM:2
error.

To correct the error, reduce Speed or Overscanning distance, or
move your graphics in toward the center of your Workspace, if
you are using Absolute Coordinates positioning. If you are using 
Current Position or User Origin to set a custom Origin, set it
closer to the center of your laser's work area.

DSP controllers handle Overscanning in hardware, but the Speed
value you enter affects the amount of distance required. If a job
on a DSP laser requires Overscanning and there isn't enough
room at the edge of the job to accommodate it, your DSP
controller may return the Not Enough Extend Space error.

To correct the error, reduce Speed or move your graphics in
toward the center of your Workspace, if you are using Absolute
Coordinates positioning. If you are using Current Position or 
User Origin to set a custom Origin, set it closer to the center of
your laser's work area.

The extra Overscanning movements are indicated in red. Toggle on 
Show traversal moves in the Preview window to see these

movements.

Line Interval

Controls the spacing between scanned rows, and indirectly
controls DPI.

Bi-directional vs. Uni-directional Scanning Comparison

Tip

Note

Excessive Overscanning: GCode

Excessive Overscanning: DSP

Overscanning Demonstration
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Lower Line Interval values lead to a greater density of lines. The
ideal Line Interval will produce lines that just touch, without
overlapping. 

Increasing Line Interval to the maximum amount that doesn't
leave gaps between lines will lead to reduced runtimes for your
projects, with no loss in quality, but you may also need to
increase Power to achieve dark engravings.

Use the Interval Test or Material Test to find the optimal Line
Interval for your laser and material.

DPI (Dots Per Inch)

Controls the pixel density of the output — this is another way of
representing Line Interval. DPI is 25.4 / Line Interval.

Dot Width Correction

Dot Width Correction compensates for the thickness of the
laser's beam by shortening the length of engraved scan lines.
The ideal Dot Width Correction value is about half the total
thickness of the laser's beam. Due to varying affects of power
output on different materials, this ideal value can vary depending
on the material you're working with. 

The number should always be smaller than whatever you’re
using as your interval setting. The valid range is from 0 to your 
Line Interval value.

Scan Angle

Scan Angle defaults to 0, meaning the laser will scan back and
forth horizontally across the image, progressing from the bottom
of the image to the top. If you set this to 180, the laser will scan
the image from top to bottom. Setting this to 90 will scan the
laser vertically over the image, progressing from left to right.

If you have a DSP controller, we advise only using scan angles
that are a multiple of 90 degrees. Horizontal and Vertical
scanning is supported natively by the hardware, and it will
automatically handle Overscanning beyond the sides of the
image to get the head to full speed before engraving starts.
Scanning at non-90 degree angles is "emulated" using normal
cutting moves. It works, but it's mostly useful as a style option,
and not recommended for general use.

Z Offset

If you have Z movement enabled, and your controller supports it,
you can use the Z offset setting to move the laser head closer to
the material (inward) or farther away from it (outward). Positive
values move the Z Axis inward, and negative values move it
outward. 

Focusing deeper into the material can sometimes help to cut
thicker material, and lifting the laser away from the material can
produce a thicker line.

Z moves have the potential to physically damage your laser by
crashing the head into the material.

If your system uses auto-focus, you may not be able to push the
focus point lower, because most systems treat the auto-focus
height as the lowest possible height (Z limit) to avoid crashing
the laser head.

Cells per Inch

Number of Halftone shading dots to compute per inch. Only
enabled when the Halftone Image Mode is selected.

Halftone Angle

Angle of the Halftone shading pattern. Only enabled when the
Halftone Image Mode is selected.

Number of Passes

How many times the laser will repeat the shapes on this layer.
Sometimes, when cutting thick material, trying to engrave very
deep, or using a lower power laser, more than one pass may be
necessary.

Ramp Length

Use this setting to slope the sides of an engraving by varying the
laser power. The ramp length controls how far from the design
the slope will extend.

This setting is useful if you create rubber stamps, particularly if
the designs have thin regions that need extra support. 

This setting is only available if you have Threshold Image Mode
selected.

Optimizing Line Interval DSP Scan Angle Warning

Warning for Z Moves
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On a DSP controller, the Ramp varies the laser power from Min
Power to Max Power, so you must set these differently to get a
ramped side. Typically, you should set Min Power to be just
above the firing threshold of your laser.

Pass-Through

When working with images that have been pre-processed for
laser engraving, enable this setting to engrave the image as-is,
rather than resampling using the Image Modes described below. 
Line Interval/DPI will be directly tied to the size of the image.

Image Mode

The Image Mode setting controls how LightBurn processes your
image. Below you can see a description of each Image Mode in
LightBurn, along with an example of how that mode changes the
look of the example image. Click on the image previews to see a
larger version.

Threshold

A simple on / off switch if the image is dark / bright at a given location. This should only be used for images that are two-color black/white to begin with, such as an
image you dithered outside of LightBurn. Don't use this mode for grayscale or color images.

Note
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When Previewing a Grayscale engraving, be sure to enable 
Shade according to power, otherwise you will see a completely
black Preview since, unlike other modes, Grayscale scans every
portion of the image, just at varying levels of laser power.

Fill Grouping

These options control which shapes are engraved at the same
time by the laser. If you run your laser fast, or your laser
accelerates slowly, it is often most efficient to scan things all at
once, so the laser spends most of its time moving at the speed
you've chosen, and less time changing direction. If you are
engraving slowly, your laser accelerates fast, or the design
contains a lot of blank space, it can be more efficient to fill
clusters of close shapes, or to fill the shapes one by one. 

If you aren't sure, try different options and use Preview to
estimate the time.

Fill all shapes at once: the default, this setting means that
everything on this layer will be filled at the same time,
sweeping back and forth across the whole job. If you are
running the laser fast (300 mm/sec or more) this is usually the
most efficient option, with some exceptions.

Fill groups together: this setting will fill all shapes in a Group
at the same time.

Fill shapes individually: this setting fills all shapes one by
one.

Override PWM Frequency

If you have an RF Excited tube, this setting allows you to control
the PWM frequency of the pulses sent to the laser, and can
change the edge finish on certain materials.

This setting is only available for lasers with Ruida controllers.

U Offset

Enter a distance here to set a per-layer U Axis offset. To use this
setting, your laser must support U Axis control, and you must
enable the U Axis in Device Settings.

This setting is only available for lasers with Ruida controllers.

Additional Options

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.
Select an option below to learn more about different groups of
settings. 
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Layer
Modes,
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Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers
in your
project.

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can
reset to
at any
time.

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control

GALVO-SPECIFIC CUT SETTINGS

Several settings are only available in the Cut Settings Editor when
working with Galvo lasers with EZCAD2 or BSL control boards.

Among these settings, some options are only available for
specific types of Galvo lasers, or specific Layer Modes.

See Main / Shared Settings for information on applying essential
settings like Speed and Power.

See Additional Options for information on specialized settings
not covered on this page.

Main Settings

For Galvo lasers, the following settings are available in the top
portion of the Cut Settings Editor, along with other essential
settings shared by all types of layers.

Frequency

The Frequency, in kHz, at which the laser will pulse during
operation. Relatively low Frequencies yield fewer pulses at
greater power output with each pulse, while relatively high
Frequencies yield more pulses at lower power output with each
pulse.

Frequencies in the mid-range of your laser's capability will often
produce the most even markings, but the exact effect of given
Frequency values varies greatly depending on your laser,
material, and other settings, such as Power, Speed, and Line
Interval.

Use the Material Test to try out different combinations of
Frequency, Q-Pulse Width, and other settings on a given
material.

Q-Pulse Width

This setting is available for MOPA Fiber and UV Galvo lasers only.

Q-Pulse Width determines the duration of each pulse of your
laser, in nanoseconds. As with Frequency, the exact effect of
given Q Pulse Widths varies greatly depending on your laser,
material, and other settings, such as Power, Speed, and Line
Interval. 

Note

Note

Tip

Note
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For UV lasers, the Power setting is grayed out because power
output is controlled solely by adjusting Frequency and Q-Pulse
Width.

Max power is achieved by applying the correct combination of
Frequency and Q-Pulse — your laser may have come with a chart
that shows expected power outputs at different combinations. In
general, you will see power increase as you increase Frequency
and Q-Pulse values, a leveling off of power output in the middle-
to-high values, and then a tailing off with very high values.

Global Passes

Enable this setting to repeat all Sub-Layers in the layer, in
sequence, the specified number of times.

Specialized Settings

For Galvo lasers, the following settings are available in the
bottom half of the Cut Settings Editor. 

Auto-Rotate and Angle Increment are only available for layers
set to Fill Mode. 

Dot Width Adjust is available for layers set to Fill or Image
Mode.

3D Sliced Image Mode and its related settings are only
available for layers set to Image Mode.

Wobble

Because Galvo lasers are not optimized for cutting, it can be hard
to apply enough power to a given area while using Line Mode to
cut through material. 

Enable Wobble to tell the laser to trace small circles along the
path of the line, creating a thicker line and forcing the beam to
spend longer in each section of the line. The Step value refers to
how far apart the circles are, and the Size value refers to the
diameter of the circles (in millimeters).

Auto-Rotate

Enable to adjust the Scan Angle by the Angle Increment with
each run of a given job, such as when you enable Run
Continuously, specify a Repeat count in the Galvo Framing
window, or manually Start a job multiple times.

Click Reset Count to reset to the original Scan Angle.

Angle Increment

For layers set to multiple Passes or Global Passes, adjusts the 
Scan Angle by this increment with each successive pass.

Dot Width Adjust

Dot Width Correction compensates for the thickness of the
laser's beam by shortening the length of engraved scan lines.
The ideal Dot Width Correction value is about half the total
thickness of the laser's beam. Due to varying affects of power
output on different materials, this ideal value can vary depending
on the material you're working with. 

The number should always be smaller than whatever you’re
using as your interval setting. The valid range is from 0 to your 
Line Interval value.

3D Sliced Image Mode

Note for UV Lasers

• 

• 

• 
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3D Sliced is a special Image Mode for Galvo lasers only, which
uses multiple passes to engrave a design one layer at a time. This
mode is intended for use with depth maps – sometimes called
height maps — which are specially designed grayscale images in
which a pixel's brightness represents depth, rather than shading.

Lighter pixels are engraved with fewer passes than darker pixels,
resulting in a deeper engrave in darker areas of the image.
Enabling Negative Image inverts brightness, leading to lighter
areas engraving deeper than darker areas.

See 3D Sliced Engravings for more detailed instructions on
creating and working with grayscale depth maps.

Enable cleanup pass

Toggle on Enable cleanup pass to add a Cleanup Sub-Layer,
where you can specify how often automatic cleanup passes
should run, and adjust the settings for those passes.

Cleanup passes are typically run with a tighter Line Interval,
higher Frequency, and lower Max Power than the main
engraving passes, and are used to clear debris and produce a
better finish.

Clean after # of passes

Specify the number of passes to run in between Cleanup passes.

Clean whole image

Enable Clean whole image to run Cleanup passes over the
entire image, rather than recent passes only.

Timings

Click Show Timings to adjust per-layer timing settings. Click 
Hide Timings to return to the main tab of the Cut Settings
Editor.

Override Default Timings

Enable Override Default Timings to set custom timings on a
per-layer basis. If you leave it disabled, your laser will instead use
the timings established in your Device Settings.

Jump Settings control how the laser moves between cuts. Each
jump causes the mirror to shake, with higher speeds and
longer distances increasing the shaking. If you have wobbly
lines at the start of a marking move, you may need to increase
the delay and/or reduce the speed of jumps.

Delay Settings control the delay between starting (or stopping)
mirror movement and firing the laser. Laser On/Off TC and 
End TC control the delays for the start and end points of a
path. Polygon TC controls the delays for other corners within
a path.

• 

• 

Setting Description

Jump Speed The speed at which the galvo
mirrors move between cuts.
Higher values will make your job
run faster at the cost of increased
vibration for the mirrors.

Min Jump Delay The minimum time the laser will
wait to allow the galvo mirrors to
stop shaking.

Max Jump Delay The maximum time the laser will
wait to allow the galvo mirrors to
stop shaking.

Jump Distance
Limit

Any jump above this limit will use
the Max Jump Delay setting
above. Jumps below this limit will
use a delay value between the
minimum and maximum settings.

Laser On TC Microseconds the laser will wait to
fire after the mirrors begin to
move. Too high a value will leave
gaps, while too low a value may
cause excessive burning at the
start of a cut.

Laser Off TC Microseconds to delay turning off
the laser at the end of a marking
move. Too high a value may cause
excessive burning at the end of a
cut, while too low a value may
cause gaps.
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Pause Before

The number of milliseconds to pause before starting a Sub-Layer.
Click the Show Timings button to show this setting or Hide
Timings to hide it.

Pause After

The number of milliseconds to pause after finishing a Sub-Layer.
Click the Show Timings button to show this setting or Hide
Timings to hide it.

Additional Options

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.
Select an option below to learn more about different groups of
settings. 

Main /
Share
Settings

Settings
shared
by
almost
all types
of lasers
and
Layer
Modes,
including
critical
settings
like 
Speed
and 
Power.

Line
Mode

Tells
your
laser to
trace a
path
along
the
outlines
of
geometry
in your
project.

Fill
Mode

Tells
your
laser to
etch or
engrave
parallel
lines
inside
the
bounds
of
closed
shapes
in your
project.

Offset
Fill
Mode

Tells your
laser to
fill closed
shapes
with lines
that
follow
the
contour
of the
outer
shape.

Image
Mode

Works
similarly
to Fill
Mode,
but
applies
additional
special
settings
to
adjust
output
based
on the
pixels in
your
image.

Galvo-
Specific
Settings

Special
settings
that are
available
for
users
with
Galvo
style
lasers
only.

Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers
in your
project.

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can
reset to
at any
time.

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

Setting Description

End TC Microseconds to pause the laser's
movement after completing a cut.

Polygon TC Microseconds the galvo head will
pause when turning corners. Too
long a delay may cause excessive
burning, while too short a delay
can cause rounded or cut-off
corners.

Note
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laser-control
SUB-LAYERS

Sub-Layers allow you to assign multiple cut or engraving
settings to the same layer and geometry. This can enable the use
of single-setup etching and cleanup passes for Galvo lasers, as
well as staggered engraving, cutting, and other operations for
more complex jobs, regardless of machine type.

All settings of individual Sub-Layers are independently editable
and presented as tabs in the Cut Settings Editor. Click a tab to
access and adjust that Sub-Layer's settings.

You may have up to 11 Sub-Layers per layer.

See Main / Shared Settings for information on applying essential
settings like Speed and Power.

See Additional Options for information on specialized settings
not covered on this page.

Creating and Managing Sub-Layers

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Adding 

Click the plus icon to create a new Sub-Layer, with the Default
Settings of the parent layer.

Duplicating 

Click the duplicate icon to create a new Sub-Layer, with identical
settings to the currently-open Sub-Layer.

Deleting 

Click the minus icon to delete the currently-open Sub-Layer. This
option is not available if you have only one Sub-Layer.

Enabling and Disabling

Toggle the Output switch on or off to determine whether a given
Sub-Layer is included in the output when you Preview, Start, 
Send, or save a project in machine-specific format.

The universal Output switch at the top of the window determines
whether an entire layer, including every Sub-Layer, is output.

Rearranging Sub-Layers

Click and drag a Sub-Layer's tab to change the order in which it
will be output. Sub-Layers are output in sequence, starting from
left to right. 

Note
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Naming Sub-Layers

To keep track of the purpose of individual Sub-Layers, you can
give them unique names in the Sub-Layer Name field.

Sub-Layers in the Cuts / Layers Window

In the Cuts / Layers Window layers with Sub-Layers display their
mode as Multi, and you may not edit the modes of individual
Sub-Layers through that window. as seen below. 

Click an individual Sub-Layer tab in the Cuts / Layers Window to
edit a limited number of settings. 

You can reorganize, as you can within the full Cut Settings Editor
in the quick settings, by clicking and dragging. Sub-Layers are
output in sequence, starting from left to right.

In older versions of LightBurn, Fill+Line mode allowed primitive
Sub-Layer use to draw an outline around an engraved shape.
This has since been superseded. The legacy behavior can be
approximated with Sub-Layers, one for Fill and a second one for
Line with the same base motion settings.

LightBurn will automatically convert pre-1.2 project files
with Fill+Line settings to Sub-Layers in 1.2, including
Fill+Line behavior. This produces two layers, one with your
legacy Fill settings, and a subsequent layer with Line
settings, to be run afterwards. Going backwards from
current project files to pre-1.2 LightBurn is likely to result in
breakages involving Sub-Layers due to how complex the
changes are.

Additional Options

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.
Select an option below to learn more about different groups of
settings. 

Main /
Share
Settings

Settings
shared
by
almost
all types
of lasers
and
Layer
Modes,
including
critical
settings
like 
Speed
and 
Power.

Line
Mode

Tells
your
laser to
trace a
path
along
the
outlines
of
geometry
in your
project.

Fill
Mode

Tells
your
laser to
etch or
engrave
parallel
lines
inside
the
bounds
of
closed
shapes
in your
project.

Offset
Fill
Mode

Tells your
laser to
fill closed
shapes
with lines
that
follow
the
contour
of the
outer
shape.

Image
Mode

Works
similarly
to Fill
Mode,
but
applies
additional
special
settings
to
adjust
output
based
on the
pixels in
your
image.

Galvo-
Specific
Settings

Special
settings
that are
available
for
users
with
Galvo
style
lasers
only.

Legacy Behavior: Fill + Line

Danger
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Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers
in your
project.

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can
reset to
at any
time.

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

cut-settings-editor laser-control

DEFAULT LAYER SETTINGS

Cut settings are normally pre-filled with the last settings used for
a given layer, but LightBurn has an option to automatically reset
to either universal settings or your own customized defaults each
time you start a new project. 

You can also reload custom or universal defaults at any time in
the Cut Settings Editor.

Material Libraries are also available for saving and reusing cut
settings, and are recommended for users who need to store and
reapply many distinct, frequently-used settings.

See Main / Shared Settings for information on applying essential
settings like Speed and Power.

See Additional Options for information on specialized settings
not covered on this page.

Setting Defaults

At the bottom of the Cut Settings Editor, there are three buttons
to manage default layer settings.

Make Default: remember the settings for this palette color.
Whatever your current settings are will become the default for
this color. Default settings are saved separately for each device
profile.

Reset to Default: reset the layer to the default settings. Hold 
Shift  while clicking Reset to Default to reset to LightBurn's

universal defaults.

Make Default for All: your current layer settings will become the
default for all palette colors.

Note

Use the Material Library to save a wider range of
settings

Note

⇧
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When entering Speed values recommended by your laser's
manufacturer or other LightBurn users, make sure to use the 
same units of distance and time as those from the recommendation,
or to convert the values to your preferred units.

A given number of millimeters per second is much faster than
that same number in millimeters per minute. Mixing up units
can lead to reduction in power output due to unexpectedly high
speeds, or excessive power output — and even fire — due to
unexpectedly slow speeds. 

Change your displayed units in the Units and Grids tab of the 
Settings window. LightBurn automatically converts any existing
values when you switch between units.

LightBurn's Universal Defaults

The universal default layer is set to Line Mode, at 6000 mm/min
(100 mm/sec) speed and 20% power, with no advanced options
enabled. 

Layers switched to Fill, Offset Fill, or Image mode after having
been restored to default will be set to the same speed and power
as above, a Line Interval of .100, and to Fill all shapes at once.
The default dithering mode of Image layers is Stucki.

Load Default Layer Settings on New or Restart

To automatically load defaults instead, enable Load default
layer settings on new or restart in the Editor Settings tab of
the Settings window.

Additional Options

The settings presented in the Cut Settings Editor depend on the
selected Layer Mode and the type of laser you're working with.
Select an option below to learn more about different groups of
settings. 

Main /
Share
Settings

Settings
shared
by
almost
all types
of lasers
and
Layer
Modes,
including
critical
settings
like 
Speed
and 
Power.

Line
Mode

Tells
your
laser to
trace a
path
along
the
outlines
of
geometry
in your
project.

Fill
Mode

Tells
your
laser to
etch or
engrave
parallel
lines
inside
the
bounds
of
closed
shapes
in your
project.

Offset
Fill
Mode

Tells your
laser to
fill closed
shapes
with lines
that
follow
the
contour
of the
outer
shape.

Image
Mode

Works
similarly
to Fill
Mode,
but
applies
additional
special
settings
to
adjust
output
based
on the
pixels in
your
image.

Galvo-
Specific
Settings

Special
settings
that are
available
for
users
with
Galvo
style
lasers
only.

Always pay attention to units of distance and time
when entering Speed settings
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Sub-
Layers

A tool for
setting
up and
applying
multiple
cut/
engraving
settings
to the
same
geometry
or layers

Default
Layer
Settings

Built-in
or
custom-
created
settings
stored
on a
per-
layer
basis,
that you
can

Some options in the Cut Settings Editor are hidden if you have 
Beginner Mode enabled.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

cut-settings default-settings laser-control layer-settings

layers reset

Note
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5.5.2 Output and Positioning

Laser Window

The Laser Window is the hub for setting up and selecting a laser,
Framing and Starting jobs, determining job positioning, and
more. 

ACCESSING THE LASER WINDOW

The Laser Window is located in the bottom right corner of
LightBurn by default. If you have closed the Laser Window, go to 
Window → Laser to re-enable it. To restore it and all other
windows to their default positions, go to Window → Reset to
Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

LASER WINDOW OPTIONS AND SETTINGS

The type of laser you have active, and certain options in the 
Settings window, including enabling Beginner Mode, will affect
the way the Laser Window looks.

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Start

Commands your laser to immediately begin running your current
project. 

If you have a Galvo laser, you'll see the Framing window first,
unless you turn off Require framing before start in your Device
Settings.

While your laser is running, you can use your keyboard's Pause

key to Pause the laser and Ctrl + Break  to Stop it. Break  is
typically on the same key as Pause , but more compact
keyboards may not have this key.

Stop

Immediately aborts a currently running job. 

Pause

Halts a running job. Click the Resume button to continue a
paused job.

Send

The Send button, if your laser supports it, transfers the current
job to the laser as a named file, so you can select and run it from
the laser's controller.

When you use Start, the controller begins running the job as
soon as sufficient data has reached the controller. Using Send
instead of Start can sometimes help prevent file corruption
during transfer. 

Hold Shift  while clicking Send to have the laser immediately
start the job after the entire project has been sent. 

The Send option is only available for DSP lasers.

Framing

This section covers Framing behavior for Gantry lasers. If you
have Galvo laser, see Galvo Framing.

Use the two Frame buttons to preview the position of the job in
your laser's work area, by commanding the laser to trace a path
around the area where your project will output. 

The speed at which the laser travels during Framing is
determined by the value set in the Speed field in the Move
Window.

Frame Continuously

Enable Frame Continuously in the Basic Settings tab of Device
Settings to command your laser to run the Framing path
repeatedly, until you tell it to stop. Framing Continuously is often
helpful when adjusting material positioning in your laser's work
area.

Laser on When Framing

Enable Laser on when framing in the Device Settings window to 
Fire the laser during the Framing process, at the Power level set
in the Move Window.

Tip

Note

Pause and Stop from the keyboard

⌃

⇧

Note

Note for Galvo users
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If Laser on when framing is not enabled, you can hold Shift

while pressing Frame to enable the laser during the framing
process.

This changes the default behavior of the laser and can cause the
laser to fire when a user is not expecting it. Enable this setting
with caution, with a very low power level, and only when using a
diode laser.

Bounding Box Frame 

Commands the laser to trace a path defined as the smallest
possible rectangle that will fully contain all graphics you're
sending to the laser.

Rubber Band Frame 

Traces the smallest possible path that fully contains all graphics
in the design you're sending to the laser, as if a rubber band were
stretched around them.

Rubber Band Framing is useful for lining up jobs with irregular
shapes where a box outline doesn't fit well. For example, a long,
thin diagonal shape, or a triangle.

Save Machine Files

This button will change depending on the type of laser you're
using — it may say Save GCode (for GRBL, Smoothieware, or
Marlin controllers), Save RD File (Ruida), Save OUT File
(TopWisdom), or Save UD5 File (Trocen).

All options save your current project as a machine-ready file, in
the appropriate format for your type of laser. You can transfer
this file to your machine to run it without ever having to directly
connect using LightBurn.

These options are also available in the File Menu.

Run Machine Files

Use this option to load and run a file previously saved in the
appropriate format for your type of laser. To use this option,
LightBurn must be directly connected to your laser.

This button will change depending on the type of laser you're
using — it may say Run GCode, Run RD File, Run OUT File, or 
Run UD5 File.

Home

Commands your laser to execute a homing cycle, during which it
moves toward the home position looking for the switches that
activate when it hits the boundary. 

Homing is how your laser locates its 0,0 position, and all
subsequent positioning information is determined relative to
that point.

Do not use this button if your laser does not have homing
switches. If you are unsure, contact your laser's manufacturer. 

Go to Origin

Commands your laser to jog to the position currently set as the 
User Origin.

See Coordinates and Job Origin for more information. 

Start From and Job Origin

These two controls determine where the job is placed on the bed
of your laser.

See Coordinates and Job Origin for more information.

Cut Selected Graphics

This toggle switch tells LightBurn to only send the portion of
your design that is currently selected when you click Start, Send,
or Save Machine File.

See Cut Selected Graphics for more information. 

⇧

Danger

Tip

Warning
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Use Selection Origin

Only available in combination with Cut Selected Graphics, the 
Use Selection Origin button tells LightBurn to calculate origin
relative to selected graphics only, and not the whole design.

See Cut Selected Graphics – Use Selection Origin for more
information. 

Show Last Position

Places a cross-hair cursor in the Workspace at the last reported
location of the laser head. If you jog the laser within LightBurn
using any of the positioning tools, the position will be updated. 

The position does not update live — for example, it will not update
while a job is running. Live updating might encourage some
users to watch the screen rather than their laser — lasers should
never be left unattended while running.

Optimization Settings

This button opens the Optimization Settings window, where
you can adjust various options that control the order in which
your graphics are cut or engraved by the laser.

See Optimization Settings for more information.

Optimize Cut Path

Toggle Optimize Cut Path on or off to enable or disable custom 
Optimization Settings. 

If Optimize Cut Path is disabled, the order will be the order in
which the objects in your project were drawn. 

Devices

Opens the Devices window, where you can create, remove, or
edit device profiles for lasers you want to use with LightBurn. 

Right-clicking the Devices button closes and re-opens the
connection to the currently selected device.

See Devices for more information.

Device Selection Dropdown

If you've created multiple device profiles for multiple lasers,
select the laser you are currently working with the dropdown
menu. 

Serial Port Dropdown

LightBurn will attempt to automatically select the correct serial
port and connect to your laser, but you may need to manually
select it from this dropdown. When connected, the Disconnected
message in the top left corner of the Laser window will change to
Ready. If you are using a GCode-based laser, you will see a
startup message in the Console window.

You may need to right-click the Devices button in the Laser
window to refresh the list of available ports.

If you're having trouble connecting to your laser, see 
Troubleshooting: Connection Problems.

Device Status

The readout in the top left of the Laser Window indicates the
current status of the laser. 

Disconnected indicates that the laser is not connected to
LightBurn.

Ready indicates that the laser is connected to LightBurn and
ready to receive commands. 

Busy indicates that the laser is connected to LightBurn and
actively completing a process. 

The progress bar indicates the percentage of commands that
have been streamed to the laser, along with a time estimate
indicating how long the laser has been streaming, and how
much longer it will continue streaming. These estimates can
be close to the total runtime of the project, but are not
identical.

Framing appears for Galvo lasers only, to indicate that the 
Framing process is active.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control output-and-positioning workflow

• 

• 

• 

• 
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Coordinates and Job Origin

There are a few ways to tell LightBurn where to ouput your
project within the work area of your machine, each available in
the Start From menu in the Laser Window. 

ABSOLUTE COORDINATES

Absolute Coordinates is the simplest option. The grid you see in
the Workspace of LightBurn represents your machine's physical
work area. Anything you place in the LightBurn grid will be
output in the corresponding location in your machine's work
area.

Using absolute positioning requires a laser with homing
switches and a fixed origin. If you have a small diode laser that
does not have homing switches, you will need to manually home
the machine. See: Machines without homing sensors / limit
switches.

In the image below, the two circles placed in the middle of the
LightBurn grid will be cut in the middle of the machine work
area. The green square in the lower left of the image represents
the Job Origin, and the red square in the same place shows the 
Machine Origin. When using Absolute Coordinates these are
always in the same place.

CURRENT POSITION

With Current Position selected, your job outputs relative to the
current position of the laser head when you hit the Start button.

The Job Origin control in the Laser window tells LightBurn how
to orient output relative to the laser head.

In this image, we're starting from the Current Position, with the
Job Origin set to the lower left:

Notice that the green Job Origin indicator has moved. This
represents the position of the laser when you start the job, so the
laser is going to move slightly up and to the right from wherever
it is, cut the two circles, and go back to where it started.

Now imagine that you want to etch this two-circle pattern onto a
coaster or a phone case. Lining it up from the lower left is not
easy. If you change the Job Origin setting to center, you get this
instead:

The job will be centered around the current position of the laser
head. If you position the laser head directly over the center of the
item you want to etch, the output will be centered on the item.

USER ORIGIN

User Origin works almost exactly the same as Current Position,
except that the starting location is programmable. To set a User
Origin, you must first jog your laser to the location you want your
job to start from, then set the origin. 

Some lasers with digital displays, such as those with Ruida
controllers, have an Origin  button which you press to set the
origin. GCode-based systems use the Set Origin button in the 
Move Window in LightBurn to do the same thing. For supported
systems, use Clear Origin to remove and reset a custom-set origin.

Note
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After setting the origin, you are free to jog your laser around its
work area. With User Origin selected as the Start From mode,
the laser will move back to that programmed location and start
the project from there.

Use the Go to Origin button in the Laser Window to command
your laser to travel back to the origin you've set. 

As with Current Position, the Job Origin setting determines how
output will be oriented relative the user-defined origin.

FINISH POSITION

The Finish Position option is only available for GCode-based
controllers. DSP controllers manage this internally.

LightBurn allows you to control where you want the head of the
laser to return after a job is finished. By default, it will return to
0,0, but this is not always optimal for all machines. 

To change your laser's Finish Position, go to the Move Window
and use the arrows to position your laser head wherever you
would like it to return to after the job is finished, then click the 
Set Finish Position button. Your machine will now remember
that spot for future jobs. Finish Position can be adjusted at any
time by repeating the above steps for a new location. This setting
requires that the job is running in Absolute Coords or User
Origin mode. It does not work when using Current Position.

Users with GCode-based lasers can also adjust or disable the
Finish Position in Device Settings. 

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

gantry laser-control output-and-positioning
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Move Window

The Move Window is used primarily for jogging, positioning, and
homing the laser.

ACCESSING THE MOVE WINDOW

By default, the Move Window is docked behind the Cuts / Layers
Window on the upper right side of your screen. Click the Move
tab to bring the Move Window to the front. 

If you have closed the Move Window go to Window → Move to
re-enable it. To restore it and all other windows to their default
positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

MOVE WINDOW OPTIONS AND SETTINGS

The type of laser you have active and certain options in the 
Settings window — including enabling Beginner Mode — will
affect the way the Move Window looks.

Click any option in the image below to jump to more information,
or scroll down for a list of options and descriptions.

Ruida Controller Devices: The Set Origin, Clear Origin, or Set
Finish Position controls will not be displayed as these are
handled by the controller itself. LightBurn will generally show
only controls you can use.

Galvo Devices: none of the functions in the Move Window are
applicable to Galvo lasers, so this window will not be displayed in
your default layout.

GET POSITION

The Get Position button queries the controller for its current
location and displays the current X, Y, Z, and U Axis coordinates.

MOVE TO POSITION

Selecting the Go button will move the laser to the X and Y Axis
coordinates in the Move to Position entry boxes.

SAVED POSITIONS

The Saved Positions drop-down displays a list of previously
stored positions. Use Saved Positions for jogging to known
locations on the work area — for example a specific corner, the
location of your rotary tool, and commonly used jigs. Manage the
contents of this list by clicking the Manage button.

Managing Saved Positions

Add new positions to the Saved Positions list by pressing the Add
New button and entering the desired coordinates.

Activate Z Axis movements by toggling the Enable Z Axis option
and updating the Z Axis coordinate.

Optionally, press the Sort by Name to sort the position list
alphabetically.

Press OK to save the list.

MANUAL MOVEMENT

Move the laser by a specific amount in a given direction through
a process called Jogging.

Move Window Directional Arrows

Jog the laser throughout its work area by clicking any of the
arrow buttons that surround the Home button. Each click will
move the laser by amount entered in the Distance field, at the
rate set in the Speed field.

Tip

Info

1. 

2. 

3. 

4. 
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The Speed settings also control the Framing speed and the
movement speed of the Position Laser tool.

If your laser has a motorized Z Axis, the dashed up and down
arrows move the Z Axis up or down.

The rotational arrows jog the A Axis, commonly used for rotaries.

If you're using an A Axis rotary, the Distance field determines
degrees of movement of the rotary axis with each click.

Continuous Jog

The Continuous Jog toggle allows supported lasers to move
continuously, by pressing and holding any of the directional
arrows. The laser will keep moving until the button is released.

See Device Settings → Enable $J Jogging for more information.

Keyboard Shortcuts

Each keyboard shortcut will move your laser by the amount
entered in the Distance field, at the rate set in the Speed field.

Jog Laser Left: Alt / Option  + Ctrl / Cmd  + [

Jog Laser Right: Alt / Option  + Ctrl / Cmd  + ]

Jog Laser Up: Shift Ctrl / Cmd  + ]

Jog Laser Down: Shift Ctrl / Cmd  + [

Keypad Jogging

You can also use a keypad to Jog your laser. In order to use
keypad Jogging, you must enable Numlock on your keyboard,
and the Edit Window / Workspace — the area where you create
and edit graphics — must be in focus.

There are several Windows and Toolbars in LightBurn that accept
user input — when a window is clicked on, it is in focus and
accepting input.

If a window other than the Edit Window is in focus, click
anywhere in the Workspace to bring it into focus.

Each press will move your laser by amount entered in the 
Distance field, at the rate set in the Speed field. If Continuous
Jog is enabled, the laser will Jog until you release the key.

Arrange Menu → Move Laser to Selection

The Jog options are also available in the Arrange Menu, within
the Move Laser to Selection submenu.

MOVE FROM MACHINE ZERO

The Move From Machine Zero toggle moves the laser from
machine zero instead of from the current position of the laser.

Instead of determining the amount of travel, the Distance field
controls the coordinate location the laser will travel to.

DEVICE-SPECIFIC BUTTONS

Focus Z

Focuses the Z Axis of the laser. To use this function, your laser
must have a movable Z Axis and have an automatic focusing
feature that is supported by LightBurn.

Set Origin

Creates a custom-set starting point, known as the User Origin.

Clear Origin

Press Clear Origin to remove and reset a custom-set User Origin.

Set Finish Position

Press Set Finish Position to establish the position the laser head
will move to after a job is finished.

See Finish Position for more information.

Fire

Turns your laser on at the Power level specified in the adjacent
field. 

Use the Fire button to enable the laser at low power for focusing,
Framing, and positioning.

The Fire button should only be used for diode lasers, which
generally don't have a red dot pointer for Framing.

Always wear proper eye protection when Firing your laser.
Consult your laser's manufacturer for information on the proper
eye protection required for your laser.

This should never be used for a CO2 laser, which has an invisble
beam that could blind you or start a fire.

Note

Note

• ⎇ ⌥ ⌃ ⌘

• ⎇ ⌥ ⌃ ⌘

• ⇧ ⌃ ⌘

• ⇧ ⌃ ⌘

What does it mean for a window to be in focus?

Danger
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See Device Settings — Enable Laser Fire Button for more
information.

Power

Sets the Power level the laser will use when you press the Fire
button, or when Framing, if you have enabled Laser on when
framing in the Device Settings window.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

GRBL UI clear-origin enable-fire-button finish-position

framing laser-control output-and-positioning set-origin

stored-positions user-interface user-origin workflow

Optimization Settings

LightBurn's Cut Planner controls the order in which your laser
cuts or engraves graphics in your project. The Cut Optimization
Settings window is where you adjust the variables by which the
Cut Planner decides on cut order and pathing.

To open the Cut Optimization Settings window, click the 
Optimization Settings button in the Laser Window.

Optimization Settings only take effect when the Optimize Cut
Path switch in the Laser Window is toggled on. If Optimize Cut
Path is toggled off, graphics are output in the order in which they
were first created.

After adjusting Optimization Settings, you can see the resulting
path the laser will take, along with a runtime estimate, in the 
Preview window.

OPTIMIZATION SETTINGS WINDOW

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Order By

The Order by options determine the initial ordering parameters
for your jobs, which is the primary way in which LightBurn
decides the order of cuts. You can choose to Order by Layer, 
Group, Priority, or combinations of these parameters. 

Using the Order by Options

Tip
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When determining the order of cuts, the Cut Planner sorts all
objects in your project into ordered lists based on the
parameters you've selected. If you select multiple Order by
options, their order within the list is important.

After splitting all the objects in your projects into lists based on
the first Order by parameter, the Cut Planner then splits each of
those lists based on the next Order by parameter in the list, and
repeats that process for however many parameters you've
selected.

With the default settings shown in the screenshot above — 
Order by Layer positioned first in the list, and Order by Priority
positioned second — the Cut Planner will first split all objects in
your projects into lists based on the Layer they are assigned to,
and will then sort the objects in each layer based on the Priority
you've set for each object.

With 2 layers and 3 objects on each layer, each set to a different
Priority, the lists will look like this:

Objects on Layer 1

Objects set to Priority 0

Objects set to Priority 1

Objects set to Priority 2

Objects on Layer 2 

Objects set to Priority 0

Objects set to Priority 1

Objects set to Priority 2

If the positions in the ordered list are reversed so that Order by
Priority is first, and Order by Layer is second, the lists will look
like this:

Objects set to Priority 0

Objects on Layer 1

Objects on Layer 2 

Objects set to Priority 1

Objects on Layer 1

Objects on Layer 2 

Objects set to Priority 2

Objects on Layer 1

Objects on Layer 2 

After sorting, each set of shapes created through this process is
then optimized with the options in the lower section of the
window.

Clicking any of the Order by options adds it to the list of ordering
parameters to use. If an Order by option is already on the list,
clicking again moves it to the top of the list, making it the first
parameter the Cut Planner will sort by. 

Order by Layer

Orders cuts according to the position of the layers in the Cuts /
Layers Window. 

Order by Group

Orders cuts by Group — all objects in a given Group are cut
together, then the next Group of objects, and so on. Ungrouped
objects will all be treated as a single group for the purposes of
this setting.

Order by Priority

Orders cuts according to individual Cut Order Priority. Priorities
are ordered such that 0 is the first priority, 1 is the second, and
so on. Assign Cut Order Priority in the Shape Properties Window.

Remove

Select an Order by option from the list and click Remove to
remove it from the list of ordering parameters.

Optimizations

The following optimizations are applied to all objects sent to your
laser, after they are sorted into lists according to the above
ordering parameters.

Cut inner shapes first

If there is an object within another object, and both are being
cut, tells your laser to cut the inner object before the outer one.
The outer shape must be closed in order for this optimization to
apply.

Example lists

1. 

a. 

b. 

c. 

2. 

a. 

b. 

c. 

1. 

a. 

b. 

2. 

a. 

b. 

3. 

a. 

b. 

Move layers up and down in the Cuts / Layers Window
by selecting and dragging them, or using the buttons to
the right of the list

Select objects and go to the Shape Properties Window
to adjust their Cut Order Priority
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This if often useful to ensure engravings and inner cutouts are
completed before cutting a shape out of the stock material,
which can cause the shape to drop or shift, depending on how
the material is held in place.

Cut in direction order

Attemps to order the shapes in your project so they're cut in
specified direction — Top to Bottom, Left to Right, etc.

When the Cut in direction order switch is enabled, you can
select one of the buttons on the right to determine order.

Reduce travel moves

Attempts to reduce non-cutting travel moves by ordering cuts
based on proximity to other shapes.

Hide backlash

This option is similar to the Backlash Repay Optimize setting
found in RDWorks — it produces a cutting order that reduces or
eliminates the misalignment between the start and end points of
a cut caused by loose or flexing belts, or other forms of play in
the mechanical parts of the laser. Enabling this option will force
some of the other options, to give it the most flexibility when
planning the cutting path.

Reduce direction changes

Attempts to choose nearby cuts that allow the laser to keep
moving in the same direction, which keeps it moving faster.

Choose best starting point

Allows the Cut Planner to start a cut at any point within a shape,
not just the first point. 

This options works best in combination with Reduce travel
moves.

Choose corners, if possible

Attempts to start cuts at sharp corners, to minimize burning or
staining on the surface of an item.

Choose best direction

Attempts to choose the direction to cut that will result in the
most efficient path.

Remove overlapping lines

Tells the Cut Planner to remove lines that are overlapping
between two graphics, and would cause the laser to cut in the
same place twice. 

The Distance field to the right of the switch controls how close
two lines need to be in order for the Cut Planner to remove one
of them when sending the job to your laser. 

Defaults

Set as Defaults

Saves your current Optimization Settings as your custom
defaults. 

Each time you start a new project, your Optimization Settings
revert to these defaults.

Reset to Defaults

Restores your current Optimization Settings to your default
settings.

Hold Shift  while clicking Reset to Defaults to restore to
LightBurn's standard default settings (as shown in the screenshot
above). 

OK

Saves any adjustments you've made in the Optimization
Settings window, overwriting previous settings. 

Any Optimization Settings you save are also stored within .lbrn
and .lbrn2  files, and opening any previously saved file will
automatically overwrite your current settings with those saved to
the file. 

Cancel

Discards any adjustments you've made in the Optimization
Settings window, reverting to previous settings. 

RELATED TOPICS

Preview

Cuts / Layers Window

Shape Properties

Grouping

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control optimization output-and-positioning

workflow

Tip

Tip

Using Remove overlapping lines

⇧

• 

• 

• 

• 
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Cut Selected Graphics / Use Selection Origin

By default, LightBurn outputs all graphics in your Workspace
when you Preview, Frame, Start, Send, or save a project in a
machine-specific file format. This works well if you have one
design in each project, but is less ideal when storing multiple
designs within the same file. 

In order to output only specific design elements, you can enable 
Cut Selected Graphics instead.

Use Selection Origin allows you to choose whether to orient
output relative to the entire project's Origin, or just the Origin of
the graphics in your selection. 

Both switches are available in the Laser Window.

Use Selection Origin will be grayed out if you've selected 
Absolute Coords as your Start From mode, or do not have Cut
Selected Graphics enabled. 

CUT SELECTED GRAPHICS

Enable Cut Selected Graphics to tell LightBurn to only output
the portion of your design that is currently selected. 

The Preview window only shows graphics that will be output to
your laser — use it to check that you've selected just the
graphics you want.

USE SELECTION ORIGIN

When used in combination with Cut Selected Graphics, the Use
Selection Origin button tells LightBurn to calculate the Job
Origin from only the parts that are selected, not the whole
design.

If you have many different graphics in a project that are
intended to be cut completely separately, enabling Use
Selection Origin simplifies the process of positioning output to
your laser, by excluding unselected graphics when calculating
the Origin.

If you're looking to rerun just one part of a larger design that
didn't cut through, disabling Use Selection Origin will ensure
that the cut lines up, by using the entire design to calculate the
origin.

The Job Origin is indicated on your design as a green square.
You'll see its position move as you toggle Cut Selected Graphics
and Use Selection Origin on and off in different combinations. 

TROUBLESHOOTING

If Cut Selected Graphics is enabled, but you have nothing in
your selection, and attempt to Preview, Start, Send, or Save a
project in machine-specific format, you'll see a warning message,
and be given the option to click Ok and abort the process but
leave Cut Selected Graphics enabled, or Turn off Cut Selected to
abort the process while automatically disabling Cut Selected
Graphics at the same time.

RELATED TOPICS

Laser Window

Coordinates and Job Origin

Preview

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

Note

Tip

• 

• 

• 

• 

• 
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Position Laser

The Position Laser tool is a quick way to jog your laser to a
location in its physical work area, by clicking in your LightBurn 
Workspace.

In order to use this tool, LightBurn must be directly connected to
your laser, and your laser must be properly homed and reporting
its position accurately. 

To enable Position Laser, go to Tools → Position Laser, click the
Position Laser button in the left side toolbar, or press Alt /

Option + L .

If your laser is not properly homed and reporting its position
accurately, using this tool may cause your laser to attempt to
travel outside its physical bounds, in some cases even crashing
into the side rails.

Before using this tool, make sure nothing is in the path of your
laser.

USING POSITION LASER

The grid in your LightBurn Workspace has a coordinate system
that matches the physical work area of your laser. The 0,0
position is always the location of your laser's Origin. You can see
the exact location of your cursor at any given position in the 
Status Bar.

After enabling Position Laser, click anywhere in your Workspace,
and LightBurn will issue a command to send your laser to the
corresponding location in its physical work area. 

The speed at which the laser travels when using Position Laser is
determined by the value set in the Speed field in the Move
Window.

Position Laser automatically turns itself off after about 10
seconds, in case you accidentally leave it on.

RELATED TOPICS

Move Laser to Selection

Move Selected Objects

⎇

⌥

Use With Caution

Position Laser Demo

• 

• 
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For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement gantry laser-control material-utilization

optimization output-and-positioning testing-tools

troubleshooting workflow workflow-optimization

Set Start Point
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Sets the point at which your laser begins to cut a shape, and the direction of travel.

Location

Modifiers Toolbar

Keyboard Modifiers

Shift  while clicking to reverse the direction

Ctrl / Cmd  while clicking to revert Start Point and
direction to default

Use the Set Start Point tool to control where your laser begins
cutting a shape, and in which direction. 

By default, the Start Point is the first point of the shape, and the
direction is the same as the direction of the animated dash
pattern that indicates when an object is selected.

Set Start Point is available in the Modifiers Toolbar, located on
the left side of the LightBurn window, by default.

USING SET START POINT

Click the Set Start Point icon in the Modifiers Toolbar to activate
it. 

If you had an object selected before you activated the Set Start
Point tool, you'll see its nodes and the current Start Point. To
select a new or different object, click any object in your 
Workspace.

The default Start Point is indicated by a gray arrow, while a user-
defined Start Point is indicated by a blue arrow.

Click any node to move the Start Point to that node. 

Hold Shift  while clicking to reverse the direction. Click
again without holding Shift  to return it to the default
direction.

Hold Ctrl / Cmd  while clicking any node to revert the Start
Point and direction back to the default. 

ADDITIONAL NOTES

Use the Edit Nodes tool to add a custom node to use as a Start
Point, if one does not already exist at the point you'd like a cut
to begin. 

Default and user-defined Start Points are overridden by certain
Optimization Settings. If you select Choose best starting

Quick Reference: Set Start Point

⇧

⌃ ⌘

• 

• ⇧

⇧

• ⌃ ⌘

• 

• 
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point or Choose best direction, LightBurn will select a
different Start Point if doing so will reduce overall cutting time.

The Start Point does not affect the direction of Fill or Image
engravings. To change the direction of an engraving, invert the
Scan Angle from 0° to 180°.

RELATED TOPICS

Edit Nodes

Line Mode

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

editing laser-control optimization

output-and-positioning path-tools

Galvo Framing

Outlines projects in your laser's work area using a red dot light.

Location

Laser Window

Keyboard Shortcuts

F1

Compatibility

LightBurn Pro

Galvo lasers

• 

• 

• 

Quick Reference: Galvo Framing
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Framing is a function of Galvo lasers that outlines projects in
your laser's work area using a red dot light, allowing you to see
where your design will output on a physical object.

Click the Frame button in the Laser Window or press F1  to
open the Live Framing window.

You may need to hold the Fn  key while pressing F1  to open
the Live Framing window.

By default, the Live Framing window will also open when you
press the Start button in the Laser Window, but you can disable 
Require framing before start in your Device Settings.

The Live Framing window contains options that determine the
style of framing, which graphics are framed, and how many times
to repeat a given project.

You can Start, Stop, and Pause your projects from the Live
Framing window, which remains open while your job is running. 

While framing, you can nudge, rotate, and rescale graphics,
adjusting them in your Workspace and live-updating them in
your laser's work area.

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

FRAMING STYLES

The different options determine how the red dot light represents
your shapes, and which shapes are shown.

Bounds

Commands the red dot light to trace a path defined as the
smallest possible rectangle that will fully contain all graphics
you're sending to the laser.

This mode is extremely fast, but doesn't represent complex
shapes well.

Hull

Commands the red dot light to trace the smallest possible path
that fully contains all graphics in the design you're sending to the
laser, as if a rubber band were stretched around them.

It is nearly as fast as Bounds, but gives a much closer fit for
rounded or smooth shapes.

Contour

Commands the red dot light to trace a path that follows the exact
contours of your shapes — it takes the longest to draw, but it's
the most accurate.

Note
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ADDITIONAL OPTIONS

Frame Individually

Determines whether to trace a single Bounds or Hull frame
around everything in your project, or around each individual
shape.

This option is grayed out when using Contour framing. 

Image Bounds

Attempts to quickly trace the outlines of any images you have in
your design, rather than only showing the rectangular boundary
of the entire image.

LightBurn determines the outline based on transparancy and
whitespace in the image — accuracy may vary.

Outside Shapes Only

Tells the software not to trace inner shapes, like the insides of
letters — typically this doesn't affect placement, but allows a
faster update of the frame (this only affects Contour mode).

Tool Layers Only

Tells LightBurn to only frame shapes that are on one of the Tool
layers.

JOB CONTROL

Start

Commands your laser to immediately begin running your current
project.

Stop

Immediately aborts a currently running job. 

Pause

Halts a running job. Click the Resume button to continue a
paused job.

JOB COUNTER AND MULTIPLE RUNS

Count

This value is incremented at the end of each successful run of
your file. You can use this to keep track of how many parts you
have marked, or how many passes of a single job you've run.

Reset Count

Resets the Count value to 0. 

Run Continuously

Tells LightBurn to re-start the job automatically after it finishes,
and update the Count after each run. 

If you turn off this switch while a job is running, the laser will
stop when the current run completes.

This is useful when you are doing very deep engraving, and are
unsure how many passes a job will need. 

Ensure your laser is properly supervised, even during long jobs
with multiple passes.

Repeat

Enable this switch and set a value in the adjacent field to tell
LightBurn to run the entire job the specified number of times,
and then stop.

If you turn off this switch while a job is running, the laser will
stop when the current run completes.

To run multiple passes of specific layers, sub-layers, or combined
sequences of sub-layers, see the Number of Passes and Global
Passes settings in the Cut Settings Editor.

Stop At

Enable this switch and set a value in the adjacent field to tell
LightBurn not to start the laser if the Count is greater than the
specified Stop At value.

This option is useful when the job is externally triggered (e.g.
with a foot switch), rather than started through LightBurn.

NUDGING, ROTATING, AND RESCALING

While framing, you can use the keyboard to nudge, rotate, and
rescale your graphics.

If your keyboard doesn't have Page Up  or Page Down , try using 
Fn + Up  or Fn + Down .

Tip

Warning

Tip

Key(s) Result

Left  / Right  / 
Up  / Down

Move graphics by 1 mm

Shift  + arrow keys Move graphics by 5 mm

Ctrl  + arrow keys Move graphics by .2 mm

Page Up Scale graphics up

Page Down Scale graphics down

.  (period) Rotate graphics 15°
clockwise

,  (comma) Rotate graphics 15°
counter-clockwise

Shift + .  (period) Rotate graphics 5°
clockwise

Shift + ,  (comma) Rotate graphics 5°
counter-clockwise

Ctrl + .  (period) Rotate graphics 45°
clockwise

Ctrl + ,  (comma) Rotate graphics 45°
counter-clockwise

← →

↑ ↓

⇧

⌃

⇞

⇟

⇧

⇧

⌃

⌃

⇞ ⇟

↑ ↓
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TROUBLESHOOTING

If the framing location or scale is inaccurate, you may need to
adjust your laser's focus, or fine-tune the values found in 
Device Settings → Galvo and Basic Settings → Red Dot. 

See our video guide for more information on adjusting red dot
alignment.

If Contour framing doesn't work, try toggling off Enable
Blanking Delay, in Device Settings, under IO Port Settings.

For information on framing behavior when using a rotary, see 
Rotary Mode (Galvo).

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

essential-functions galvo laser-control

output-and-positioning

Move Laser to Selection

Moves laser to parts of design. 

Location

Arrange Toolbar

Arrange → Move Laser to Selection

The Move Laser to Selection tools move your laser in its
physical work area to a location that corresponds to a position on
your current selection in your LightBurn Workspace. 

Use these tools to align your laser and physical objects to the
positions of graphics in your LightBurn grid.

In order to use Move Laser to Selection, LightBurn must be
connected to your laser, and it must be capable of reliably
homing and reporting its position accurately. If the position
reported by the laser is inaccurate, using this feature may cause
your laser to attempt to travel outside of its physical bounds. 

UI LOCATIONS

All Move Laser to Selection tools are available in the Arrange
Menu or in drop down menus in the Arrange Toolbar and 
Arrange (long) Toolbars. 

You can also hold the Ctrl  or Cmd  key while pressing one
of the Move Selected Objects buttons to move the laser head to
the location on the selection, rather than moving the objects. 

• 

• 

• 

Quick Reference: Move Laser to Selection

Warning

⌃ ⌘
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Hold Ctrl / Cmd  while clicking the Move Selected Objects
buttons in the Arrange (long) Toolbar to move the laser to the
chosen location on your selection instead, or open the
dropdown menu to select any option. 

OPTIONS AND ICONS

All below options move the laser to the location in its physical
work area that corresponds with the location of the chosen point
on your current selection in your LightBurn Workspace. 

The grid in your LightBurn Workspace has a coordinate system
that matches the physical work area of your laser. The 0,0
position is always the location of your laser's Origin.

For example, if the bottom right corner of your selection is at 100
mm in the horizontal (X) dimension, and 200 mm in the vertical
(Y) dimension in your LightBurn Workspace, selecting Move
Laser to Lower Right of Selection will move the laser head to X:
100 and Y: 200 in its physical work area. 

Move Laser to Selection in the Arrange Menu

Move Laser to Selection in the Arrange Toolbar

Move Laser to Selection in the Arrange (long) Toolbar

⌃ ⌘

Option Icon Action

Move Laser to
Selection Center

Moves laser to
the center of
selected objects.

Move Laser to
Upper Left of
Selection

Moves laser to
the top left
corner of
selected objects.

Move Laser to
Upper Right of
Selection

Moves laser to
the top right
corner of
selected objects.

Move Laser to
Lower Left of
Selection

Moves laser to
the bottom left
corner of
selected objects.

Move Laser to
Lower Right of
Selection

Moves laser to
the bottom right
corner of
selected objects.

Move Laser to
Left of Selection

Moves laser to
the left-center
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SELECTION COORDINATES

Edges and centers of selections are defined according to the
farthest points of any object in the selection area, in each
direction — imagine the selection area as the smallest possible
rectangle that can contain every object in your selection. The
edges and center of a selection are the same as the edges and
center of that imaginary rectangle.

You can read the coordinates of any location on your selection in
the Numeric Edits Toolbar. Click a point in the 9-dot control to
see the horizontal position (XPos) and vertical position (YPos) of
that location on your selection, in your Workspace.

LASER COORDINATES

You can read your laser's current cooridinates in the Move
Window, by clicking the Get Position button. 

The Move Laser to Selection tools can only move your laser in
the X and Y dimensions. 

RELATED TOPICS

Move Selected Objects

Position Laser

Selection Tools

Coordinates and Origin

Move Window

Numeric Edits Toolbar

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrangement laser-control material-utilization

optimization output-and-positioning testing-tools

troubleshooting workflow workflow-optimization

Option Icon Action

of selected
objects.

Move Laser to
Right of
Selection

Moves laser to
the right-center
of selected
objects.

Move Laser to
Top of Selection

Moves laser to
the top-center
of selected
objects

Move Laser to
Bottom of
Selection

Moves laser to
the bottom-
center of
selected objects.

Note

• 

• 

• 

• 

• 

• 
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Material Test

Quick Reference: Material Test
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Location

Laser Tools → Material Test

LightBurn has a built-in test pattern generator to help you find
the best settings for your laser and any material you're working
with. 

To open the Material Test Generator, go to the Laser Tools
Menu and select Material Test.

MATERIAL TEST EXAMPLE

A material test showing different speeds and powers on black anodized
aluminum

On the left side, each row is labeled with the engraving speed.
Along the bottom, columns are labeled with the power level
used. At the top, the sample shows additional universal settings
— in this case, Interval, Passes, and Frequency — that are used
for each box in the grid.

USING THE MATERIAL TEST GENERATOR

The Material Test dialog as it appears for a DSP laser

After opening the Material Test Generator, you'll be able to
configure your test pattern. By default, the Material Test
Generator will create a 10x10 grid of boxes with varying Power
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and Speed. Use the Param dropdown to select different
parameters to test. 

Positioning

The output location of the test grid is determined by the Start
From mode you select before opening the Material Test
Generator. Current Position and User Origin work exactly as they
do for all other output, while Absolute Coordinates location is
controlled by the X/Y Center options in the Material Test
configuration.

Test Configuration

Use the settings below to configure your test grid. The
parameters tested can be Power, Speed, Interval, or Passes. 
Frequency and Q-Pulse width can also be tested, if your laser
supports those settings. 

Cut Settings

The three buttons at the bottom of the dialog box open the Cut
Settings Editor, where you can adjust the settings to use in your
test. There are two switches to enable or disable the text labels
and border.

When entering Speed values recommended by your laser's
manufacturer or other LightBurn users, make sure to use the 
same units of distance and time as those from the recommendation,
or to convert the values to your preferred units.

A given number of millimeters per second is much faster than
that same number in millimeters per minute. Mixing up units
can lead to reduction in power output due to unexpectedly high
speeds, or excessive power output — and even fire — due to
unexpectedly slow speeds. 

Change your displayed units in the Units and Grids tab of the 
Settings window. LightBurn automatically converts any existing
values when you switch between units.

Running the Test

The buttons on the right side allow you to Preview the test grid, 
Frame to check output location, run the laser, and more.

MATERIAL TEST CUTTING AND ENGRAVING ORDER

The order in which test boxes are cut or engraved is determined
according to an ascending list of potential risk of burning or
charring material.

In other words, boxes with the highest Speed, lowest Power,
lowest Interval, and fewest Passes will run first, followed by the
next highest, lowest, fewest, and so on. 

SAVING AND EXPORTING

There is also a dropdown allowing you to select a saved Preset.
This is useful if you have custom settings you like to run
frequently, such as a smaller test pattern you want to use on
metal tags, or a range of settings you want to test on various
woods.

At the top are buttons allowing you to save, delete, export, and
import presets. 

To locate the presets saved on your computer, go to File → Open
Prefs Folder. You'll find the material_test_presets.lbmt  file inside
the presets  folder.

Presets can also be exported in a User Bundle.

Test Grid
Settings

Explanation

Count How many rectangles are in each
row/column

Param The setting being tested along this
axis

Min The lowest value to be used for
this setting

Max The highest value to be used for
this setting

Height/Width The height/width of each rectangle
in the test grid

Y Center/X
Center

The position of the center of the
test grid (if using Absolute
Coordinates)

Button Explanation

Edit Material
Setting

Base settings for the test — the
two settings chosen in Param will
be varied in the grid, but all other
settings applied here will apply to 
every test box

Edit Text Setting Settings to use for the text labels

Enable Text This switch controls whether text
labels are output

Edit Border
Setting

Settings to use for the border
around the test grid — available in
LightBurn 1.5 and higher

Enable Border This switch controls whether the
border around the test grid is
output

Always pay attention to units of distance and time
when entering Speed settings

Laser Controls Explanation

Preview Generate a preview of the test
grid

Frame Frame the test grid to see its
position on the material

Start Start running the material test

Pause Pause the material test

Stop Stop running the material test

Save RD File/Save
GCode

Device-dependent — if available,
saves the test grid in RD or
GCode format
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BUILT-IN PRESETS

LightBurn provides four Built-in Presets for users with Diode or
CO2 lasers. All four are selectable from the dropdown menu in
the Material Test Generator dialog window.

RELATED TOPICS

Material Library

Interval Test

Focus Test

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control optimization quality-optimization

testing-tools troubleshooting

Focus Test

Tests for the optimal focus height.

Location

Laser Tools → Focus Test

You can also use the Focus Test to try out different amounts of
defocusing. Defocusing your laser produces thicker lines where
it marks the material, which in turn allows you to increase the 
Line Interval setting on Fill layers, and speed up jobs. 

The Focus Test generates and runs a test pattern to help you
identify the optimal focal height for your laser. 

Focal height affects the strength and size of the laser dot where
it meets the material. A laser that is perfectly focused will have
the strongest power output and smallest dot size possible.

The Focus Test pattern is made up of a user-specified number of
lines, each engraved at a different Z Axis height. Text is engraved
beneath each line to indicate the Z height the line was engraved
at. 

• 

• 

• 

Quick Reference: Focus Test

Tip
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Go to Laser Tools → Focus Test to open the Focus Test setup
window, where you set the parameters used to generate the test
pattern.

PREPARATION

Z Axis Control

In order to use the Focus Test, your laser must have a motorized
Z Axis that is controllable through LightBurn, and Z Axis control
must be enabled in your Device Settings.

You'll receive a warning message if Z Axis control is not enabled
in your Device Settings, and you attempt to open the Focus Test. 

If you are not using Relative Z moves, you must set the Material
height for the material you will be testing on in the Cuts / Layers
Window, before opening the Focus Test. You'll need at least one
object in your Workspace in order to adjust the Material height
— any objects in your Workspace will be ignored when the Focus
Test pattern is sent to your laser.

Material

You'll be engraving a test pattern onto a piece of material placed
in your laser's bed. It's best to have the material loaded into your
laser before opening the Focus Test, so you can set and check
positioning. 

Your laser's optimal focus doesn't depend on the type of material
you're engraving on, but if you're purposely testing a range of
defocused heights, you may need to run unique tests on each
different material you work with to get the most accurate results.

Positioning

The Focus Test pattern will be output in your laser's work area
according to the Start From mode and Job Origin you select 
before opening the Focus Test. 

If you select Absolute Coords, the Focus Test pattern will be
centered in your laser's work area.

Current Position and User Origin work exactly as they do for all
other output.

See Coordinates and Job Origin for more information on these
settings. 
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FOCUS TEST SETUP WINDOW

Start Z determines the Z height of the first line in the Focus Test
pattern. 

End Z determines the height of the final line in the test pattern. 

If you are using Relative Z moves only, Start Z, End Z, and all Z
heights tested in between are determined relative to the current
Z position of your laser, at the time the test begins. In other
words, the first line will be engraved at the laser's current Z
position plus the value you enter in the Start Z field, and so on
for all Z heights tested, until the End Z.

If you are not using Relative Z moves only, Start Z, End Z, and all
Z heights tested in between are determined relative to the 
Material height you enter in the Cuts / Layers window before
opening the Focus Test.

Steps determines the total number of lines to create in the test
pattern. The total number of lines is equal to Steps + 1. The
amount that Z height will advance between each step is equal to:
(End Z - Start Z) / Steps. 

Speed sets the speed at which your laser will engrave the lines.

Max Power sets the power at which your laser will engrave the
lines.

Set Max Power just high enough to mark your material — if the
power is set too high, the laser may char or cut through your
material, making it challenging to determine which Z height was
the optimal focal height. 

Turn on High Power Laser Mode to enable Perforation Mode for
the labels beneath each line, if they are overburning. Perforation
Mode switches the laser off and on during cuts, reducing overall
power output.

Preview shows a preview of the Focus Test pattern, as it will
output to your laser.

Frame commands your laser to travel around the area the Focus
Test pattern will be output to in your laser's work area.

Save GCode saves the test pattern in GCode format.

Start commands your laser to begin engraving the Focus Test
pattern.

Press OK to save your Focus Test settings — saved settings will
be present when you open the Focus Test later.

Press Cancel to discard any changes you've made to the Focus
Test settings — settings will revert to previously saved settings
when you open the Focus Test later.

Start Z determines the Z height of the first line in the Focus Test
pattern. 

End Z determines the height of the final line in the test pattern. 

If you are using Relative Z moves only, Start Z, End Z, and all Z
heights tested in between are determined relative to the current
Z position of your laser, at the time the test begins. In other
words, the first line will be engraved at the laser's current Z
position plus the value you enter in the Start Z field, and so on
for all Z heights tested, until the End Z.

If you are not using Relative Z moves only, Start Z, End Z, and all
Z heights tested in between are determined relative to the 
Material height you enter in the Cuts / Layers window before
opening the Focus Test.

Steps determines the total number of lines to create in the test
pattern. The total number of lines is equal to Steps + 1. The
amount that Z height will advance between each step is equal to:
(End Z - Start Z) / Steps. 

Speed sets the speed at which your laser will engrave the lines.

Max Power sets the power at which your laser will engrave the
lines, once it reaches the Speed you've set.

Set Max Power just high enough to mark your material — if the
power is set too high, the laser may char or cut through your
material, making it challenging to determine which Z height was
the optimal focal height. 

Min Power sets the power at which your laser will begin
engraving the lines. As the laser accelerates, power will increase
until the laser reaches maximum Speed, and Max Power.

Turn on High Power Laser Mode to enable Perforation Mode for
the labels beneath each line, if they are overburning. Perforation
Mode switches the laser off and on during cuts, reducing overall
power output.

Preview shows a preview of the Focus Test pattern, as it will
output to your laser.

Frame commands your laser to travel around the area the Focus
Test pattern will be output to in your laser's work area.

Save RD file saves the test pattern in RD file format. 

Start commands your laser to begin engraving the Focus Test
pattern.

Press OK to save your Focus Test settings — saved settings will
be present when you open the Focus Test later.

Press Cancel to discard any changes you've made to the Focus
Test settings — settings will revert to previously saved settings
when you open the Focus Test later.

INTERPRETING RESULTS

After engraving the test pattern, inspect the results. 

The thinnest line in the engraving is the one that was run at the Z
height closest to your laser's optimal focal height. 

To dial in the optimal focal height further, you can re-run the 
Focus Test — select the two lines that look closest to ideal, and
set Start Z and End Z to match their Z heights.

RELATED TOPICS

Material Test

Interval Test

Z Axis control

Fill Mode - Interval

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control quality-optimization testing-tools

troubleshooting workflow-optimization

GCode DSP

• 

• 

Note

• 

• 

• 

Tip

• 

• 

• 

• 

• 

• 

• 

• 

• 

Note

• 

• 

• 

Tip

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 
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Interval Test

Generates an engraving pattern to test a range of Line Interval settings.

Location

Laser Tools → Interval Test

The Interval Test provides a quick way to determine the optimal Line Interval for a given combination of machine, material, and focal length. 

The Interval Test pattern is made up of a user-specified number of sample squares, each engraved at a different Line Interval. Text is engraved next to each square to indicate the Line Interval it was engraved at.

Line Interval is the distance between scan lines when raster engraving, making it one of the key settings determining the quality of engravings on Image and Fill Layers. It is mathematically tied to the Lines per Inch value, and both are set in the Cut Settings Editor.

Quick Reference: Interval Test

5.5.3 Quality Optimization

- 290/400 - ©️ LightBurn Software, LLC

../../img/QuickRef-IntervalTest.png
../../img/QuickRef-IntervalTest.png


Unlike in traditional print media, a higher density of scan lines
(lower interval) doesn't necessarily produce a higher quality
image when laser-engraving — an optimal value must be found.

If Line Interval is set too low, the engraving time is vastly
increased, and the images appear dark and muddy. 

If the Line Interval is set too high, more power is required to
achieve the same depth and darkness, and gaps may appear
between the lines. Stepping may also appear on curved edges. 

USING THE LINE INTERVAL TEST

Preparation

Place a scrap piece of the material to be tested into the laser, and
focus the laser as per your manufacturer's instructions. 

The location of the test on your material is determined by the 
Start From mode and the Job Origin that you select before
opening the Interval Test. If you select Absolute Coords, the test
will be centered on your laser's bed. Current Position and User
Origin work exactly as they do for all other output. See 
Coordinates and Job Origin for more information on these
settings. 

Interval Test Setup Window

Open the Interval Test by navigating to Laser Tools → Interval
Test, and adjust the settings: 

Speed sets the maximum speed the laser head will travel. The 
Material Test can help you find the optimal speed.

Power sets the maximum power output the laser source
should deliver. The Material Test can help you find the optimal
power. 

Steps determines the number of sample squares to make.
Reducing this will reduce the material needed, but will also
result in larger differences between each test square.

Min Interval determines the minimum distance between lines
to test (try 0.08 mm as a start).

Max Interval determines the maximum distance between
lines to test (try 0.16 mm as a start).

Size sets the size of each sample square. Reducing this will
reduce the material required, but may make the results harder
to read. 

Select Simple Fill to created sample squares with a solid black
fill. 

Select Dithered Image to create sample squares that are a
gradient from black to white. These are often easier to read
and provide more information to those seeking to engrave
images.

Preview shows a preview of the Interval Test pattern, as it will
output to your laser.

Frame commands your laser to frame the area the Interval
Test pattern will be output to in your laser's work area.

Save saves the test pattern in the appropriate file format for
your type of laser.

Start commands your laser to begin engraving the Interval
Test pattern.

Press OK to save your Interval Test settings — saved settings
will be present when you open the Interval Test later.

Press Cancel to discard any changes you've made to the
Interval Test settings — settings will revert to previously saved
settings when you open the Interval Test later.

Interpreting Results

Results are best observed under good lighting and with
magnification, if available. Look for the sample square where the
scan lines touch without overlapping. 

Adjust your Line Interval setting in the Cut Settings Editor, and
save your settings to the Material Library for future use. 

RELATED TOPICS

Focus Test

Material Test

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

dpi fill-mode image-mode laser-control line-interval

lpi quality-optimization testing-tools
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Material Library

LightBurn's Material Library provides a place to store, organize,
and apply preset Cut Settings for different operations and
materials. 

ACCESSING THE MATERIAL LIBARY

In the default layout, the Library Window is the tab after Laser,
in the bottom right of the screen. 

If you have closed the Library Window, go to Window → Library
to re-enable it. To restore it and all other windows to their default
positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

OPTIONS AND SETTINGS

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Creating New Material Library Presets

Click Create new from layer to save settings from the active 
layer (including Sub-Layers) to a new preset entry in the Library.
Enter the below details and hit OK to save the material preset to
the active Library. 

Material Name: The highest folder within the Library to
include this material in. 

Thickness: The Z-height of the material to be cut through.
Appears as the sub-folder name when in use. 

For surface operations like "Engrave" or "Score" that don't
depend on the material thickness enable No Thickness and
enter the operation into Title. This disables the Thickness
option, and appears as the sub-folder name when used. 

Description: Provide greater detail about these settings, for
example "Cut — Quick and Dirty". Appears as the name of the
entry in the list. 

All saved presets are organized in collapsible folders on the left
side of the Library Window. 

Using Material Library Presets

To apply presets to a layer in your project, first activate the layer
by selecting a graphic set to that layer, or clicking the layer in the 
Cuts / Layers Window. 

Next, select a preset from the list in the Library Window, and
click Assign or Link.

Assign

Applies the preset settings from the selected entry to the active
layer.

After applying the presets to the layer, you may adjust them in
the Cut Settings Editor, and edits made in the Cut Settings Editor
will not affect the Library entry, or vice-versa.

Link

Syncs the active layer to the settings stored in the selected preset
entry. This disables the ability to edit the layer in the Cut Settings
Editor, but any changes made to the Library entry will be
automically applied to the layer. 

This is often useful for files that you'll be running again in the
future, so that future improvements to your custom presets will
be automatically applied in your project.

Tip

• 

• 

• 

• 

Tip
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Modifying Presets

You can modify existing presets by selecting them in the list, then
clicking one of the options in the right side of the window.

Edit Cut

Opens the Cut Settings Editor for this preset. After making
changes, click OK to override the existing entry in the Library
with your changes. 

Edit Description

Click Edit Description to modify the Name, Thickness and 
Description for the highlighted entry.

Duplicate

Copies the highlighted preset to a new entry in the Library. 

Combined with Edit Description and Edit Cut, you can keep the
same Material Name and Thickness to create nested entries
(e.g. 3 mm cut, scan, and image). Keeping just the Name while
changing the Thickness allows nesting of different thicknesses of
the same material. 

Delete

Permanently removes the selected preset from the Library. 

Managing Material Libraries

New

Creates a blank Library. 

Save

Stores or overwrites a previously a stored Library with an
updated version containing any changes you've made since you
last saved the Library. Libraries are saved with the .clb  file
extension.

Save As

Saves a copy of the active Library to your files with a different file
name. Useful for archival purposes. 

Merge

Combines two Libraries together. Useful when importing settings
from external parties. 

Load

Open your system's file browser, where you can navigate to the
location of a previously saved .clb  file and select it, to add it to
the Select Library dropdown list. 

Select Library

Select one of the Loaded Libraries from the dropdown list.

Rename

Changes the name of the Library.

Unload

Removes the Library from the Select Library list. 

ADVANCED USAGE

Multiple Lasers

If you have multiple lasers, it's typically best to create a Material
Library for each laser. 

When you save a Library, it is linked to the currently active device.
In the future, when you select that device, the Library associated
with it will load automatically. 

When you change Libraries, LightBurn will check any Linked
layers against the newly-loaded Library. If there's a Linked preset
in each of the old and new Libraries that have matching details —
Material Name, Thickness/Title, Description — LightBurn will
automatically Link the layer to the preset in the new Library, and
update the layer's Cut Settings accordingly.

Multiple Computers

Multiple computers can access a single Material Library file
hosted on a network drive or from cloud service storage (e.g.
Dropbox, Google Drive, iCloud, OneDrive, etc.). To open up a
shared Material Library on a different computer, use the Load
button in the Library Window.

If you have multiple computers pointing to the same Material
Library file, updates made from one computer won't show on
the other computer(s) until LightBurn is restarted or the Library
is reloaded with the Load button.

RELATED TOPICS

Cut Settings Editor

Color Palette

Art Library

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI cut-settings device-management laser-control

libraries quality-optimization

Tip

Note

• 

• 

• 
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Print and Cut

Quick Reference: Print and Cut
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Location

Modes Toolbar

Laser Tools → Print and Cut

Keyboard Shortcuts

Windows: Alt + 0

Mac: Option + 0

Compatibility

Gantry lasers

Print and Cut aligns a current project to existing Target
Positions — also called registration marks — in a previously
output design. 

Print and Cut works by measuring the difference in location,
orientation, and scale between two Target Positions in your
laser's physical work area and the positions of two
corresponding graphics in your LightBurn Workspace.

Use Print and Cut to cut around a pre-printed design, to cut a
project larger than your laser's work area, to run a second pass
over a previous cut, or to restart a halted job. 

To open the Print and Cut Wizard, go to Laser Tools → Print and
Cut → Start Wizard, press Alt / Option + 0 , or click the
Print and Cut Icon in the Modes Toolbar. 

All individual Print and Cut steps are also selectable from the Print and Cut submenu, without opening the wizard.

Print and Cut Requirements and Notes

Print and Cut is only available for Gantry style lasers. 

In order to use Print and Cut, your laser must be connected to
your computer, reporting its position accurately, and properly
homed — for best results, you'll need a laser capable of
automatic homing. 

You must use Absolute Coordinates positioning with Print and
Cut. When you Align Output to Targets with Print and Cut,
Absolute Coordinates will automatically be selected as your 
Start From mode — switching out of that mode will cause
misalignment. 

⎇

⌥

⎇ ⌥

• 

• 

• 
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When aligning your laser to the Target Positions, you must
jog it using the commands in the Move Window, its controller's
keypad (if applicable), or the button in the Print and Cut
Wizard. You must not move your laser by hand at any point in the
process.

The accuracy of Print and Cut depends on the reliability of your
laser's motion system and the precision of your laser's beam
or red dot pointer's alignment to the Target Positions. 

If your laser slips, snags, or loses position in any other way
due to to mechanical problems, you will be unable to achieve
accurate alignment with Print and Cut. See Troubleshooting:
Mechanical Issues for advice on addressing those issues.

If the beam or red dot is not perfectly aligned to the center of
the Target Positions, output will not be perfectly aligned either.

Alignments with sub-millimeter accuracy are achievable, but
you should anticipate minor deviations in most cases.

USING PRINT AND CUT

Notes on Target Positions

To use Print and Cut, you must align your laser to two Target
Positions in a previously output design, and have corresponding,
selectable Target Position graphics in your LightBurn Workspace.
LightBurn uses the reported position of the laser over the Target
Positions to align new output to the existing design. 

The standard use case of Print and Cut is to align laser output to
registration marks that were specially added to a file in order to
use them as Target Positions later. In this case, the original file is
intended to be printed by one device, and cut out (or around) by
a laser later on. 

In order to align to a previously printed design, the printed file
must be in a format that can be Imported by LightBurn.

The Target Position graphics must always maintain their
relative position to the design after it is first output, in order to
accurately align to them later. 

Lock all objects in your project to ensure they always maintain
their relative position to one another.

The Target Position graphics must be a single object or single 
Group of objects. 

Output is aligned relative to the center of the object or Group
used as a registration mark. 

The farther apart the Target Positions are positioned from one
another, the greater the accuracy of your alignment will be. 

Crosshair marks make ideal Target Positions. Include them in
any printed design you intend to cut with your laser.

In LightBurn, crosshairs must consist of one vertical and one
horizontal line, Grouped together.

Create a circle with lines between its top and bottom and left
and right midpoint Snapping locations to make a perfect
crosshair.

The crosshairs cannot be images, or part of a larger image.
They must be individually selectable vector graphics. 

Set the crosshairs to a Tool layer if you do not want them to be
cut or engraved by your laser.

To cut a project larger than your laser, you can divide it and
engrave sets of crosshairs with each section, and use them to
align the next section to the previous section.

You can also center crosshair marks over sharp corners in an
existing cut or engraving, and align to those corners. Useful
for running a second pass over an incomplete cut, or
recovering halted jobs. 

Left: Crosshairs imported from a pre-existing design for use as
Target Positions. 

Right: Crosshairs placed over sharp corners in pre-existing
design, to use as Target Positions. 

• 

• 

• 

• 

• 

• 

• 

Tip

• 

• 

• 

• 

• 

Tip

• 

• 

• 
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Rotary Mode

ROTARY MODE

Rotaries are used to turn cylindrical objects so that their surfaces
can be marked by a laser. In order to use your laser with a rotary,
you must first establish several important parameters in the 
Rotary Setup window that control the rotary's motion.

To open Rotary Setup, go to Laser Tools → Rotary Setup
( Ctrl / Cmd + Shift + R ), or click the rotary icon in the 
Modes Toolbar. 

For more information on setting up and using a rotary with your 
type of laser, see:

Rotary Mode (DSP)

Rotary Mode (GCode)

Rotary Mode (Galvo)

You can enable or disable Rotary Mode by toggling the Enable
Rotary switch in the Rotary Setup window, or, if Show rotary
enable in main window is enabled in your Settings/Preferences,
by toggling the switch in the Laser Window.

When Rotary Mode is enabled, you'll see a status indication in
the bottom right corner of your screen:

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control modes-and-advanced-control rotary

ROTARY MODE (DSP)

The Rotary Setup window is not available for lasers with
TopWisdom or Trocen controllers. See below for more
information on setting up a rotary with these controllers.

Rotaries are used to turn cylindrical objects so that their surfaces
can be marked by a laser. In order to use your laser with a rotary,
you must first establish several important parameters in the 
Rotary Setup window that control the rotary's motion.

To open Rotary Setup, go to Laser Tools → Rotary Setup
( Ctrl / Cmd + Shift + R ), or click the rotary icon in the 
Modes Toolbar. 

Rotary Setup (Ruida)

Click any option in the images below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Rotary Setup for Ruida Controllers (Chuck)

⌃ ⌘ ⇧

Note

⌃ ⌘ ⇧
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Rotary Setup for Ruida Controllers (Roller)

Rotary Type

Select whether your rotary is a Chuck or Roller style rotary.
Chuck rotaries have adjustable jaws that grab and hold objects,
while Roller rotaries have revolving rollers or wheels that objects
are placed on top of.

Enable Rotary

If Show rotary enable in main window is enabled in your 
Settings/Preferences, you can also enable or disable Rotary
Mode using the switch in the Laser Window.

This switch controls whether Rotary Mode is enabled. When
enabled, rotational commands are sent to the laser to control
rotary motion, and output is split into segments.

When Rotary Mode is enabled, you'll see a status indication in
the bottom right corner of your screen:

Mirror Output to Rotary

Enable the Mirror Output to Rotary switch if output to the
rotary is inverted in the dimension of rotation. 

Rotary Axis

For most lasers with Ruida controllers, the Rotary Axis is
automatically set to Y and cannot be changed. 

If your rotary is connected to a U Axis port, the controller will
handle transferring the commands the correct axis, provided the
firmware version running on the controller supports U Axis
rotary output. In some cases, you may need to manually select
the U Axis through the controller. 

Consult your laser's manufacturer for more information on U
Axis rotary support. 

Rotary Settings Steps Per Rotation

With a Roller style rotary, it is the roller or wheel driven by the
motor that must make one complete rotation when you click the
Test button, and not an object on the rotary.

Set the steps per rotation value to the number of motor steps
required to spin the rotary one complete rotation. 

If this value is incorrect, output will be shrunk or stretched. 

In most cases, steps per rotation will be provided by the
manufacturer of your rotary or machine — consult the
manufacturer if the steps per rotation value was not provided in
the instructions included with your device.

Test

When the Test button is pressed, the rotary should turn a full 360
degrees, pause, then rotate back to the starting point. If the
rotary turns too far, reduce the steps per rotation value. If it does
not turn far enough, increase it.

Roller Diameter

This option is only presented for Roller style rotaries.

In most cases, Roller Diameter is provided by your rotary's
manufacturer. If not, carefully measure the diameter of the roller
or wheel driven by the rotary motor. 

Once this measurement is accurately identified and set, it never
needs to be adjusted again. If it is inaccurate, output will be
shrunk or stretched. 

Tip

Note
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Object Diameter

Use high precision calipers to guarantee the accuracy of your
diameter measurement. 

For Chuck style rotaries, carefully measure and enter the Object
Diameter of the item on your rotary. This value must be updated
every time you place an object with a different diameter on your
rotary. If it is inaccurate, output will be shrunk or stretched. 

For Roller style rotaries, Object Diameter does not affect output,
but can be entered here to calculate the Circumference of your
object.

If your object is tapered, check out our Taper Warp tool.

Circumference

Object Circumference is automatically calculated based on the
value entered in the Object Diameter field. The converse is also
true — Diameter is automatically calculated from Circumference. 

Use this value to adjust the size of your graphics — for full wrap
designs, the combined height of your graphics should be
identical to the Circumference.

Read Settings

Instructs LightBurn to read rotary settings settings from your
laser's controller. 

Writing Changes

After changing rotary settings, you must power-cycle the
controller, as the internal logic isn't adjusted for the new settings
until you do. 

Change the setting, press OK to close the Rotary Setup window
and write the changes to the controller, then power off the
control board and power it back on. 

You may need to press the Esc (or stop) button on the controller
to prevent it from trying to home itself, if the rotary is plugged
into the Y Axis port and the laser cannot travel in Y. 

Rotary Setup (TopWisdom and Trocen)

Positioning

If your rotary is plugged into your laser's Y Axis, position the
laser head toward the center of its work area before plugging in
the rotary.

In most cases, Current Position is the best Start From mode to
use when working with a rotary. 

Align the object under your laser head in the X dimension.
Output will be positioned on the object in the X dimension
relative to the laser head and Job Origin selection. The Job Origin
is indicated on your graphics by a green square. Parts of the
graphic to left of the green square will output to the left of your
laser head, and parts to the right will output to the right. 

Turn the rotary or object on the rotary to determine where the
engraving will output on the object in the dimension of rotation.
Output in this dimension is also determined relative to your Job
Origin selection — the rotary will turn to reach graphics
positioned above or below the Origin.

See Coordinates and Job Origin for more information on the Start
From mode and Job Origin settings. 

Tip
Users with TopWisdom controllers must enable Rotary Mode and
set parameters through the Machine Settings of the controller
itself. 

In LightBurn, go to Edit → Machine Settings to enable Rotary
Mode as well as view and adjust the rotary controls. 

The options presented here are the same as those available in
AutoLaser, the stock software for the TopWisdom. For more
information on these settings, refer to this manual, or contact
your machine's manufacturer.

Users with Trocen controllers must enable Rotary Mode and
adjust settings through the controller display. For more
information on these settings, refer to this manual, or contact
your machine's manufacturer.

TopWisdom Trocen

Tip
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In the above example, output will be centered around the starting
position of the laser head.

For some Trocen controllers, the Start From mode must always
be selected through the controller display. 

Troubleshooting

If your output is shrunk or stretched in the direction of
rotation, either steps per rotation, Object Diamater (if
working with a Chuck style rotary), or Roller Diameter (if
working with a Roller style rotary), is incorrect. 

Use the Test button in the Rotary Setup window to check
steps per rotation. The rotary should make one 360 degree
rotation before returning to the start. If you are working with a
Roller rotary, it is the roller or wheel driven by the motor that
must make one complete rotation and not an object on the
rotary. If it turns too far or not far enough, adjust steps per
rotation.

Use high precision calipers to double-check the Object or
Roller Diameter value.

If the controller returns a "Y Slop Over" or similar error when
you try to start a job, jog the rotary using the Y Axis arrows
until it reports a position near to the center of its work area
(half the max travel distance in Y.)

If an object slips on a Roller rotary, try:

Wrapping the rollers with a non-slip material, or even rubber
bands.

Placing weights inside the object, such as ball bearings or
other small round objects, to help press the object against the
rollers.

Going to Edit → Machine Settings and reducing the
Acceleration value of your rotary axis, in your machine's
firmware settings. 

If you end up with a flat part at the bottom of the engraving, it
means your rotary gear mechanism has backlash. Usually,
tightening any belts in the rotary device will fix this, but, if not,
you can place a small line a few mm below the bottom of your
design, set to very low power (0.1%) and set it as the first layer
to run. The rotary will spin to this position, then back up over
that few millimeters of gap, and will take up the backlash with
that movement.

Related Topics

Taper Warp

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

DSP gantry laser-control modes-and-advanced-control

rotary rotary-mode

Note

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 
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ROTARY MODE (GCODE)

Rotaries are used to turn cylindrical objects so that their surfaces
can be marked by a laser. In order to use your laser with a rotary,
you must first establish several important parameters in the 
Rotary Setup window that control the rotary's motion.

To open Rotary Setup, go to Laser Tools → Rotary Setup
( Ctrl / Cmd + Shift + R ), or click the rotary icon in the 
Modes Toolbar. 

Rotary Setup

Click any option in the images below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Rotary Setup for GCode (Chuck)

Rotary Setup for GCode (Roller)

Rotary Type

Select whether your rotary is a Chuck or Roller style rotary.
Chuck rotaries have adjustable jaws that grab and hold objects,
while Roller rotaries have revolving rollers or wheels that objects
are placed on top of.

Enable Rotary

If Show rotary enable in main window is enabled in your 
Settings/Preferences, you can also enable or disable Rotary
Mode using the switch in the Laser Window.

⌃ ⌘ ⇧

Tip
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This switch controls whether Rotary Mode is enabled. When
enabled, rotational commands are sent to the laser to control
rotary motion, and output is split into segments.

When Rotary Mode is enabled, you'll see a status indication in
the bottom right corner of your screen:

Mirror Output to Rotary

Enable the Mirror Output to Rotary switch if output to the
rotary is inverted in the dimension of rotation. 

Rotary Axis

Select which axis LightBurn will output rotational commands to.

Select Y Axis if you are unplugging your Y Axis stepper motor
wire and plugging it into the rotary instead. Some lasers use the
Y Axis with a dedicated port and switch. 

Select Z Axis or A Axis if you are plugging your rotary into a
dedicated rotary axis. Consult your laser's manufacturer for help
identifying the correct axis. 

Rotary Settings MM Per Rotation

With a Roller style rotary, it is the roller or wheel driven by the
motor that must make one complete rotation when you click the
Test button, and not an object on the rotary.

Set the mm per rotation value to the distance of commanded
movement in millimeters required to spin the rotary one
complete rotation. 

If this value is incorrect, output will be shrunk or stretched. 

In most cases, mm per rotation will be provided by the
manufacturer of your rotary or machine — consult the
manufacturer if the mm per rotation value was not provided in
the instructions included with your device.

Test

When the Test button is pressed, the rotary should turn a full 360
degrees, pause, then rotate back to the starting point. If the
rotary turns too far, reduce the mm per rotation value. If it does
not turn far enough, increase it.

Roller Diameter

This option is only presented for Roller style rotaries.

In most cases, Roller Diameter is provided by your rotary's
manufacturer. If not, carefully measure the diameter of the roller
or wheel driven by the rotary motor. 

Once this measurement is accurately identified and set, it never
needs to be adjusted again. If it is inaccurate, output will be
shrunk or stretched. 

Object Diameter

Use high precision calipers to guarantee the accuracy of your
diameter measurement. 

For Chuck style rotaries, carefully measure and enter the Object
Diameter of the item on your rotary. This value must be updated
every time you place an object with a different diameter on your
rotary. If it is inaccurate, output will be shrunk or stretched. 

For Roller style rotaries, Object Diameter does not affect output,
but can be entered here to calculate the Circumference of your
object.

If your object is tapered, check out our Taper Warp tool.

Circumference

Object Circumference is automatically calculated based on the
value entered in the Object Diameter field. The converse is also
true — Diameter is automatically calculated from Circumference. 

Use this value to adjust the size of your graphics — for full wrap
designs, the combined height of your graphics should be
identical to the Circumference.

Before configuring the above, you may need to set up the rotary
axis on your controller. LightBurn sends rotary moves as angle
values, and the GCode controller translates those angles into
actual movements. To do this, it needs to know the correct
number of motor steps to take for one degree of movement on
the rotary motor.

If you have a Smoothieboard or other uncommon GCode-based
controller, the number is usually 200 times your microstepping
multiplier (usually 8 or 16) times any gear reduction, divided by
360.

For a Cohesion3D or HolgaMods rotary, this is usually

3200 steps (200 x 8 micro steps x 2x reduction) / 360 =
8.88888888 steps per degree 6400 steps (400 x 8 micro steps x
2x reduction) / 360 = 17.7777778 steps per degree

The steps per degree number, along with acceleration and
maximum speed will need to be set in the appropriate location
for the controller. With Smoothieware, those are the delta
settings in the config.txt file on the controller.

Positioning

If your rotary is plugged into your laser's Y Axis, position the
laser head toward the center of its work area before plugging in
the rotary.

Note

Tip

Notes for Smoothieware Users

Tip
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In most cases, Current Position is the best Start From mode to
use when working with a rotary. 

Align the object under your laser head in the X dimension.
Output will be positioned on the object in the X dimension
relative to the laser head and Job Origin selection. The Job Origin
is indicated on your graphics by a green square. Parts of the
graphic to left of the green square will output to the left of your
laser head, and parts to the right will output to the right. 

Turn the rotary or object on the rotary to determine where the
engraving will output on the object in the dimension of rotation.
Output in this dimension is also determined relative to your Job
Origin selection — the rotary will turn to reach graphics
positioned above or below the Origin.

See Coordinates and Job Origin for more information on the Start
From mode and Job Origin settings. 

In the above example, output will be centered around the starting
position of the laser head.

Troubleshooting

If your output is shrunk or stretched in the direction of
rotation, either mm per rotation, Object Diamater (if
working with a Chuck style rotary), or Roller Diameter (if
working with a Roller style rotary), is incorrect. 

Use the Test button in the Rotary Setup window to check mm
per rotation. The rotary should make one 360 degree rotation
before returning to the start. If you are working with a Roller
rotary, it is the roller or wheel driven by the motor that must
make one complete rotation and not an object on the rotary. If
it turns too far or not far enough, adjust mm per rotation.

Use high precision calipers to double-check the Object or
Roller Diameter value.

If your controller returns an Alarm:2, Soft Limits error, enter 
$20=0  in the Console Window to temporarily disable Soft
Limits. When you are done working with the rotary, be sure to
enter 20=1  to re-enable Soft Limits in your machine's firmware.

This error is due to the amount of commanded travel on the
rotary axis exceeding the Max Travel limit for the Y Axis, as set
in your laser's firmware. During flat engraving, this protects
the machine from attempting to travel out of bounds and
potentially damaging itself. Since the rotary can turn forever, it
is ok to disable this setting when engraving with a rotary, but
take care not to give the laser commands that could cause it
to travel out of bounds in the X dimension.

If the object slips on a Roller rotary, try:

Wrapping the rollers with a non-slip material, or even rubber
bands.

Placing weights inside the object, such as ball bearings or
other small round objects, to help press the object against the
rollers.

Going to Edit → Machine Settings and reducing the
Acceleration value of your rotary axis, in your machine's
firmware settings. 

If you end up with a flat part at the bottom of the engraving, it
means your rotary gear mechanism has backlash. Usually,
tightening any belts in the rotary device will fix this, but, if not,
you can place a small line a few mm below the bottom of your
design, set to very low power (0.1%) and set it as the first layer
to run. The rotary will spin to this position, then back up over
that few millimeters of gap, and will take up the backlash with
that movement.

Related Topics

Taper Warp

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

GCode GRBL gantry laser-control

modes-and-advanced-control rotary rotary-mode
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ROTARY MODE (GALVO)

Rotaries are used to turn cylindrical objects so that their surfaces
can be marked by a laser. In order to use your laser with a rotary,
you must first establish several important parameters in the 
Rotary Setup window that control the rotary's motion.

To open Rotary Setup, go to Laser Tools → Rotary Setup
( Ctrl / Cmd + Shift + R ), or click the rotary icon in the 
Modes Toolbar. 

Rotary Setup

Click any option in the images below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Rotary Setup for Galvo (Chuck)

Rotary Setup for Galvo (Roller)

Rotary Type

Select whether your rotary is a Chuck or Roller style rotary.
Chuck rotaries have adjustable jaws that grab and hold objects,
while Roller rotaries have revolving rollers or wheels that objects
are placed on top of.

Enable Rotary

⌃ ⌘ ⇧
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If Show rotary enable in main window is enabled in your 
Settings/Preferences, you can also enable or disable Rotary
Mode using the switch in the Laser Window.

This switch controls whether Rotary Mode is enabled. When
enabled, rotational commands are sent to the laser to control
rotary motion, and output is split into segments.

When Rotary Mode is enabled, you'll see a status indication in
the bottom right corner of your screen:

Rotary Settings Steps Per Rotation

With a Roller style rotary, it is the roller or wheel driven by the
motor that must make one complete rotation when you click the
Test button, and not an object on the rotary.

Set the steps per rotation value to the number of motor steps
required to spin the rotary one complete rotation. 

If this value is incorrect, output will be warped or disconnected. 

In almost all cases, steps per rotation will be provided by the
manufacturer of your machine, either as a screenshot of the
rotary params page in EZCAD or in a text document.

Common steps per rotation values for Galvo rotaries are 9,600,
12,800, and 25,600. 

Test

When the Test button is pressed, it should rotate a full 360
degrees, pause, then rotate back to the starting point.

Roller Diameter

This option is only presented for Roller style rotaries.

In most cases, Roller Diameter is provided by your rotary's
manufacturer. If not, carefully measure the diameter of the roller
or wheel driven by the rotary motor. 

Once this measurement is accurately identified and set, it never
needs to be adjusted again. If it is inaccurate, output will be
warped or disconnected. 

Object Diameter

Use high precision calipers to guarantee the accuracy of your
diameter measurement. 

For Chuck style rotaries, carefully measure and enter the Object
Diameter of the item on your rotary. This value must be updated
every time you place an object with a different diameter on your
rotary. If it is inaccurate, output will be warped or disconnected. 

For Roller style rotaries, Object Diameter does not affect output,
but can be entered here to calculate the Circumference of your
object.

If your object is tapered, check out our Taper Warp tool.

Circumference

Object Circumference is automatically calculated based on the
value entered in the Object Diameter field. The converse is also
true — Diameter is automatically calculated from Circumference.

Use this value to adjust the size of your graphics — for full wrap
designs, the combined height of your graphics should be
identical to the Circumference, if the rotary is set to the Y Axis, or
the width, if it is set to the X Axis. See below for information on
Axis selection.

Split Setup Split Size

When working with a rotary and Galvo laser, graphics are split
into segments (slices). Each slice is marked on the object, then
the rotary turns, the next slice is marked, and so on, until the
entire graphic has been marked. 

The size of each segment is determined by the Split size setting.
If your object is tapered, irregularly shaped, or not perfectly
aligned with the rotary axis, using a small Split size can help
reduce gaps or misalignment of the splits.

A larger Split size will reduce the time spent running the job, but
it can be harder to dial in the settings such that there are no
overlaps or gaps.

Overlap

If you are removing paint, anodizing, or other surface coating,
using a small overlap is recommended. If you are annealing or
marking the material directly, adding overlaps may produce
visible artifacts.

Tip

Note

Tip

Tip
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To help eliminate visible gaps between slices, you can tell
LightBurn to overlap them. Enter an Overlap value to produce
that much overlap on the ends of each slice, like this:

Rotary Axis

When rotating on the X Axis, you'll want to engrave along the Y
Axis, with a Scan Angle of 90 or 270. When rotating on the Y Axis,
you'll want to engrave along the X Axis, with a Scan Angle of 0 or
180.

Select the X Axis if your rotary is oriented across your laser's
work area from top to bottom (or vice versa), and will be rotating
in the direction of X Axis motion. 

Select the Y Axis if your rotary is oriented across your laser's
work area from right to left (or vice versa), and will be rotating in
the direction of Y Axis motion.

Motor Speed Settings

The following settings control how fast the rotary moves and
accelerates. In most cases, you do not need to adjust these
settings from their default values. 

Min Speed

The minimum speed at which in the rotary will rotate, in pulses/
second.

If your rotary is losing steps, or an object on a Roller type rotary
is slipping, reduce Max Speed and increase Acceleration time. 

Max Speed

The maximum speed at which in the rotary will rotate, in pulses/
second.

Acceleration Time

Time to accelerate the rotary to full speed, in milliseconds. Lower
values mean the rotary will accelerate faster. 

Return Speed

The speed at which the rotary will return to its starting position,
in pulses/second. 

Reverse Rotary Direction

Enable the Reverse Rotary Direction switch if output is
backwards or sliced in the wrong order. 

Return to Starting Point

Enable Return to starting point to have the rotary return to its
starting point after the job is complete. 

Rotary Marking Window

When Rotary Mode is enabled, pressing the Start button in the 
Laser Window will bring up the Rotary Marking window.

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Split Size and Overlap

Split size and Overlap in the Rotary Marking window are linked
to the values set in Rotary Setup window. Changing either value
in either window automatically changes it in both places.

You will see a warning message if you set Split size lower than
the smallest possible Split size. Minimum split size is equal to the
circumference of your object divided by steps per rotation. For a
roller style rotary, it is the circumference of the roller divided by
steps per rotation.

See above for more information on these settings. 

Object Diameter (Rotary Marking Window)

Object Diameter is linked to the value set in the Rotary Setup
window. Changing the value in either window will automatically
update it in both places.

Tip

Tip
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See above for more information.

This option is not presented in the Rotary Marking window when
working with a Roller style rotary.

Run Whole Shapes, If Possible

Enabling Run whole shapes if possible tells LightBurn to create
splits in such a way that shapes are not broken into segments.
The rotary will jog to the center of each valid shape and mark it
in its entirety. This can produce a higher quality finish without
gaps or misalignment within shapes. 

Max Shape Size

When Run whole shapes if possible is enabled, Max Shape Size
determines the maximum size of objects that the laser will run in
their entirety. Objects larger than the Max Shape Size will be split
into segments.

If Max Shape Size is set too high, the laser's beam may go out of
focus toward the edges of large shapes due to the curvature of
the object on your rotary, and mark weakly, or not at all. 

Output Center

Output will be centered on this line on the axis your rotary is set
to. By default it is set to half of the maximum length of your 
Workspace, meaning output defaults to the center of the laser's
field. 

This setting allows you to shift the center position of your rotary
output to compensate for the center of the rotary not lining up
precisely with the center of the field. This value cannot be
negative.

Show

The Show button commands your laser to Frame a line in the
location Output Center is set to. 

Run Shapes in Shape Order

Shapes will be run in their planned order, allowing the rotary to
rewind. This option is best suited to Chuck style rotaries.

Run All Shapes in Each Slice

All shapes in each slice will be run before the rotary advances,
preventing the rotary from rewinding. This option is best for
Roller style rotaries, where objects may lose position due to
rewinding. 

Imagine your project has two layers, and you've selected Order
by Layer in Optimization Settings.

If you select Run shapes in shape order, the rotary will run all
splits containing the first layer, rewind back to the beginning,
and then run all splits containing the second layer.

If you select Run all shapes in each slice, the rotary will run the
first layer and then the second layer on each split, before
advancing to the next split, until the job is complete. 

Rotary Positioning Position

The value displayed next to Pos. shows the current location of
the rotary along the axis of rotation.

Go to Zero

Commands the rotary to return to the zero point on the axis of
rotation. 

Jog

The Jog << / >> buttons command the rotary to turn forward or
backward in the increment set in the field above the Go to Zero
button.

Set Zero

Sets the current position of the rotary as the zero point.

Start, Pause, Stop

These options work exactly as they do in the Laser Window
during flat marking operations to begin (Start), temporarily
pause (Pause) a job until your press Resume, or permanently
halt (Stop) a job.

Frame

Frames individual slices that show where graphics will be
engraved on the surface of your object.

Click Previous Slice and Next Slice to command the rotary to
turn forward or backward to frame each slice in order. 

The current segment being framed and total number of
segments are displayed beneath the buttons.

Warning

Run shapes in shapes order vs. Run all shapes in each
slice behavior comparison
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The size of slices when framing is distinct from the user-specified
Split size used during engraving. Instead, the amount of slices is
automatically determined based on the size of your object and
the graphics you'll be engraving. 

Larger objects have less curvature and therefore more area that
the red dot can reach and adequately frame, often resulting in
fewer framing slices for larger objects than smaller ones.

Setup

Opens the Rotary Setup window. 

Sanity Check

Checks whether your settings make sense, including whether
your Scan Angle is set to engrave along the dimension of
rotation, or have enabled Run whole shapes if possible but
selected Fill all shapes at once in the Cut Settings Editor.

Positioning Graphics

Enable Show work area center cross for a clear visualization of
your Workspace's center lines.

When using a rotary with a Galvo device, the center line of your
LightBurn Workspace represents the starting position of the
rotary. If the rotary is set to the Y Axis, it is represented by the
horizontal center line, and if it's set to the X Axis, it is
represented by the vertical center line.

The farther away from the center line a graphic or part of a
graphic is positioned in LightBurn, the more the rotary will turn
to reach the location it will be marked on your object. 

If graphics are straddling the center line, the rotary will first turn
in one direction to reach the furthest extent of the graphics, then
begin marking, eventually crossing the zero point to mark
graphics positoned on the other side of the center line. 

Use the X and Y Position fields in the Numeric Edits Toolbar to
guarantee precise positioning. 

To have the rotary begin marking without turning first, position
your graphics so that their edge is just above or below (if the
rotary is set to Y) or to the left or right (if the rotary is set to X) of
the center line of your Workspace. 

Graphics can be positioned as normal in the dimension the
rotary is not set to rotate on, to adjust the location they will
output to along the object you're marking. 

Troubleshooting

If output is stretched or there are gaps between slices, double
check the steps per rotation and Object Diameter values. If
you are using a Roller style rotary, check Roller Diameter
instead of Object Diameter.

In the Rotary Setup window, make sure the rotary — and not
an object on the rotary — makes a single 360 degree rotation
before returning to the starting location when you click the 
Test button.

Use high precision calipers for best results when measuring
the diameter of your object or roller. 

If output to your rotary is sent to the far left or bottom of your
laser's work area, check to make sure the Output Center value
is not set to 0. By default, it should be set to half of your
Workspace's maximum width or height.

If your graphics are only outputting as a line or narrow band
on your object, switch to the alternate Rotary Axis setting, or
change the physical orientation of your rotary to match the
current setting. 

If output to your rotary is backwards or sliced in the wrong
order, enable Reverse Rotary Direction.

Related Topics

Cylinder Correction

Taper Warp

Repeat Marking

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

galvo laser-control modes-and-advanced-control rotary

rotary-mode

Framing slice size

Tip

Tip

• 

• 

• 

• 

• 

• 

• 

• 

• 
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Repeat Marking

Enables the use of a rotating or linear axis table with Galvo lasers to repeat identical jobs.

Location

Laser Tools → Repeat Marking

Versions

LightBurn Pro

Galvo lasers

The Repeat Marking tool enables the use of a Rotating or 
Linear axis table with Galvo lasers, to move parts past a laser
while running repetitions of identical jobs. 

By specifying an Increment of movement as well as a desired
number of repetitions, or Count, you can command your laser to
mark a design, move an external axis by the specified increment,
then run the project again, and repeat that process until it has
completed the set number repetitions.

To open the Repeat Marking tool, go to Laser Tools → Repeat
Marking.

The Repeat Marking tool is separate from, and incompatible
with, Rotary Mode. When using Repeat Marking, make sure that
Rotary Mode is disabled.

EXTERNAL AXIS SETUP

Before you use Repeat Marking for the first time, you must
configure the settings for the Rotating or Linear axis table
connected to your laser.

Click the Setup button in the Repeat Marking window to open
the External Axis Setup window. 

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Motor #

If your laser has two motor outputs, select which is connected to
your Rotating or Linear table.

Axis Type

Select whether your device is a Rotating table that can make
continuous, complete revolutions, or a Linear table that moves
back and forth along an axis.

Reverse Direction

Enable Reverse Direction to tell your device to travel in the
opposite direction it travels by default, without changing its
orientation or rewiring it. 

Steps Per Rotation / Steps Per MM

For Rotating tables, the Steps per rotation value is the
number of commanded steps required for the table to make
on complete rotation. 

For Linear tables, the Steps per mm value is the number of
commanded steps required to move the table one millimeter. 

Your device's manufacturer should provide you with the correct
value for your device.

Test

For Rotating tables, when the Test button is pressed, and Steps
per rotation is correct, the table will rotate a full 360 degrees,
pause, then rotate back to the starting point.

Quick Reference: Repeat Marking

Warning

• 

• 
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For Linear tables, when the Test button is pressed, and Steps
per mm is correct, the table will move 50 mm, then back to its
starting point. 

Min Speed

The minimum speed at which in the table will travel, in Steps/
second.

Max Speed

The maximum speed at which in the table will travel, in Steps/
second.

Acceleration Time

Time to accelerate the table to full speed, in milliseconds. Lower
values mean the table will accelerate faster. 

Return to Start Position

Enable Return to starting point to have the table return to its
starting point after the job is complete. 

Return Speed

The speed at which the table will return to its starting position, in
Steps/second. 

Homing

Home on Start

Enable Home on start to have LightBurn send a command to
home a Linear table at the start of a job.

Speed

The speed at which the table will home.

Timeout

Amount of time before the table will abort the homing process. 

REPEAT MARKING WINDOW

Use the Repeat Marking window to jog your table into its
starting position, set the number of repetitions it will run, and
determine the amount of movement between each repitition. 

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Count

The number of times (repetitions) your laser will mark a given set
of graphics. 

Your laser will mark a single set of graphics once, then the table
will rotate or move, and the laser will mark the same set of
graphics again, and so on until it reaches the Count you've set.

Increment

For Rotating tables, the angle, in degrees, to rotate the axis
between repetitions.

For Linear tables, the distance, in millimeters, to move the axis
between repetitions. 

Calculate

The Calculate button is only available if the axis type in External
Axis Setup is set to Rotating, and can automatically determine
the correct rotation Increment based on the number of
positions in your Rotating table. To use it, set Count to the
number of positions in your table, then click Calculate.

Afteward, you can change the Count to any other number of
repetitions, but make sure not to click Calculate again, or the
correct Increment value will be lost. 

Pause After Move

If your Rotating table wobbles when it stops, adding a pause
here gives it time to settle before marking starts again.

Completed

The total number of runs of a given project, from the time you
first open the Repeat Marking window, until you close it. Use
this number to track the total number of parts you have marked. 

Clear

Resets the Completed count to zero.

Positioning

Position

The value displayed next to Pos. shows the current location of
the Rotating or Linear table.

Go to Zero

Commands the table to return to the zero point on the axis.

Jog

The Jog << / >> buttons command the table to turn (or move)
forward or backward in the increment set in the field above the 
Go to Zero button.

Set Zero

Sets the current position of the table as the zero point.

Start, Pause, Stop

These options work exactly as they do in the Laser Window
during regular marking operations to begin (Start), temporarily
pause (Pause) a job until your press Resume, or permanently
halt (Stop) a job.
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Frame

Framing works as it does with regular marking operations.

The Rotating or Linear table will not jog to Frame each
repetition — to verify that your Increment and Steps per
rotation or Steps per mm values are correct before running a
job, try Jogging the table by the amount you've set for your
Increment, and Framing multiple positions on the table.

Setup

Click the Setup button to open the External Axis Setup window
and configure the settings for your table table.

RELATED TOPICS

Rotary Mode (Galvo)

Variable Text

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

LightBurn-Pro batch-production galvo laser-control

modes-and-advanced-control

Feeder Setup

Auto-feeders are conveyers that feed materials such as fabric or
leather into a laser in stepped increments. The laser runs
repetitions of the same engraving or cutting job between each
increment. 

Go to Laser Tools → Feeder Setup ( Ctrl / Cmd + Shift

+ F ) to open the Auto-feed settings window, where you can
set the parameters by which your auto-feeder will feed material
into your laser, and the laser will run repeat jobs.

Feeder Setup is only available for DSP lasers with Ruida or
Trocen controllers. 

Tip

• 

• 

⌃ ⌘ ⇧

Note
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AUTO-FEED SETTINGS

Enable Auto-Feed turns on Auto-Feed mode. This setting must
be enabled in order to operate your auto-feeder.

Feed before cutting commands the feeder to move material
into the laser before the laser performs its first run of the job.

Pause after feed move tells the laser to pause after a feed
move, before cutting. This option is not available on all
controllers. 

There are three options for feed distance in the drop-down
menu. Feed distance controls the amount that the feeder will
advance your material with each repetition. 

Job Height: the feeder will advance the same distance as the
height of the job you send to the laser. 

You can see your job's height in the Numeric Edits Toolbar after
selecting all graphics you'll be outputting to the laser.

Y Axis length: the feeder will advance the same distance as the
length of your laser's bed in the Y dimension.

Manual: the feeder will advance by the amount you specify in
the field next to the drop-down menu.

Distance Adjust offsets the feed distance by the amount
entered. For example, with Job Height selected, and a project
height of 50 mm, entering 5 mm in the Distance Adjust field will
command the feeder to advance 55 mm with each repetition.
Offsets can also be negative. 

Repeat Count determines the number of times the laser will run
the job and the feeder will advance.

Press OK to save Auto-feed settings or Cancel to discard any
settings changes made and restore to previous settings.

Be sure to click OK to save settings after enabling or disabling
Auto-Feed mode, or adjusting any settings. Cancelling or "X-ing"
out of the Auto-feed settings window will not apply the changes
you've made. 

Enable Auto-Feed turns on Auto-Feed mode. This setting must
be enabled in order to operate your auto-feeder.

There are three options for feed distance in the drop-down
menu. Feed distance controls the amount that the feeder will
advance your material with each repetition. 

Job Height: the feeder will advance the same distance as the
height of the job you send to the laser. 

You can see your job's height in the Numeric Edits Toolbar after
selecting all graphics you'll be outputting to the laser.

Y Axis length: the feeder will advance the same distance as the
length of your laser's bed in the Y dimension.

Manual: the feeder will advance by the amount you specify in
the field next to the drop-down menu.

Distance Adjust offsets the feed distance by the amount
entered. For example, with Job Height selected, and a project
height of 50 mm, entering 5 mm in the Distance Adjust field will
command the feeder to advance 55 mm with each repetition.
Offsets can also be negative. 

Repeat Count determines the number of times the laser will run
the job and the feeder will advance.

Delay after feed (secs) tells the laser to pause for the specified
amount of time after each feed.

Press OK to save Auto-feed settings or Cancel to discard any
settings changes made and restore to previous settings.

Be sure to click OK to save settings after enabling or disabling
Auto-Feed mode, or adjusting any settings. Cancelling or "X-ing"
out of the Auto-feed settings window will not apply the changes
you've made. 

Ruida Trocen

• 

• 

• 

• 

• 

Tip

• 

• 

• 

• 

• 

Warning

• 

• 

• 

Tip

• 

• 

• 

• 

• 

• 

Warning
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RELATED TOPICS

Rotary Mode (DSP)

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

LightBurn-Pro advanced-control batch-production

hardware workflow

Center Finder

Finds the center of circular stock in your laser's work area.

Location

Laser Tools → Center Finder

Compatibility

Gantry lasers

The Center Finder is a tool for finding the center of circular
stock, as well as defining that stock in your LightBurn Workspace.

By jogging your laser to three positions on a circle (or other 
regular shape), and setting those positions in the Center Finder
Wizard, LightBurn can calculate the circle that passes through
those three points, jog your laser to its center, and create a circle
in your LightBurn Workspace matching those dimensions, to
represent your stock. 

The Center Finder is available in the Laser Tools Menu.

• 
Quick Reference: Center Finder
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USING THE CENTER FINDER

First Steps

Home your machine.

If your machine does not have homing switches, make sure to
start the machine with the laser head at the 0,0 point of its
work area — that is typically the lower left corner for GCode-
based devices. 

If the stock you are referencing is light or can be moved easily,
make sure to secure it so it does not get bumped during the
operations. 

Set the Points

Point 1

Jog the laser head to the first position on the edge of your circle,
as shown in the wizard, then click Set First Circle Point.

You must jog the laser head with the laser control panel or from
the Move Window. Center Finder will not work if you move the
laser head by hand.

Point 2

Jog the laser head to the next position on the edge of your circle,
as shown in the wizard, then click Set Second Circle Point.

• 

• 

• 

Warning

5.5.4 Modes and Advanced Control

- 314/400 - ©️ LightBurn Software, LLC

../../img/Ref-CenterFinder-InMenu.png
../../img/Ref-CenterFinder-InMenu.png
../../img/Ref-CenterFinder-WizardPoint1.png
../../img/Ref-CenterFinder-WizardPoint1.png


Point 3

Jog the laser head to the last position on the edge of your circle,
as shown in the wizard, then click Set Third Circle Point. Align to Center

Move to Center

The last step will show you the calculated center of your circle
and allow you to jog to that point. 
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Create Guide Circle

Toggle on Add Guide Circle to Project to create a circle on the 
T1 Tool layer, that will provide a representation of your stock in
your LightBurn Workspace. 

Set Origin

Absolute Coordinates

If you use Absolute Coordinates for your workflow, move your
design to the guide circle, and make sure your Start From mode
is set to Absolute Coords.

User Origin — Center

If you use User Origin make sure the center radio button is
selected as Job Origin.

After you move the laser to the center of your stock, press the 
Origin button on your DSP control panel or the Set Origin
button in the Move Window.

Notes

You can set the points in any order, and they do not need to be
positioned exactly as shown in the reference photos — they
need only be far enough apart from one another along the
perimeter of the shape that they are valid for calculating the
center. The reference photos are meant as guidelines for
acceptable distance. 

This tool can find the center of any shape that can be described
with a circle diameter:

Squares (pick 3 corners)

• 

• 

• 
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Equilateral Triangles

Hexagons

ERROR MESSAGES

Unable to Query the Current Position of the Laser

This happens when LightBurn is unable to get the position of the
laser from the controller. 

Often, the laser is still moving, or another command is still in
process. Click OK, and try again after waiting a few seconds.

If the warning persists, make sure the controller is still
connected and is showing Ready at the top of the Laser
Window. If you are unable to connect, see Troubleshooting:
Connection Problems.

Not Enough Separation Between Points

You have not moved the laser away from the last point or have
not moved it far enough to make an acceptable calculation. 

Try moving farther away and setting the point again. 

You must jog the laser using its control panel or the Move
Window, and not by hand. 

Unable to Calculate Center

LightBurn can't calculate center, or it would be outside your
laser's work area. 

This typically happens on machines without homing switches
that were not manually homed properly. 

Restart your machine with the head at your machine origin
and try to run the wizard again. 

TROUBLESHOOTING

The accuracy of the Center Finder depends on the accuracy of
your point placement. If you have a red dot laser that is
accurate, one trick is to try to split the dot on the edges of your
stock.

If you set a point incorrectly, hit the Reset button. This will
clear all points saved. After, restart from the current point. You
can set the points in any order.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

gantry laser-control modes-and-advanced-control

output-and-positioning

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

5.5.4 Modes and Advanced Control

- 317/400 - ©️ LightBurn Software, LLC

../../img/Ref-CenterFinder-Triangle.png
../../img/Ref-CenterFinder-Triangle.png
../../img/Ref-CenterFinder-Hexagon.png
../../img/Ref-CenterFinder-Hexagon.png
../../img/Ref-CenterFinder-CommunicationFailed.png
../../img/Ref-CenterFinder-CommunicationFailed.png
../../img/Ref-CenterFinder-UnableToCalculate.png
../../img/Ref-CenterFinder-UnableToCalculate.png
https://forum.lightburnsoftware.com/
mailto:support@lightburnsoftware.com


Cylinder Correction

Warps the output of your design to correct for distortion caused by engraving cylindrical objects.

Location

Modes Toolbar

Laser Tools → Cylinder Correction Setup

Compatibility

LightBurn Pro

Galvo lasers

Cylinder Correction warps the output of your design to correct for distortion caused by engraving cylindrical objects, without using a rotary. This tool is currently only
available for Galvo lasers. EZCAD users may already be familiar with this tool by the name ProjectMark.

USING CYLINDER CORRECTION

Open the Cylinder Correction Setup window by going to Tools
→ Cylinder Correction Setup. Make sure Enable Cylinder
Correction is turned on. 

Quick Reference: Cylinder Correction
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From the setup window, you'll adjust the Mirror Distance, 
Object Diameter, axis to curve around, and direction of the
curve.

LightBurn will calculate the Cylinder Correction assuming the
design to be output is centered on the object. If you are unable
to place the item you're engraving at the center of the laser's
working area, move your design to match the actual location of
the object.

Mirror Distance

This is not the focus distance between the object and the lens,
but the distance to the galvo mirrors themselves. Keep reading
for help measuring this.

To use Cylinder Correction, you'll need to identify where your
mirrors are. The mirrors are typically centered along a tube
connecting the galvo head to the laser source. In the image
below, a horizontal line marks the center of this tube.

Measure the vertical distance from this line to the bottom of the
lens — shown with a vertical line in the image above — and add
this to your focus distance to find the mirror distance. We
recommend saving this measurement so you don't have to keep
re-measuring.

Object Diameter

Measure the diameter of the object and enter it into this box.

X or Y Axis

Select whether the object curves along the X (horizontal) axis or Y
(vertical) axis. Only one of the two can be selected. The images
below the options show a simplified representation of what each
option would look like.

Convex or Concave

Select whether the object is Convex — curving outwards to make
up the outer surface of a cylinder — or Concave — curving
inwards to make up the inner surface of a cylinder. As with the X
and Y Axis, the images show a simplified representation of
Convex and Concave curves.

Show Valid Boundary

There are limits to where on a given object your laser can actually
reach. The Show Valid Boundary button will insert a rectangle
on the T1 Tool layer into your design to show the area that can
be engraved.

If you try to Preview or run a cylinder-corrected engraving while a
portion of your design is outside of the valid area, LightBurn will
pop up a warning asking you whether you'd like to continue
anyway, show the valid boundary, or cancel. If you engrave
anyway, LightBurn will automatically cut off the portions of the
design outside the valid boundary area, as shown below.

Warning
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HOW IT WORKS

Galvo lasers project the laser from a single point above your
object. When marking a cylindrical object, the increased travel
distance for the laser as the surface of the object curves away
causes the shape to widen and bend, similarly to the uncorrected
rectangle in the diagram below.

Cylinder Correction alters the output to warp your design in the
opposite direction, negating the warping caused by the curve of
the object. If your measurements are correct, this produces
clean, undistorted output like the result shown in the diagram
above.

Lens Selection

When using Cylinder Correction, you'll be marking across a
larger range of focal distances than is typical when marking flat
surfaces. For instance, if you have a 75 mm diameter tumbler
and are engraving a 50 mm wide graphic, there will be about 10
mm difference in focal distance across your design.

For best results, use a lens with a larger field (working area) if
possible. Wider field lenses have a lower power density but a
longer focal range. To take advantage of the full focal range,
focus your lens below the upper surface of the cylinder, as shown
in the diagram below.

TROUBLESHOOTING

If the outer parts of your design are missing, make sure that
it's fully within the valid boundaries.

If the placement of your engraving is wrong, check that the
location of your design matches the actual location of the
object you're marking. Confirm that the placement is right by 
framing before running the job.

RELATED TOPICS

Rotary Mode

Taper Warp

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

galvo laser-control modes-and-advanced-control rotary

• 

• 

• 

• 
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Taper Warp

Warps graphics to compensate for the taper of physical objects.

Location

Laser Tools → Taper Warp

The Taper Warp tool assists in rotary engravings on tapered objects by adjusting graphics
to compensate for the difference in diameter between the top and the bottom of the
object. Open the Taper Warp window by going to Laser Tools → Taper Warp.

USING TAPER WARP

Open the Taper Warp window and adjust the settings shown to
match your object. The diagram on the right side of the window
helps illustrate what the settings refer to.

As you adjust the settings, you'll see a preview of the effects of
the Taper Warp in your Workspace. The image below shows the
effect of Taper Warp on parallel rectangles.

Press OK to confirm settings and adjust the graphics, or Cancel
to discard the changes.

When engraving your object, make sure that it's positioned so
that the surface to engrave on is parallel to the bed of the laser.

Object Top

Set Object Top to either Top, Left, or Right so LightBurn knows
where the top and bottom of the taper are — this is where the
top of the physical object you're engraving is.

Quick Reference: Taper Warp
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Top Diameter

Measure the diameter of the top of the object. Be as precise as
possible – calipers can be very helpful, especialy dealing with
round objects.

Length

Measure the length of the object and enter it here.

Bottom Diameter

Measure and enter the diameter of the bottom of the object.

TROUBLESHOOTING

Taper Warp corrects for the difference in diameter between
the top and bottom of the object. It does not account for
different focal lengths or distances from the laser. Make sure
the object you're engraving is held in the rotary so the surface
to engrave is parallel to the laser's bed.

The results of Taper Warp depend on the accuracy of the
measurements you enter — if Taper Warp does not properly
compensate for the taper of your object, double-check your
measurements.

RELATED TOPICS

Rotary Mode

Cylinder Correction

Warp and Deform

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

laser-control laser-tools modes-and-advanced-control

object-manipulation rotary-mode

Galvo Lens Calibration

All Galvo lenses have distortion which must be corrected in order
for output from your laser to have an appearance that's true to
the design you see in your LightBurn Workspace.

When working with a new laser, you can usually import lens
correction values provided by your machine's manufacturer
when you first set up your laser with LightBurn.

If you purchase a new lens for a laser you already own, however,
you may need to use LightBurn's Galvo Lens Calibration wizard
to find the appropriate corrections.

To open the Galvo Lens Calibration wizard, go to Laser Tools → 
Calibrate Galvo Lens → 9 Point Correction (Easy).

REQUIREMENTS

To complete the Galvo Lens Calibration process, you will need:

A properly set up device profile for your laser, with the correct 
Laser Type and (if applicable) Fiber Type selected in the 
Device Settings window.

A material your laser is capable of marking with high contrast.
Black construction paper works well for lasers with Fiber
sources, and white paper works well for lasers with CO2
sources.

A ruler or calipers, to measure the distance between markings
made on the material you selected.

GALVO LENS CALIBRATION WIZARD

Field Size and Test Area

• 

• 

• 

• 

• 

• 

• 

• 
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Each of the fields in this step will be automatically populated
based on the Field setting in the Device Settings window, but can
be adjusted manually if those settings are inaccurate. 

Enter the working area of your lens (this value is usually
provided by the manufacturer) as well as the size of the box to
output — a value between 85% and 90% of the working area is
ideal.

Click Next to continue to the next step, or Cancel to exit the
process (progress will not be saved).

Laser Output Settings

Enter appropriate settings for your laser to mark the material
you selected, with strong contrast. If you are unsure what
settings to use, try running a Material Test first, or consulting
your laser's manufacturer for suggested settings.

The Frame, Start, and Stop buttons work exactly as they do for all
other output. 

Use the Frame button to verify that the size of the box to
output is valid for your laser's working area. Mark the design if it
fits, or return to the previous step using the Go Back button, if
you need to adjust the size.

Click Next to continue to the next step, or Cancel to exit the
process (progress will not be saved).

Orientation

Select the LightBurn Dragon that matches the orientation of the
output from your laser. Only one orientation will match exactly —
take care to select the correct one.

Click Next to continue to the next step, Go Back to return to a
previous step and adjust settings, or Cancel to exit the process
(progress will not be saved).

Horizontal Measurements

Measure and enter the horizontal distances between lines, as
indicated in the graphic. Take care to measure the distances as
accurately as possible — the accuracy of the lens correction
depends on the accuracy of these measurements.

Click Next to continue to the next step, Go Back to return to a
previous step and adjust settings, or Cancel to exit the process
(progress will not be saved).

Vertical Measurements

Measure and enter the vertical distances between lines, as
indicated in the graphic. Take care to measure the distances as
accurately as possible — the accuracy of the lens correction
depends on the accuracy of these measurements.

Click Next to continue to the next step, Go Back to return to a
previous step and adjust settings, or Cancel to exit the process
(progress will not be saved).
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Results

The final page displays the resulting corrections that will be
applied to each Galvo. 

Toggle on Maximize working area to increase your laser's Field
to the maximize size possible, if a larger possible size is indicated
by the measurements you entered. Note that you may see a
reduction in power output in areas outside the dimensions
specified by the lens' manufacturer.

Click Done to exit the process and automatically apply the
corrections to your Device Settings, Go Back to return to a
previous step and adjust settings, or Cancel to exit the process
(progress will not be saved).

RELATED TOPICS

Add Galvo

Changing a Lens

Focusing

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

LightBurn-Pro calibration devices galvo hardware

laser-control modes-and-advanced-control

Dual Laser Control

LightBurn provides special setup options for machines with two
laser tubes. These settings will only be available when using DSP
devices.

ENABLE LASER 2 CONTROLS

Two options for working with dual lasers are available in the 
Basic Settings tab of Device Settings.

Turn on Enable Laser 2 Controls to expose switches in the Cuts /
Layers Window and Cut Settings Editor that will allow you to
enable or disable each tube for a given layer and adjust their
power settings separately.

Turn on Enable Laser 2 Offset to specify an offset to account for
the distance between the second and first laser head, if your
laser has dual heads in addition to dual tubes.

INDIVIDUAL LASER CONTROLS

The switches in the Cuts / Layers Window and Cut Settings Editor
are used to enable one or both lasers on a per-layer basis. Each
laser's Max Power and Min Power settings can be managed
individually, but all other settings are shared when both laser
lasers are enabled at the same time. 

In the Cut Settings Editor, both lasers' switches and power
settings are visible simultaneously. In the Cuts / Layers Window,
select the button for the laser you wish to adjust to show the
switch and cut settings for that laser.

• 

• 

• 
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Both Lasers Enabled at Once

The option to enable both lasers at once is intended for lasers
with dual heads. With both lasers enabled for the same layer, the
lasers will run simultaneously in tandem, meaning two copies of
the same output will be cut or engraved at once, without any
offset applied to the output from the second laser.

Make sure your laser heads are physically spaced far enough
apart from one another that each has room to cut or engrave the
entire graphic, without overlapping or running into the side of
your machine. This means that any graphic you run with both
lasers enabled must be narrower than the distance between the
two heads. 

Only One Laser Enabled at a Time

If each of your laser tubes is optimized for different processes,
you may choose to enable one laser for engraving and the other
laser for cutting. Any layer or Sub-Layer can be set to output
using only Laser 1 or only Laser 2.

To have one laser engrave a graphic and the other cut the outline
of the same graphic, create a Sub-Layer for the layer the graphic
is assigned to, and enable only the appropriate laser for the
operation assigned to each Sub-Layer. 

If you are engraving and cutting separate graphics in the same
job, set each to their own layer, and enable only the appropriate
laser for the operation assigned to each layer. 

If each of your laser tubes also has its own head, in order for
output from Laser 2 to align to output from Laser 1, you must
measure and apply an accurate Laser 2 Offset. 

See our Set Laser 2 Offset Guide for more information.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

advanced-features dual-laser
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5.5.5 Machine Management

Device Settings

BASIC SETTINGS

The Basic Settings tab of Device Settings contains the most
commonly used settings, and is available regardless of device
type.

The image below shows the Device Settings window for a DSP
device — several alternate options will be presented if you are
using a different type of device.

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a full list of
options and descriptions, for both DSP and GCode-based lasers.

The Basic Settings tab of Device Settings

Basic
Settings

The most
commonly
used device
settings.

GCode

Modify
GCode
output
for
GCode
Devices.

Additional
Settings

Settings
for
simulating
previews
and
estimating
time.

Custom
GCode

Advanced
GCode
customization
for the
Custom
GCode
device type.

Galvo
and
Basic
Settings

The
most
commonly
used
device
settings
for
Galvo
lasers.

Ports
and
Laser
Settings

Configure
a Galvo
laser's
ports and
laser
source.

Working Size

The maximum X (Width) and Y (Height) travel for your laser. This
sets the size of the work area in LightBurn, but does not affect
the laser itself.

Origin

The location of your laser's Origin, or home. If this is set
incorrectly, the orientation of your laser's output will be mirrored
or inverted.

For help with troubleshooting your laser's Origin, please see 
Troubleshooting: Wrong Orientation.

Laser Offset

If your laser has a red dot pointer for Framing and positioning,
this setting allows you to compensate for misalignment between
the pointer and the actual cutting location. Enable this setting to
shift the laser's output relative to the red dot location. 

See Laser Offset Setup for instructions on calculating the offset. 

Z Control

This section contains settings for your laser's Z Axis, which
controls the distance between the laser and the workpiece. The
options available will vary depending on what laser you're using.

Enable Z Axis

Enable this to allow LightBurn to control the Z Axis of your
machine.
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Enabling this setting means that LightBurn will always emit Z
values for a running job. If using this setting, you must either
enable Relative Z moves only or set a Material height value in
the Cuts / Layers window.

If you do not take either of these steps, the default Material
height of 0 may result in your laser head crashing into the
workpiece.

Reverse Z Direction

If your machine's Z Axis moves in the opposite direction of what
you expect, toggle this switch to flip the direction for Z moves.

Relative Z Moves Only

This setting treats the machine's height at the start of the job as
0, and uses that height as the starting point for all Z moves.
Material height is ignored when Relative Z Moves are enabled.

This is the simplest way to work, as you set your focus according
to the manufacturer's directions and LightBurn will treat that
height as the correct height to start from.

For DSP devices, LightBurn must be connected to your machine
to use Relative Z moves.

Optimize Z Moves

By default, LightBurn always retracts the Z back to the starting
height after completing a shape with a Z Offset. This is done to
prevent the laser head from crashing into the workpiece.

With Optimize Z Moves enabled, LightBurn will only issue Z
moves when the Z height actually changes. If you know your
material is flat and that none of the Z moves will result in the
laser moving low enough to run into anything on your work
table, this can save a lot of time.

OMTech Polar

Enable this if using an OMTech Polar device.

General Options

Tab Pulse Width

When using Tabs, the Tab Pulse Width allows for additional
control of the Tab Cut Power setting. Change this length to
increase or decrease the width of the pulses used to simulate
reduced power cuts.

Enable Job Checklist

When this setting is enabled, LightBurn will display a text box
with a list of items whenever you Start or Send a job to your
laser. This is typically used as a reminder of things that need to
be done before starting the laser, such as turning on an exhaust
fan or putting on protective glasses.

To create a custom checklist, click the Edit button.

Frame Continuously

This setting alters the behavior of the Frame button. When
enabled, LightBurn will frame your project repeatedly until
stopped, instead of a single time.

Continuous Framing is often useful for adjusting material
placement within the laser. 

Overwrite Files on Device by Default

When enabled, LightBurn will automatically overwrite pre-
existing files of the same name when sending a project to your
laser's controller. Keep this setting disabled to receive a warning
message whenever LightBurn will need to overwrite a file in
order to send a new one. 

Scanning Offset Adjust

This setting is used to compensate for minor delays in your
power supply causing the laser's firing point to be a little behind
where it should be when scanning back and forth at high speeds.
For more information, see Scanning Offset Adjustment. For an
example of what Scanning Offset problems might look like,
please see Troubleshooting: Blurry Edges.

The Add, Delete, Import, and Export buttons allow you to
create, edit, load, and save your Scanning Offset settings. You
can use this to Import settings provided by your machine's
manufacturer, share adjustments with other users, or back up
your settings before making changes.

Other Options

GCode Devices

These settings are only available for GCode-based lasers.

Auto-home on startup

If your laser has homing switches, enable this to automatically
home the machine on startup. For lasers without homing
switches, disable this setting to prevent GRBL Error 5.

Swap X/Y output to laser

Enable this setting to rotate your LightBurn Workspace to match
your machine's physical orientation, and swap X/Y output to your
laser accordingly.

The green dot in the dialog window indicates the location of the
machine's 0,0 point (the location it homes to) in the machine's
physical orientation. Select the image that matches your
machine's orientation, then click OK. LightBurn will automatically
adjust your Origin and rotate your Workspace and output to your
machine to account for the new orientation.

This option is intended for machines with Y dimensions that are
longer than their X dimensions.

Warning

Info
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CNC Machine

Enable this setting if your machine has a rear right-origin and
uses a negative coordinate system. 

Fast Whitespace Scan

This setting boosts your laser's travel speed through blank areas
of an image engraving, if the speed you set here is faster than
your laser's engraving speed.

This can save a lot of time if you're engraving an image slowly to
get a good burn, particularly if there are large blank areas in the
image.

Since Marlin treats G0 and G1 moves identically, this value is
used to specify the speed for rapid moves. If you do not set this
value, LightBurn will use the same speed as the G1 moves.

Enable $J Jogging

Newer versions of GRBL (1.1 and later) can use this custom
jogging mode. $J Jogging, also called Continuous Jogging, has
several benefits over normal jogging:

It does not affect the GCode parser state.

If soft limits are enabled, jog commands that would go out of
bounds are ignored without triggering an error or alarm.

It allows for cancelling a jog move. After enabling Continuous
Jogging in the Move Window, hold an arrow key to begin
jogging in a direction, and release to stop (cancel) the move.

Enable DTR Signal

This setting controls whether LightBurn sends a Data Terminal
Ready signal to the controller to start serial communication.
Many programmable hobby-level controllers, including Arduino-
based systems, use the DTR pin to reset the controller. LightBurn
usually sets this value for you, but if your GCode controller won't
communicate, toggling this setting may help.

Enable laser fire button

Enable this setting to add a Fire button and power setting to the 
Move Window to allow you to turn on the laser at low power for
focusing, Framing, and positioning. When the Fire button is
enabled, you can hold the Shift  key while Framing to enable
the beam.

This setting should only be used for diode lasers, which generally
don't have a red dot pointer for Framing. This should never be

used for a CO2 laser, which has an invisible beam that could blind
you or start a fire.

Laser on when framing

This setting turns on the laser at the power level you specify
while Framing.

This changes the default behavior of the laser and can cause the
laser to fire when a user is not expecting it. Enable this setting
with caution, with a very low power level, and only when using a
diode laser.

Enable 'Out of Bounds' warning

Enable this setting to have LightBurn warn you if a job will cause
your machine to travel out of bounds. This setting requires that
your device has been properly homed and is reporting
coordinates correctly, and that your Workspace size is set
accurately in LightBurn.

Enable GCode Clustering

GCode Clustering condenses the commands sent to your device.
For devices that support it, this reduces the bandwidth needed
for communication and allows the controller's motion planner to
see further ahead. For devices that don't support this feature,
enabling it will result in a GRBL error. More information is
available in this post in our forum.

Return to Finish Position

This setting tells LightBurn to send the laser to the specified
position after a job is run. This requires that the job is running in 
Absolute Coords or User Origin mode. 

Air Assist

This setting determines whether LightBurn uses an M7 or M8
command to enable air assist.

S-value Max

This setting tells LightBurn how to represent 100% power for
GRBL and Smoothieware controllers. Current versions of GRBL
default to 1000 for this, while older versions use 255. This value
needs to match what your controller expects. Read more in 
GRBL: Low or No Power Output.

Baud Rate

This setting controls the speed at which LightBurn attempts to
communicate with your laser's controller.

LightBurn defaults to 115,200 baud for GRBL controllers and
250,000 baud for Marlin controllers. Some Marlin controllers use
115,200 baud, and some GRBL controllers go as low as 9600
baud. If you are having trouble communicating with your
controller and are certain the controller and firmware are
supported, contact the manufacturer for the correct baud rate
for the board, which may be different from the default value.

Transfer Mode

Note

• 

• 

• 

⇧

Safety Warning
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LightBurn defaults to the Buffered Transfer mode for
communication with GRBL devices. This is faster and more
reliable than the Synchronous Transfer mode. However, there
are a few devices that are incompatible with Buffered Transfer
mode. These devices will stutter, stop, or even restart when
buffered communication is selected. If you notice this
happening, try switching the Transfer mode to Synchronous.

DSP Devices

These settings are only available for DSP lasers.

Enable U Axis

Enable this setting to apply per-layer U Axis offsets. This is not
supported by all controllers.

Start and End Delay

Start Delay allows you to set a delay before the job starts
cutting, and End Delay allows you to delay the end of the job
after the cut is complete. This is typically used to allow the
exhaust fan to start up and spin down.

This feature is only available on Ruida controllers, and only works
if the controller's wiring is compatible. Your success in enabling it
will be dependent on your specific hardware.

Enable Laser 2 Controls

This setting enables controls for a second laser tube within the
same machine. Enable this setting only if your machine has two
laser tubes. 

Enable Laser 2 Offset

If you are using a dual head laser, use this setting to specify the
position of the second laser head relative to the main one.

See Dual Laser Control for more information on dual laser setup.

Increment Filename on Send

This option will automatically increment file names when sending
jobs to your laser, to make identifying separate runs easier and
maintain your file history. Your file name must contain a digit in
order to auto-increment. 

Disable Start Button

Use this setting to disable the Start button.

On some lasers, streaming a job with the Start button can be
unreliable, so this feature allows you to ensure that all jobs are
sent to the laser using the Send button, which transfers the
entire job to the laser before it can be started.

Check Bounds When Framing

Enable this setting to have LightBurn check that a job won't
travel out of bounds when Framing.

Network Timeout

This setting determines how long LightBurn will attempt to
communicate with a networked device before reporting a
communication failure. Increasing the value from the default of
5000 ms (5 seconds) can help with slower connections.

Troubleshooting

If you aren't seeing a setting you expected to see, check which
tab you're in and make sure it's applicable to your laser.

Related Topics

Settings/Preferences

Machine Settings

Devices

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

DSP GCode device-management device-settings

settings

• 

• 

• 

• 
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GCODE

The GCode tab of Device Settings allows for modification of the
GCode output for GCode devices. Please see Device Settings:
Custom GCode if you are using a Custom GCode device.

Click an option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

The GCode tab of Device Settings

Basic
Settings

The most
commonly
used device
settings.

GCode

Modify
GCode
output
for
GCode
Devices.

Additional
Settings

Settings
for
simulating
previews
and
estimating
time.

Custom
GCode

Advanced
GCode
customization
for the
Custom
GCode
device type.

Galvo
and
Basic
Settings

The
most
commonly
used
device
settings
for
Galvo
lasers.

Ports
and
Laser
Settings

Configure
a Galvo
laser's
ports and
laser
source.

Start / End Scripts

Some devices may need additional commands before or after
running a job. GCode entered into these boxes will be added to
the start or end of each job LightBurn sends to your device.

LightBurn does not validate whether these commands are valid
or safe. Any modifications here are done at your own risk.

Use G0 Moves for Overscan

Enable this setting to use G0 moves for overscan instead of G1.
Some controllers, such as FabCreator Smoothieware boards,
have a non-zero power value for their minimum output, causing
them to burn during the overscan portion of an engraving. If you
find that your laser doesn't shut off completely for overscan
moves, try enabling this setting.

Emit S Value With Every G1 Command

Enable this setting to have LightBurn specify the output power of
the laser with every move command, rather than only when the
power level changes. Enable this setting if your laser does not
turn back on after travel moves.

Troubleshooting

If you aren't seeing a setting you expected to see, check which
tab you're in and make sure it's applicable to your laser.

Warning

• 
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Related Topics

Settings/Preferences

Machine Settings

Devices

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

GCode device-management device-settings settings

ADDITIONAL SETTINGS

The Additional Settings tab of Device Settings controls the
settings used in Preview for simulating a preview and estimating
time. Changing these settings will not change anything about
how the job actually runs, but can make time estimates more
accurate.

The Additional Settings tab of Device Settings

• 

• 

• 
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Read From Controller

Use the Read From Controller button to sync these settings with
your laser's internal settings, providing much more accurate time
estimates without manual adjustment.

Manual Adjustment

Y Axis Speed and Acceleration values are often set lower than X.
Due to the greater mass of the Y Axis gantry, many lasers must
travel slower in the Y dimension to avoid slipping. 

Troubleshooting

If you aren't seeing a setting you expect to see, check which
tab you're in and make sure it's applicable to your laser.

Related Topics

Settings/Preferences

Machine Settings

Devices

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

acceleration accuracy device-settings preview speed

Note

Setting Description

Maximum Speed
X/Y

The maximum speed at which the
laser can travel on the X and Y
axes, individually.

Cut Acceleration
X/Y

The maximum rate at which the
laser can speed up or slow down
during Line operations.

Engrave
Acceleration X/Y

The maximum rate at which the
laser can speed up or slow down
during Fill operations.

Corner Accuracy A value used to estimate
cornering speed. Corner Accuracy
is not read from the controller.
Read more about how this value

Setting Description

works for lasers with GRBL
controllers here.

Minimum
Corner Speed

The slowest possible speed the
laser will turn corners at.

Cut Speed Scale Scales cut speed estimates by this
percentage when simulating job
times. Not read from controller.
Use this value to manually fine-
tune estimates.

Global Speed
Scale

Scales all estimates by this
percentage when simulating job
times. Not read from controller.
Use this value to manually fine-
tune estimates.

• 

• 

• 

• 
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CUSTOM GCODE

The Custom GCode tab of Device Settings allows for advanced
GCode customization when using the Custom GCode device type.

The Custom GCode tab of Device Settings

Basic
Settings

The most
commonly
used device
settings.

GCode

Modify
GCode
output
for
GCode
Devices.

Additional
Settings

Settings
for
simulating
previews
and
estimating
time.

Custom
GCode

Advanced
GCode
customization
for the
Custom
GCode
device type.

Galvo
and
Basic
Settings

The
most
commonly
used
device
settings
for
Galvo
lasers.

Ports
and
Laser
Settings

Configure
a Galvo
laser's
ports and
laser
source.

Custom GCode Options

In this section, you can set some baseline options for your
custom GCode profile.

GCode Commands

This section lists each command that can be customized. Leaving
a command blank will leave it unchanged from the default based
on your Custom GCode Options.

Name Description

GCode Flavor What flavor of GCode to use as a
base

Dwell Units Whether pause times are given in
seconds or milliseconds

Comment
Characters

What character(s) are used to
indicate comments

Suppress
Comments

Enabling this will strip all
comments from the GCode
LightBurn generates

Tool State
Automatic

Enabling this will cause the tool to
automatically turn on during a
cut move

Variable Laser
Power

Enabling this will allow you to
control the laser's power beyond
on and off
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The title indicates what command you're working with.

The text box contains the default value in gray text, if there is a
default. If there is no default value, the text box is blank.

Below the text box is a preview of what the output for the
command would look like, based on current settings.

Hover over a section for more detailed information. For
information on variables to use in the commands, see Custom
GCode Variables.

Custom GCode Variables

These variables can be used in your GCode templates. Some
variables are only available for MillMage.

Custom GCode Macros

Relative and absolute mode are controlled by the software, so if
you need to change it within your GCode template, use the
following macros to prevent the software overriding your
changes. You must always use |RESTORE|  when you're done to
ensure a return to the previous mode.

Optional and Required Values

Surrounding the letter before a variable with []  will tell
LightBurn that this portion of the command has not changed
since the last emit. Putting a *  in front of any variable will tell
LightBurn to skip the entire line if it has not been changed.

G1 X{x} Y{y} Z{z}  will always output the X, Y, and Z values.

G1 [X]{x} [Y]{y} [Z]{z}  will skip any values that have not
changed.

M106 S{*power}  this will output the M106  command only if it has
been changed.

Non-Printable / Non-Typeable Characters

Control characters can be output by using \x  followed by the
two digit hex value of the character. For instance, \x18  represents
an immediate job abort on a GRBL device.

Troubleshooting

If you aren't seeing a setting you expected to see, check which
tab you're in and make sure it's applicable to your laser.

Related Topics

Settings/Preferences

Machine Settings

Devices

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

GCode device-management device-settings settings

• 

• 

• 

Variable Description Availability

x X Axis position

y Y Axis position

z Z Axis position

r , a , u , rot , 
rotation

Rotary axis
position

x_probe X probe offset MillMage-only

y_probe Y probe offset MillMage-only

z_probe Z probe offset MillMage-only

s , speed Movement
speed

feed , feedrate Movement
speed

MillMage-only

p , power Laser Power

rpms , spindlespeed Spindle speed
or RPM/s

MillMage-only

dwell Dwell time

tool Tool number

Macro Description

|REL| Enter relative mode

|ABS| Enter absolute mode

|RESTORE| Restore previous mode

• 

• 

• 

• 

• 

• 

• 
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GALVO AND BASIC SETTINGS

The Galvo and Basic Settings tab of Device Settings is the
Galvo laser version of Basic Settings and contains the most
commonly used settings for Galvo lasers.

If you used the EZCAD importer when setting up your Galvo
laser, these settings will be pre-configured for you.

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

The Galvo and Basic Settings tab of Device Settings
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The most
commonly
used device
settings.
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GCode
output
for
GCode
Devices.

Additional
Settings

Settings
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simulating
previews
and
estimating
time.

Custom
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Advanced
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customization
for the
Custom
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and
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Settings

The
most
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used
device
settings
for
Galvo
lasers.

Ports
and
Laser
Settings

Configure
a Galvo
laser's
ports and
laser
source.

Field

These settings refer to the field — the area that the lens installed
in a Galvo laser can physically cover when focused. Changing
lenses requires going through setup and calibration again, and
we recommend setting up additional devices for each lens you
use with your Galvo laser.

Red Dot

The red dot laser is separate from the marking laser and is used
for framing and positioning. It fires through the same optics as
the marking laser, but may require fine-tuning for alignment. For
additional help, see our video on Galvo Laser Red Dot Alignment
below.

Info

Setting Description

Width/Height The size of the field for the
currently installed lens. Sets the
size of the Workspace in LightBurn.

Offset X/Y Fine-tune the position of the field
by offsetting it if needed.

Angle Rotational correction. Use this to
compensate for the Galvo head
being rotated relative to the
physical fixturing of your work.
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Galvo Configuration

Load COR File

This section allows you to import and apply EZCAD lens
correction files, also known as COR files. 

If your EZCAD folder contains a COR file, it will automatically
load when using the EZCAD importer during Setup.

If you skipped the importer, or you create a new COR file, you
can load it here.

If you don't have a COR file, you can enter lens correction
settings manually in the Per Galvo Settings below.

Per Galvo Settings (Galvo 1/Galvo 2)

Each Galvo head is responsible for an axis and can be fine-tuned
individually.

Frame Speed

The travel speed for the red dot laser while framing.

Jump Setting Defaults

Jump Settings control how the laser moves between cuts. Each
jump causes the mirror to shake, with higher speeds and longer
distances increasing the shaking. If you have wobbly lines at the
start of a marking move, you may need to increase the delay
and/or reduce the speed of jumps.

Delay Defaults

Delay settings control the delay between starting (or stopping)
mirror movement and firing the laser. Laser On/Off TC and End
TC control the delays for the start and end points of a path. 
Polygon TC controls the delays for other corners within a path.

Other Options

Setting Description

Offset X/Y Fine-tune the position of the
framing output.

Scale X/Y Fine-tune the size of the framing
output.

Rest Pos X/Y Set the resting position of the red
dot when not in use.

• 

• 

• 

Setting Description

Galvo # is X Axis Specifies which axis is responsible
for horizontal motion. If your
output is rotated 90 degrees,
switch which Galvo is toggled on.

Reverse
Direction
(Negate)

Reverses the direction for the
selected Galvo. If output to an
axis is mirrored or inverted,
toggle this setting.

Scale Percentage by which to scale
output for a given axis.

Bulge Adjusts for distortion near the
center of the engraving field.

Skew Adjusts for distortion near the
edges of the field.

Trapezoid Adjusts corner tapering to fix
keystoning.

Setting Description

Jump Speed The speed at which the galvo
mirrors move between cuts.
Higher values will make your job

Setting Description

run faster at the cost of increased
vibration for the mirrors.

Min Jump Delay The minimum time the laser will
wait to allow the galvo mirrors to
stop shaking.

Max Jump Delay The maximum time the laser will
wait to allow the galvo mirrors to
stop shaking.

Jump Distance
Limit

Any jump above this limit will use
the Max Jump Delay setting
above. Jumps below this limit will
use a delay value between the
minimum and maximum settings.

Setting Description

Laser On TC Microseconds the laser will wait to
fire after the mirrors begin to
move. Too high a value will leave
gaps, while too low a value may
cause excessive burning at the start
of a cut.

Laser Off TC Microseconds to delay turning off
the laser at the end of a marking
move. Too high a value may cause
excessive burning at the end of a
cut, while too low a value may
cause gaps.

End TC Microseconds to pause the laser's
movement after completing a cut.

Polygon TC Microseconds the galvo head will
pause when turning corners. Too
long a delay may cause excessive
burning, while too short a delay can
cause rounded or cut-off corners.

Setting Description

Play Sound on
Job Finished

If enabled, the computer will play
a sound when your current run is
complete.

Require
Framing Before
Start

If enabled, the Start Button in the
Laser Window will open the Live
Framing window instead of
starting the laser directly.

Enable Job
Checklist

If enabled, LightBurn will display a
window with user-configured text
before running the laser. The user
will need to press OK to confirm
they're ready before the laser will
start. This is often used for a
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Troubleshooting

If you aren't seeing a setting you expected to see, check which
tab you're in and make sure it's applicable to your laser.

Related Topics

Settings/Preferences

Devices

Galvo Lens Calibration

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

device-management device-settings devices galvo

settings

PORTS AND LASER SETTINGS

The Ports and Laser Settings tab of Device Settings allows you
to configure your laser's Input and Output (IO) ports and laser
source.

The Ports and Laser Settings tab of Device Settings

Setting Description

checklist of reminders before
running the laser. Use the Edit
button to create or edit the
checklist.

• 

• 

• 

• 
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IO Ports

This section controls external switches or features attached to
the laser's control board.

Most boards use a High signal to indicate that a port is active,
but some instead use a Low signal as the trigger. If most or all of
your ports are green by default, you'll probably need to change
the trigger type to Low using the button next to the port
selection.

The numbered boxes at the top show the current state of each
port. Red indicates that the port is currently Low (off), while green
indicates that the port is currently High (on).

Use the dropdowns to select a port to assign to a feature, and
use the High/Low button to set the trigger type. If the port is set
to None, the feature is disabled or unavailable.

Laser Source Configuration

Laser Source settings should be imported from EZCAD or copied 
very carefully if entering manually. Incorrect settings may
damage your laser.

Low vs High

Setting Description

Ready Light Select the appropriate port to
enable on/off control of LEDs
mounted on the galvo head to
illuminate your work.

Busy Light If you have a light hooked up to
indicate the laser is in use, select
the appropriate port to allow

Setting Description

LightBurn to enable it when the
laser is in use.

Red Dot If you are using an external switch
to enable the red dot laser, select
the appropriate port.

Red Dot Always
On

Enable this setting to force the red
dot laser to be always on.

Enable Blanking If enabled, attempts to turn off
the red dot laser between drawing
shapes. Not supported on all
devices. Disable if your laser will
not frame when you select 
Contour Framing.

Start Framing Select the appropriate port to
enable an external switch to start
framing.

Start Marking Select the appropriate port to
enable an external switch –
typically a foot switch – to start an
engraving job. If not using a foot
switch, it's best to set this to None
to prevent accidental firing as a
result of static or electrical noise.

Require 'Full
Pulse' to Start

Enable this toggle to require the
external switch to activate and be
released before starting a job.

Stop Marking Select the appropriate port to use
an external switch to stop running
an engraving job.

Done Marking Select the appropriate port to
send a signal when an engraving
job is complete.

Door Protect Select the appropriate port to look
for a signal from an enclosure's
safety interlock to prevent
unprotected laser firing.

Warning

Setting Description

Laser Type The source for the Galvo laser.
Currently CO2, Fiber, UV, or SPI.

Fiber Type For Fiber lasers, the specific
manufacturer or type of Fiber
laser. Certain options enable
additional settings.

Enable Q-Pulse
Width Setting

MOPA Fiber lasers only. Allows
fine adjustment of the laser's
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Troubleshooting

If you aren't seeing a setting you expected to see, check which
tab you're in and make sure it's applicable to your laser.

Related Topics

Settings/Preferences

Devices

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

device-settings galvo

DEVICE SETTINGS

The Device Settings window contains device-specific settings for
your laser. The settings available change based on the device
selected — not all settings described below will necessarily be
shown in your instance of LightBurn. 

Access Device Settings by selecting Edit → Device Settings or by

clicking  in the Main Toolbar.

Select the correct device in the Devices dropdown in the Laser
Window.

Device Settings Window

The Device Settings window

The Device Settings window is split into several tabs, not all of
which will be available for all machines.

Setting Description

pulse timing in Cut Settings.
Smaller timing values increase the
density of the pulse's impact.

MO Enabled
ONLY When
Running

MOPA fiber lasers only.

Open MO Delay MOPA fiber lasers only. Allows fine
control of the laser's frequency.

Enable PWM Always enabled for Fiber and SPI
lasers. Toggle on or off for CO2
Galvo lasers, to enable or disable
PWM. When enabled, adjust the
valid range of minimum and
maximum frequencies in the
boxes below.

Enable Tickle For CO2 Galvo lasers only. CO2
lasers require constant low power
to fire consistently at low powers.
Enable Tickle to provide this
constant low power. Appropriate
settings for Tickle Pulse and
Frequency should be provided by
your manufacturer.

Enable First
Pulse Killer
(FPK)

For CO2 Galvo lasers only. CO2
lasers require a higher power
draw when initially turned on. FPK
settings allow you to tune that
initial pulse. Check with your
manufacturer for settings, but this
can be found through trial and
error if needed.

UV Min/Max
Pulse

For UV Galvo lasers only. Minimum
and maximum Q-pulse values to
use.

SPI Simmer
Current

For SPI lasers only.

• 

• 

• 

Have Multiple Lasers?
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Troubleshooting

If you aren't seeing a setting you expected to see, check which
tab you're in and make sure it's applicable to your laser.

Related Topics

Settings/Preferences

Machine Settings

Devices

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

additional-settings basic-settings delay device-settings

dual-laser laser-offset offset origin scanning-offset

settings u-axis working size z-control

Devices

The Devices window shows all the devices you've added to
LightBurn. Use this window to add new devices, Import and 
Export devices, and manage existing devices.

ACCESSING THE DEVICES WINDOW

To open the Devices window, click the Devices button in the 
Laser Window.

MANAGING DEVICES

Device List

The main section of the Devices window lists all the devices
you've added to LightBurn. Click a machine to select it and see a
device summary below the Device List. Some buttons in this
window are only available with a device selected.

On a fresh install, this list will be empty. LightBurn will ask you to
set up a device in order to continue. There are a few ways to do
this:

• 

• 

• 

• 

5.5.5 Machine Management

- 340/400 - ©️ LightBurn Software, LLC

https://forum.lightburnsoftware.com/
mailto:support@lightburnsoftware.com
../../img/Ref-Devices.png
../../img/Ref-Devices.png
../../img/Ref-Devices-DevicesButton.png
../../img/Ref-Devices-DevicesButton.png


Use Find My Laser to attempt to automatically detect a laser
connected over USB.

Use Create Manually to manually set up a laser that can't be
automatically detected.

Import a .lbdev  file to load a pre-configured machine profile.

You must add at least one device in order to use LightBurn. If you
don't have a laser yet, you can choose Create Manually and
select No Machine to create a device to act as a placeholder.

Find My Laser

Starts the Device Discovery Wizard to attempt to automatically
detect a laser connected over USB. If your laser is not detected,
use Create Manually.

Create Manually

Starts the New Device Wizard to manually set up a laser. If you
don't have a laser yet, a No Machine option is available.

LightBurn Bridge

Starts the Bridge Discovery Wizard to set up a LightBurn Bridge
device.

Import

Imports a .lbdev  file to recreate a device you've exported from
another LightBurn installation. See Migration for more
information.

Make Default

Sets the currently selected device as the default. If you have
multiple devices, use this to set which device is active when
LightBurn launches. The current default device has an asterisk
before the name.

Edit

Opens the New Device Wizard to go back through the device
creation process on the selected laser. You can also double-click
any device in the list to re-open the New Device Wizard for that
device.

See Device Settings for help with settings not covered in the
device creation process.

Remove

Removes the selected laser from LightBurn. Make sure you have
the right device selected!

Export

Exports a .lbdev  file for the selected device. Use this to back up a
device or recreate the device on a different computer. See 
Migration for more information.

Devices Context Menu

Right-click any device in the list to open a context menu with
additional options.

Duplicate

Opens the New Device Wizard and populates each step with
identical settings from the selected device, with the exception of
appending (Duplicate) to the name. You can adjust any setting,
including the name, during this process. 

Set Icon

Opens your system's file browser, where you can select a custom
icon for the selected device from your computer. The icon must
be 1024 x 1024 pixels or fewer in size.

Order by Name

Rearranges the list of devices in alphabetical order.

Order by Type

Rearranges the list of devices by type. Sections of types are
arranged in alphabetical order. 

OK and Cancel

Click OK to save any changes you've made and exit the Devices
window.

Click Cancel or X-out of the window to discard any changes you
don't want to save. 

TROUBLESHOOTING

If the button you want is disabled, make sure you have a
device selected.

If you haven't added any lasers yet and try to close the
window, LightBurn will open a window asking you to either go
back and create a device profile, create a dummy machine, or
quit LightBurn. Use the Create a dummy machine button if
you don't have a laser to add yet.

RELATED TOPICS

Migration

Device Settings

Add a Laser

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

LightBurn-Bridge create-manually find-my-laser

laser-control laser-window machine-management

• 

• 

• 

• 

• 

• 

• 

• 
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Machine Settings

The Machine Settings window allows you to view and edit
firmware settings on lasers with Ruida, TopWisdom, or GRBL-
based controllers. 

To open the Machine Settings window, go to Edit → Machine
Settings.

Left: The Machine Settings window for a GRBL controller.
Right: The Machine Settings window for a DSP controller. 

WORKING WITH MACHINE SETTINGS

The settings available are determined by your laser controller's
firmware. In general, if your laser is working correctly, you can
(and should) leave the settings here alone. For additional
information on specific settings, consult your laser's
manufacturer, or see the documentation for your laser's
controller.

Outputs Setup / Vendor Settings

This section will display differently depending on whether you
are connected to a DSP or GRBL laser. All settings in this section
are hidden by default, and you'll see a warning message if you
click to expand and view them. These settings are typically set by
the manufacturer, and should generally be left alone unless
instructed otherwise by support.

Save to File

Saves your current controller firmware settings to a .lbset  file.
We strongly recommend using this feature to back up firmware
settings before making any modifications.

Load from File

Loads a .lbset  file and overwrites all firmware settings with its
contents. In some cases, your laser manufacturer may make this
file available as a backup.

This will overwrite all values. Make sure you back up your
existing settings first using the Save button, and only load
parameters from a known and trusted source.

Load From Backup

Use Load from Backup to restore automatically-generated
backups of firmware settings. LightBurn will automatically store
backups each time you Write new settings to your controller.

Read

Reload the settings from the controller. Any changes that haven't
been written to the controller will be lost.

Write

Writes all currently modified settings back to the controller,
saving your changes. Changes are not saved unless you click 
Write.

Calibrate Axis

The Calibrate Axis tool is a shortcut to help you calculate the 
Steps/mm or Step Length value for each axis, if they need
adjustment — if the current values are inaccurate, output may be
stretched or squished. 

See Explainer: Steps/MM for more information.

To use Calibrate Axis:

Warning
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Choose an axis to calibrate in Calibration Axis.

Enter a distance to travel in Requested Distance. Larger distances
can be helpful when measuring with less precise tools.

Mark the start point, move the laser the specified distance, and
mark the end point. The easiest way is to burn a line the specified
length, although you can also use the Jog functions in the Move
Window or built into some controllers.

Measure the actual distance traveled and enter it into Actual
Distance.

Click on Write to save the value to the controller.

This may need to be done multiple times, especially for less
precise measuring tools, to reach an acceptable level of accuracy.

TROUBLESHOOTING

If LightBurn is unable to read the Machine Settings, make
sure your laser is connected and turned on.

See Troubleshooting: Connection Issues for help connecting to
your laser.

RELATED TOPICS

Device Settings

Console Window

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

firmware machine-management machine-settings

settings troubleshooting

Get Controller Info

The Controller Status Info window provides information about
your connected laser's controller. It primarily shows usage
statistics, but also contains information about the controller's
firmware version.

To view Controller Info, go to Edit → Get Controller Info.

Get Controller Info is only available for lasers with Ruida
controllers.

CONTROLLER STATUS INFO

TROUBLESHOOTING

If LightBurn is unable to open the Controller Status Info
window, make sure the laser is connected and turned on.

See Troubleshooting: Connection Issues for help connecting to
your laser.

RELATED TOPICS

Device Settings

1. 

2. 

3. 

4. 

5. 

• 

• 

• 

• 

Note

Name Description

Total 'on' time Total time the laser has been on
for.

Total job processing
time

The total time the laser has
spent processing jobs sent to it.

Previous job
processing time

The time the laser spent
processing the most recent job
sent to it.

Total job 'laser on'
time

The total time the laser has
spent running jobs.

Total job count The total number of jobs run on
the laser.

X Total travel The total horizontal distance
traveled in meters.

Y Total travel The total vertical distance
traveled in meters.

Mainboard
firmware version

The firmware version installed
on the laser controller.

• 

• 

• 
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Machine Settings

Devices

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

device-management devices laser-control

machine-management troubleshooting

Console Window

The Console Window displays messages from your laser's
controller and commands sent to it by LightBurn. You can also
input direct commands to your laser through this window. 

The Console Window functions are only available when LightBurn
is directly connected to a GCode-based laser. 

Users with DSP or Galvo lasers with Ruida, TopWisdom, Trocen,
EZCAD2 or BSL boards cannot use the Console Window to
communicate with their laser's controllers.

ACCESSING THE CONSOLE WINDOW

If you have a GCode-based device profile selected, the Console
Window will be located in the upper right side of LightBurn,
docked behind the Cuts / Layers Window, by default. 

If you have closed the Console Window, go to Window → 
Console to re-enable it. To restore it and all other windows to
their default positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

STARTUP MESSAGE

When you first connect to your laser you will see a response
message in the Console Window, indicating that LightBurn is
successfully communicating with the controller. 

The startup response message displays the type and specific
version of firmware your laser's controller is running. Most
GCode-based lasers run GRBL firmware, version 1.1f or later. 

• 

• 

Note

Tip
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If you do not see a similar message from the controller when you
start up and attempt to connect to your laser, see 
Troubleshooting: Connection Problems. 

ERROR MESSAGES

The Console Window will sometimes display alarm or error
messages sent to LightBurn by the laser's controller, indicating
that there was a problem with the machine's operation. 

See Troubleshooting: GRBL Errors to find solutions to common
alarms and errors.

COMMON GRBL COMMANDS

Use the text box in the Console Window to directly enter
commands to your laser's controller. These commands are only
valid for lasers running GRBL firmware.

Request Information

Use the following commands to prompt your laser to return
information on its settings or status.

$I : display the controller's firmware version.

$$ : display GRBL settings. See the official GRBL
documentation for more information on each setting.

$# : display stored offsets in the machine's coordinate systems.

? : display status and current position.

Alter Settings and Status

Use the following commands to adjust firmware settings or
change machine status.

$X : unlock machine if it has been locked due to an alarm or
error.

$[setting]=[value] : adjust a specific GRBL setting by entering $ ,
followed by the number of the setting to be adjusted, = , and
the new value to assign to the setting.

Example command: $110=6000

RST=# : reset all offsets stored in the machine's coordinate
systems.

RST=$ : restore all GRBL settings to "factory" default.

RST=* : reset all EEPROM data used by GRBL, including all
offsets stored in the machine's coordinate systems and GRBL
settings.

Do not reset these settings unless directed by to do so by your
machine's manufacturer, or LightBurn support. 

In most cases, resetting GRBL settings restores all values to
those set by your machine's manufacturer, but can sometimes
restore them to stock GRBL settings, which will necessitate
significant reconfiguration in order to operate your laser. 

MACROS

Use the Macro buttons to store frequently used commands. 

Right-click a Macro button to open a window with Macro options.

Name the Macro according to the commands you'll be entering.

Enter one or more commands to send to the controller when the
Macro button is left-clicked.

Click OK to save the Macro, or Cancel to discard changes.

SHOW ALL

Enable the Show All switch to display all communications
between LightBurn and your controller. When Show All is
disabled, the Console Window will display startup messages,
simple commands, alarm or error messages, and all responses to

• 

• 

• 

• 

• 

• 

• 

• 

• 

• 

Warning

1. 

2. 

3. 

4. 
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status queries, but hide extensive commands such as those used
to jog or fire your laser.

RELATED TOPICS

Identify Your Laser 

Troubleshooting: Connection Problems

Troubleshooting: GRBL Errors

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

GCode GRBL UI change-settings commands

communication console control error-messages

firmware macros

File List Window

Use the File List Window to browse and manage files stored on
your laser's controller. This window is only available for users
with DSP controllers that allow saving files to the controller.

ACCESSING THE FILE LIST WINDOW

If you have a DSP device profile selected, the File List Window is
located in the upper right side of LightBurn, docked behind the 
Cuts / Layers Window, by default.

If you have closed the File List Window, go to Window → File List
to re-enable it. To restore it and all other windows to their default
positions, go to Window → Reset to Default Layout.

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

FILE LIST WINDOW OPTIONS

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

Select File

Select a file from the list to enable all relevant buttons.

• 

• 

• 

Tip
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Refresh

Queries the DSP controller to update the list of files stored on the
laser file system.

Start

Commands the laser to run the selected file.

Upload

Opens your system's file browser, where you can select and send
any files previously saved to your computer in machine-specific
format to the laser's controller. 

Use the Send button in the Laser Window to upload the current
project in the LightBurn Workspace.

Delete

Removes the selected file from the DSP controller file system. 

Deleted files cannot be recovered.

Start deleting from the bottom of the list. Starting from the top
of the list may lead to extended file compaction time.

Calc Time

Press the Calc Time button to begin computing the job
completion time for the selected file. The Calc Time button is
available only on supported DSP controllers (Ruida). This can take
a considerable amount of time for engraving jobs, as the
controller is simulating the job through the onboard DSP
microprocessor. Once complete, the calculated completion time
will be shown in the Info column.

Delete All Files

Removes all files from the DSP controller file system.

Deleted files cannot be recovered.

RELATED TOPICS

File Management

File Menu

Laser Window

Identify Your Laser

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

DSP Ruida file-list laser-control

machine-management

Upload Current Project

Warning

Tip: Ruida Controllers

Warning

• 

• 

• 

• 
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LightBurn Bridge

The LightBurn Bridge was created by LightBurn to simplify
Ethernet connections to Ruida controllers, especially for
computers without Ethernet ports or where running a cable
between the laser and computer is impractical. The LightBurn
Bridge connects to your laser with an Ethernet cable and to your
computer using Wi-Fi, and acts as a relay between the two. There
are no drivers to install, and the Bridge typically sends data much
faster than a USB connection.

LightBurn Bridge

LightBurn Bridge is intended to be an appliance. The software is
thoroughly tested, but we do not support modifications to the
hardware or firmware. If you alter the system to add
functionality beyond what is covered here or in the LightBurn
Bridge Guide, we will not be able to provide support.

BASIC SETUP

The steps below cover basic setup for the LightBurn Bridge. For
additional help or more advanced configuration, please see the 
LightBurn Bridge Guide.

Hardware Setup

Before you can configure the Bridge in LightBurn, you will need
to connect the hardware and set the appropriate IP address on
your Ruida controller:

Use the Ruida control panel on your laser to set the IP address
to 10.0.3.3.

Use an Ethernet cable to connect the Bridge to the laser's
Ethernet port.

Power up the Bridge with its power adapter.

Add Device to LightBurn

In LightBurn's Devices window, click LightBurn Bridge to open
up the Bridge Discovery Wizard, which will walk you through
connecting LightBurn to the Bridge. If you need to go back later,
you can double-click the laser in the Devices window to re-open
the wizard and change the LightBurn Bridge configuration, or
you can adjust your device's configuration from Device Settings,
just as if you were connecting directly to the laser.

TROUBLESHOOTING

If you're not sure which corner to use for the origin, power on
your laser. The corner the head goes to is your origin.

The LightBurn Bridge is only for use with Ruida controllers.
Other lasers will not work with it.

RELATED TOPICS

Devices

LightBurn Bridge Guide

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

DSP Ethernet Ruida Wi-Fi bridge

Warning
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• 

• 

• 
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5.6 Camera

5.6.1 Camera Selection Helper

The Camera Selection Help window provides information to
help you select an appropriate camera for your laser. The
information provided is specifically for the cameras sold on 
LightBurn's website, which are known to work well with
LightBurn and have calibration presets built into the software for
easier Lens Calibration.

Possibly. Interactions between cameras and computers are
complex, and although a wide range of cameras are compatible
with LightBurn, we can't guarantee your camera will work. If you
want to try using your own camera, make sure it's a fixed-zoom
USB camera.

Selecting a Camera

To select a camera, you'll need to know two things:

The size of your laser's work area, in millimeters.

The distance between the height from which you want to mount
the camera and the surface of your laser's work area.

Diagram showing ideal mounting location

To select a camera:

Enter the machine size into the Camera Selection Help window.

Look through the list to find a camera with a minimum mounting
height about 2 inches less than the height you intend to mount at.
This leaves room for adjustment. 

Double-click an entry in the list to visit the product page to
purchase it.

Troubleshooting

Some computers may cause complications with the use of
cameras. In some cases – especially with newer computers such
as M1 or newer Macs – this comes from incompatibilities
between USB 3.0 ports and older USB 2.0 cameras. Try using a
USB 2.0 hub or adapter between the camera and the computer.

See Camera Troubleshooting for more information.

Related Topics

Camera Installation and Focusing

Calibrate Camera Lens

Calibrate Camera Alignment

Camera Control Window

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

camera help help-menu troubleshooting

Can I Use a Camera I Already Have?

1. 

2. 

1. 

2. 

3. 
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5.6.2 Camera Installation and Focusing

The best place to mount an overhead camera is directly above
the center of the bed of the laser, with the bed completely visible.
The best way to accomplish this is usually to mount the camera
on the inside of the lid, so the placement is correct when the lid is
open.

Diagram showing ideal placement

Camera installed in a laser

Mounting tips:

The camera should be focused as well as possible. Most
LightBurn cameras are manually focused by gently twisting
the lens.

The camera must be solidly mounted to be in exactly the same
position when using it as it was when you performed the 
alignment process. If you mount it to the lid of your laser,
make sure the lid opens to the same place every time. You can
use a cord or rod to ensure the lid is always at the same
position when opened.

If your camera is in a mount, make sure it doesn't move within
the mount. A small piece of EVA foam or even tissue can hold
the camera securely in the mount.

Mount your camera so it isn't in the path of the laser head, and
run the cable so it is not in the path of the beam. Ramming the
laser head into your shiny new camera is a great way to
increase your blood pressure.

Focus the camera so as much of the bed is in focus as possible.
Some cameras, like the 5mp-60, have a narrow focus depth,

and if mounted high, can be tricky to focus. If this happens,
focus on a circle that is roughly halfway from the center of the
bed to the edge of the image, like this:

If you can't get the entire area in focus, try to focus approximately
where the green circle is

The camera system depends on the camera being in the same
position relative to the work area of your laser and the same
distance from the top of the material. If your laser uses a
variable focus distance instead of a variable height work table,
you will need to align for the material height you are using.

Cameras used with LightBurn should plug in to your computer
as directly as possible. An active USB 2.0 amplifier to extend the
distance may work, but is not guaranteed. Do not connect your
USB camera to any USB port on your laser. USB 2.0 has a native
max length of approximately 16 feet. (5 meters).

To use LightBurn's camera functionality, you must use Absolute
Coords mode, so LightBurn can accurately position the work. If
you use an older Trocen controller, they do not allow setting this
mode from software, so you must change the working mode
through the controller menu.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

camera

• 

• 

• 

• 

• 

Warning

Info

Info
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5.6.3 Camera Control Window

The Camera Control Window is where you capture and adjust
an Overlay produced by a camera, allowing you to position
designs directly over objects in your laser's work area. You can
also trace artwork or objects placed in your laser and captured by
the camera.

To use all of the features in the Camera Control Window, you
must first properly Calibrate and Align your camera.

Accessing the Camera Control Window

The Camera Control Window is not enabled by default. To
enable it, go to Window → Camera Control.

The Camera Control Window will appear docked behind the 
Cuts / Layers Window on the upper right side of your screen.
Click the Camera Control tab to bring the Camera Control
Window to the front. 

The layout of LightBurn is highly customizable. For more
information on enabling and disabling windows and toolbars, or
rearranging the default layout, see Customizing the LightBurn
Window.

Camera Control Window Options and Settings

Click any option in the image below to jump directly to the
relevant section for that option, or scroll down for a list of
options and descriptions.

CAMERA SELECTION MENU

Opens a dropdown menu where you can select the appropriate
camera — in order to use all the features in the Camera Control
Window, this must be the same camera you selected during the 
Calibration and Alignment process. 

If you accidentally select the incorrect camera in version 1.7.00,
you will lose your Camera Calibration data, and will need to
recalibrate. 

Camera Information Tooltip

After selecting a camera, hover over it to view information on
that camera, indicating its Resolution and whether it is 
Calibrated and Aligned.

A camera that is properly set up will have its Resolution indicated
at the top of the tooltip, followed by the words Calibrated,
Aligned.

A camera that has not yet been set up will have its Resolution
indicated, followed by the words Not Calibrated, Not Aligned.
Perform the Camera Calibration and Alignment processes to use
your camera.

Note

Tip

Warning
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Finally, if your camera's calibration was performed at a different
Resolution than the one it is now presenting, you will see two
Resolutions indicated. 

If you see a discrepancy in these resolutions, verify that you've
selected the correct camera from the dropdown menu. 

If you're sure you have, you'll need to perform the Camera
Calibration and Alignment processes over again. 

If the problem reocurrs with the same camera, it may not be
fully compatible with LightBurn.

UPDATE OVERLAY

Captures a new image to use as an Overlay for your Workspace.

You can also click the Update Overlay icon  in the 
Main Toolbar, or press Alt / Option + C .

Using the Overlay

When you press Update Overlay, the Start From mode in the 
Laser Window is automatically set to Absolute Coords. As long
as this mode remains selected, anything you place in the
LightBurn grid will be output in the corresponding location in
your machine's work area. Position graphics over objects
captured in the Overlay to engrave or cut directly on them. 

If you switch to an alternative Start From mode, your graphics
will no longer be aligned to the objects visible in your Overlay.

Graphics positioned over a physical object in an Overlay.

The final result of the engraving on the object.

If you completed the Camera Alignment process for a Head-
Mounted camera, see Head Mounted Camera — Capturing an
Overlay for information on producing an Overlay.

TRACE

Captures an image and opens the Trace Image dialog window,
where you can adjust settings to produce a vector graphic from
the captured image.

It's likely that the artwork you're tracing won't take up the
camera's entire view. Click and drag within the Image Trace
dialog window to select a specific area of the capture to trace. 

• 

• 

• 

⎇ ⌥

Warning

Head-Mounted Camera Overlays

Tip
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SAVE SETTINGS

Saves any adjustments you've made in the Width and Height or X
and Y Shift fields.

AUTO EXPOSURE

The Auto Exposure and Auto Brightness switches are available
on Windows only — on macOS, Exposure and Brightness are
always automatic.

Leave the switch enabled to set camera Exposure automatically,
or toggle it off to manually adjust exposure using the slider
below.

AUTO BRIGHTNESS

Leave the switch enabled to set camera Brightness
automatically, or toggle it off to manually adjust brightness using
the slider below.

FADE

Toggle whether or not the Overlay in your Workspace is dimmed.

A faded Overlay

An unfaded Overlay

SHOW

Toggle whether or not the Overlay in your Workspace is visible.

WIDTH AND HEIGHT

Use Width, Height, X, and Y Shift to fine-tune placement and
scale if your Overlay's alignment is close, but not quite accurate.
For larger discrepancies, see Troubleshooting: Using a Camera
— Overlay Misaligned.

The Width and Height fields increase or decrease the size of the
Overlay in the X (Width) or Y (Height) dimension.

X AND Y SHIFT

The X and Y Shift fields move the Overlay left, right, up, or down,
in the X and Y dimension.

PREVIEW CAPTURE

The image at the bottom of the Camera Control Window is the
pre-processed picture from your camera. In order to produce an
accurate alignment, the camera must be able to see your laser's
entire work area in its pre-processed field of view.

Camera Control Window Context Menu

Right-click anywhere in the Camera Control Window to open a
context menu with additional options.

CAMERA SELECTION HELP

Opens the Camera Selection Help dialog window.

EXPORT CAMERA SETTINGS

Opens your system's file browser, where you can name and select
a location to save your camera settings on your computer. The
file will be saved with the .lbcm  extension, and can be
transferred to another computer, where it can be imported.

IMPORT CAMERA SETTINGS

Opens your systems file browser, where you can name and
navigate to the location of a previously saved .lbcm  file, select,
and Import it, to load the settings contained in the file. 

CALIBRATE CAMERA LENS

Opens the Lens Calibration Wizard.

CALIBRATE CAMERA ALIGNMENT

Opens the Camera Alignment Wizard.

Related Topics

Camera Selection Helper

Note

Tip

• 
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Camera Installation and Focusing

Calibrate Camera Lens

Calibrate Camera Alignment

Troubleshooting: Using a Camera

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

camera output-and-positioning

• 

• 

• 

• 
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5.6.4 Calibrate Camera Lens

Calibration and alignment are both essential to proper camera
setup. Don't forget to go through the alignment process after
completing calibration.

Compensates for camera lens distortion when producing an Overlay.

Location

Laser Tools → Calibrate Camera Lens

Camera lenses are not perfectly flat, and distort the image they
capture. This effect is stronger on the fisheye lenses needed to
capture the working area of larger lasers. 

To use your camera, you must compensate for this distortion using
the Lens Calibration Wizard. This process takes a little effort, but
once your camera is calibrated well, it's not something you'll need
to repeat often.

To begin the calibration process, go to Laser Tools → Calibrate
Camera Lens or right-click in the Camera Control window and
select Calibrate Camera Lens from the context menu.

Calibration Presets

If you're using an official LightBurn camera, you can use a preset
instead of calibrating manually. Select the appropriate preset for
your camera from the Use Preset dropdown menu on the first
page of the Lens Calibration Wizard.

After selecting a preset, click Next then Finish to close out of the
Lens Calibration Wizard and save the calibration information, or 
Align Camera to move immediately on to the Camera
Alignment Wizard.

Manual Camera Lens Calibration

OVERVIEW

In order to work properly, the calibration pattern must be:

undistorted

perfectly flat

surrounded by a 6 mm (¼") or larger margin

About ⅓rd of the size of the camera's viewing area in both
directions (1/9th of the its total field of view)

The size of the printed calibration pattern is not important, as
long as it is positioned to take up about 1/9th of your camera
view which each capture. You can scale the image up or down
when printing it, as well as raise or lower the printed pattern to
adjust how much of the camera view it takes up.

Download and print one of the following images: 

AprilTags in PDF or LBRN2 format (recommended)

CalibrationCircles.png

You'll need to select the corresponding Calibration Pattern in
the Lens Calibration Wizard later.

Mount the printed image to something stiff and flat, such as
cardboard, foam board, wood, or a clipboard.

Don't forget about alignment!

Quick Reference: Calibrate Camera Lens

Calibration Pattern Details

• 

• 

• 

• 

• 
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If your camera is already positioned in your laser, you are
using the Calibration Circles pattern, and the laser has a
honeycomb bed or other surface with a lot of visible circles,
cover it with a patternless material (cardboard, paper, or
bedsheets all work).

It is not necessary to mount the camera in the machine to
perform the lens calibration. This process depends only on
the camera's lens, not its placement in your machine — as
long as the camera and calibration pattern are perfectly still,
calibration can be performed anywhere.

Make sure the bed of your laser has good, consistent lighting
and the camera is in focus.

Most offical LightBurn cameras can be manually focused by 
gently twisting their lenses. 

In the Laser Tools Menu, select Camera Lens Calibration. 

Follow the directions in the Lens Calibration Wizard. For more
help, continue below.

WALKTHROUGH

The Lens Calibration Wizard walks you through capturing
multiple images of the Calibration Pattern you've printed out.
The software analyzes how the pattern appears in the images,
and compares that against its internal knowledge of how the
pattern should look. It determines the amount and shape of
distortion produced by the lens of the camera, and computes a
lens correction that is accurate for your camera.

After following the steps from the overview above, you should be
ready for the calibration process and looking at a screen like this
one:

Lens Calibration window.

Choose your camera from the list, and you'll see the view from
the camera in the area to the left. 

Choose the same Calibration Pattern as the one you downloaded
and printed earlier.

With the correct camera and Calibration Pattern selected, click 
Next.

The view will change to include a Capture button, and a diagram
to show you how to position the printed pattern. For the first
capture, place the pattern in the center of the field of view of the
camera, with the printed face of the card pointed directly at the
camera, as shown in the small view up top. If you cannot easily
match your capture image with the suggested image, you may
need to adjust the scale of your printed card, or take the camera
out of the machine for lens calibration.

Preparing for the first image capture.

Click the Capture button and you should see something like this:

First capture complete. The calibration pattern is attached to a piece of
cardboard to keep it flat and smooth.

Above the image on the right you see:

Image 1 (3840 x 2160) : 54 Markers found - Score: 0.38 - Great! Click 
Next

If you used the circles pattern instead, you'll see a similar
message:

Image 1 (2592 x 1944) : Pattern found - Score: 0.31 - Great! Click Next

• 

Note on camera placement

• 

Focusing a LightBurn camera

• 

• 
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This tells you:

You may find that early captures are strongly distorted. This is
temporary and is the result of only having a single calibration
capture to work with. As you continue, LightBurn will collect
more information about your camera's lens distortion and the
rest of the image will clear up.

The image was successfully captured

The resolution of the captured image is 3840 x 2160 (higher is
better)

All 54 Markers were identified in the April Tags pattern

This image scored reasonably well — lower scores are better.
In this image, after distortion removal, the positions of the
dots in the image align with the positions of the real dots with
an average error of only 0.38 pixels — that's great, and well
below the target score of 0.5 pixels of error.

If the Calibration Pattern is not found, LightBurn will tell you so.
Make sure the pattern faces directly toward the camera and
occupies roughly the same amount of view area shown in the
reference image. It is okay if the pattern is rotated within the
view if that makes it easier to place.

Example of pattern rotated within camera view.

As you advance through the captures, the reference image will
update. The first five images are the center, bottom, left, right,
then top. If your camera has a very strong fisheye effect, it may
be necessary for you to move the non-center images inward a
little to get a successful capture. That is ok.

The final four images are the corners, and those can be difficult
to capture with high-distortion cameras. If your first 5 images
score very well (below 0.3) you may skip the final four images
(the Next button will show as Skip in this case). If you are having
trouble capturing the last four images and don't have the option
to skip, you can place the card anywhere within the view and
capture that instead — the placement does not always need to
match the suggested images to successfully complete this
process.

Even after only a few good captures, the image on the right
should be free of lens distortion, as shown here:

A poorly calibrated result will still show lens distortion, and may
have other artifacts, like the "wobble" seen in the lower-left of
the gray image below:

If you aren't getting good results, you can re-capture the current
image, or just go back to the beginning and try again. It can take
a few tries to get a feel for how to align the card with the camera
to get the lowest score.

When you have advanced through all the steps, and you are
satisfied that you have a good calibration result with a nicely
undistorted image, click Finish to save the results. You can also
click the Align Camera button on the final page to move
immediately on to the Camera Alignment Wizard.

Troubleshooting

See Camera Troubleshooting for guidance on common camera
issues. 

Related Topics

Calibrate Camera Alignment

Camera Control Window

Camera Selection Helper

Camera Installation and Focusing

Distorted images during the calibration process

• 

• 

• 

• 

• 

• 

• 

• 
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For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

camera laser-control laser-tools output-and-positioning
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5.6.5 Calibrate Camera Alignment

Align a camera capture to your LightBurn Workspace.

Location

Laser Tools → Calibrate Camera Alignment

After your camera's lens is calibrated, you can move on to the next
step, alignment. 

By engraving a target marker pattern and then tagging the
markers in your camera's field of view, the alignment process tells
LightBurn where your camera's capture is in relation to the work
area of your machine.

Before you start, make sure the camera is firmly mounted in the
position it will be in when you use it. 

Selecting Camera Position

To begin the alignment process, go to Laser Tools → Calibrate
Camera Alignment or right-click in the Camera Control window
and select Calibrate Camera Alignment from the context menu.

If you have a Gantry style laser, the first dialog will ask you to
choose your camera's mounting location. If you have a Galvo
style laser, you'll be taken directly to the Overhead Camera
Alignment Wizard.

If you have an Overhead camera, mounted above your laser,
select the option on the left side: Camera is over the work
area, in a fixed position. This type of camera is the most
common option. Proceed to Overhead Camera Alignment for
instructions on the rest of the setup process.

If you have a Head-Mounted camera, attached to your laser
head, selection the option on the right side: Camera is
mounted to the laser head, and moves with the laser. This
option is less common, and Head-Mounted camera support is
still in beta. Go to Head-Mounted Camera Alignment for
instructions on the rest of the setup process. 

Head-Mounted Camera support is still in beta, and your
results may vary. Report any issues you encounter while using
this feature to support@lightburnsoftware.com.

Quick Reference: Calibrate Camera Alignment

• 

• 

Warning
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Overhead Camera Alignment

PREPARATION

Make sure your camera is securely mounted and correctly
positioned, as described in Camera Installation and Focusing. 

You can mount the camera to a movable part of your laser,
like the lid, but the camera must be able to return to the exact
same position it was in when you completed the alignment
process, with each subsequent use. If the camera's position
changes relative to your laser's work area, the overlay will be
misaligned.

Place a piece of material into your laser that is large enough to
engrave the target marker pattern onto — it must be at least
200 mm x 200 mm (roughly 8" square), but larger materials
and engravings are much better for larger lasers.

Focus your laser to the material you're using.

In the Laser Tools Menu, select Calibrate Camera Alignment
to start the Camera Alignment Wizard. Select the option on
the left side: Camera is over the work area, in a fixed
position.

Select the same camera you used with the Lens Calibration
Wizard.

After verifying that you see an image from the camera, click 
Next to begin the alignment process.

ENGRAVING THE TARGET MARKERS

The rest of this process will be completed within the Camera
Alignment Wizard, which will command your laser to engrave a
target pattern onto a piece of material, such as card stock, paper,
cardboard, or thin wood, and ask you to tag the center of the
targets.

Before starting the alignment process, make sure your camera is
securely mounted in the position you'll be using it — any
movement of the camera relative to your work area after
completing the alignment process will cause misalignment later.

Step 1

Place your material in the center of your laser's work area. 

Ignore the Material Thickness setting if you don't usually use it
for your laser.

The Material Thickness setting is only used by lasers with a
motorized Z Axis that are not normally operated using Relative Z
moves only.

Step 2

Enter appropriate Speed and Power settings to get a moderately
dark engraving without burning through. This will vary based on
your laser and the material you're using, so we can't provide
these for you.

For best results, increase the Scale value to the maximum
amount you can adjust it to while still fitting the target marker
engraving to your material and work area. 

Click 100% Scale to automatically adjust scale to a 200 mm (8")
square — the engraving will fit on a typical sheet of A4 letter
paper at this scale.

Click Fit Workspace to increase the scale to the maximum size
that will fit in your laser's work area.

Step 3

Frame the pattern to make sure it's positioned on the material
you're using.

• 

Warning

• 

• 

• 

• 

• 

Important Preparation

Additional Info
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Step 4

Start the engraving. If it's not dark enough, you can adjust the
settings and run it again. When the pattern is clearly visible and
easy to see, click Next.

It's vital that the alignment pattern maintain its exact location
within the laser for the alignment process to work correctly.

If the pattern has been moved, it cannot be used again for a
subsequent alignment. 

If your camera is mounted to a moving part of the laser, such as
the lid, make sure that the camera is in the exact position it will
be in when you use it later, before continuing on. 

CAPTURING THE TARGET MARKER IMAGE

From this screen, you'll capture the alignment image. 

Use the Jog or Send to Corner buttons in the bottom left
corner to move the laser out of the view of the camera. 

When the camera has a clear view of all four targets, click the 
Capture Image button. 

You should see an undistorted version of the camera view
appear in the top left side of the window, with all four corner
targets visible, as shown below.

Click Next when done.

The camera alignment capture window before capturing an image.

Camera alignment capture completed. The image should be clean and
undistorted. If not, use the Lens Calibration Wizard to calibrate the

camera.

MARKING THE TARGETS

In this step, you tag each of the targets by double-clicking in the
center of each one in order. You can pan and zoom around the
image using the same controls as the LightBurn Workspace and 
Preview window, or use the Zoom In and Zoom Out buttons. 

When you double-click, a red "+" mark will appear. Place a tag in
the center of each of the four targets, in the order they are
numbered (1, 2, 3, 4). If you place one incorrectly, you can
double-click near it to shift it around, or click Undo Last to
remove it and try again.

You must tag the targets in their exact numbered order, or the
alignment will not be correct. If the markers are upside down or
mirrored in your camera's field of view, that's ok — as long as
you mark them in the correct order, LightBurn will correct for
that when it produces an overlay.

Place each marker as accurately as you can. Zooming in can help.

Don't move the target marker pattern after engraving
it!

• 

• 

• 

• 

Warning
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Here's an example of a correctly placed marker:

When you have placed all four markers in order, zoom back out
and verify that all four are visible and clearly centered on the
targets, like this:

Click Next to finish the marker placement screen and click Finish
to complete the process and store the results. You're done!

Now that everything is aligned, open the Camera Control
Window again, and click Update Overlay or press Alt /

Option + C  to capture and project whatever is in the camera
view onto your Workspace, as shown here:

See Camera Control Window for full instructions on using the
camera after it has been successfully aligned. 

Troubleshooting

See Camera Troubleshooting for guidance on common camera
issues. 

Related Topics

Camera Control Window

Calibrate Camera Lens

Camera Selection Helper

Camera Installation and Focusing

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

camera camera-alignment camera-calibration

head-mounted-camera overhead-camera

⎇

⌥

• 

• 

• 
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5.6.6 Save Background Capture

Saves a copy of a camera Overlay to your computer.

Location

File → Save Background Capture

Use Save Background Capture to save a bitmap image of an
Overlay produced by a camera affixed over your laser's work
area. 

Saving Background Captures

In order to use Save Background Capture you must first
properly Calibrate and Align your camera.

Click Update Overlay in the Camera Control Window to produce
an overlay.

Go to File → Save Background Capture to save the camera
overlay.

A dialog window will open, allowing you to name and navigate to
the location you'd like to save the capture. 

Related Topics

Camera Control Window

Calibrate Camera Lens

Calibrate Camera Alignment

Camera Installation and Focusing

Save Processed Bitmap

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

Quick Reference: Save Background Capture

• 

• 

• 

• 

• 
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5.6.7 Head-Mounted Camera Alignment

This feature is still in beta, and your results may vary. Report any
issues you encounter while using this feature to 
support@lightburnsoftware.com.

Head-Mounted cameras are affixed to a laser's head and move
with it as it moves around its work area. After properly 
Calibrating and Aligning your Head-Mounted camera, LightBurn
will be able to stitch together captures taken by the camera at
multiple locations in the work area, producing an Overlay for
your Workspace that you can use to position graphics over
material.

Head-Mounted Camera Alignment

PREPARATION

Make sure your camera is securely mounted to your laser
head, with no ability to move or wiggle as the laser jogs.

Place a piece of material into your laser that is large enough to
engrave the target marker pattern onto — it must be at least
50 mm x 50 mm (roughly 2 in square).

Focus your laser to the material you're using.

In the Laser Tools Menu, select Calibrate Camera Alignment
to start the Camera Alignment Wizard. Select the option on
the right side: Camera is mounted to the laser head, and
moves with the laser.

Select the same camera you used with the Lens Calibration
Wizard.

After verifying that you see an image from the camera, click 
Next to begin the alignment process.

ENGRAVING THE ALIGNMENT PATTERN

The rest of this process will be completed within the Head-
Mounted Camera Alignment Wizard, which will command your
laser to engrave a pattern onto a piece of material, such as card
stock, paper, cardboard, or thin wood, and ask you to tag points
on the pattern.

Step 1

Place your material in the center of your laser's work area. 

Step 2

Enter appropriate Speed and Power settings to get a moderately
dark engraving without burning through. This will vary based on
your laser and the material you're using, so we can't provide
these for you.

Step 3

Frame the pattern to make sure it's positioned on the material
you're using.

Step 4

Start the engraving. If it's not dark enough, you can adjust the
settings and run it again. When the pattern is clearly visible and
easy to see, click Next.

Don't move the target marker pattern after engraving it! It's vital
that it maintain its exact location within the laser for the
alignment process to work correctly.

CENTERING THE LASER OVER THE PATTERN

Use the Jog arrows to move the laser head, and with it the
camera, until the pattern is postioned roughly in the center of
the camera's field of view.

The field in the center fo the arrows controls the amount of
distance the laser will move with each click. 

TAGGING THE PATTERN

Next you'll mark four locations near the center of the pattern,
and finally four more around the outside of the grid.

When you double-click, a red "+" mark will appear. If you place
one incorrectly, you can double-click near it to shift it around.

Double-click the center of the grid to place a red "+" mark there.
When the marker is accurately placed, click Next.

Warning

• 

• 

• 

• 

• 

• 

Warning

• 

• 
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Double-click the intersection nearest to Point 1 in the engraved
pattern. Click Next when you're satisfied with the location.

Based on the location you clicked for Point 1, LightBurn will predict
a new location at the next grid intersection over. If the "+" mark is
not perfectly aligned to a grid intersection, double-click at the
closest intersection to align it. Click Next.

Double-click the intersection nearest to Point 2 in the engraved
pattern. Click Next. 

Based on the location you clicked for Point 2, LightBurn will predict
a new location at the next grid intersection over. If the "+" mark is
not perfectly aligned to a grid intersection, double-click at the
closest intersection to align it. Click Next.

LightBurn will now predict 4 intersections around the outside of the
grid. If they are not perfectly positioned over an intersection, click
the nearest intersection to realign them to that point. Click Next
when each "+" is aligned to the nearest intersection.

Double-click a point to Jog the laser to that location — the point
should be centered in the camera's field of view after it is finished
jogging. 

If the alignment is accurate, click Next to close and finish the
process. If it's inaccurate, click Back until the beginning of the
tagging process, and try tagging the points again.

2. 

3. 

4. 

5. 

6. 

7. 
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Capturing an Overlay

Click Update Overlay in the Camera Control Window to
command your laser to jog, pause, take a capture, and repeat,
producing multiple images that LightBurn will stitch together to
produce an Overlay.

If you have an object in your selection, the laser will jog to take
captures of only the area within the selected object, and
produce an Overlay confined to that area in your Workspace.

If you have nothing in your selection, the laser will jog to take
captures of the entire work area and produce an Overlay that
covers your entire Workspace.

Troubleshooting

If the Overlay is misaligned, try rerunning the entire process,
taking care to mark the points in the pattern as precisely as
possible, and to not move the pattern at all from its original,
engraved position.

This feature is still in beta. If you encounter bugs or other
unexpected behavior, please contact us at 
support@lightburnsoftware.com.

Related Topics

Camera Control Window

Calibrate Camera Alignment (Overhead)

Calibrate Camera Lens

Camera Selection Helper

Camera Installation and Focusing

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

camera

• 

• 

• 

• 
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5.7 Settings and Preferences

5.7.1 Beginner Mode

Beginner Mode simplifies the LightBurn interface by removing
several options that new users are unlikely to use. 

You can enable or disable Beginner Mode at any time in the 
Editor Settings tab of the Settings window.

When Beginner Mode is active, you'll see a message in the title
bar, next to the location where your currently selected device
profile is indicated. 

Although Beginner Mode can make it easier to get started, it
also means that your interface will look a little different than
most video tutorials or screenshots you'll see.

If you're searching for a button or features and you don't see it,
it might be because of Beginner Mode, but it could also be
because you're using a machine that doesn't support the feature
you're looking for. LightBurn's interface adapts to only show you
the features that are compatible with your machine type.

Beginner Mode Changes

TRANSFORM CONTROL TOGGLES

The toggles for Move, Rotate, Shear and Scale are hidden. 

LASER WINDOW

The following buttons and options are hidden in the Laser
Window:

Save Machine File

Run Machine File

Optimization Settings

Cut Selected Graphics

Enable Rotary and Enable Cylinder Correction

These options only appear if Show rotary enable on main
window and Show cylinder correction enable on main
window in your Settings. Enabling Beginner Mode hides
them, but disabling Beginner Mode does not show them, by
itself.

ARRANGE TOOLBAR

The simplified version of the Arrange Toolbar is automatically
selected. 

The Move Selected Objects tools appear in a dropdown menu.

The Distribute tools are hidden.

Mirror Across Line is hidden.

Note

• 

• 

• 

• 

• 

• 

Note

• 

• 

• 

• 
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The Align tools are replaced with the Align Tools Helper. Click
the Align left icon to open a dialog window where you can
select any Align option and see the result before clicking OK to
confirm the changes, or Cancel to discard them. 

BOOLEAN ASSISTANT

In the Modifiers Toolbar, the Boolean tools are replaced with
the Boolean Assistant. Click the Boolean Union icon to open
a dialog window where you can select any Boolean option and
see the result before clicking OK to confirm the changes, or 
Cancel to discard them. 

CUT SETTINGS EDITOR

All advanced setting are hidden in the Cut Settings Editor.
Advanced settings are ignored in cases where enabling them
is optional, and defaults are applied in cases where a selection
is required.

Fill layers are always set to Bi-directional fill and Fill all
shapes at once. Scan Angle is set to 0°.

TABS

The Tabs / Bridges section of the Cut Settings Editor for Line
layers is hidden.

The Add Tabs tool is removed from the Tools Toolbar.

• 

• 

• 

• 

• 

• 
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SET START POINT

The Set Start Point tool is hidden in the Modifiers Toolbar. 

Related Topics

Get Started

Main Window

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

arrange-toolbar beginner boolean-assistant

cut-settings-editor editor-settings interface-settings

laser-window main-window set-start-point settings

tabs transform-control-toggles

• 

• 

• 

5.7.1 Beginner Mode

- 370/400 - ©️ LightBurn Software, LLC

https://forum.lightburnsoftware.com/
mailto:support@lightburnsoftware.com


5.7.2 Settings/Preferences

The Settings window contains global user preferences for
LightBurn — these settings apply regardless of what lasers you
have set up, and which one you currently have selected.

The Settings window is split into five tabs:

Editor Settings

Units and Grids

Display

Import / Export

Camera

Accessing the Settings Window

To open the Settings window, click the gears icon in the top
toolbar, or go to Edit → Settings.

If you're on macOS, go to LightBurn → Preferences instead.

Settings Window

Click any option in the images below to jump directly to the
relevant section for that option, or scroll down for an
alphabetized list of options and descriptions for each tab.

Click a tab to jump to the relevant section for that tab and the
settings it contains. 

EDITOR SETTINGS

Automatically check for updates

Permits (or denies) LightBurn the ability to automatically check
for updates, and inform you of them. 

Auto-save Interval (minutes)

Sets the frequency of auto-saves, in minutes. Setting the Auto-
save Interval to 0 disables auto-saving.

Auto-saves are stored in the same location as you saved the
original file, with _backup  appended to its name. If you’ve never
named a file, the auto-save will be in your computer's
Documents folder.

Each auto-save overwrites the previous auto-save, and when you
manually save the file, the auto-saved copy is deleted. 

Auto-launch files in running copy of LightBurn

When opening projects through your system's file explorer,
automatically open any LightBurn project files on your computer
within a running copy of LightBurn, rather than opening an
additional copy of the program.

Beginner Mode

Enables a simplified version of the LightBurn interface which
removes several options that new users are unlikely to use.

See Beginner Mode for more information.

Default "Cut Selected" State

Automatically enables Cut Selected Graphics each time you
restart LightBurn.

Default "Use Selection Origin" State

Automatically enables Use Selection Origin each time you
restart LightBurn.

Ignore out-of-bounds shapes if possible

When Starting or Sending projects to your laser, tells LightBurn
not to send graphics positioned outside of the grid in your 
Workspace.

Graphics that are partially inside and partially outside the grid
will be ignored. 

Ignore 'Start' button if monitor is off or asleep

Prevents you from accidentally starting the laser by pressing the
wrong key when waking the computer. This is particularly useful
on lasers that don't have enclosures with safety interlocks, such
as most diode and Galvo lasers.

Invert mouse wheel zoom direction

Overrides the default scrolling behavior within LightBurn to
match preferences for macOS or Windows.

Load default layer settings on new or restart

Cut settings are normally pre-filled with the last settings used for
a given layer. If Load default layer settings on new or restart is
enabled, any time you open up a new project or restart
LightBurn, all settings for all layers will be restored to defaults.

If you've never set up your own defaults, all layers will be
restored to LightBurn's universal defaults. 

See Working With Default Layer Settings for more information.

Load / Save dialogs

These settings permit you to use non-native system dialogs to
perform Save/Open/Import/Export operations with LightBurn.

• 

• 

• 

• 

• 
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Use internal Load / Save dialogs uses LightBurn's internal
code to load and save files. 

Use external Load / Save dialogs opens a second application
to load and save files. 

Bypass system Load / Save dialogs bypasses your system's
Load / Save dialogs.

Try external Load / Save dialogs or Bypass system Load / Save
dialogs if LightBurn crashes when when performing Save/Open/
Import/Export operations.

Play error sound if file send fails

Produces an audible chime if uploading a file to a DSP controller
fails. 

Save Cut Selected / Selection Origin to project

Stores the status of the Cut Selected Graphics and Use
Selection Origin switches to any project you save.

Save Job Log

Instructs LightBurn to save a log of projects that are run, on what
laser profile, and at what time.

It will save a file called LightBurnJobs.csv in your system's
Documents folder.

Save Job Origin to Project

Stores your selected Job Origin with any project you save.

Save state of Move / Rotate / Scale switches

Stores the state of the Transform Control Toggles so they persist
between restarts of LightBurn.

Text Settings

See Create and Edit Text — Text Settings for information on these
settings.

Use System Clipboard

Enabling this makes Copy and Paste operations slightly slower,
but allows LightBurn to:

Copy and Paste across different runs of LightBurn, or between
two running copies of the app

Paste images copied from other software or web browsers

Paste text directly into the Workspace, auto-creating a Text
Object

UNITS AND GRIDS

Click Selection Tolerance (pixels)

Determines how close your cursor must be to a line or vertex, in
screen pixels, to click it. 

Increase this number if you have trouble selecting things,
decrease it if you find yourself selecting things you didn't mean
to.

Grid Contrast

Adjust the brightness of the grid in your Workspace, relative to
the background.

• 

• 

• 

• 

• 

• 
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Grid Contrast off

Low contrast grid

Medium contrast grid

High contrast grid

Grid Snap Distance

Determines how close lines and other primitives must be to a
grid line to snap to it. 

Object Snap Distance (pixels)

Controls how close, in screen pixels, your cursor has to be to an
object node or center to activate the Object Snapping behavior.

Shape Move Increments

When moving objects with the arrow keys in the Workspace,
these values control the distance to move the selection. 

Assign individual values to movements when pressing:

The Left , Right , Up , and Down  arrow keys

Ctrl  while pressing an arrow key

Grid Contrast Comparison

• ← → ↑ ↓

• ⌃
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Shift  while pressing an arrow key

Snapping

LightBurn has two snapping behaviors which you can enable or
disable here. 

Snap to Objects will snap your pointer location to the nearest
object center or vertex when creating new objects, drawing lines,
or moving objects, making it easier to connect and align shapes. 

Snap to Grid will snap your cursor position to the nearest grid
location, as specified by the Grid Snap Distance value. Note that
the Grid Snap Distance and the Visual Grid Spacing do not have
to be the same.

Hold Ctrl / Cmd  while moving an object to toggle the status
of the snapping behaviors — if they are currently enabled, they
will be temporarily disabled, and if they're disabled, they'll be
temporarily enabled. 

See Snapping for more information.

Units

Determines the units displayed in LightBurn.

LightBurn internally operates in millimeters, but can display in
either millimeters or inches. Speeds can be represented as either
units per second or units per minute. 

Users with diode lasers will likely prefer the units per minute
setting, while CO2 lasers generally express speeds using units
per second.

LightBurn automatically converts any existing values when you
switch between units.

Visual Grid Spacing

Visual Grid Spacing determines the visual size of grid squares at
the standard zoom level. As you Zoom In, you'll see a secondary
10 x 10 grid of squares within each larger square. Each smaller
square is 1/10th the size of the Visual Grid Spacing value. 

Note that this setting is independent of the Grid Snap Distance,
which controls how close lines and other shapes must be to a
grid line to snap to it.

DISPLAY

Cursors / Nodes

Adjusts the size of special cursors used when Snapping, applying 
radiuses, Bending text, and more, as well as the size of individual
nodes when using Edit Nodes.

Adjust the slider to select between Normal, Larger, and Largest.

• ⇧

⌃ ⌘
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Normal nodes

Large nodes

Largest nodes

Curve Quality

Controls the precision LightBurn uses in displaying curves on the
screen. All curves are displayed as a series of short lines, but the
higher this value is, the shorter those lines will be.

Reduce this value to improve performance if your system is slow.

Enable Antialiasing (slower, but pretty)

Antialiasing smooths the appearance of lines on your screen.
Enabling anti-aliasing will make your design rendering look much
nicer, but increases demand on your machine. 

If you notice your computer lagging, especially on older
computers or when working with very complex designs, try
disabling this setting.

Node Size Comparison

Curve Quality comparison
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Filled Rendering (slower)

Renders shapes that are assigned to layers set to Fill Mode as
solid shapes. 

This takes longer than rendering the wire outlines, and it can
hide graphics behind Filled shapes that may still be sent to the
laser, so we recommend using this only for spot-checking your
work, and not for general editing.

See View Style for more information.

Font Size

Increases or decreases the font size for LightBurn window text
anywhere in the program. This allows for manual overrides for
HiDPI screens, UI scaling, and visually impaired users. Not all UI
elements may fit on screen if increased too high.

Adjust the slider to select Default, or a size between 8 and 24.

Setting this slider too high may result in clipping of UI elements.
If you scale font up or down such that you cannot reach the
menu items to re-open the Settings window and shrink it, use
the method listed here to reset LightBurn.

Reduce Motion (slower)

Instructs LightBurn to try to reduce motion or other flickering
effects in the rendering. 

If you notice your computer lagging, especially on older
computers, or when working with very complex designs, try
disabling this setting.

Show cylinder correction enable on main window

Adds a toggle to the Laser Window to enable or disable Cylinder
Correction mode.

Show full screen line cursor

Draws a moving crosshair, centered on your cursor, that spans
the entire edit screen.

Show Palette Button Labels

Shows numbered labels on the Color Palette swatches, making it
easier to tell similar colors apart.

Show rotary enable on main window

Adds a toggle to the Laser Window to enable or disable Rotary
Mode.

Show work area center cross

Draws an immovable crosshair through the center of your 
Workspace, spanning the entire grid.

Toolbar Icon Size

Changes the scaling of icon elements in the LightBurn UI. This
allows for manual overrides for HiDPI screens, UI scaling, and
visually impaired users. Not all UI elements may fit on screen if
this is increased too high.

Adjust the slider to choose between Smallest, Smaller, Normal, 
Larger, Large, Very Large, and Largest.

Setting this slider too high may result in clipping of UI elements.
If you scale icons up or down such that you cannot reach the
menu items to re-open the Settings window and shrink them,
use the method listed here to reset LightBurn.

Use Dark Background

Shows the Workspace using a dark color scheme.

Antialiasing comparison

Filled vs. Wireframe comparison

Warning

Warning
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IMPORT / EXPORT

DXF Export Settings

When exporting in DXF format, choose whether to Export Arcs
or Convert Arcs to Lines.

When Convert Arcs to Lines is selected, arcs in your LightBurn
designs will be exported as a series of small line segements. 

DXF Import Settings

Enable Auto-detect units if possible to have LightBurn
automatically detect the units used to produce the DXF, if it can.

Select the appropriate unit of measurement for your DXF if the
units are not contained in the file, or the DXF may import at an
incorrect scale.

Auto-close tolerance (mm) determines how close together
imported nodes must be for LightBurn to automatically close
them, placing them on a shared path. 

Allow importing to Tool layers

Enables importing graphics directly onto Tool layers in LightBurn.

Group imported shapes

Automatically Groups shapes imported from a single file
together, so they don't get scattered in a complex design.

HPGL / PLT Import precision

Determines the precision of files imported from HGPL or PLT
format.

Import hidden layers from AI files

Enables importation of layers hidden in the source file, when
importing from AI (Adobe Illustrator) files.

Output Settings

Curve Tolerance specifies the maximum amount of error
allowed when projects are output to your laser. The lower the
value, the more accurate the curve will be. A value of 0 would be
"perfect", but would create very dense data, as some lasers can
only process line segments. Most users will be fine leaving this at
the default value of 0.05 mm.

In the above image, the blue curve between the two points is the
ideal shape. The black line is a straight line between them, and
the red line shows the error (how far the line is from the curve).
LightBurn measures this error, and if it's equal to or lower than
the Curve Tolerance value, it outputs the straight line. If not, the
curve is subdivided into two linear segments and the process
repeats with each new segment. Those segments are shown
below in violet, along with their new error values. You can see
that the two new lines do a much better job of approximating
the original curve.

Most people will probably never need to change this — the
default is 0.05 mm, which is about ½ the width of a typical beam.
Note that this is the maximum error value allowed, typical output
will be better than this, and this only affects curves, not straight
lines or vertices — which are exact.

Select imported shapes

Automatically selects shapes upon importing them.

SVG Import Settings

Select whether to import SVGs at:

96 DPI — the default for Inkscape 

72 DPI — the default for Adobe Illustrator

If your SVGs import at the incorrect scale, try the alternate
setting to the one you currently have selected. 

CAMERA

Camera Capture System

Technical Details

• 

• 

Windows Only
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Select whether to access the camera using LightBurn's Custom
Capture System or a Default Capture System provided by our
cross-platform framework. 

Select Default Capture System if you are having trouble accessing
your camera.

Camera Resolution

Choose Highest (the default) for general use. Switch to Efficient
(an experimental option) if you are on a resource-constrained
system, are worried about USB hub congestion, or experience
other camera-related issues.

Camera View

Select whether to show overlay captures from your camera in 
Full Color or Black and White.

Rotate captures 90 degrees (obsolete, do not use)

This option has been rendered unncessary by changes to
LightBurn's camera support. Do not enable it.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

camera display editing editor export grid import

interface optimization preferences settings

troubleshooting units workflow workflow-optimization
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5.7.3 Managing Preferences

The Preferences submenu provides several tools to manage
your LightBurn Preferences. Access the Preferences submenu by
going to File → Preferences. For information about adjusting
Preferences themselves, see Settings/Preferences.

Importing and Exporting Preferences

The following tools are useful for backing up, restoring, saving,
importing, and migrating LightBurn Preferences between
computers.

User Bundles streamline the process of migrating between
computers, allowing you to export not only your Preferences,
but also your Custom Hotkeys, Material Test Presets, Image
Presets, Devices, Material Libraries, and Art Libraries, all in one
bundle.

IMPORT/EXPORT PREFS

The Export Prefs command allows you to save a copy of your
LightBurn Preferences as a .lbprefs  file. You can import this file
to another LightBurn installation using the Import Prefs
command.

OPEN PREFS FOLDER

The Open Prefs Folder command opens the folder containing
your LightBurn Preferences. 

LOADS PREFS BACKUP

The Load Prefs Backup command allows you to import
preferences from a timestamped list of automatic backups. Click
a backup in the list to see the list of Devices available in that
backup, on the right side of the window. 

Click Load to restore the settings from the selected backup, or 
Cancel to close the window and maintain your current settings. 

EDIT HOTKEYS

Opens the Hotkey Editor window, where you can customize
keyboard shortcuts.

Related Topics

LightBurn Migration

Settings/Preferences

User Bundles

Hotkey Editor

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

migration preferences settings settings-and-preferences

Tip

• 

• 

• 

• 
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5.7.4 User Bundles

Groups and exports LightBurn data for migration to a new computer.

Location

File → Bundles

User Bundles simplify the process of migrating LightBurn
between computers. Go to File → Bundles → Export Bundle to
create a bundle, and import a bundle by dragging the .lbzip  file

into the LightBurn Main Window or using File → Bundles → 
Import Bundle.

A bundle can include any of the following. You can export
everything, or select only the components you want to include:

LightBurn Settings

Custom Hotkeys

Material Test Presets

Image Presets

Devices

Material Libraries

Art Libraries

It's important to keep in mind that this list does not include your
project files. If you want these available on your new computer,
be sure to copy or move them separately.

Working With Bundles

EXPORT BUNDLE

In an existing and already configured LightBurn installation, go to 
File → Bundles → Export Bundle.

Make sure that all components of the current installation that you
want to include are selected and click Export. Save the file
somewhere you can find it again easily.

IMPORT BUNDLE

Quick Reference: User Bundles
• 

• 

• 

• 

• 

• 

• 

1. 

2. 
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Move the .lbzip  file created by Export Bundle to the new
computer.

Open LightBurn on the new computer. Go to File → Bundles → 
Import Bundle and select the file. Click Okay.

Make sure that all components you want to import are selected,
and uncheck any components you don't want to import.
Components that are already detected on the computer will be
grayed out and unavailable, with some exceptions:

If you choose to a import a Device that conflicts with one that
already exists, a duplicate will be created, and the existing profile
preserved.

If the new computer has an existing Material Library or Art Library
with the same name but different contents as the one contained in
the bundle, a new copy of the library will be created, without
overwriting the original. 

Click Import to complete the process.

You can also import a bundle by dragging the .lbzip  file into
LightBurn.

Related Topics

Migration Guide

Managing Preferences

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

migration settings

1. 

2. 

3. 

• 

• 

4. 

Tip

• 

• 

5.7.4 User Bundles

- 381/400 - ©️ LightBurn Software, LLC

https://forum.lightburnsoftware.com/
mailto:support@lightburnsoftware.com


5.7.5 Edit Hotkeys

Use the Hotkey Editor to customize LightBurn's hotkeys. From
this window, you can add new keyboard shortcuts and edit or
delete existing ones. Access the Hotkey Editor by going to File → 
Preferences → Edit Hotkeys.

Using the Hotkey Editor

To customize hotkeys:

Find the command you want to modify using the categories on the
left or the search bar at the top of the window.

Select the command.

Click in the Shortcut text box.

Type the new hotkey, or press Clear to erase the hotkey.

Click OK to save your changes when you're finished.

From this window, you can also use Reset All to return hotkeys
to their defaults, or use the Export and Import buttons to back
up your custom hotkeys or restore a backup. Custom hotkeys can
also be imported and exported as part of a User Bundle.

Related Topics

Settings/Preferences

User Bundles

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

hotkeys preferences

1. 

2. 

3. 

4. 

5. 

• 

• 
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5.7.6 Reset to Default Layout

Reset to Default Layout restores the layout of the full LightBurn
window to the same format it was in when you first installed and
opened LightBurn. If you've made lots of changes to your layout
that you want to reverse all at once, or you've lost sight of the 
Laser Window, Cuts / Layers Window, Color Palette, or any other
default windows or toolbars, use this option to get them back.

Resetting the layout doesn't reset anything else — your
preferences, devices, and libraries are all preserved.

Go to Window → Reset to Default Layout to re-open and re-
dock all default windows in their original order, while closing any
that are not visible by default.

Holding Shift  while clicking to open LightBurn will also reset
the layout. 

Related Topics

Workspace

Main Window

Customizing the LightBurn Window

Reset to Default Settings

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

troubleshooting ui workflow

⇧

• 

• 

• 

• 
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5.8 Help and Software Questions

5.8.1 Check for Updates

Check for Updates checks whether there is a more recent
version of LightBurn available than the version currently running,
and whether it was released within your license's valid update
period. If a valid newer version is available, you can begin
downloading it from the Check for Updates dialog window.

Check for Updates Responses

Go to Help → Check for Updates to tell LightBurn to check for
available updates. There are three possible responses. 

Version Up to Date

The currently running version is up to date. No further action is
required.

Newer Version Available

A newer version is available. Click Yes to automatically begin
downloading the newer version. Click No to remain on the
current version.

License Expired

A newer version is available, but your license has expired. To use
the newest version, you must renew your license. You will be able
to continue receiving updates for one year after you renew your
license. 

Related Topics

How the License Works

Install LightBurn

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

license-management

• 

• 
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5.8.2 Help and Notes

Open the Help and Notes window by going to Help → About,
Help → Quick Help and Notes, or pressing F1 .

This window has three tabs:

Hotkeys summarizes some of the most frequently used
mouse and keyboard shortcuts. See Hotkey Editor for
information on setting custom hotkeys.

Usage contains tips to help you get started.

About contains information about the version of LightBurn
installed on your computer.

Related Topics

Help Menu

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

UI build-date help help-and-notes help-menu

hotkeys keyboard-shortcuts version

• 

• 

• 

• 
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5.8.3 License Management

If your LightBurn installation has not been activated, you'll see
the License Page as soon as you open LightBurn. From this
page, you can:

Enter and activate a license key you've already purchased

Start a free 30 day trial

Purchase a license key from our website

Extend your free trial

Deactivate a license to free up an installation for a different
computer

You can get back to this screen in LightBurn at any time by going
to Help → License Management. For more information on
License Management, including offline activation and
deactivating a computer, please see our License Management
Guide.

Left: The License Page before activation
Right: The License Page after activation 

Activate Trial

Click the Activate Trial button to activate a free 30 day trial of
LightBurn.

Extend Trial

Click Extend Trial to automatically extend your trial period. You
can extend your trial up to 3 times, for an additional 15 days each
time. Trial keys over a year old are extended for 30 days, but may
only be eligible for a single auto-extension.

Activate License

If you already have a license key, enter it into the License Key
field and click Activate License. Be sure to enter your license key
exactly as provided, including the dashes. We recommend

copying the license key directly from your original order email
and pasting it into the License Key field.

USE PROXY SERVER

See System Locked and Floating Licenses: Network Restrictions
for information on connecting to LightBurn's licensing server
through a proxy.

TROUBLESHOOTING

If you receive an error message when trying to activate your
license, see Troubleshooting: License Activation and
Management.

Request Offline Activation and Deactivation

If you will be using LightBurn on a computer without an internet
connection, please see our Offline Activation instructions.

Deactivate License

Click Deactivate License to deactivate LightBurn on your
computer, freeing up an activation to be used on another
computer.

See our License Management Guide for information on
deactivating a computer that you no longer have access to.

After Activation Information

LICENSE EXPIRATION

After you've activated your license, you'll see the number of days
remaining on your license at the top of the License Page.

After your key has expired, you'll still be able to use the last
version of LightBurn released before it expired forever, but you'll
need to Renew your key in order to receive future updates.

DEVICES SUPPORTED

Beneath the Deactivate License button, you'll see the list of
device types supported by your key. To add support for new
device types to your key, see our website.

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

activation license-management trial

• 

• 

• 
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5.8.4 Enable Debug Log

Use Enable Debug Log to begin recording a log saved in the My
Documents folder on Windows or Documents on Mac. You can
send a Debug Log to LightBurn Support to aid in troubleshooting
or bug fixing.

Enabling and Disabling the Debug Log

Go to Help → Enable Debug Log to begin recording a log of the
actions you take in LightBurn. A check mark will appear next to it
when it's enabled, and logging will continue until you select
Enable Debug Log again to disable it, or restart LightBurn.

No check mark — Debug Log not enabled

Check mark — the Debug Log is enabled

The Debug Log will automatically save to My Documents on
Windows or Documents on Mac, with the file name 
LightBurnLog.txt .

The Debug Log is cumulative — each time you use Enable Debug
Log it will append to any existing log, so it's a good idea to delete
it after you're finished and have sent the log to LightBurn
Support.

Related Topics

Generate Support Data

Get Controller Info

Troubleshooting

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

• 

• 

• 
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6. Collections

Lasers are versatile machines, and what you do with them is up to you. No matter your aim, it's likely LightBurn has a tool to help you
achieve it, as long you know where to look. We've assembled a range of tools, features, and resources into collections below, organized
according to the goals they'll help you accomplish.

6.1 Getting Started

New to lasers or LightBurn? Everyone's a beginner once, and we know there's a lot to learn — here are some resources that will help you hit
the ground running, and get to making things with your machine. 

Identify Your Laser

What you can do in
LightBurn – and what
license you need –
depends on what type of
laser you have. This page
can help you identify it.

Install LightBurn

Get help installing
LightBurn on Windows,
macOS, and Ubuntu Linux,
as well as links to current
and old releases.

Add a Laser

Get help adding a laser to
your LightBurn
installation.

Connect to a Laser

Get help making sure your
computer is able to
communicate with your
laser.

First Project

Follow along to create
your first LightBurn
project – a coaster with a
QR code to connect to
your WiFi network.

Next Steps

Next steps for beginners
getting started with
LightBurn.

Coordinates and Origin

Get familiar with
LightBurn's coordinates
and origin settings.

Layer Modes

Learn the difference
between the four Layer
Modes that determine
how your laser will cut or
engrave graphics in your
design.

Laser Types

The type of laser you have
determines what it's
capable of, what type of
license you need, and
what the LightBurn UI
looks like.

6.2 Job Optimization

The faster your laser finishes one job, the sooner you can start another. These tools will help you learn how speed up your project runtimes,
without any loss in quality of the finished product, so you can spend less time waiting and more time making things.

6. Collections

- 388/400 - ©️ LightBurn Software, LLC



Line Interval

Read more about how 
Line Interval affects your
design and how to adjust
it.

Optimization Settings

Learn more about how
you can speed up your
jobs using Optimization
Settings.

Fill-by Modes

Learn to control how filled
objects are grouped
together when you send a
job to your laser.

Preview

Learn more about the 
Preview window and how
to use it.

Additional Settings

Learn to adjust your 
Device Settings to make
the time estimate in the 
Preview window more
accurate.

Speed vs. Power

Learn more about the
relationship between
speed and power.

Material Test

Learn to use the Material
Test tool to determine
optimal cut settings for
your laser and material.

Material Library

Save cut settings to a 
Material Library to be
reused in the future.

6.3 Material Utilization

No one likes it when unusable scraps pile up in their workshop, so the more you can get out of a sheet of acrylic or piece of wood, the better.
These tools will help you lay out and arrange graphics so they're close-fitting, directly next to each other, or perfectly positioned for the
material you're working with. 

Grid Array

Creates copies of an object
in rows and columns.

Circular Array

Creates copies of an object
in a circular pattern.

Docking

Moves objects in a
particular direction until
they meet the edge of
either the Workspace or
another object.

Distribute and Move
Together

Moves objects to space
them evenly.

Alignment Tools

Repositions selected
objects to align them
along edges or center
points.

Camera

Helps you postion your
design on oddly-shaped
material using a camera.

6.3 Material Utilization
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Snapping

Align objects to other
shapes in your Workspace
or to the Workspace grid.

Move Laser to
Selection

Physically moves your
laser to a location based
on your current selection
in LightBurn.

Move Selected Objects

Move objects to a corner,
midpoint, or center of your
Workspace. Can also
move to the last reported
laser position for gantry
style machines.

Position Laser

Click in the Workspace to
jog your laser to a new
location.

Remove Overlapping
Lines

Removes overlapping lines
that would cause your
laser to cut in the same
place twice.

6.4 Batch Production

Once you've mastered the craft of making one thing really well, you're going to want to make many more of that thing really well. Use these
tools to lay out copies of your design, or set your laser up for several runs in succession. If you're a small business owner with orders to fill,
these features will help you scale up and expedite your production process.

Grid Array

Creates copies of an object
in rows and columns.

Circular Array

Creates copies of an object
in a circular pattern.

Material Library

Save cut settings to a 
Material Library to be
reused in the future.

Variable Text

Automatically replaces
specially formatted
expressions with data you
choose, similar to how
Mail Merge works.

Coordinates and Origin

Various ways to tell
LightBurn where to output
your work within your
laser's work area.

Feeder Setup

Set up an Auto-feeder to
feed material into your
laser.

6.4 Batch Production
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Repeat Marking

Use a Rotating or Linear
axis table with Galvo lasers
to run repetitions of
identical jobs.

Optimization Settings

Learn more about how
you can speed up your
jobs using Optimization
Settings.

Print and Cut

Aligns a current project to
existing Target Positions in
a previously output
design.

Rotary Mode

Set up LightBurn to
engrave cylindrical objects
with a rotary.

Bar Codes and QR
Codes

Creates bar codes, QR
codes, and other similar
formats.

6.5 Design Tools

Looking to get creative? LightBurn contains a suite of tools for designing projects from scratch. If you have a background in other design
software, many of these tools may be familiar to you — instead of bouncing between programs, you can keep all your laser-design work
under one roof.

Create Text

Add and edit text in
LightBurn.

Primary Shapes

Create and edit Primary
Shapes, including 
Rectangles/Squares, 
Ellipses/Circles, and 
Polygons.

Edit Nodes

Make precise edits to
individual nodes of vector
paths.

Draw Lines

Create vector paths out of
straight and curved line
segments.

Tools Toolbar

Tools for selecting,
creating, and editing
objects.

Transform Controls

Directly edit selected
objects using control
handles to alter their
position, dimensions,
orientation, or shape.

Selection

Overview of methods to
select objects in LightBurn.

Grouping and
Ungrouping

Combines selected objects
into single units and splits
them back up.

Boolean Tools

Combine existing shapes
into more complex new
shapes.

6.5 Design Tools
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Locking

Locks selected objects,
preventing accidental
editing.

Automatic Guidelines

Guidelines help place and
align objects within your 
Workspace.

Distribute and Move
Together

Moves objects to space
them evenly.

Alignment Tools

Repositions selected
objects to align them
along edges or center
points.

Tool Layers

Create layers that will
never be output to the
laser and can be used for
positioning and
placement.

Grid Array

Creates copies of an object
in rows and columns.

Circular Array

Creates copies of an object
in a circular pattern.

Image Tracing

Convert imported images
into vector graphics.

Shape Properties

Displays editable
properties of selected
objects, making them
available for adjustment.

6.6 Working Quickly in LightBurn

LightBurn is packed with tools that speed up the process of getting from idea to finished product. We've listed some of our most powerful
workflow optimization features below — check them out to become a LightBurn ace.

Automatic Guidelines

Guidelines help place and
align objects within your 
Workspace.

Alignment Tools

Repositions selected
objects to align them
along edges or center
points.

Snapping

Align objects to other
shapes in your Workspace
or to the Workspace grid.

Distribute and Move
Together

Moves objects to space
them evenly.

Locking

Locks selected objects,
preventing accidental
editing.

Quick Tip Videos

Short videos with tips for
using LightBurn
effectively.

6.6 Working Quickly in LightBurn
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Grid Array

Creates copies of an object
in rows and columns.

Circular Array

Creates copies of an object
in a circular pattern.

Transform Controls

Directly edit selected
objects using control
handles to alter their
position, dimensions,
orientation, or shape.

Variable Text

Automatically replaces
specially formatted
expressions with data you
choose, similar to how
Mail Merge works.

Two Point Rotate and
Scale

Turn and resize objects
around custom pivot
points in your Workspace

Move Laser to
Selection

Physically moves your
laser to a location based
on your current selection
in LightBurn.

Hotkey Editor

Customize LightBurn's
hotkeys to suit your
preferences.

Equation Support in
the Numeric Edits
Toolbar

The position, width, and
height boxes in the 
Numeric Edits Toolbar
accept units of
measurements and
equations.

Offset Shapes

Create a new shape by
outlining selected shapes
at a distance you specify.

Delete Duplicates

Find and remove
duplicated objects in your
project.

Make Same Width and
Height

Resize all selected objects
to the width or height of a
single object in the
selection.

Move Selected Objects

Move objects to a corner,
midpoint, or center of your
Workspace. Can also
move to the last reported
laser position for gantry-
based machines.

6.7 Getting a Design Laser-Ready

So you've imported a design into LightBurn that wasn't made with laser engraving in mind, and it's going to take some work to get it ready
to go. Don't worry — the tools below are up to the job and then some. 

6.7 Getting a Design Laser-Ready
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Preview

Learn more about the 
Preview window and how
to use it.

Edit Nodes

Make precise edits to
individual nodes of vector
paths.

Delete Duplicates

Find and remove
duplicated objects in your
project.

Boolean Tools

Combine existing shapes
into more complex new
shapes.

Grouping and
Ungrouping

Combines selected objects
into single units and splits
them back up.

Tool Layers

Create layers that will
never be output to the
laser and can be used for
positioning and
placement.

Open vs. Closed Shapes

Learn more about the
difference between open
and closed shapes.

Close Path

Create a closed path from
an open one by
connecting the start and
end points with a line.

Close Selected Paths
with Tolerance

Create a closed path from
an open one by
connecting the start and
end points with a line. Set
a tolerance to determine
how close together these
points must be in order to
be closed.

Optimize Selected
Shapes

Simplifies and smooths
selectd shapes. Often
useful for imported or
traced artwork.

Trim Shapes

Cut line segments back to
the next intersection with
another line. Deletes the
entire shape if it doesn't
intersect with any other
lines.

Auto-join Selected
Shapes

Automatically connects
line start and end nodes of
shapes when they are
direclty on top of each
other but not technically
connected. Often useful
for imported graphics.

View Styles

Control the appearance of
vector graphics in your 
Workspace

Convert to Path

Transforms LightBurn's
built-in shapes into paths
editable by the Edit Nodes
tool.

Resize Slots

Adjust the size of slots or
tabs in selected objects.

6.7 Getting a Design Laser-Ready
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Kerf Offset

Compensate for the extra
material removed by the
laser when cutting without
modifying the underlying
shape.

Measuring Kerf Width

Learn to measure your
laser's kerf in a given
material for use with the 
Kerf Offset setting.

6.8 Working With Images

Engraving images is one of the coolest things your laser can do, but it's also one of the hardest processes to get just right. Check out the
following pages to learn the basics of image engraving with LightBurn, along with some advanced techniques for when you're a seasoned
pro.

5 Steps to Perfect
Image Engraving

Learn more about how to
make your image
engravings even better in
this guide.

Image Mode

A special engraving mode
for images, which is
similar to Fill Mode but
with additional image
processing.

Adjust Image

Streamlines the process of
tweaking Image Settings
and Layer Settings.

Shape Properties

Displays editable
properties of selected
objects, making them
available for adjustment.

Images vs. Vectors

Learn more about the
differences between
images and vector objects.

Mask Image

Use a closed shape to hide
unwanted portions of an
image.

Convert to Bitmap

Turns selected vector
graphics into bitmap
images.

Image Tracing

Convert imported images
into vector graphics.

For more help using LightBurn, please visit our forum to talk with LightBurn staff and users, or email support.

6.8 Working With Images
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7. Explainers

7.1 Explainers

Our explainers go into detail about the concepts behind using LightBurn effectively.

LightBurn Cut Settings and EZCAD2
Hatches

Images vs. Vectors

Layer Modes Open vs. Closed Shapes

Steps Per Millimeter

For more help using LightBurn, please visit our forum to talk with LightBurn staff and users, or email support.

_index
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7.2 LightBurn Cut Settings and EZCAD Hatches

If you're coming from EZCAD2 and having trouble finding hatch settings you're used to, follow this guide to match your usual hatch settings to
LightBurn's Fill settings.

If you're not sure how to adjust cut and engraving settings, see the Cut Settings Editor page.

7.2.1 Mark Contour

EZCAD2's "Mark Contour" option can be replicated with
LightBurn's Sub-Layers. By creating a Line Sub-Layer and a Fill
Sub-Layer, you can achieve the same effect. The Sub-Layers will
be cut in the order they appear in the Cut Settings Editor.

7.2.2 Hatch 1, Hatch 2, Hatch 3

EZCAD2 allows for three different hatches on the same geometry.
This is equivalent to LightBurn's Sub-Layers. 

7.2 LightBurn Cut Settings and EZCAD Hatches
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7.2.3 Cross-Hatch

This functionality is the same between the two programs, and is
a checkbox in each.

7.2.4 Hatch Patterns and Settings

Unidirectional hatch & Bidirectional hatch

EZCAD2's bidirectional hatch and unidirectional hatch are the
same as the default hatch in LightBurn, with the Bi-directional fill
toggle either on or off.

Ring-like hatch / Pyramid Hatch

EZCAD2's ring-like hatch is equivalent to LightBurn's Offset Fill.

Snake Hatch

Snake hatch is equivalent to a regular fill in LightBurn with Flood
Fill enabled.

Auto Rotate Hatch Angle

LightBurn's Angle Increment setting is equivalent to EZCAD2's
"auto rotate hatch angle".

For more help using LightBurn, please visit our forum to talk with
LightBurn staff and users, or email support.

cut-settings explainer galvo

7.2.3 Cross-Hatch
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7.3 Images vs. Vectors

Understanding the difference between vectors and images is essential for creating and editing custom projects. It influences the tools and
methods used in LightBurn, as well as the settings, speed, and quality of jobs. 

There are two main ways a computer can describe something visually:

Images Vectors

7.3 Images vs. Vectors
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